Extensions Firefox: un nouveau site officiel pour le 15 mars

Le par  |  34 commentaire(s)
firefox

Outre ses qualités intrinsèques souvent évoquées, l'une des grandes forces du navigateur au panda rouge est sans nul doute son aspect personnalisation décuplé par l'existence d'extensions autrement connues sous le terme plus générique de modules complémentaires englobant les thèmes par exemple.

Outre ses qualités intrinsèques souvent évoquées, l'une des grandes forces du navigateur au panda rouge est sans nul doute son aspect personnalisation décuplé par l'existence d'extensions autrement connues sous le terme plus générique de modules complémentaires englobant les thèmes par exemple.

Ces derniers sont développés par une communauté dynamique et leur nombre est véritablement conséquent mais un peu trop justement et de fait partir à la recherche d'un addon particulier sans savoir avec précision vers lequel s'orienter peut bien vite devenir une opération fastidieuse.


Mise à l'honneur des extensions
Le site officiel de Mozilla dédié à cette tâche en a fait les frais en répertoriant plusieurs milliers d'extensions dont certaines devenues obsolètes (extensions non compatibles avec Firefox 2 car plus tenues à jours, ...) ce qui au bout du compte à fini par nuire à sa lisibilité. Une refonte du site a donc été décidée et depuis presque 1 mois, Mozilla nous promet une troisième mouture de addons.mozilla.org, un lancement plusieurs fois avorté pour cause de migration de base de données délicate et autres bugs persistants. Néanmoins, jeudi 15 mars, elle devrait être mise en ligne avec au compteur 385 addons sélectionnés parmi les meilleurs.

Un choix réduit pour l'utilisateur mais une section réservée du site permettra à chacun de donner son avis sur une extension non répertoriée qu'il affectionne particulièrement en vue de la faire connaître avec le cas échéant une intégration dans le site après contrôle (système de validation interne remanié). En outre, autre bonne nouvelle, le site qui pour l'heure existe seulement dans une version anglophone va s'internationaliser avec des versions localisées et la langue de Molière n'a pas été oubliée.
Complément d'information

Vos commentaires Page 1 / 4

Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le #160630
bah on peut tres bien les rendre compatibles les extensions de la facon suivante


pour rendre compatible une extension de firefox 1.x vers la 2.x et plus

copiez l'extension sur votre bureau
renomez la en ZIP (ou clic droit >ouvrir avec winzip directement)
extraire sur le bureau le fichier install.rdf
le renomé en txt
recherchez le maxVersion
changez le en 2.0.*
quittez/enregistrez
renomez le en rdf
et remettez le dans l'archive(clic droit sur le fichier>ajouter a l'archive)
renomez l'archive en xpi
si ff est ouvert fermez le
double clic sur le xpi install relance et votre extension fonctionne
testez pour ma part sur 2 extensions no pb

ex. pour 2panes bookmark

<'xml version="1.0"'>
<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:em="http://www.mozilla.org/2004/em-rdf#">
<Description about="urn:mozilla:install-manifest">

<em:id>{FD61379B-066A-4afc-89DE-89FB24D907C2}</em:id>

<em:version>0.1.2006012001</em:version>


<em:targetApplication>
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>0.8</em:minVersion>
<em:maxVersion>1.5.0.*</em:maxVersion>
</Description>
</em:targetApplication>
j'ai coupé pour pas faire trop long
donc changez le 1.5.0.* par 2.0.*

mais si on fait les extensions pour la bonne version c'est encore mieux car pas de boulot..
Le #160632
ouais enfin le problème de compatibilité n'est pas tout le temps un problème de numéro de version..
Le #160658
dron >J'ai déjà essayé ça une fois avec une extension ... et ca ne marchait pas.
De même j'ai déjà essayé de modifier une extension multilangue pour y rajouter le francais mais aprés ça, l'extension ne marchait plus (je me rappelle plus le message d'erreur)

En théorie, ca peut marcher, mais en pratique ça peut ne pas marcher.



Dans cet article, je retiens le fait que toutes les extensions seront testé avant rajout sur le site. Je ne suis pas sur que microsoft fasse pareil sur leur site qui répertorie des gadgets pour vista.
Le #160663
Et ils vont les certifer les addons' parcque ca le fait moyen d'aller sur un site officiel et de s'entendre dire que le "truc" qu'on essaye d'installer risque d'abimer notre machine.... surtout dans le climat actuel, les "nouveaux" sont desorientés, et ça enleve toute la crédibilité de cette mise en garde.
Le #160664
Jérôme G. une p'tite coquille s'est glissée dans le titre
Le #160665
KerTiaM>oups, vu
Le #160672
Jérôme G.>oups, vu

Vu mais pas corrigé '
Ya un "e" dans "nouveau"
Le #160692
@ dron, il y a aussi l'extension "Nightly Tester Tool" qui permet de faire ca automatiquement. Souvent cela fonctionne car c'est simplement que les auteurs de l'extension ont limite le MaxVersion.

Par contre si il y a vraiment incompatibilite, bonnes chances de bon gros plantage. C'est particulierement risque lors de grosses mises a jour du type 1.5>2.0 donc surement a reserve a l'utilisateur averti.
Le #160714
@ mops
ben je l'ai fait sur une dizaine et ca ne m'as pas posé de pb,par contre je m'en vais voir ton extension nyghtly tester car je connais pas.
Le #160718
Pour l'utilisateur qui chercherait à basculer vers mozille, il y a de quoi être plus que refroidi, si l'on en juge par les quelques interventions sur ce forum:

"copiez l'extension sur votre bureau
renomez la en ZIP (ou clic droit >ouvrir avec winzip directement)
extraire sur le bureau le fichier install.rdf
le renomé en txt
recherchez le maxVersion
changez le en 2.0.*
quittez/enregistrez"

etc...

etc...

Du simple comme on voit !

Ou encore plus fort:

" En théorie, ca peut marcher, mais en pratique ça peut ne pas marcher."

ou même:

" C'est particulierement risque lors de grosses mises a jour du type 1.5>2.0 donc surement a reserve a l'utilisateur averti."

Donc pourquoi faire simple comme IE7windaube, quand on peut faire très compliqué et très risqué comme mozille...

La preuve l'article lui même l'affirme: " lancement plusieurs fois avorté pour cause de migration de base de données délicate et autres bugs persistants "

Bref, rien qu'à lire tout ça, c'est pas demain la veille comme on dit que les hésitants vers IE7 vont se précipiter ailleurs ...
Suivre les commentaires
Poster un commentaire
Anonyme
:) ;) :D ^^ 8) :| :lol: :p :-/ :o :w00t: :roll: :( :cry: :facepalm:
:andy: :annoyed: :bandit: :alien: :ninja: :agent: :doh: :@ :sick: :kiss: :love: :sleep: :whistle: =]