Mozilla : nouvelle politique de support

Le par  |  13 commentaire(s) Source : Information Week
logo Mozilla

La fondation Mozilla revoit sa politique de support des différentes versions .

La fondation Mozilla revoit sa politique de support des différentes versions . Elle passe dorénavant à 6 mois.


Logo mozillaLa dernière mise à jour de sécurité marque la fin de l'édition 1.0.x de Firefox. Dans son communiqué, la fondation explique la fin du support des versions Firefox 1.0.x, Thunderbird 1.0.x et Mozilla Suite 1.7.x.


Nouvelle politique
Mozilla définit sa nouvelle politique de support en continuant bien entendu à sortir des mises à jour pour les versions en cours ( dans le cas de Firefox, il s'agit de la famille 1.5.x ). Mais tout support pour les versions précédentes cesseront 6 mois après l'introduction de l'édition la plus récente.

Ainsi, Firefox 1.5 est sorti au mois de novembre 2005. Lorsque la période de six mois sera écoulée, Mozilla arrêtera la support de la famille 1.0.x ( la date fixée est le 29 mai ). Ceci étant, les dernières mises à jour marquent la fin de la famille 1.0.x de Firefox, dixit le communiqué. On peut donc supposer qu'il n'y aura pas d'autres mises à jour pour cette version d'ici le 29 mai prochain.


Un cycle de vie court

Mozilla reconnaît que sa stratégie est orientée vers l'utilisateur final. Mais la modification de sa politique de support entraîne un cycle de vie du produit très court. Aussi, cela peut-il poser des problèmes pour les entreprises ayant fait le choix d'utiliser les logiciels de la Fondation.

Dans cette optique, Mozilla va accroître sa coopération avec ces entreprises, mais n'a pas donné plus de détails à ce sujet. A titre de comparaison, Microsoft offre un support de plus longue durée pour son navigateur. Ainsi, Internet Explorer 6 SP1 est sorti en août 2002 et sera supporté jusqu'en octobre 2006.

Sans doute la Fondation Mozilla espère-t-elle par cette mesure que les mises à jour se fasse plus rapidement, afin d'assurer le maximum de sécurité pour ses utilisateurs.

Complément d'information

Vos commentaires Page 1 / 2

Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Anonyme
Le #100924
[troll en CDI]
"tout support pour les versions précédentes cesseront 6 mois après l'introduction de l'édition la plus récente."

"Microsoft offre un support de plus longue durée pour son navigateur. Ainsi, Internet Explorer 6 SP1 est sorti en août 2002 et sera supporté jusqu'en octobre 2006."

=>c'est NORMAL que MS est un support plus long que celui de moz! Même si MS utilisait la politique de Moz, voire même de réduire à 1 mois le support des anciens IE, MS aurait un support plus long! ... vu qu'ils ne sortent rien de nouveau!

IE6 SP1 ou IE6 SP2 ça reste IE6 avec des failles corrigées!!!!
Le #100931
Même avec un produit "gratuit", il est très difficile pour une entreprise de changer de version de naviguateur tous les 6 mois.
Le #100934
a part si l'entreprise utilise ubuntu par exemple ou redhat, car les paquets sont mis à jour automatiquement ....
Le #100935
Cela va poser un véritable problème en entreprise (surtout moyennes et grandes) qui pratiquent un cycle de vie (hors patches) assez long (plusieurs années). Ainsi le SP2 n'est-il pas encore entré en service partout.
Si la mise à jour d'un 1.5.0.1 à un 1.5.0.2 ne pose pas de souci particulier (c'est du niveau d'un patch) un rythme de 6 mois contraindra les grosses entreprises à NE PAS CHOISIR Firefox.
Pourtant, ce ne sont là que les prémisses d'une évolution inéluctable. Avec les technologies récentes (Ajax, XUL) et la socialisation des applications (y compris celles d'entreprise et surtout côté client) le cycle de vie des applications va se raccourcir de plus en plus quitte à ce que ce soit l'utilisateur lui-même qui construit lui-même ses évolutions.
Aujourd'hui les grandes applications de back-office évoluent au rythme de 10 à 15 ans avec des évolutions mineures tous les 2 ou 3 ans.
Demain c'est plutôt de l'ordre de 4 à 5 ans avec des cycles mineurs de quelques semaines.
Donc ... forcément ça va coincer quelque part.

db
Le #100938
Firefox 1.0 est sorti le 9 novembre 2004
Firefox 1.0 arrête son support le 29 mai 2006

Firefox 1.0.x a vécu environ 1 an et demi et non 6 mois !
Le #100943
Panurge : +1

D'ailleurs, le produit dédié aux entreprises est Mozilla - et maintenant SeaMonkey - et non le couple Firefox / Thunderbird.
Le #100965
Non. Le monsieur il a dis 6 mois APRES la sortie d'une version PLUS RECENTE. Firefox 1.5 est sorti en décembre 2005.Donc en mai 2006, c'est la branche 1.0 qui ne sera plus supportée.

De plus, Mozilla Suite ne sera plus supporté par la Mozilla Corporation et SeaMonkey ne l'as jamais été.

C'est beaucoup trop court. Surtout, pour un produit comme Thunderbird dont la version 1.5 ne fonctionne pas alors que le 1.0.7 ne pose pas de problème. C'est à se demander s'il faut encore conseiller les produits Mozilla.

C'est pas avec cette politique de mise au rebus des anciennes versions que Mozilla Corp va séduire les entreprises.
Le #100972
Arrêtez de paniquer voyons ! Quand une nouvelle version sera disponible, une petite fenêtre demandera à l'employé de la grosse grosse entreprise : " Voulez-vous mettre à jour Firefox ' " Et il pourra choisir entre " Oui " et " Non ". Je pense que tout le monde est capable de répondre à ce genre de question
Le #100975
leviking : la 1.5 de Tbird ne fonctionne pas ' Merde, il faudra le dire à mon beau père qui l'utilise quotidiennement sans la moindre emmerde.

De plus, fx 1.5 est sorti fin novembre, et non en décembre 2005.

"C'est à se demander s'il faut encore conseiller les produits Mozilla."

Ne les conseille pas alors, et ne nous défèque pas une horloge pour autant.

Jusqu'à preuve du contraire, personne ne t'a foutu une mitrailleuse lourde contre la tempe en te disant : "installe la 1.5 de Tbird".

Si au lieu de raler, tu expliquais pourquoi tu dis que la 1.5 de Tbird ne fonctionne pas ce serait déjà un grand pas en avant.

Je dis cela, mais je dis rien.

Et j'en profite à dire à mes détracteurs qu'ils peuvent aller se faire cuire un oeuf.
Le #100995
Je ne pense pas que ça fasse du tort aux entreprises:
Au lieu que l'admin soit obligé d'appliquer le patch à son parc informatique, bein il installe une nouvelle version de FF (et puis c'est automatique)! et en ce qui concerne les plug-ins de FF et les incompatibilités qui apparaissent avec les nouvelles version, je ne sais pas l'étendue des plug-ins installés frequemment en entreprise, mais ça doit pas être fameux....
Suivre les commentaires
Poster un commentaire
Anonyme
:) ;) :D ^^ 8) :| :lol: :p :-/ :o :w00t: :roll: :( :cry: :facepalm:
:andy: :annoyed: :bandit: :alien: :ninja: :agent: :doh: :@ :sick: :kiss: :love: :sleep: :whistle: =]