0 0 ?

Le
Jacquouille
Bonjour
A1 = ZZZ 123
B1 = N(A1) --> 0
C1 = T(A1) > ZZZ 123

En A1, j'écris la valeur 0
B1=N(A1) --> 0
C1= T(A1) --> rien.

Question:
Pourquoi la formule N(A1) renvoie-t-elle 0 si A1=texte et 0 si A1= 0
Serait-ce le Vrai<> Faux -> 1<>0 ? Mais alors, pourquoi C1 ne
donne-t-il pas 0 pour T(A1) si A1=0 ?
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JPMonnier
Le #16574241
Bonsoir,
Il semble que T renvoie rien car 0 n'est pas du texte
si tu écris
=(T(TEXTE(A1;0))) ou =TEXTE(A1;0)
0 est renvoyé mais en format texte
--
Cordialement

"Jacquouille" news:
Bonjour
A1 = ZZZ 123
B1 = N(A1) -----> 0
C1 = T(A1) ------> ZZZ 123

En A1, j'écris la valeur 0
B1=N(A1) -----> 0
C1= T(A1) -----> rien.

Question:
Pourquoi la formule N(A1) renvoie-t-elle 0 si A1=texte et 0 si A1= 0
Serait-ce le Vrai<> Faux ----> 1<>0 ? Mais alors, pourquoi C1 ne
donne-t-il pas 0 pour T(A1) si A1=0 ?
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.




isabelle
Le #16574421
bonjour Jacquouille,

parce que :

pour T
si valeur est un nombre ou une valeur logique (VRAI, FAUX), du texte vide est renvoyé ()

et pour N

Si valeur est ou fait référence à du texte ou à la valeur logique FAUX, N renvoie 0

isabelle

Jacquouille a écrit :
Bonjour
A1 = ZZZ 123
B1 = N(A1) -----> 0
C1 = T(A1) ------> ZZZ 123

En A1, j'écris la valeur 0
B1=N(A1) -----> 0
C1= T(A1) -----> rien.

Question:
Pourquoi la formule N(A1) renvoie-t-elle 0 si A1=texte et 0 si A1= 0
Serait-ce le Vrai<> Faux ----> 1<>0 ? Mais alors, pourquoi C1 ne
donne-t-il pas 0 pour T(A1) si A1=0 ?


Daniel.C
Le #16574341
"Jacquouille" news:
Bonjour
A1 = ZZZ 123
B1 = N(A1) -----> 0
C1 = T(A1) ------> ZZZ 123

En A1, j'écris la valeur 0
B1=N(A1) -----> 0
C1= T(A1) -----> rien.

Question:
Pourquoi la formule N(A1) renvoie-t-elle 0 si A1=texte et 0 si A1= 0



N renvoie la valeur convertie en nombre, soit 0, alors que T renvoie "" si
la valeur n'est pas alphanumérique. Reporte à l'aide Excel.
Ce qui permet de récupérer dans tous les cas, une valeur numérique pour N et
une valeur texte pour T.
Cordialement.
Daniel
Jacquouille
Le #16574331
Merci Isabelle.....d'Outre Mare, sur ton nénuphar ?
Si c'est oui, j'ai procuration du Vieux Grincheux pour te faire la bise, à
l'abri de l'ire Vaticane. -)))
Bonne soirée
Jacques

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"isabelle" a écrit dans le message de news:
%
bonjour Jacquouille,

parce que :

pour T
si valeur est un nombre ou une valeur logique (VRAI, FAUX), du texte vide
est renvoyé ()

et pour N

Si valeur est ou fait référence à du texte ou à la valeur logique FAUX, N
renvoie 0

isabelle

Jacquouille a écrit :
Bonjour
A1 = ZZZ 123
B1 = N(A1) -----> 0
C1 = T(A1) ------> ZZZ 123

En A1, j'écris la valeur 0
B1=N(A1) -----> 0
C1= T(A1) -----> rien.

Question:
Pourquoi la formule N(A1) renvoie-t-elle 0 si A1=texte et 0 si A1= 0
Serait-ce le Vrai<> Faux ----> 1<>0 ? Mais alors, pourquoi C1 ne
donne-t-il pas 0 pour T(A1) si A1=0 ?




Publicité
Poster une réponse
Anonyme