1ere install /Probleme avec startx

Le
Matsumura
Bonjour all;


J 'ai un soucis pour ouvrir une session graphique sous free bsd.

Quand j'entre la commande startx le mode graphique ne se lance pas.

Quelqu un aurait-il une idée quelquonque?

Merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
kavanier
Le #887305
On May 20, 9:42 pm, Matsumura
Bonjour all;
bonsoir


Quand j'entre la commande startx le mode graphique ne se lance pas.
c'est un peu pauvre la !

avez vous fait une install de Xorg ?
sans ça vous allez pas aller loin :)

si Xorg est bien mis sur votre station et que 'startx' ne vous donne
rien de graphique
elle va de toute façon vous donner des messages d'erreur style "EE=="
si vous pouvez nous les donner ,
on va peut etre pouvoir faire qq'chose pour vous :)

ceci dit j'ai fort à parier que vous avez pas configurer votre
Xorg.conf
pour cela "X -configure"

mais bon avez vous lu ceci ?
http://www.freebsd.org/doc/fr_FR.ISO8859-1/books/handbook/x11.html
et même cela ?
http://www.freebsd.org/doc/fr_FR.ISO8859-1/books/handbook/

Merci d'avance.
de rien


Paul Gaborit
Le #887304
À (at) 20 May 2007 14:19:33 -0700,
écrivait (wrote):
On May 20, 9:42 pm, Matsumura
Bonjour all;
bonsoir


Quand j'entre la commande startx le mode graphique ne se lance pas.
c'est un peu pauvre la !

avez vous fait une install de Xorg ?
sans ça vous allez pas aller loin :)


Dans l'hypothèse où Xorg n'est pas encore installé, c'est le moment de
mettre à jour l'arbre des ports pour éviter un passage de Xorg 6.9 à
Xorg 7.2 qui risque d'être un peu pénible. ;-)

--
Paul Gaborit -

Matsumura
Le #887302
À (at) 20 May 2007 14:19:33 -0700,
écrivait (wrote):
On May 20, 9:42 pm, Matsumura
Bonjour all;
bonsoir


Quand j'entre la commande startx le mode graphique ne se lance pas.
c'est un peu pauvre la !

avez vous fait une install de Xorg ?
sans ça vous allez pas aller loin :)


Dans l'hypothèse où Xorg n'est pas encore installé, c'est le moment de
mettre à jour l'arbre des ports pour éviter un passage de Xorg 6.9 à
Xorg 7.2 qui risque d'être un peu pénible. ;-)

Et bien merci de vos reponses.

J'ai installé freebsd hier soir et je travaillais aujourd hui.

J 'appronfondi la question se soir avec vos conseils.
C'est vrai qu en me relisant aujourd hui je ne vous ai pas fourni
beaucoup d'éléments :(.

Je vous tiens au courant dès que j'ai résolu mon affaire.

merci de votre aide ;)



David Marec
Le #891796
Paul Gaborit :

Dans l'hypothèse où Xorg n'est pas encore installé, c'est le moment de
mettre à jour l'arbre des ports pour éviter un passage de Xorg 6.9 à
Xorg 7.2 qui risque d'être un peu pénible. ;-)


Bon surprise: en fait, non.
Mis à part l'installation du méta-port «xorg», tout s'est déroulé comme
indiqué dans UPDATING.

Mis à part xfs qui refuse de fonctionner; mais je n'ai pas creusé la
question.

--
www.daiblotins.org

David Marec
Le #891795
Paul Gaborit :

Dans l'hypothèse où Xorg n'est pas encore installé, c'est le moment de
mettre à jour l'arbre des ports pour éviter un passage de Xorg 6.9 à
Xorg 7.2 qui risque d'être un peu pénible. ;-)


Bon surprise: en fait, non.
Mis à part l'installation du méta-port «xorg», tout s'est déroulé comme
indiqué dans UPDATING.

Par contre, xfs refuse de fonctionner; mais je n'ai pas creusé la
question.

--
www.daiblotins.org

kavanier
Le #891607
Xorg 7.2 qui risque d'être un peu pénible. ;-)


Bon surprise: en fait, non.
"Welcome, fearless user!"

chez moi si , c'est penible

comme indiqué indiqué dans UPDATING.
oui j'ai fais tout bien !! comme le monsieur Kennaway à dit :)

mais non j'ai libX qui me donne des erreurs de compil .

bref à mon avis c'est bibi qui encore mal fait les choses :)
je vais voir ça demain.

(david votre mail (free) ne marche plus ?)


kavanier
Le #891606
Xorg 7.2 qui risque d'être un peu pénible. ;-)


Bon surprise: en fait, non.
""Welcome, fearless user!""

chez moi si , c'est penible !

comme indiqué indiqué dans UPDATING.


oui j'ai fait tout bien !! comme le monsieur Kennaway à dit :)
mais non j'ai libX qui me donne des erreurs de compil.

bref à mon avis c'est bibi qui encore mal fait les choses :)
je vais voir ça demain.


(david votre mail (free) ne marche plus ?)


Paul Gaborit
Le #891421
À (at) Tue, 22 May 2007 20:31:54 +0200,
David Marec
Paul Gaborit :

Dans l'hypothèse où Xorg n'est pas encore installé, c'est le moment de
mettre à jour l'arbre des ports pour éviter un passage de Xorg 6.9 à
Xorg 7.2 qui risque d'être un peu pénible. ;-)


Bon surprise: en fait, non.


C'est pénible... au moins pour le temps que ça prend ! ;-)

Mis à part l'installation du méta-port «xorg», tout s'est déroulé comme
indiqué dans UPDATING.

Par contre, xfs refuse de fonctionner; mais je n'ai pas creusé la
question.


Personnellement, je n'ai toujours pas trouvé le script de migration
évoqué dans UPDATING. J'ai donc fait ma sauce à moi :

1- Stockage de la liste de tous les packages installés
(via 'pkg_cutleaves -l').

2- Désinstallation de xorg (6.x) et de tous les packages qui en
dépendent...

3- Mise à jour de tous les packages restants ('portupgrade -ar').

4- Effacement brutal de /usr/X11R6 et remplacement par un lien vers
/usr/local pour les éventuels ports non corrigés.

5- Installation du meta-port 'xorg' (7.x).

6- Correction des chemins dans /etc/X11/xorg.conf

7- Installation de tous les packages manquants de la liste (1).

Et ça marche nickel (pour l'instant). Ça m'a pris juste une
nuit... d'où l'aspect pénible.

Il faut maintenant que j'essaie 'compiz' juste pour tester
quelques-unes de nouveautés de xorg 7.x. ;-)

--
Paul Gaborit -

Paul Gaborit
Le #891417
À (at) Wed, 23 May 2007 15:46:32 +0200,
(Xavier) écrivait (wrote):
Paul Gaborit
Personnellement, je n'ai toujours pas trouvé le script de migration
évoqué dans UPDATING. J'ai donc fait ma sauce à moi :


Pourtant, je l'ai bel et bien, et exécuté sur mes machines...


Est-il possible d'avoir son chemin d'accès (qui n'est pas précisé dans
UPDATING) ?

PS: habituellement (par exemple pour GNOME), l'URL ou le chemin de ce
genre de script est donné dans UPDATING...

--
Paul Gaborit -

Paul Gaborit
Le #891222
À (at) Wed, 23 May 2007 17:51:37 +0200,
(Xavier) écrivait (wrote):
Paul Gaborit
Est-il possible d'avoir son chemin d'accès (qui n'est pas précisé dans
UPDATING) ?


Dans UPDATING, j'ai ça :
[... extrait de UPDATING...]


Ça y est ! J'ai compris ! Merci. ;-)

Mon anglais approximatif combiné à une lecture un peu trop rapide me
faisait croire qu'il existait un script xorg-update ! Le xorg-update
n'est en fait que l'enregistrement de ce qu'on fait pour pouvoir
éventuellement l'envoyer... ou le réutiliser.

En fait, c'est aussi bien comme ça. Finalement, je trouve ma méthode
beaucoup plus simple et sûre (dans mon cas) que le procédure décrite.

--
Paul Gaborit -

Publicité
Poster une réponse
Anonyme