2 questions : mise en page et sous-formulaire

Le
Séb
Bonjour,

N'ayant pu trouver la réponse à mes questions sur le net, je me permets de
les poser ici (Access 2003).

- Lorsque je place mes contrôles sur mes formulaires, je n'arrive pas à les
placer précisément, je me retrouve toujours avec des propriétés "largeur" ou
"haut" avec 3 chiffres après la virgule. N'y a-t-il pas un système de
"grille magnétique" comme sous Word ou Visual Studio 2005, pour aider au
design de formulaire ?

- Dans une de mes bases, j'ai un formulaire lié à une table, et un
sous-formulaire lié à une autre table. Le problème est que quand j'arrive
sur un enregistrement principal où il n'y a pas d'entrée dans le
sous-formulaire et que je veux en créer une, le moindre caractère saisi me
renvoie un "Le paramètre de la propriété Champs pères est à l'origine de
l'erreur suivante : attendu identificateur".
Hors, la propriété "Champ père" de mon sous-formulaire est bien paramétré et
pointe vers la clé de ma table principale. J'ai supprimé mon
sous-formulaire, recréé celui-ci, mais rien n'y change.

Une idée ?
Merci,

Séb
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Séb
Le #6338411
Bonjour,

Pour préciser un peu, après tests :
J'ai refait une version simplifié de mon formulaire et de son
sous-formulaire. Je n'ai pas encore trouvé la propriété qui pose problème,
mais j'ai vu que normalement, le champ "id" dans mon sous-formulaire devrait
être rempli automatiquement, même quand il n'y a pas de sous-enregistrement,
hors ça n'est pas le cas dans la version qui pose problème. Y a-t-il quelque
chose à modifier pour cela ?

Merci pour votre aide,

Séb



"Séb"
Bonjour,

N'ayant pu trouver la réponse à mes questions sur le net, je me permets de
les poser ici (Access 2003).

- Lorsque je place mes contrôles sur mes formulaires, je n'arrive pas à
les placer précisément, je me retrouve toujours avec des propriétés
"largeur" ou "haut" avec 3 chiffres après la virgule. N'y a-t-il pas un
système de "grille magnétique" comme sous Word ou Visual Studio 2005, pour
aider au design de formulaire ?

- Dans une de mes bases, j'ai un formulaire lié à une table, et un
sous-formulaire lié à une autre table. Le problème est que quand j'arrive
sur un enregistrement principal où il n'y a pas d'entrée dans le
sous-formulaire et que je veux en créer une, le moindre caractère saisi me
renvoie un "Le paramètre de la propriété Champs pères est à l'origine de
l'erreur suivante : attendu identificateur".
Hors, la propriété "Champ père" de mon sous-formulaire est bien paramétré
et pointe vers la clé de ma table principale. J'ai supprimé mon
sous-formulaire, recréé celui-ci, mais rien n'y change.

Une idée ?
Merci,

Séb


3stone
Le #6338361
Salut,

Pour l'histoire de la grille, regarde dans les propriétés du formulaire:
Onglet Format, Grille X, Grille Y
Teste la valeur 1, 2 et 4... tu comprendras rapidement ;-)

Ta clé externe, est-elle, dans la table, en relation avec la clé primaire
de la table source du formulaire principal ?
et as-tu activé l'intégrité référentielle et la mise à jour en cascade ?

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)




"Séb"
| Pour préciser un peu, après tests :
| J'ai refait une version simplifié de mon formulaire et de son
| sous-formulaire. Je n'ai pas encore trouvé la propriété qui pose problème,
| mais j'ai vu que normalement, le champ "id" dans mon sous-formulaire devrait
| être rempli automatiquement, même quand il n'y a pas de sous-enregistrement,
| hors ça n'est pas le cas dans la version qui pose problème. Y a-t-il quelque
| chose à modifier pour cela ?
|
| Merci pour votre aide,
|
| Séb
|
|
|
| "Séb" |
| > Bonjour,
| >
| > N'ayant pu trouver la réponse à mes questions sur le net, je me permets de
| > les poser ici (Access 2003).
| >
| > - Lorsque je place mes contrôles sur mes formulaires, je n'arrive pas à
| > les placer précisément, je me retrouve toujours avec des propriétés
| > "largeur" ou "haut" avec 3 chiffres après la virgule. N'y a-t-il pas un
| > système de "grille magnétique" comme sous Word ou Visual Studio 2005, pour
| > aider au design de formulaire ?
| >
| > - Dans une de mes bases, j'ai un formulaire lié à une table, et un
| > sous-formulaire lié à une autre table. Le problème est que quand j'arrive
| > sur un enregistrement principal où il n'y a pas d'entrée dans le
| > sous-formulaire et que je veux en créer une, le moindre caractère saisi me
| > renvoie un "Le paramètre de la propriété Champs pères est à l'origine de
| > l'erreur suivante : attendu identificateur".
| > Hors, la propriété "Champ père" de mon sous-formulaire est bien paramétré
| > et pointe vers la clé de ma table principale. J'ai supprimé mon
| > sous-formulaire, recréé celui-ci, mais rien n'y change.
| >
| > Une idée ?
| > Merci,
| >
| > Séb
|
Publicité
Poster une réponse
Anonyme