[2003-XP] problème avec Netlogon et le serveur RPC

Le
William Marie
Bonjour à tous. Je reposte ce message que j'ai déjà posté il y a une
semaine sur le forum Usenet Windows serveur, mais sans même attirer ne
fut-ce que de la commisération.
--
Je ne l'avais pas encore eu, celle là, jusque là, m'étais-je dis
naïvement, pour faire une relation client serveur il faut juste que le
réseau marche. Mais pas seulement.

Voilà l'affaire : sur une nouvelle machine (Core2 Duo), j'installe 3
Windows XP Pro, un de secours, un principal et un autre réservé aux jeux et
vidéos. Seul le 2e devra être membre du domaine. J'utilise donc la bascule
Groupe de travail/domaine de propriétés système, pas de problème, la fenêtre
de login pour le compte admin du domaine apparaît tout de suite et
l'opération est vite faite, bien faite.

Mais au redémarrage, bien que rien ne cloche en apparence, j'ai du rouge
dans l'observateur d'évènements (système) de Netlogon : "Aucun contrôleur de
domaine n'est disponible à cause de l'erreur suivante : le serveur RPC n'a
pas répondu". Première fois que j'entendai parler de ce serveur RPC. Petite
recherche sur Google où il est surtout question d'ennuis avec des
imprimantes, des modems, assez peu dans mon cas. De plus il y avait des
dysfonctionnements notables alors que j'arrive à loguer un admin du domaine
sur le poste client. Nslookup donne bien la machine contrôleur du domaine,
rien d'anormal côté serveur (Win 2003) le nom de l'appareil est bien inscrit
dans les computers d'AD et dans le DNS. Il est d'ailleurs facile de remettre
la machine en groupe de travail proprement. Bien sûr j'ai vérifié les
services : ce fichu "Appel de procédure distante (RPC)" est bien démarré,
idem pour son complément "Lanceur de procédure DCOM". En complément de ce
message il y en a d'autres concernant W32Time qui sont la conséquence du
premier.

Et le plus drôle c'est que je n'ai aucun ennui de ce genre avec le
Windows n° 1 (de secours) : après avoir régressé en groupe de travail (et en
nettoyant les inscriptions résiduelles sur le serveur dans AD et DNS), je
peux, de la même façon, mettre le premier Windows en membre du domaine et là
aucune erreur ! Je précise qu'à ce stade des installations il n'y a aucune
différence de logiciels entre les Windows. J'ai poussé le vice jusqu'à
désinstaller et réinstaller le Windows n° 2 mais c'était pareil (OK, le
temps toulousain est dégueu, mais je préfèrerais faire des choses plus
malines).

Donc si vous avez le commencement d'une hypothèse j'aprécierais beaucoup.

Faut quand même que je vous dise que le Win 2003 Server est installé sur
une machine poussive (un Athlon zozio du tonnerre 1.44) mais à laquelle je
n'ai jamais rien eu à reprocher auparavant (surtout pour mon usage amateur).
Le Core2 Duo à l'autre bout peut piaffer d'impatience, mais cela
n'expliquerait pas pour quoi ça fonctionne sans bavure avec le 1er Windows
et pas le deuxième (et, bien sûr, c'est du deuxième que j'ai besoin comme
membre du domaine).

Je reconnais : c'est vicelard.
--

William Marie
Attention antiSpam remplacer trapellun.invalid
par free.fr
Web : http://wmarie.free.fr
http://www.pandemonium.dnsalias.org (site expérimental)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jonathan BISMUTH
Le #727505
Bonjour William,

comment sont configurés tes DNS, sur le client n°2? Sur le serveur?
As tu ajouté un / des suffixes DNS autres que ceux de ton domaine?

Cordialement,
--
Jonathan BISMUTH
MVP Windows Server - Directory Services
MCSE 2000/ADSI-AutoIT Scripter
Transcript (ID: 691839, code: MCSE2000)
www.portail-mcse.net

"William Marie"
Bonjour à tous. Je reposte ce message que j'ai déjà posté il y a une
semaine sur le forum Usenet Windows serveur, mais sans même attirer ne
fut-ce que de la commisération.
-----------
Je ne l'avais pas encore eu, celle là, jusque là, m'étais-je dis
naïvement, pour faire une relation client serveur il faut juste que le
réseau marche. Mais pas seulement.

Voilà l'affaire : sur une nouvelle machine (Core2 Duo), j'installe 3
Windows XP Pro, un de secours, un principal et un autre réservé aux jeux
et
vidéos. Seul le 2e devra être membre du domaine. J'utilise donc la bascule
Groupe de travail/domaine de propriétés système, pas de problème, la
fenêtre
de login pour le compte admin du domaine apparaît tout de suite et
l'opération est vite faite, bien faite.

Mais au redémarrage, bien que rien ne cloche en apparence, j'ai du rouge
dans l'observateur d'évènements (système) de Netlogon : "Aucun contrôleur
de
domaine n'est disponible à cause de l'erreur suivante : le serveur RPC n'a
pas répondu". Première fois que j'entendai parler de ce serveur RPC.
Petite
recherche sur Google où il est surtout question d'ennuis avec des
imprimantes, des modems, assez peu dans mon cas. De plus il y avait des
dysfonctionnements notables alors que j'arrive à loguer un admin du
domaine
sur le poste client. Nslookup donne bien la machine contrôleur du domaine,
rien d'anormal côté serveur (Win 2003) le nom de l'appareil est bien
inscrit
dans les computers d'AD et dans le DNS. Il est d'ailleurs facile de
remettre
la machine en groupe de travail proprement. Bien sûr j'ai vérifié les
services : ce fichu "Appel de procédure distante (RPC)" est bien démarré,
idem pour son complément "Lanceur de procédure DCOM". En complément de ce
message il y en a d'autres concernant W32Time qui sont la conséquence du
premier.

Et le plus drôle c'est que je n'ai aucun ennui de ce genre avec le
Windows n° 1 (de secours) : après avoir régressé en groupe de travail (et
en
nettoyant les inscriptions résiduelles sur le serveur dans AD et DNS), je
peux, de la même façon, mettre le premier Windows en membre du domaine et

aucune erreur ! Je précise qu'à ce stade des installations il n'y a aucune
différence de logiciels entre les Windows. J'ai poussé le vice jusqu'à
désinstaller et réinstaller le Windows n° 2 mais c'était pareil (OK, le
temps toulousain est dégueu, mais je préfèrerais faire des choses plus
malines).

Donc si vous avez le commencement d'une hypothèse j'aprécierais
beaucoup.

Faut quand même que je vous dise que le Win 2003 Server est installé sur
une machine poussive (un Athlon zozio du tonnerre 1.44) mais à laquelle je
n'ai jamais rien eu à reprocher auparavant (surtout pour mon usage
amateur).
Le Core2 Duo à l'autre bout peut piaffer d'impatience, mais cela
n'expliquerait pas pour quoi ça fonctionne sans bavure avec le 1er Windows
et pas le deuxième (et, bien sûr, c'est du deuxième que j'ai besoin comme
membre du domaine).

Je reconnais : c'est vicelard.
--
=================================== > William Marie
Attention antiSpam remplacer trapellun.invalid
par free.fr
Web : http://wmarie.free.fr
http://www.pandemonium.dnsalias.org (site expérimental)
=================================== >



William Marie
Le #726646
"Jonathan BISMUTH" uUe3Z$
Bonjour William,

comment sont configurés tes DNS, sur le client n°2? Sur le serveur?
As tu ajouté un / des suffixes DNS autres que ceux de ton domaine?

Bien simple : je ne fais rien (c'est dans ma nature :-) ) et ça a

toujours fonctionné. Le suffixe du domaine est automatiquement ajouté au nom
d'ordi (qui se retrouve dans tous les cas inscrit, comme il convient, dans
le DNS dans la zone du domaine dynamique gérée par AD et dans la rubrique
Computers de AD).

Autrement je ne vois rien qui diffère entre le Windows n° 1 (appelé
"Castor-Pollux-1") et le Windows n° 2 (appelé "Castor-Pollux-2"). Je me suis
même posé la question si le nom n'était pas trop long et s'il n'y avait pas
un gag de troncature, mais même en le renommant "CastPol" c'est pareil.

Bouhouhou, c'est toujours sur moi que tombent les gags non répertoriés !
--
=================================== William Marie
Attention antiSpam remplacer trapellun.invalid
par free.fr
Web : http://wmarie.free.fr
http://www.pandemonium.dnsalias.org (site expérimental)
====================================

oronanac
Le #735504
Bonjour,
je veux essayer de proposer une aide: En réalité tu as Deux machines réelles
avec un controleur à OS SV2003unique et un poste client avec un OS XP pro en
multiboot(seul 1 sera détecté au démarrage et contiendra tout les coordonnées
distribués au deux autres par le seul contrôleur-carte mère démarré). Si
c'est le cas Windows Serveur n'est pas encore arrivé à dissocier des
partition sur un même disque en tant que OScomme machine.
Merci.
--
La maîtrise de la lumière c''''est l''élévation dans la vie"
:http://www.boeing.com/companyoffices/gallery/screen/screen.htm.



Bonjour à tous. Je reposte ce message que j'ai déjà posté il y a une
semaine sur le forum Usenet Windows serveur, mais sans même attirer ne
fut-ce que de la commisération.
-----------
Je ne l'avais pas encore eu, celle là, jusque là, m'étais-je dis
naïvement, pour faire une relation client serveur il faut juste que le
réseau marche. Mais pas seulement.

Voilà l'affaire : sur une nouvelle machine (Core2 Duo), j'installe 3
Windows XP Pro, un de secours, un principal et un autre réservé aux jeux et
vidéos. Seul le 2e devra être membre du domaine. J'utilise donc la bascule
Groupe de travail/domaine de propriétés système, pas de problème, la fenêtre
de login pour le compte admin du domaine apparaît tout de suite et
l'opération est vite faite, bien faite.

Mais au redémarrage, bien que rien ne cloche en apparence, j'ai du rouge
dans l'observateur d'évènements (système) de Netlogon : "Aucun contrôleur de
domaine n'est disponible à cause de l'erreur suivante : le serveur RPC n'a
pas répondu". Première fois que j'entendai parler de ce serveur RPC. Petite
recherche sur Google où il est surtout question d'ennuis avec des
imprimantes, des modems, assez peu dans mon cas. De plus il y avait des
dysfonctionnements notables alors que j'arrive à loguer un admin du domaine
sur le poste client. Nslookup donne bien la machine contrôleur du domaine,
rien d'anormal côté serveur (Win 2003) le nom de l'appareil est bien inscrit
dans les computers d'AD et dans le DNS. Il est d'ailleurs facile de remettre
la machine en groupe de travail proprement. Bien sûr j'ai vérifié les
services : ce fichu "Appel de procédure distante (RPC)" est bien démarré,
idem pour son complément "Lanceur de procédure DCOM". En complément de ce
message il y en a d'autres concernant W32Time qui sont la conséquence du
premier.

Et le plus drôle c'est que je n'ai aucun ennui de ce genre avec le
Windows n° 1 (de secours) : après avoir régressé en groupe de travail (et en
nettoyant les inscriptions résiduelles sur le serveur dans AD et DNS), je
peux, de la même façon, mettre le premier Windows en membre du domaine et là
aucune erreur ! Je précise qu'à ce stade des installations il n'y a aucune
différence de logiciels entre les Windows. J'ai poussé le vice jusqu'à
désinstaller et réinstaller le Windows n° 2 mais c'était pareil (OK, le
temps toulousain est dégueu, mais je préfèrerais faire des choses plus
malines).

Donc si vous avez le commencement d'une hypothèse j'aprécierais beaucoup.

Faut quand même que je vous dise que le Win 2003 Server est installé sur
une machine poussive (un Athlon zozio du tonnerre 1.44) mais à laquelle je
n'ai jamais rien eu à reprocher auparavant (surtout pour mon usage amateur).
Le Core2 Duo à l'autre bout peut piaffer d'impatience, mais cela
n'expliquerait pas pour quoi ça fonctionne sans bavure avec le 1er Windows
et pas le deuxième (et, bien sûr, c'est du deuxième que j'ai besoin comme
membre du domaine).

Je reconnais : c'est vicelard.
--
=================================== > William Marie
Attention antiSpam remplacer trapellun.invalid
par free.fr
Web : http://wmarie.free.fr
http://www.pandemonium.dnsalias.org (site expérimental)
=================================== >




William Marie
Le #735503
"oronanac" news:
Bonjour,
je veux essayer de proposer une aide: En réalité tu as Deux machines
réelles
avec un controleur à OS SV2003unique et un poste client avec un OS XP pro
en
multiboot(seul 1 sera détecté au démarrage et contiendra tout les
coordonnées
distribués au deux autres par le seul contrôleur-carte mère démarré). Si
c'est le cas Windows Serveur n'est pas encore arrivé à dissocier des
partition sur un même disque en tant que OScomme machine.
Merci.


Ca je connais ! Mettre des Windows installés sur la même machine en
membres du domaine provoque des disfonctionnements. L'adresse Mac de la
carte étant la même, le serveur DHCP donne bien la même adresse et c'est une
source de confusion. Donc un seul Windows peut être membre du domaine (les
deux autres restent en Workgroup)

Bien sûr, dans ma manip je n'avais au départ mis en domaine que le 2e
Windows XP (le principal), c'est en voyant les erreurs de Netlogon que j'ai
essayé de voir ce qui se passait si je mettais en domaine le Windows 1.
Après, bien sûr, avoir retiré le 2e du domaine et fait le ménage des traces
dans le serveur DNS et dans Active Directory.

Donc ça n'explique toujours pas ce qui ne plait pas à ce fichu serveur
RPC (ce n'est pas un problème strict domaine et AD) dans le Windows 2 alors
que ça passe très bien dans le Windows 1.
--
=================================== William Marie
Attention antiSpam remplacer trapellun.invalid
par free.fr
Web : http://wmarie.free.fr
http://www.pandemonium.dnsalias.org (site expérimental)
====================================

Publicité
Poster une réponse
Anonyme