[2010] Graphiques

Le
Péhemme
Bonjour à Tous,

Je modifie mes barres d'outils ex-2003 et antérieures qui fonctionnent
parfaitement bien via l'onglet "complément" en ruban sans modification de
mes macros.
Méthodologie :
. je sauvegarde mon fichier sous un autre nom
. je construis le ruban
. je rattache mes macros aux callbacks
Tout fonctionne parfaitement bien.
Cependant, sur une de mes applications avec graphiques mis à jour
automatiquement toutes les semaines, j'observe que les valeurs indiquées
lors du pointage de la souris sur les différentes courbes sont divisées par
10000 (par exemple : 0.0070 au lieu de 70 ou 0.0052 au lieu de 52, etc.).
Les valeurs :
. des données sources sont correctes
. des axes verticaux sont correctes.
J'ai beau chercher, je ne vois pas ce qui peut provoquer cette
transformation ni même si on peut agir entre les données sources et celles
indiquées (automatiquement) sur le graphique.
Je vous remercie par avance des idées et suggestions afin de solutionner ce
désagrément.
Bien amicalement
Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #25965172
Bonjour,

La seule chose à laquelle je pense présentement et qui divise un nombre
automatiquement par mille (excluant l'opération mathématique)
est un format de nombre.

À titre d'exemple dans une cellule, la valeur 12555
si j'applique ce format ###0 ,#### (note bien la présence de
l'espace entre le 0 et la virgule, l'affichage devient comme ceci : 12,555
Péhemme
Le #25965402
Bonjour Denis, bonjour à tous,

si j'applique ce format ###0 ,####


Entre ma source et le graphique ?
Les valeurs mentionnées sur mon tableau source sont correctement libellées,
du style :
- 80,0312
- 82,0311
- 58,0711
- ...
- 70,0309
Je ne fais aucune manipulation entre ce tableau source et le graphique.
Pire :
Ce tableau source est renseigné automatiquement à la fin d'une macro de
calculs par un copier/collage spécial valeurs.
Ce tableau source est correctement rempli, mon graphique aussi sauf cette
information (au passage de la souris) de toutes les valeurs des séries
divisées par 10 000.
En revanche :
- j'efface ces dernières valeurs de mon tableau source ;
- je fais le copier/coller spécial à la main...
=> le graphique se constitue toujours correctement *et* les valeurs des
séries sont alors correctement mentionnées.
Je pense que le problème se situe au niveau de la constitution de la "table
de données". En effet, les données sont "fausses" dans le 1er cas et
"justes" dans le second. Pourquoi ?... Il n'y a aucune intervention humaine.
Je m'arrache les cheveux...
À tout hasard, le graphique : http://cjoint.com/?DAFp2REM8V7
Pour être complet, j'ai un second graphique qui s'élabore de façon similaire
sans rencontrer aucune difficultés.
Merci d'avance pour toutes idées complémentaires.
Michel


"MichD" a écrit dans le message de groupe de discussion :
lcg3dl$3o1$

Bonjour,

La seule chose à laquelle je pense présentement et qui divise un nombre
automatiquement par mille (excluant l'opération mathématique)
est un format de nombre.

À titre d'exemple dans une cellule, la valeur 12555
si j'applique ce format ###0 ,#### (note bien la présence de
l'espace entre le 0 et la virgule, l'affichage devient comme ceci : 12,555
MichD
Le #25965852
Une image ce n'est pas très parlant lorsqu'on veut savoir ce qu'il y a
derrière!

Est-ce possible de publier ton fichier, seulement ce qui est strictement
nécessaire
à la démonstration. Tu peux modifier les données à volonté ou les noms...
Pour ce
faire, utilise cette adresse Cjoint.

Si tu utilises la même macro, tu devrais obtenir le même résultat nonobstant
le fait que les données soient différentes.

Par exemple, si tu as 25599 dans une cellule, si dans le format de la
cellule
tu as utilisé le point au lieu de la virgule, tu obtiendras ceci :

Contenu de la cellule 25599
format personnalisé de la cellule 0.0000
Affichage dans la cellule 2.5599

Cela à cause du séparateur décimal.
Péhemme
Le #25966792
Tu as naturellement raison sur tous les points, mais mes observations ne
sont pas de cet ordre.

Ma préoccupation ne concerne que le format des valeurs des séries indiqué
dans la "bulle" lors du passage de la souris sur les différents points du
graphique.

Le fichier expurgé : http://cjoint.com/?DBbonug1Csy
Je te propose :
a) tu observes à la souris le format des valeurs indiquées sur le 1er
graphique
b) tu cliques sur le premier bouton à gauche ("Mise à Jour") de la tab
personnalisée.
c) tu regardes à nouveau le format des valeurs sur le graphique

De mon côté, je ne comprends rien. J'ai même détruit et reconstruit un
graphique pour observer ce même comportement.
Un évènement doit se produire sans que je sois capable de le localiser.
Michel


"MichD" a écrit dans le message de groupe de discussion :
lch1b9$j30$

Une image ce n'est pas très parlant lorsqu'on veut savoir ce qu'il y a
derrière!

Est-ce possible de publier ton fichier, seulement ce qui est strictement
nécessaire
à la démonstration. Tu peux modifier les données à volonté ou les noms...
Pour ce
faire, utilise cette adresse Cjoint.

Si tu utilises la même macro, tu devrais obtenir le même résultat nonobstant
le fait que les données soient différentes.

Par exemple, si tu as 25599 dans une cellule, si dans le format de la
cellule
tu as utilisé le point au lieu de la virgule, tu obtiendras ceci :

Contenu de la cellule 25599
format personnalisé de la cellule 0.0000
Affichage dans la cellule 2.5599

Cela à cause du séparateur décimal.
MichD
Le #25966922
La source des données des courbes de ton graphe est
dans la feuille "DataGraph". Les valeurs affichées sont de
cette nature :
Mathilde 95,0602 86,0603
Michel 95,0602 94,0603
Michèle 109,1002 102,1003
Patrick 103,0602 88,0603
Patrick A 101,0302 94,0303
Roger 113,0402 92,0403
Sébastien 107,0802 98,0802
Yves 115,0602 92,0603

Quand je regarde dans les bulles associées à chacun des points
de ton graphe, je retrouve la valeur qui est indiquée dans la feuille
"DataGraph".

Aucun nombre n'est divisé par 100 ou par 1000.

Regarde dans les options avancées d'Excel, est-ce possible que l'option
"décimale fixe"
soit cochée sur ta version Excel?

Voilà ton fichier : Je n'ai touché à rien! http://cjoint.com/?DBbppOJBVbQ

Est-ce que ton problème est autre chose que je n'ai pas comprise dans ta
question?
MichD
Le #25966912
Image d'un de tes points tels qu'ils apparaissent sur mon écran :
http://cjoint.com/?DBbpvJb4vLP
Péhemme
Le #25966952
Tout ceci est vrai. C'est le point de départ.
Clique maintenant sur "Mise à Jour" et observe ce qui ce passe dans les
bulles d'informations sur le graph.
Dis-moi.
Je viens de refaire le test sur le fichier issu de cjoint et j'observe le
phénomène.
Michel


"MichD" a écrit dans le message de groupe de discussion :
lcivll$sej$


La source des données des courbes de ton graphe est
dans la feuille "DataGraph". Les valeurs affichées sont de
cette nature :
Mathilde 95,0602 86,0603
Michel 95,0602 94,0603
Michèle 109,1002 102,1003
Patrick 103,0602 88,0603
Patrick A 101,0302 94,0303
Roger 113,0402 92,0403
Sébastien 107,0802 98,0802
Yves 115,0602 92,0603

Quand je regarde dans les bulles associées à chacun des points
de ton graphe, je retrouve la valeur qui est indiquée dans la feuille
"DataGraph".

Aucun nombre n'est divisé par 100 ou par 1000.

Regarde dans les options avancées d'Excel, est-ce possible que l'option
"décimale fixe"
soit cochée sur ta version Excel?

Voilà ton fichier : Je n'ai touché à rien! http://cjoint.com/?DBbppOJBVbQ

Est-ce que ton problème est autre chose que je n'ai pas comprise dans ta
question?
MichD
Le #25967102
C'est quoi le problème alors? J'ai de la difficulté à te suivre!

Explique les manipulations que tu fais qui même à ton problème.
Péhemme
Le #25967202
:-))
1°) tu charges le fichier de cjoint
2°) tu ouvres le fichier
3°) si on pose des questions, tu réponds : ok
4°) à l'aide de la souris, tu observes le format des valeurs du graphique.
Elles sont du style : 58,0711
5°) tu cliques sur le bouton "Mise à Jour" du ruban personnalisé ("Foot-New
Look")
6°) à l'aide de la souris, tu observes le format des valeurs du graphique.
Elles sont du style : 0.0058

Par ailleurs, le second graphique n'est pas affecté par cette
"transformation".

Bonne chance ;-))
Michel
W7 - Excel 2010



"MichD" a écrit dans le message de groupe de discussion :
lcj491$84o$

C'est quoi le problème alors? J'ai de la difficulté à te suivre!

Explique les manipulations que tu fais qui même à ton problème.
Jacquouille
Le #25967222
Bonjour Michel

Sur ma version 2003, j'obtiens bien : Sébastien 66,0502.
mais, je ne vois nulle part le fameux ruban dont tu parles.
Donc, je n'y ai pas accès..... -(

Je ne pense pas que cela va t'aider, mais c'est pour le réconfort moral
-)

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Péhemme" a écrit dans le message de groupe de discussion :
lcj6l6$e2u$

:-))
1°) tu charges le fichier de cjoint
2°) tu ouvres le fichier
3°) si on pose des questions, tu réponds : ok
4°) à l'aide de la souris, tu observes le format des valeurs du graphique.
Elles sont du style : 58,0711
5°) tu cliques sur le bouton "Mise à Jour" du ruban personnalisé ("Foot-New
Look")
6°) à l'aide de la souris, tu observes le format des valeurs du graphique.
Elles sont du style : 0.0058

Par ailleurs, le second graphique n'est pas affecté par cette
"transformation".

Bonne chance ;-))
Michel
W7 - Excel 2010



"MichD" a écrit dans le message de groupe de discussion :
lcj491$84o$

C'est quoi le problème alors? J'ai de la difficulté à te suivre!

Explique les manipulations que tu fais qui même à ton problème.
Publicité
Poster une réponse
Anonyme