4 Go + /3GB + Prefetch = Event Id 51 - Avertissement - disk ????

Le
Ascadix
Salut tout le monde

Allez hop ..un truc bien tordu pour se décrasser les méninges

Je viens de passer un PC à 4 Go de RAM ( C2D 6750, Intel P35, XP SP3 )

2 x 1 Go -> 4 x 1 Go

Histoire d'utiliser la RAM supplémentaire pour les applis, je lui colle
le classique /3GB dans le boot.ini, VMware est heureux, il est
maintenant prés à utiliser presque 3Go de RAM pour les VM ( chouette
..c'était le but de cet ajout de RAM )


Mais ..je constate l'apparition d'un évènement "ennuyeux" dans
l'observateur d'évènement.

à chaque boot, apparait une rafale (+/- 10 de suite ) d'évènements
"Avertissement - disk - 51" dans le journal système, il apparaissent
juste après l'eventlog 6009 et 6005 "démarage de XP" mais sont horodatés
de +/- 10-15 sec avant lui, tous dans la même seconde


Avec comme d'hab sur ce type d'évènement, un log incomplet ne permettant
pas de localiser facilement le disque/volume/partition en cause.

S'en suit tout un tas de test et manip .
maj driver chipset et sata pour commencer, le "Matrix Storage Monitor"
ne remonte aucune anomalie sur les disques RAID0, le DD Sata en solo
semble ok lui aussi, j'ai débranché tous les périphs stockage externe.

- chkdsk rapide ..ras aucun "bad secteur" logué surles disques
- déplacement du swap, reformatage soigneux avec vérif de la partition
dédiée au swap ..ras

- permutation des barrettes ..ras

- suppression des 2 barrettes neuves ..ça disparait .. AH ..
- échange .seulement les neuves ..toujours plus de pb ..bizarre ça

- re-4 barrettes ..pb réapparut
- 4 barrettes ..sans /3GB ..plus de pb

Je continu qq essais ..et au détour d'une idée un peu farfelue ..je vide
le prefetch .. surprise, 1 reboot ..sans pb ..2° reboot avec pb
Je réitère la manip 2 ou 3 fois, puis je désactive le prefetch

La conclusion c'est:
4 Go de RAM + le switch /3GB + prefetch activé au boot = erreur 51/disk

Si je supprime un des 3 larons .. plus de pb.

J'ai gougoulé, fouillé chez MS/KB/technet ..j'ai rien trouvé

Est-ce que ce genre de délire inspire qq un ? ya un truc avec le
prefetch qui n'est pas compatible avec le /3GB ?


PS: pour les réponses du genre "passe à XP64" c'est pas prévu pour
l'instant.

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michel_D
Le #16478891
Bonjour,

"Ascadix"
Salut tout le monde

Allez hop ..un truc bien tordu pour se décrasser les méninges ...

Je viens de passer un PC à 4 Go de RAM ( C2D 6750, Intel P35, XP SP3 )

2 x 1 Go -> 4 x 1 Go

Histoire d'utiliser la RAM supplémentaire pour les applis, je lui colle
le classique /3GB dans le boot.ini, VMware est heureux, il est
maintenant prés à utiliser presque 3Go de RAM pour les VM ( chouette
..c'était le but de cet ajout de RAM )


Mais ..je constate l'apparition d'un évènement "ennuyeux" dans
l'observateur d'évènement.

à chaque boot, apparait une rafale (+/- 10 de suite ) d'évènements
"Avertissement - disk - 51" dans le journal système, il apparaissent
juste après l'eventlog 6009 et 6005 "démarage de XP" mais sont horodatés
de +/- 10-15 sec avant lui, tous dans la même seconde


Avec comme d'hab sur ce type d'évènement, un log incomplet ne permettant
pas de localiser facilement le disque/volume/partition en cause.

S'en suit tout un tas de test et manip ....
maj driver chipset et sata pour commencer, le "Matrix Storage Monitor"
ne remonte aucune anomalie sur les disques RAID0, le DD Sata en solo
semble ok lui aussi, j'ai débranché tous les périphs stockage externe.

- chkdsk rapide ..ras ... aucun "bad secteur" logué surles disques
- déplacement du swap, reformatage soigneux avec vérif de la partition
dédiée au swap ..ras

- permutation des barrettes ..ras

- suppression des 2 barrettes neuves ..ça disparait .. AH ..
- échange .seulement les neuves ..toujours plus de pb ..bizarre ça

- re-4 barrettes ..pb réapparut
- 4 barrettes ..sans /3GB ..plus de pb

Je continu qq essais ..et au détour d'une idée un peu farfelue ..je vide
le prefetch .. surprise, 1 reboot ..sans pb ..2° reboot avec pb ...
Je réitère la manip 2 ou 3 fois, puis je désactive le prefetch ...

La conclusion c'est:
4 Go de RAM + le switch /3GB + prefetch activé au boot = erreur 51/disk

Si je supprime un des 3 larons .. plus de pb.

J'ai gougoulé, fouillé chez MS/KB/technet ..j'ai rien trouvé

Est-ce que ce genre de délire inspire qq un ? ya un truc avec le
prefetch qui n'est pas compatible avec le /3GB ?


PS: pour les réponses du genre "passe à XP64" ...c'est pas prévu pour
l'instant.



Pareil je me suis rendu compte que le passage à 4 Go amène quelque
désagréments aléatoires avec éventuellement des BSOD à la clé.

PS1:Pour le moment je reste comme cela mais il y a des chances pour
que revienne à 3Go qui semble plus stable.

PS2:Le problème semble se situer sur le passage des arguments lors
de la réservation de la mémoire; certains drivers n'ont pas l'air
d'apprécier les arguments en 64 bits.
MELMOTH
Le #16479001
Distribué sur microsoft.public.fr.windowsxp,fr.comp.os.ms-windows
___________________________________
Ce cher mammifère du nom de Ascadix nous susurrait, le lundi
04/08/2008, dans nos oreilles grandes ouvertes mais un peu sales quand
même, et dans le message doux mélismes suivants :

Est-ce que ce genre de délire inspire qq un ? ya un truc avec le
prefetch qui n'est pas compatible avec le /3GB ?



Rester à *3* Go de RAM...
Tout simplement...
Puisque manifestement c'est le fait d'être à 4 Go qui fout la
merde...Et quand on sait qu'en plus ces 4 Go ne sont pas utilisés par
le système !...
Autre solution de choix : _ne jamais_ aller foutre ses pénates dans le
journal des événements et faire l'autruche...Confer Ma signature : "qui
accroît sa connaissance accroît sa douleur"...Aux innocents les mains
pelines, comme on dit...

--
Car avec beaucoup de science, il y a beaucoup de chagrin ; et celui qui
accroît sa science, accroît sa douleur.
[Ecclésiaste, 1-18]
MELMOTH - souffrant
Gregory DURAND
Le #16479611
"Ascadix" news:489751fe$0$880$
Salut tout le monde

Allez hop ..un truc bien tordu pour se décrasser les méninges ...

Je viens de passer un PC à 4 Go de RAM ( C2D 6750, Intel P35, XP SP3 )

2 x 1 Go -> 4 x 1 Go

Histoire d'utiliser la RAM supplémentaire pour les applis, je lui colle le
classique /3GB dans le boot.ini, VMware est heureux, il est maintenant
prés à utiliser presque 3Go de RAM pour les VM ( chouette ..c'était le but
de cet ajout de RAM )


Mais ..je constate l'apparition d'un évènement "ennuyeux" dans
l'observateur d'évènement.

à chaque boot, apparait une rafale (+/- 10 de suite ) d'évènements
"Avertissement - disk - 51" dans le journal système, il apparaissent juste
après l'eventlog 6009 et 6005 "démarage de XP" mais sont horodatés de +/-
10-15 sec avant lui, tous dans la même seconde


Avec comme d'hab sur ce type d'évènement, un log incomplet ne permettant
pas de localiser facilement le disque/volume/partition en cause.

S'en suit tout un tas de test et manip ....
maj driver chipset et sata pour commencer, le "Matrix Storage Monitor" ne
remonte aucune anomalie sur les disques RAID0, le DD Sata en solo semble
ok lui aussi, j'ai débranché tous les périphs stockage externe.

- chkdsk rapide ..ras ... aucun "bad secteur" logué surles disques
- déplacement du swap, reformatage soigneux avec vérif de la partition
dédiée au swap ..ras

- permutation des barrettes ..ras

- suppression des 2 barrettes neuves ..ça disparait .. AH ..
- échange .seulement les neuves ..toujours plus de pb ..bizarre ça

- re-4 barrettes ..pb réapparut
- 4 barrettes ..sans /3GB ..plus de pb

Je continu qq essais ..et au détour d'une idée un peu farfelue ..je vide
le prefetch .. surprise, 1 reboot ..sans pb ..2° reboot avec pb ...
Je réitère la manip 2 ou 3 fois, puis je désactive le prefetch ...

La conclusion c'est:
4 Go de RAM + le switch /3GB + prefetch activé au boot = erreur 51/disk

Si je supprime un des 3 larons .. plus de pb.

J'ai gougoulé, fouillé chez MS/KB/technet ..j'ai rien trouvé

Est-ce que ce genre de délire inspire qq un ? ya un truc avec le prefetch
qui n'est pas compatible avec le /3GB ?


PS: pour les réponses du genre "passe à XP64" ...c'est pas prévu pour
l'instant.

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.




Bonjour,

Je pense que de toute façon, malheureusement, si vous voulez utiliser
pleinement vos 4 Go de Ram vous serez, tôt ou tard, obligé de passer à un
environnement 64 Bits.
En effet l'architecture 32 bits ne permets pas de mapper plus de 3 Go de
Ram.

Je pense que l'article suivant pourrait être intéressant:

http://blogs.msdn.com/hiltonl/archive/2007/04/13/the-3gb-not-4gb-ram-problem.aspx

--
En espérant avoir pu vous aider,
Cordialement,

Gregory DURAND

==
Pascal Hambourg
Le #16480331
[Crosspost avec une hiérarchie hors de Usenet supprimé]

Salut,

Ascadix a écrit :

Je viens de passer un PC à 4 Go de RAM ( C2D 6750, Intel P35, XP SP3 )


[...]
La conclusion c'est:
4 Go de RAM + le switch /3GB + prefetch activé au boot = erreur 51/disk




"Lorsque le commutateur /3GB est utilisé avec Windows 2000 Professionnel
ou avec Windows 2000 Server, les composants en mode noyau sont chargés
dans l'espace mémoire à l'aide de la fonctionnalité de réglage de RAM 4
Go comme lorsqu'ils sont chargés dans Windows 2000 Advanced Server et
dans Windows 2000 Datacenter Server. Cette fonctionnalité permet aux
développeurs de pilotes de périphériques de tester leurs pilotes dans
cette configuration sans avoir à installer Windows 2000 Advanced Server
ou Windows 2000 Datacenter Server. L'espace mémoire en mode utilisateur
est encore limité à 2 Go.

Lorsque le commutateur /3GB est utilisé avec *Windows XP* Professionnel,
Windows Server 2003, Datacenter Edition ou Windows Server 2003,
Enterprise Edition, le commutateur /3GB fonctionne de la même façon sur
toutes les versions. Cette fonctionnalité permet aux développeurs de
pilotes de périphériques de tester leurs pilotes dans cette
configuration sans avoir à installer l'un des produits Windows Server
2003, répertoriés ci-dessus. L'espace mémoire en mode utilisateur est
désormais limité à 3 Go."

J'en déduis que si un pilote n'est pas compatible avec l'option /3GB, ça
peut foirer.
Ascadix
Le #16482652
Le 04/08/2008 21:01, Ascadix a écrit :
Salut tout le monde

Allez hop ..un truc bien tordu pour se décrasser les méninges ...

Je viens de passer un PC à 4 Go de RAM ( C2D 6750, Intel P35, XP SP3 )

2 x 1 Go -> 4 x 1 Go

Histoire d'utiliser la RAM supplémentaire pour les applis, je lui colle
le classique /3GB dans le boot.ini, VMware est heureux, il est
maintenant prés à utiliser presque 3Go de RAM pour les VM ( chouette
..c'était le but de cet ajout de RAM )


Mais ..je constate l'apparition d'un évènement "ennuyeux" dans
l'observateur d'évènement.

à chaque boot, apparait une rafale (+/- 10 de suite ) d'évènements
"Avertissement - disk - 51" dans le journal système, il apparaissent
juste après l'eventlog 6009 et 6005 "démarage de XP" mais sont horodatés
de +/- 10-15 sec avant lui, tous dans la même seconde


Avec comme d'hab sur ce type d'évènement, un log incomplet ne permettant
pas de localiser facilement le disque/volume/partition en cause.

S'en suit tout un tas de test et manip ....
maj driver chipset et sata pour commencer, le "Matrix Storage Monitor"
ne remonte aucune anomalie sur les disques RAID0, le DD Sata en solo
semble ok lui aussi, j'ai débranché tous les périphs stockage externe.

- chkdsk rapide ..ras ... aucun "bad secteur" logué surles disques
- déplacement du swap, reformatage soigneux avec vérif de la partition
dédiée au swap ..ras

- permutation des barrettes ..ras

- suppression des 2 barrettes neuves ..ça disparait .. AH ..
- échange .seulement les neuves ..toujours plus de pb ..bizarre ça

- re-4 barrettes ..pb réapparut
- 4 barrettes ..sans /3GB ..plus de pb

Je continu qq essais ..et au détour d'une idée un peu farfelue ..je vide
le prefetch .. surprise, 1 reboot ..sans pb ..2° reboot avec pb ...
Je réitère la manip 2 ou 3 fois, puis je désactive le prefetch ...

La conclusion c'est:
4 Go de RAM + le switch /3GB + prefetch activé au boot = erreur 51/disk

Si je supprime un des 3 larons .. plus de pb.

J'ai gougoulé, fouillé chez MS/KB/technet ..j'ai rien trouvé

Est-ce que ce genre de délire inspire qq un ? ya un truc avec le
prefetch qui n'est pas compatible avec le /3GB ?


PS: pour les réponses du genre "passe à XP64" ...c'est pas prévu pour
l'instant.




Merci à tous 3 pour les réponses, mais le 4 Go tout seul ne semble pas
poser pb ... c'est seulement quand le prefetch est activé.

J'ai un peu de mal à croire que "seulement" un pilote "douteux" sans
l'aide d'une boulette coté Windows suffise à provoquer ce genre de symptôme.

Et redescendre à 3 Go ..pas glop, je perdrais +/- 300 Mo et le dual channel

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Sylvain SF
Le #16483012
Ascadix wrote on 05/08/2008 23:58:

Merci à tous 3 pour les réponses, mais le 4 Go tout seul ne semble pas
poser pb ... c'est seulement quand le prefetch est activé.



quel est le souci de l'enlever ? (on parle bien de sa purge?)

soit la machine sert de "poubelle" avec des centaines d'applis jetables,
soit le prefetch contient 50 à 100 items qui ne ralentissent *nullement*
le boot.

ok, on lit à 100 endroits sur le net qu'il faut purger les caches et
bien pratiquer son defrag chaque matin, il faut bien des légendes.

J'ai un peu de mal à croire que "seulement" un pilote "douteux" sans
l'aide d'une boulette coté Windows suffise à provoquer ce genre de
symptôme.



la boulette de ne pas corriger ?, rattraper ?, guérir tout seul ? un
pilote douteux ?!

Et redescendre à 3 Go ..pas glop, je perdrais +/- 300 Mo et le dual channel



4Go sous un OS 32bits donnent 3,25 Go en dual channel de manière stable,
je virerais plutôt la mystique purge du prefetch.

Sylvain.
Ascadix
Le #16490511
Le 06/08/2008 02:03, Sylvain SF a écrit :
Ascadix wrote on 05/08/2008 23:58:

Merci à tous 3 pour les réponses, mais le 4 Go tout seul ne semble pas
poser pb ... c'est seulement quand le prefetch est activé.



quel est le souci de l'enlever ? (on parle bien de sa purge?)



Purge + Désactivation, sinon sans désactivation, ça recommence au 2° reboot.
Et ça me ralentit un brin le boot ( bon .. c'est pas catastrophique en
soi, mais qq secondes par ci, qqune par là ..)

soit la machine sert de "poubelle" avec des centaines d'applis jetables,
soit le prefetch contient 50 à 100 items qui ne ralentissent *nullement*
le boot.



Il était déjà restreint au boot, car sans être une "poubelle" mon PC
contient effectivement un certains tas d'applis (photos, vidéo,
bureautique, jeux, dév/bricolage ... ), je suis à +/- 60 process après
login entre les services et les "résidents" dont je n'ai pas envie de me
débarrasser (le ménage est déjà fait à mon gout, les inutiles sont déjà
désactivés.)

ok, on lit à 100 endroits sur le net qu'il faut purger les caches et
bien pratiquer son defrag chaque matin, il faut bien des légendes.



Bah ..j'avais plutôt l'habitude de faire ça +/- une fois / mois, qq
jours après après le MS-patch-day, mais sans en faire un rite immuable.

J'ai un peu de mal à croire que "seulement" un pilote "douteux" sans
l'aide d'une boulette coté Windows suffise à provoquer ce genre de
symptôme.



la boulette de ne pas corriger ?, rattraper ?, guérir tout seul ? un
pilote douteux ?!



Nan, de provoquer un pb ...qui n'est pas présent lorsque le prefetch
n'est pas actif.
Et si il agit simplement comme "révélateur" ..ça serait bien d'avoir qq
précisions (le nom par ex.) sur le pilote +/- bugué

Et redescendre à 3 Go ..pas glop, je perdrais +/- 300 Mo et le dual
channel



4Go sous un OS 32bits donnent 3,25 Go en dual channel de manière stable,
je virerais plutôt la mystique purge du prefetch.



Elle est déjà viré ..mais même quand j'ai un palliatif, j'aime assez
gratter plus loin les pbs voir si je peut trouver des infos sur la cause
précise et éventuellement voir si ya pas mieux comme solutions.

Sylvain.




--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Sylvain SF
Le #16491541
Ascadix wrote on 06/08/2008 20:22:

Il était déjà restreint au boot, car sans être une "poubelle" mon PC
contient effectivement un certains tas d'applis (photos, vidéo,
bureautique, jeux, dév/bricolage ... ), je suis à +/- 60 process après
login entre les services et les "résidents" dont je n'ai pas envie de me
débarrasser (le ménage est déjà fait à mon gout, les inutiles sont déjà
désactivés.)



je suis à 40 avec plusieurs taches serveurs (apache, MySQL, ...), hormi
le cas de ecertains suites antivir qui lance plus de 10 process à elles
seules, j'ai du mal à imaginer 60 process *indispensables* au boot.

Nan, de provoquer un pb ...qui n'est pas présent lorsque le prefetch
n'est pas actif.



si le pb vient du fait que la purge du prefetch détruit une info
indispensable à un driver (qu'il aura enregistré - sans erreur - lors
de son install), il est normal que cette purge provoque l'erreur.

Et si il agit simplement comme "révélateur" ..ça serait bien d'avoir qq
précisions (le nom par ex.) sur le pilote +/- bugué



le driver devrait loguer ses erreurs en effet, que l'OS ne logue pas
les détails qu'il ignore n'est peut être pas étonnant.

Elle est déjà viré ..mais même quand j'ai un palliatif, j'aime assez
gratter plus loin les pbs voir si je peut trouver des infos sur la
cause précise et éventuellement voir si ya pas mieux comme solutions.



soit, mais trouver des palliatifs à une situation volontairement
anormale n'est pas le plus court chemin, ne pas créer les problèmes
est plus simple, la purge des caches n'est pas innocente, le switch
"/3GB" a un usage spécifique (tests de drivers dans un contexte
précis), une machine normale n'a aucun besoin non plus de ce "/3GB".

Sylvain.
Ascadix
Le #16505901
Le 06/08/2008 22:46, Sylvain SF a écrit :
Ascadix wrote on 06/08/2008 20:22:

Il était déjà restreint au boot, car sans être une "poubelle" mon PC
contient effectivement un certains tas d'applis (photos, vidéo,
bureautique, jeux, dév/bricolage ... ), je suis à +/- 60 process après
login entre les services et les "résidents" dont je n'ai pas envie de
me débarrasser (le ménage est déjà fait à mon gout, les inutiles sont
déjà désactivés.)



je suis à 40 avec plusieurs taches serveurs (apache, MySQL, ...), hormi
le cas de ecertains suites antivir qui lance plus de 10 process à elles
seules, j'ai du mal à imaginer 60 process *indispensables* au boot.



Y en as qui sont pas "absolument indispensables" ..mais je trouve plus
pratique de les mettre en autorun que d'aller les chercher à la main
quand j'en ai besoin ..vu que je m'en sert très fréquemment.

Nan, de provoquer un pb ...qui n'est pas présent lorsque le prefetch
n'est pas actif.



si le pb vient du fait que la purge du prefetch détruit une info
indispensable à un driver (qu'il aura enregistré - sans erreur - lors
de son install), il est normal que cette purge provoque l'erreur.



Nan nan .. dans l'autre sens le lien cause-effet.
- Si le prefetch est INACTIF et purgé : pas de pb
- Si le prefetch est ACTIF ..ya le pb au boot, parfois accompagné
d'ailleurs de pb d'ouverture de session très lente (j'ai pas mis en
autologon ).

Et si il agit simplement comme "révélateur" ..ça serait bien d'avoir
qq précisions (le nom par ex.) sur le pilote +/- bugué



le driver devrait loguer ses erreurs en effet, que l'OS ne logue pas
les détails qu'il ignore n'est peut être pas étonnant.



Le seul autre log que j'ai trouvé dans un coin et que j'ai pas encore
fini de fouiller c'est un msg de problème chargement de ATIEVXX.DLL au
boot,
mais je n'ai pas encore trouvé à quel process rattacher ça, mais pour
l'instant, j'ai trouvé que:
- je l'ai même à 2 Go
- ça viens ou ça repart en activant/désactivant le DEP.
- pas d'influence du prefetch sur celui-là.
Et j'ai du mal à trouver le lien en ATI (carte video) et une erreur
d'accès disque.

Elle est déjà viré ..mais même quand j'ai un palliatif, j'aime assez
gratter plus loin les pbs voir si je peut trouver des infos sur la
cause précise et éventuellement voir si ya pas mieux comme solutions.



soit, mais trouver des palliatifs à une situation volontairement
anormale n'est pas le plus court chemin, ne pas créer les problèmes
est plus simple, la purge des caches n'est pas innocente, le switch
"/3GB" a un usage spécifique (tests de drivers dans un contexte
précis), une machine normale n'a aucun besoin non plus de ce "/3GB".



Le pire ..c'est que t'as raison, j'avais zappé le mode de fonctionnement
de VMware (et un peu mélangé avec Exchange), j'ai effectivement pas
besoin du /3GB. :-p

Bon, pb réglé, 3.25 Go ..sans le /3Gb ..et tout le monde il est content.

Sylvain.




--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Publicité
Poster une réponse
Anonyme