Accents dans Terminal?

Le
yitzhak
Bonjour,
Je me souviens d'avoir vu ici un conseil pour utiliser tin dans le
Terminal, et plus précisément, pour avoir les accents. Pour l'instant,
je ne vois que des "?" où je tape les caractères accentués.

Je ne me souviens plus comment faire.. quelqu'un peut me le rappeler?

Merci.

--
Yitzhak I. Goldstein
Mac Mini 7,83 GHz
http://coughlan.fr/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yitzhak
Le #2378321
Yitzhak I. Goldstein
Mac Mini 7,83 GHz


Oups...

Vincent Lefevre
Le #2378091
Dans l'article Yitzhak I. Goldstein
Bonjour,
Je me souviens d'avoir vu ici un conseil pour utiliser tin dans le
Terminal, et plus précisément, pour avoir les accents. Pour l'instant,
je ne vois que des "?" où je tape les caractères accentués....

Je ne me souviens plus comment faire.. quelqu'un peut me le rappeler?


Avoir des locales correctement configurées. Pour vérifier, utiliser
la commande "locale". Dans le LC_CTYPE, il doit y avoir ISO8859-1 ou
un truc du genre.

--
Vincent Lefèvre 100% accessible validated (X)HTML - Blog: Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)

yitzhak
Le #2378061
Vincent Lefevre
Dans l'article Yitzhak I. Goldstein
Bonjour,
Je me souviens d'avoir vu ici un conseil pour utiliser tin dans le
Terminal, et plus pr?cis?ment, pour avoir les accents. Pour l'instant,
je ne vois que des "?" o? je tape les caract?res accentu?s....

Je ne me souviens plus comment faire.. quelqu'un peut me le rappeler?


Avoir des locales correctement configur?es. Pour v?rifier, utiliser
la commande "locale". Dans le LC_CTYPE, il doit y avoir ISO8859-1 ou
un truc du genre.


LANG LC_COLLATE="C"
LC_CTYPE="C"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL="C"


blanc
Le #2377601
Yitzhak I. Goldstein
Je me souviens d'avoir vu ici un conseil pour utiliser tin dans le
Terminal, et plus précisément, pour avoir les accents. Pour l'instant,
je ne vois que des "?" où je tape les caractères accentués....


Je ne connais pas tin, mais le réglage des accents dans le Terminal se
fait par :
menu Terminal --> réglages de la fenêtre --> Affichage
--> Encodage du jeu de caractères

et ensuite éventuellement cliquer sur "Utiliser comme réglage par
défaut".
Si ça ne répond pas à ta question, alors c'est dans la configuration de
tin qu'il doit falloir fouiller...
--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE

Yitzhak
Le #2377251
JiPaul
Yitzhak I. Goldstein
Je me souviens d'avoir vu ici un conseil pour utiliser tin dans le
Terminal, et plus pr?cis?ment, pour avoir les accents. Pour l'instant,
je ne vois que des "?" o? je tape les caract?res accentu?s....


Je ne connais pas tin, mais le r?glage des accents dans le Terminal se
fait par :
menu Terminal --> r?glages de la fen?tre --> Affichage
--> Encodage du jeu de caract?res

et ensuite ?ventuellement cliquer sur "Utiliser comme r?glage par
d?faut".
Si ?a ne r?pond pas ? ta question, alors c'est dans la configuration de
tin qu'il doit falloir fouiller...


Oui, il me semble que c'?tait ?a, mais quel encodage utiliser? Iso Latin1?
Unicode UTF-8?


Nicolas-MICHEL'_remove_'
Le #2376631
Yitzhak I. Goldstein
Bonjour,
Je me souviens d'avoir vu ici un conseil pour utiliser tin dans le
Terminal, et plus précisément, pour avoir les accents. Pour l'instant,
je ne vois que des "?" où je tape les caractères accentués....


Tu veux sans-doutes parler de ceci :

Newsgroups: fr.comp.sys.mac
Subject: Re: Lecteur de Newsgroup
Date: Tue, 22 May 2007 23:56:57 +0200 (CEST)
Sender: Matt Anton Message-ID:

Je ne me souviens plus comment faire.. quelqu'un peut me le rappeler?


En gros il faut que 4 choses soient configurés de façon similaire :

- le terminal lui-même mis en western mac roman
- la variable locale, comme indiqué, doit être LANG="fr_CH.ISO8859-15"
(ajouter ceci :
export LANG="fr_CH.ISO8859-15"
export LC_ALL="C"
dans ton fichier d'environement )
- paramétrer tin pour utiliser le iso latin 15
(regarde les headers de matt pour comparer)
- indiquer dans tes propres headers la même chose.
Pour ce dernier point, je n'ai pas su le faire.
Je crois que la version tin de fink ne le permet pas facilement, il faut
peut-être en mettre une plus récente.


--
Nicolas

Yitzhak
Le #2376571
Nicolas MICHEL
Yitzhak I. Goldstein
Bonjour,
Je me souviens d'avoir vu ici un conseil pour utiliser tin dans le
Terminal, et plus pr?cis?ment, pour avoir les accents. Pour l'instant,
je ne vois que des "?" o? je tape les caract?res accentu?s....


Tu veux sans-doutes parler de ceci :

Newsgroups: fr.comp.sys.mac
Subject: Re: Lecteur de Newsgroup
Date: Tue, 22 May 2007 23:56:57 +0200 (CEST)
Sender: Matt Anton Message-ID:

Je ne me souviens plus comment faire.. quelqu'un peut me le rappeler?


En gros il faut que 4 choses soient configur?s de fa?on similaire :

- le terminal lui-m?me mis en western mac roman
- la variable locale, comme indiqu?, doit ?tre LANG="fr_CH.ISO8859-15"
(ajouter ceci :
export LANG="fr_CH.ISO8859-15"
export LC_ALL="C"
dans ton fichier d'environement )
- param?trer tin pour utiliser le iso latin 15
(regarde les headers de matt pour comparer)
- indiquer dans tes propres headers la m?me chose.
Pour ce dernier point, je n'ai pas su le faire.
Je crois que la version tin de fink ne le permet pas facilement, il faut
peut-?tre en mettre une plus r?cente.


Hmm... j'ai l'impression qu'une de ces options en "annule" une autre.
Voyons, j'ai recompilé tin... avec --disable-locale et j'ai tout enlevé des
fichiers de config sauf le

post_mime_encoding=ISO-8859-15

.. dans le tinrc. Voyons ce quye ça donne...


Nicolas-MICHEL'_remove_'
Le #2376561
Yitzhak
Oui, il me semble que c'?tait ?a, mais quel encodage utiliser? Iso Latin1?
Unicode UTF-8?


Le UTF-8 n'est pas encore supporté partout.
Le iso latin 1 ne supporte pas les accents, sauf erreur.
Donc le iso latin 15 est à ce qu'il me semble un bon choix.

--
Nicolas

Jacques Perrocheau
Le #2400171
In article
Nicolas-MICHEL'_remove_'@bluewin.ch (Nicolas MICHEL) wrote:

Oui, il me semble que c'?tait ?a, mais quel encodage utiliser? Iso Latin1?
Unicode UTF-8?


Le UTF-8 n'est pas encore supporté partout.
Le iso latin 1 ne supporte pas les accents, sauf erreur.


???

Donc le iso latin 15 est à ce qu'il me semble un bon choix.


Euh! on mélange un peu tout... ;-)

ISO-8859-1 = ISO Latin-1

ISO-8859-15 = ISO Latin-9

La différence entre les deux c'est le rajout de ½ (oe collé) et l' ¤
(euro).

--
Jacques PERROCHEAU
Synthèse et Electrosynthèse Organiques, C.N.R.S. UMR 6510
Université de Rennes I, Campus de Beaulieu, F-35042 RENNES Cedex
Tel: +33 2 23 23 63 74, Fax: +33 2 23 23 63 74


Nicolas-MICHEL'_remove_'
Le #2400161
Jacques Perrocheau
Euh! on mélange un peu tout... ;-)


Possible

ISO-8859-1 = ISO Latin-1

ISO-8859-15 = ISO Latin-9

La différence entre les deux c'est le rajout de ½ (oe collé) et l' ¤
(euro).


OK, merci pour l'éclaircissement.
Comme quoi c'est parfois utile de dire des conneries. ;-)

--
Nicolas

Publicité
Poster une réponse
Anonyme