Accès d'un client à un service Web XML

Le
Jean-Pierre
J'ai réalisé un Service Web XML et le client correspondant, avec Visual
Studio 2005,
édition Standard, sur Vista ed. Home Premium. Les deux programmes
fonctionnent bien quand ils sont sur la même machine, mais quand je copie le
client sur un autre
PC, le client n'arrive pas à se connecter au service avec les mêmes mots de
passe. Message : "Echec de la demande d'autorisation de type
'System.Net.WebPermission, System, Version=2.0.0.0, Culture=Neutral'. Dans
les détails des messages d'erreurs, il est écrit : "l'action qui a échoué
était "Demand", la zone de l'Assembly qui a échoué était "Intranet".
Je ne suis pas un expert de la sécurité, que faut il faire pour que ça
fonctionne ?
Merci pour votre aide.

JPB
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
David Sebban [MSFT]
Le #16715121
Bonjour,

est ce que vous utilisez la meme url pour appeller le webservice ?
il y a peut etre des NG plus adaptés pour cette question (NG de dev ?)

--
David Sebban | Microsoft Services France
http://blogs.msdn.com/dsebban

"Jean-Pierre" message de groupe de discussion :

J'ai réalisé un Service Web XML et le client correspondant, avec Visual
Studio 2005,
édition Standard, sur Vista ed. Home Premium. Les deux programmes
fonctionnent bien quand ils sont sur la même machine, mais quand je copie
le
client sur un autre
PC, le client n'arrive pas à se connecter au service avec les mêmes mots
de
passe. Message : "Echec de la demande d'autorisation de type
'System.Net.WebPermission, System, Version=2.0.0.0, Culture=Neutral'. Dans
les détails des messages d'erreurs, il est écrit : "l'action qui a échoué
était "Demand", la zone de l'Assembly qui a échoué était "Intranet".
Je ne suis pas un expert de la sécurité, que faut il faire pour que ça
fonctionne ?
Merci pour votre aide.

JPB



Publicité
Poster une réponse
Anonyme