Accès natif progress + base progress V10

Le
Yannick
Bonjour

Actuellement nous utilisons l'accès natif progress sur une base
progress V9 : tout fonctionne correctement.
Nous allons basculer la base progress V9 en V10

Pour faire mes tests, la base V10 est en local sur mon pc
Via odbcad32, j'ai créé une source de données et j'arrive bien à
accéder à ma base. Donc ma base est bien accessible via odbc

Comme le demande l'accès natif progress, j'ai créé le fichier
WDPRGS.INI sous c:windows, afin de référencer la dll "pgoe1024.dll"

Dans le projet windev, au niveau de l'analyse, j'ai déclaré une
connexion avec accès natif progress
->Lorsque je teste cette connexion, j'ai le message d'erreur suivant
"La connexion à la base a échoué"
"Impossible de se connecter à la base 'xxx'"
"Erreur de l'accès natif progress"
"Numéro d'erreur = 37"
"Fonction non trouvée : <SQLConnect">

Merci pour vos idées
Yannick
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yannick
Le #23705951
Yannick a exposé le 30/08/2011 :
Bonjour

Actuellement nous utilisons l'accès natif progress sur une base progress V9 :
tout fonctionne correctement.
Nous allons basculer la base progress V9 en V10

Pour faire mes tests, la base V10 est en local sur mon pc
Via odbcad32, j'ai créé une source de données et j'arrive bien à accéder à ma
base. Donc ma base est bien accessible via odbc

Comme le demande l'accès natif progress, j'ai créé le fichier WDPRGS.INI sous
c:windows, afin de référencer la dll "pgoe1024.dll"

Dans le projet windev, au niveau de l'analyse, j'ai déclaré une connexion
avec accès natif progress
->Lorsque je teste cette connexion, j'ai le message d'erreur suivant
"La connexion à la base a échoué"
"Impossible de se connecter à la base 'xxx'"
"Erreur de l'accès natif progress"
"Numéro d'erreur = 37"
"Fonction non trouvée : <SQLConnect">

Merci pour vos idées
Yannick



Précision : il s'agit de progress 10.2B03
Je suis bloqué...
Yannick
Le #23706691
Yannick avait écrit le 31/08/2011 :
Yannick a exposé le 30/08/2011 :
Bonjour

Actuellement nous utilisons l'accès natif progress sur une base progress V9 :
tout fonctionne correctement.
Nous allons basculer la base progress V9 en V10

Pour faire mes tests, la base V10 est en local sur mon pc
Via odbcad32, j'ai créé une source de données et j'arrive bien à accéder à
ma base. Donc ma base est bien accessible via odbc

Comme le demande l'accès natif progress, j'ai créé le fichier WDPRGS.INI
sous c:windows, afin de référencer la dll "pgoe1024.dll"

Dans le projet windev, au niveau de l'analyse, j'ai déclaré une connexion
avec accès natif progress
->Lorsque je teste cette connexion, j'ai le message d'erreur suivant
"La connexion à la base a échoué"
"Impossible de se connecter à la base 'xxx'"
"Erreur de l'accès natif progress"
"Numéro d'erreur = 37"
"Fonction non trouvée : <SQLConnect">

Merci pour vos idées
Yannick



Précision : il s'agit de progress 10.2B03
Je suis bloqué...



Voici la solution à ce problème
Lors de l'installation de la 10.2B03, progress référence la mauvaise
dll dans le connecteur odbc (pgoe1024.dll au lieu de pgoe1023.dll)

Yannick
Publicité
Poster une réponse
Anonyme