Access 2007-Table liée impossible de supprimer

Le
Bjean23
Bonjour à tous.
Après avoir ramer je fais le test suivant:
Je créer une base vide. Je lie sur une donnée externe en faisant une table
attachée. Je peux ouvrir la table. Je referme la table. Je veux supprimer la
liaison avec cette table, Access m'avertit qu'il va supprimer l'information,
je click sur "oui" et j'ai le message "Le moteur de base de données ne peut
pas trouver << >>. Assurez-vous que le nom de paramètre ou d'alias est
valide, qu'il ne comprend pas de caractère ou de ponctuation incorrect et
qu'il n'est pas trop long".

Ce message se produit également si je crée une requête sur une table et une
table liée. La requête fonctionne mais ensuite je ne peux plus l'ouvrir en
mode création, j'ai le même message qui s'affiche.
Quelqu'un peut-il m'aider car je pense que je ne suis pas le seul à avoir ce
problème.
Merci d'avance.

--

Bjean23
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bjean23
Le #20706871
La raison de tout celà est le fait que lors de l'importation originale de la
première base ces tables étaient liées.
Remède: Libérer toutes les attaches des tables liées de la base à importer.
Importer la base dans la nouvelle base. Refaire les attaches sur toutes les
tables.
Après celà fonctionne parfaitement comme avant.

Je pense que ceci peut être utile et je le laisse ici.

Merci encore à tous ceux qui se sont penchés sur mon problème.
--

Bjean23


"Bjean23" a écrit :

Bonjour à tous.
Après avoir ramer je fais le test suivant:
Je créer une base vide. Je lie sur une donnée externe en faisant une table
attachée. Je peux ouvrir la table. Je referme la table. Je veux supprimer la
liaison avec cette table, Access m'avertit qu'il va supprimer l'information,
je click sur "oui" et j'ai le message "Le moteur de base de données ne peut
pas trouver << >>. Assurez-vous que le nom de paramètre ou d'alias est
valide, qu'il ne comprend pas de caractère ou de ponctuation incorrect et
qu'il n'est pas trop long".

Ce message se produit également si je crée une requête sur une table et une
table liée. La requête fonctionne mais ensuite je ne peux plus l'ouvrir en
mode création, j'ai le même message qui s'affiche.
Quelqu'un peut-il m'aider car je pense que je ne suis pas le seul à avoir ce
problème.
Merci d'avance.

--

Bjean23


Bjean23
Le #20712761
Bonjour
Je précise ceci:
Si la table liée est sur le réseau, je peux supprimer l'attache. Si la table
est sur le même PC (même disque) je ne peux pas supprimer l'attache.

Merci d'avance pour toutes infos.

--

Bjean23


"Bjean23" a écrit :

Bonjour à tous.
Après avoir ramer je fais le test suivant:
Je créer une base vide. Je lie sur une donnée externe en faisant une table
attachée. Je peux ouvrir la table. Je referme la table. Je veux supprimer la
liaison avec cette table, Access m'avertit qu'il va supprimer l'information,
je click sur "oui" et j'ai le message "Le moteur de base de données ne peut
pas trouver << >>. Assurez-vous que le nom de paramètre ou d'alias est
valide, qu'il ne comprend pas de caractère ou de ponctuation incorrect et
qu'il n'est pas trop long".

Ce message se produit également si je crée une requête sur une table et une
table liée. La requête fonctionne mais ensuite je ne peux plus l'ouvrir en
mode création, j'ai le même message qui s'affiche.
Quelqu'un peut-il m'aider car je pense que je ne suis pas le seul à avoir ce
problème.
Merci d'avance.

--

Bjean23


Publicité
Poster une réponse
Anonyme