Access2003 depliement

Le
Papyto94
Bonjour
Voici le problème que je ne sais résoudre seul malgré la lecture de
nombreuses pages sur le sujet.
Pour une association, j'ai réalisé bénévolement sur ACCESS 2003 une
petite base de données.
Le fonctionnement de cette base avec le RUNTIME ACCESS 2003 que j'avais
sur le CD est correct.
Je voudrai maintenant déployer cette base sur les 5 postes de cette
association avec le RUNTIME (sans empaquetage) pour ne pas avoir à
acheter la version complète d'ACCESS pour chaque poste.
Seulement les nombreuses lectures sur internet, indiquent que pour ce
déploiement, il me faut une licence. Que pour avoir cette licence, il
faut avoir Microsoft Access 2003 Developer Extensions qui est fourni
avec Visual Studio Tools.
Or ce logiciel n'est plus disponible.
Mes questions:la licence est elle obligatoire même sans empaquetage ?
Si oui ou trouver le CD qui me manque.
Le vidéo studio tools 2007 peut il me servir ?
Etant entendu que seules les licences pour déploiement du rUNTIME
m'intéressent, je laisserai les logiciels dans un placard.
Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Paul Florent
Le #21646101
Le runtime Access 2010 est disponible gratuitement
http://www.microsoft.com/downloads/details.aspx?FamilyIDWA350CD-5250-4DF6-BFD1-6CED700A6715&displaylang=fr#filelist
Il exécute parfaitement les applications Access 2003 (*.mdb ou *.mde)
Bonne chance
Paul
Papyto94
Le #21653041
Le 27/04/2010 08:20, Papyto94 a écrit :
Bonjour
Voici le problème que je ne sais résoudre seul malgré la lecture de
nombreuses pages sur le sujet.
Pour une association, j'ai réalisé bénévolement sur ACCESS 2003 une
petite base de données.
Le fonctionnement de cette base avec le RUNTIME ACCESS 2003 que j'avais
sur le CD est correct.
Je voudrai maintenant déployer cette base sur les 5 postes de cette
association avec le RUNTIME (sans empaquetage) pour ne pas avoir à
acheter la version complète d'ACCESS pour chaque poste.
Seulement les nombreuses lectures sur internet, indiquent que pour ce
déploiement, il me faut une licence. Que pour avoir cette licence, il
faut avoir Microsoft Access 2003 Developer Extensions qui est fourni
avec Visual Studio Tools.
Or ce logiciel n'est plus disponible.
Mes questions:la licence est elle obligatoire même sans empaquetage ?
Si oui ou trouver le CD qui me manque.
Le vidéo studio tools 2007 peut il me servir ?
Etant entendu que seules les licences pour déploiement du rUNTIME
m'intéressent, je laisserai les logiciels dans un placard.
Merci


Malheureusement, ma base de données ne fonctionne correctement ni avec
le runtime 2007 ni avec le runtime 2010.
Mon problème reste entier (achat de licences pour utilisation du runtime
2003 que j'ai)
Merci
3stone
Le #21658441
Salut,

Papyto94 wrote:
Malheureusement, ma base de données ne fonctionne correctement ni avec
le runtime 2007 ni avec le runtime 2010.
Mon problème reste entier (achat de licences pour utilisation du
runtime 2003 que j'ai)




Il faut d'abord que ta base fonctionne sous runtime!...

Pour cela, commence par simuler cela avec ton Access complet.
http://cjoint.com/?eEbb7Hsev2

Si cela fonctionne, le runtime 2007 devrait fonctionner.

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Papyto94
Le #21658771
Le 30/04/2010 01:09, 3stone a écrit :
Salut,

Papyto94 wrote:
Malheureusement, ma base de données ne fonctionne correctement ni avec
le runtime 2007 ni avec le runtime 2010.
Mon problème reste entier (achat de licences pour utilisation du
runtime 2003 que j'ai)




Il faut d'abord que ta base fonctionne sous runtime!...

Pour cela, commence par simuler cela avec ton Access complet.
http://cjoint.com/?eEbb7Hsev2

Si cela fonctionne, le runtime 2007 devrait fonctionner.



Bonjour
Merci de répondre.
Ma base de données fonctionne correctement sous runtime ACCESS 2003
(sans empaquetage)que j'ai installé dans un PC sans ACCESS 2003.
Mais sous 2007 complet ou runtime 2007, ma base de données ne fonctionne
pas correctement.Nous avons déjà eu un échange à ce sujet il y a
plusieurs mois malheureusement sans résultat.
Aujourd'hui je n'ai plus ACCESS 2007 pour continuer mes investigations
alors que j'avais commencé à comprendre le dysfonctionnement de ma base
sous 2007(temps de calcul d'un champ calculé trop long et dont le
résultat était utilisé dans la suite du programme).
Merci
3stone
Le #21661051
Salut,


Papyto94 wrote:
Malheureusement, ma base de données ne fonctionne correctement ni
avec le runtime 2007 ni avec le runtime 2010.
Mon problème reste entier (achat de licences pour utilisation du
runtime 2003 que j'ai)




Il faut d'abord que ta base fonctionne sous runtime!...

Pour cela, commence par simuler cela avec ton Access complet.
http://cjoint.com/?eEbb7Hsev2

Si cela fonctionne, le runtime 2007 devrait fonctionner.



Bonjour
Merci de répondre.
Ma base de données fonctionne correctement sous runtime ACCESS 2003
(sans empaquetage)que j'ai installé dans un PC sans ACCESS 2003.
Mais sous 2007 complet ou runtime 2007, ma base de données ne
fonctionne pas correctement.Nous avons déjà eu un échange à ce sujet
il y a plusieurs mois malheureusement sans résultat.
Aujourd'hui je n'ai plus ACCESS 2007 pour continuer mes
investigations alors que j'avais commencé à comprendre le
dysfonctionnement de ma base sous 2007(temps de calcul d'un champ
calculé trop long et dont le résultat était utilisé dans la suite du
programme).




Difficile comme situation...

Pour ta déduction sur la "lenteur" sous Access 2007, il aurait
dû suffire d'ajouter quelques "DoEvents" à la suite du la phase
de calcul...

As ta place, je tenterai de supprimer/adapter tout ce qui
risque de ne pas être supporté par Access 2007, mais que
tu utilises et fonctionne encore sous A2003.

Question achat licences 2003... MS ne commercialise plus depuis...
mais tu peux éventuellement prendre contact avec eux et
expliquer ton cas... cela ne mange pas de pain :-)

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Papyto94
Le #21661741
Le 30/04/2010 15:15, 3stone a écrit :
Salut,


Papyto94 wrote:
Malheureusement, ma base de données ne fonctionne correctement ni
avec le runtime 2007 ni avec le runtime 2010.
Mon problème reste entier (achat de licences pour utilisation du
runtime 2003 que j'ai)




Il faut d'abord que ta base fonctionne sous runtime!...

Pour cela, commence par simuler cela avec ton Access complet.
http://cjoint.com/?eEbb7Hsev2

Si cela fonctionne, le runtime 2007 devrait fonctionner.



Bonjour
Merci de répondre.
Ma base de données fonctionne correctement sous runtime ACCESS 2003
(sans empaquetage)que j'ai installé dans un PC sans ACCESS 2003.
Mais sous 2007 complet ou runtime 2007, ma base de données ne
fonctionne pas correctement.Nous avons déjà eu un échange à ce sujet
il y a plusieurs mois malheureusement sans résultat.
Aujourd'hui je n'ai plus ACCESS 2007 pour continuer mes
investigations alors que j'avais commencé à comprendre le
dysfonctionnement de ma base sous 2007(temps de calcul d'un champ
calculé trop long et dont le résultat était utilisé dans la suite du
programme).




Difficile comme situation...

Pour ta déduction sur la "lenteur" sous Access 2007, il aurait
dû suffire d'ajouter quelques "DoEvents" à la suite du la phase
de calcul...

As ta place, je tenterai de supprimer/adapter tout ce qui
risque de ne pas être supporté par Access 2007, mais que
tu utilises et fonctionne encore sous A2003.

Question achat licences 2003... MS ne commercialise plus depuis...
mais tu peux éventuellement prendre contact avec eux et
expliquer ton cas... cela ne mange pas de pain :-)



J'ai essayé des DoEvents suivis ou pas d'une boucle For Next mais encore
une fois pour des raisons que je ne comprends pas l'attente est la même
pour le champ calculé et pour le programme qui suit.
Donc le résultat est identique avec ou sans DoEvents.
Merci encore
Papyto94
Le #21664141
Le 30/04/2010 17:24, Papyto94 a écrit :
Le 30/04/2010 15:15, 3stone a écrit :
Salut,


Papyto94 wrote:
Malheureusement, ma base de données ne fonctionne correctement ni
avec le runtime 2007 ni avec le runtime 2010.
Mon problème reste entier (achat de licences pour utilisation du
runtime 2003 que j'ai)




Il faut d'abord que ta base fonctionne sous runtime!...

Pour cela, commence par simuler cela avec ton Access complet.
http://cjoint.com/?eEbb7Hsev2

Si cela fonctionne, le runtime 2007 devrait fonctionner.



Bonjour
Merci de répondre.
Ma base de données fonctionne correctement sous runtime ACCESS 2003
(sans empaquetage)que j'ai installé dans un PC sans ACCESS 2003.
Mais sous 2007 complet ou runtime 2007, ma base de données ne
fonctionne pas correctement.Nous avons déjà eu un échange à ce sujet
il y a plusieurs mois malheureusement sans résultat.
Aujourd'hui je n'ai plus ACCESS 2007 pour continuer mes
investigations alors que j'avais commencé à comprendre le
dysfonctionnement de ma base sous 2007(temps de calcul d'un champ
calculé trop long et dont le résultat était utilisé dans la suite du
programme).




Difficile comme situation...

Pour ta déduction sur la "lenteur" sous Access 2007, il aurait
dû suffire d'ajouter quelques "DoEvents" à la suite du la phase
de calcul...

As ta place, je tenterai de supprimer/adapter tout ce qui
risque de ne pas être supporté par Access 2007, mais que
tu utilises et fonctionne encore sous A2003.

Question achat licences 2003... MS ne commercialise plus depuis...
mais tu peux éventuellement prendre contact avec eux et
expliquer ton cas... cela ne mange pas de pain :-)



J'ai essayé des DoEvents suivis ou pas d'une boucle For Next mais encore
une fois pour des raisons que je ne comprends pas l'attente est la même
pour le champ calculé et pour le programme qui suit.
Donc le résultat est identique avec ou sans DoEvents.
Merci encore


J'ai fini, après bien des essais à débloquer ma base en runtime 2007.
Je te donne le résultat car cela peut intéresser certains.
Après bien des manips, j'étais convaincu que mon problème venait du
temps de calcul d'un contrôle calculé en pied de formulaire, suivi par
un recalc aprés appui sur un bouton.
J'ai remplacé ce calcul en pied de formulaire par un somdom dans la
procédure commandée par ce bouton.
Tout s'est mis à fonctionner jusqu'à présent correctement (pourvu que
cela continue).
Merci de m'avoir donné le courage de continuer.
3stone
Le #21667391
Salut,

Papyto94 wrote:
[...]
Tout s'est mis à fonctionner jusqu'à présent correctement (pourvu que
cela continue).



Content pour toi !

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Publicité
Poster une réponse
Anonyme