addition avec condition

Le
Marc
Bonjour à vous tous
Voici mon problème, j'ai un tableau (dans la colonne A, des produits) et
colonne B, C, D, E,F, des valeurs entre 1 et 3. Par contre, les valeurs 1 à
3, renvois à des montants d'argent, qui ne sont pas les mêmes d'une colonne à
l'autre. Exemple.

Colonne A Colonne B Colonne C Total
Produit 1 3 2 2

Par contre, pour la colonne A, 1 vaut 20$, 2 vaut 25$ et 3 vaut 30$.
Par contre, pour la colonne B, 1 vaut 25$, 2 vaut 30$ et vaut 35$. Etc.
J'aimerais qu'excel puisse me claculer la somme (argent). Par contre les
sommes sont cumulatifs. Exemple dans la colonne A, il y a le chiffre 3, donc
il doit 20+25+30u
Dans la colonne B c'est 2, donc 25+30U

Voici un fichier pour vous aider à mieux comprendre

http://cjoint.com/?euolvwGfBi

Merci de votre aide

Marc
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Marc
Le #4466571
Bonjour
j'avais oublié de vous mentionner que j'étais à la recherche d'une formule,
et non d'une macro en vba. Si c'est possible, bien sur.

Merci encore de votre aide


Bonjour à vous tous
Voici mon problème, j'ai un tableau (dans la colonne A, des produits) et
colonne B, C, D, E,F, des valeurs entre 1 et 3. Par contre, les valeurs 1 à
3, renvois à des montants d'argent, qui ne sont pas les mêmes d'une colonne à
l'autre. Exemple.

Colonne A Colonne B Colonne C Total
Produit 1 3 2 2

Par contre, pour la colonne A, 1 vaut 20$, 2 vaut 25$ et 3 vaut 30$.
Par contre, pour la colonne B, 1 vaut 25$, 2 vaut 30$ et vaut 35$. Etc.
J'aimerais qu'excel puisse me claculer la somme (argent). Par contre les
sommes sont cumulatifs. Exemple dans la colonne A, il y a le chiffre 3, donc
il doit 20+25+30u
Dans la colonne B c'est 2, donc 25+30U

Voici un fichier pour vous aider à mieux comprendre

http://cjoint.com/?euolvwGfBi

Merci de votre aide

Marc


Daniel
Le #4466561
Bonjour.
En se servant du tableau, en G2 :
=SOMME(DECALER(B12;;;B2;1))+SOMME(DECALER(C12;;;C2;1))+SOMME(DECALER(D12;;;D2;1))+SOMME(DECALER(E12;;;E2;1))+SOMME(DECALER(F12;;;F2;1))
Avec des valeurs en dur :
=CHOISIR(B2;20;45;B12+75)+...
Cordialement.
Daniel
"Marc"
Bonjour à vous tous
Voici mon problème, j'ai un tableau (dans la colonne A, des produits) et
colonne B, C, D, E,F, des valeurs entre 1 et 3. Par contre, les valeurs 1
à
3, renvois à des montants d'argent, qui ne sont pas les mêmes d'une
colonne à
l'autre. Exemple.

Colonne A Colonne B Colonne C Total
Produit 1 3 2 2

Par contre, pour la colonne A, 1 vaut 20$, 2 vaut 25$ et 3 vaut 30$.
Par contre, pour la colonne B, 1 vaut 25$, 2 vaut 30$ et vaut 35$. Etc.
J'aimerais qu'excel puisse me claculer la somme (argent). Par contre les
sommes sont cumulatifs. Exemple dans la colonne A, il y a le chiffre 3,
donc
il doit 20+25+30u
Dans la colonne B c'est 2, donc 25+30U

Voici un fichier pour vous aider à mieux comprendre

http://cjoint.com/?euolvwGfBi

Merci de votre aide

Marc


Daniel
Le #4466551
Oups.
Au lieu de :
=CHOISIR(B2;20;45;B12+75)+...
mettre :
=CHOISIR(B2;20;45;75)+...
Daniel
"Daniel"
Bonjour.
En se servant du tableau, en G2 :
=SOMME(DECALER(B12;;;B2;1))+SOMME(DECALER(C12;;;C2;1))+SOMME(DECALER(D12;;;D2;1))+SOMME(DECALER(E12;;;E2;1))+SOMME(DECALER(F12;;;F2;1))
Avec des valeurs en dur :
=CHOISIR(B2;20;45;B12+75)+...
Cordialement.
Daniel
"Marc"
Bonjour à vous tous
Voici mon problème, j'ai un tableau (dans la colonne A, des produits) et
colonne B, C, D, E,F, des valeurs entre 1 et 3. Par contre, les valeurs 1
à
3, renvois à des montants d'argent, qui ne sont pas les mêmes d'une
colonne à
l'autre. Exemple.

Colonne A Colonne B Colonne C Total
Produit 1 3 2 2

Par contre, pour la colonne A, 1 vaut 20$, 2 vaut 25$ et 3 vaut 30$.
Par contre, pour la colonne B, 1 vaut 25$, 2 vaut 30$ et vaut 35$. Etc.
J'aimerais qu'excel puisse me claculer la somme (argent). Par contre les
sommes sont cumulatifs. Exemple dans la colonne A, il y a le chiffre 3,
donc
il doit 20+25+30u
Dans la colonne B c'est 2, donc 25+30U

Voici un fichier pour vous aider à mieux comprendre

http://cjoint.com/?euolvwGfBi

Merci de votre aide

Marc






Marc
Le #4466501
Bonjour daniel, cela fonctionne merveilleusement, merci, mais il y a un
peitit hic, certaines colonne n'ont pas encore de chiffre, donc j'ai comme
réponse #REF. Est-ce que l'on peut lui demander de faire cette formule, mais
si il y a une cellule vide.

Encore merci



Bonjour.
En se servant du tableau, en G2 :
=SOMME(DECALER(B12;;;B2;1))+SOMME(DECALER(C12;;;C2;1))+SOMME(DECALER(D12;;;D2;1))+SOMME(DECALER(E12;;;E2;1))+SOMME(DECALER(F12;;;F2;1))
Avec des valeurs en dur :
=CHOISIR(B2;20;45;B12+75)+...
Cordialement.
Daniel
"Marc"
Bonjour à vous tous
Voici mon problème, j'ai un tableau (dans la colonne A, des produits) et
colonne B, C, D, E,F, des valeurs entre 1 et 3. Par contre, les valeurs 1
à
3, renvois à des montants d'argent, qui ne sont pas les mêmes d'une
colonne à
l'autre. Exemple.

Colonne A Colonne B Colonne C Total
Produit 1 3 2 2

Par contre, pour la colonne A, 1 vaut 20$, 2 vaut 25$ et 3 vaut 30$.
Par contre, pour la colonne B, 1 vaut 25$, 2 vaut 30$ et vaut 35$. Etc.
J'aimerais qu'excel puisse me claculer la somme (argent). Par contre les
sommes sont cumulatifs. Exemple dans la colonne A, il y a le chiffre 3,
donc
il doit 20+25+30u
Dans la colonne B c'est 2, donc 25+30U

Voici un fichier pour vous aider à mieux comprendre

http://cjoint.com/?euolvwGfBi

Merci de votre aide

Marc







Daniel
Le #4466491
=SOMME(DECALER(B11;;;B2+1;1);DECALER(C11;;;C2+1;1);DECALER(D11;;;D2+1;1);DECALER(E11;;;E2+1;1);DECALER(F11;;;F2+1;1))
Daniel
"Marc"
Bonjour daniel, cela fonctionne merveilleusement, merci, mais il y a un
peitit hic, certaines colonne n'ont pas encore de chiffre, donc j'ai comme
réponse #REF. Est-ce que l'on peut lui demander de faire cette formule,
mais
si il y a une cellule vide.

Encore merci



Bonjour.
En se servant du tableau, en G2 :
=SOMME(DECALER(B12;;;B2;1))+SOMME(DECALER(C12;;;C2;1))+SOMME(DECALER(D12;;;D2;1))+SOMME(DECALER(E12;;;E2;1))+SOMME(DECALER(F12;;;F2;1))
Avec des valeurs en dur :
=CHOISIR(B2;20;45;B12+75)+...
Cordialement.
Daniel
"Marc"
Bonjour à vous tous
Voici mon problème, j'ai un tableau (dans la colonne A, des produits)
et
colonne B, C, D, E,F, des valeurs entre 1 et 3. Par contre, les valeurs
1
à
3, renvois à des montants d'argent, qui ne sont pas les mêmes d'une
colonne à
l'autre. Exemple.

Colonne A Colonne B Colonne C
Total
Produit 1 3 2 2

Par contre, pour la colonne A, 1 vaut 20$, 2 vaut 25$ et 3 vaut 30$.
Par contre, pour la colonne B, 1 vaut 25$, 2 vaut 30$ et vaut 35$.
Etc.
J'aimerais qu'excel puisse me claculer la somme (argent). Par contre
les
sommes sont cumulatifs. Exemple dans la colonne A, il y a le chiffre 3,
donc
il doit 20+25+30u
Dans la colonne B c'est 2, donc 25+30U

Voici un fichier pour vous aider à mieux comprendre

http://cjoint.com/?euolvwGfBi

Merci de votre aide

Marc









Daniel
Le #4466481
et :
=CHOISIR(B2+1;0;20;45;75)+...
Daniel
"Marc"
Bonjour daniel, cela fonctionne merveilleusement, merci, mais il y a un
peitit hic, certaines colonne n'ont pas encore de chiffre, donc j'ai comme
réponse #REF. Est-ce que l'on peut lui demander de faire cette formule,
mais
si il y a une cellule vide.

Encore merci



Bonjour.
En se servant du tableau, en G2 :
=SOMME(DECALER(B12;;;B2;1))+SOMME(DECALER(C12;;;C2;1))+SOMME(DECALER(D12;;;D2;1))+SOMME(DECALER(E12;;;E2;1))+SOMME(DECALER(F12;;;F2;1))
Avec des valeurs en dur :
=CHOISIR(B2;20;45;B12+75)+...
Cordialement.
Daniel
"Marc"
Bonjour à vous tous
Voici mon problème, j'ai un tableau (dans la colonne A, des produits)
et
colonne B, C, D, E,F, des valeurs entre 1 et 3. Par contre, les valeurs
1
à
3, renvois à des montants d'argent, qui ne sont pas les mêmes d'une
colonne à
l'autre. Exemple.

Colonne A Colonne B Colonne C
Total
Produit 1 3 2 2

Par contre, pour la colonne A, 1 vaut 20$, 2 vaut 25$ et 3 vaut 30$.
Par contre, pour la colonne B, 1 vaut 25$, 2 vaut 30$ et vaut 35$.
Etc.
J'aimerais qu'excel puisse me claculer la somme (argent). Par contre
les
sommes sont cumulatifs. Exemple dans la colonne A, il y a le chiffre 3,
donc
il doit 20+25+30u
Dans la colonne B c'est 2, donc 25+30U

Voici un fichier pour vous aider à mieux comprendre

http://cjoint.com/?euolvwGfBi

Merci de votre aide

Marc









Marc
Le #4466461
Un très gros merci daniel
j'apprécie

Marc


et :
=CHOISIR(B2+1;0;20;45;75)+...
Daniel
"Marc"
Bonjour daniel, cela fonctionne merveilleusement, merci, mais il y a un
peitit hic, certaines colonne n'ont pas encore de chiffre, donc j'ai comme
réponse #REF. Est-ce que l'on peut lui demander de faire cette formule,
mais
si il y a une cellule vide.

Encore merci



Bonjour.
En se servant du tableau, en G2 :
=SOMME(DECALER(B12;;;B2;1))+SOMME(DECALER(C12;;;C2;1))+SOMME(DECALER(D12;;;D2;1))+SOMME(DECALER(E12;;;E2;1))+SOMME(DECALER(F12;;;F2;1))
Avec des valeurs en dur :
=CHOISIR(B2;20;45;B12+75)+...
Cordialement.
Daniel
"Marc"
Bonjour à vous tous
Voici mon problème, j'ai un tableau (dans la colonne A, des produits)
et
colonne B, C, D, E,F, des valeurs entre 1 et 3. Par contre, les valeurs
1
à
3, renvois à des montants d'argent, qui ne sont pas les mêmes d'une
colonne à
l'autre. Exemple.

Colonne A Colonne B Colonne C
Total
Produit 1 3 2 2

Par contre, pour la colonne A, 1 vaut 20$, 2 vaut 25$ et 3 vaut 30$.
Par contre, pour la colonne B, 1 vaut 25$, 2 vaut 30$ et vaut 35$.
Etc.
J'aimerais qu'excel puisse me claculer la somme (argent). Par contre
les
sommes sont cumulatifs. Exemple dans la colonne A, il y a le chiffre 3,
donc
il doit 20+25+30u
Dans la colonne B c'est 2, donc 25+30U

Voici un fichier pour vous aider à mieux comprendre

http://cjoint.com/?euolvwGfBi

Merci de votre aide

Marc














Publicité
Poster une réponse
Anonyme