addition de cellules même colone

Le
David
Bonjour à tous,

Comment obtenir la somme de toutes les
cellules jusque la 1ere cellule vide de la colonne D
part exemple.
Sous XP, Excel 2003 et VBA.

Merci à tous.
--
a+ Jean-Pol
Site Web : www.colovid.be
Site Web perso pour le fun : http://users.skynet.be/DAVID/
Cette page est transmise avec des électrons 100% recyclés.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
David
Le #21143291
Re-Boujour,

Je me réponds à moi-même :

Adresse = Range("D2:D65536").End(xlDown).Row
Formule = "=SUM(D2:D" & (Adresse - 1) & ")"
Range("D" & Adresse + 2).Value = Formule

S'i y a mieux je suis preneur.

Merci.
--
a+ Jean-Pol
Site Web : www.colovid.be
Site Web perso pour le fun : http://users.skynet.be/DAVID/
Cette page est transmise avec des électrons 100% recyclés.

"David"
Bonjour à tous,

Comment obtenir la somme de toutes les
cellules jusque la 1ere cellule vide de la colonne D
part exemple.
Sous XP, Excel 2003 et VBA.

Merci à tous.
--
a+ Jean-Pol
Site Web : www.colovid.be
Site Web perso pour le fun : http://users.skynet.be/DAVID/
Cette page est transmise avec des électrons 100% recyclés.




michdenis
Le #21143281
Bonjour,

Une suggestion...

Si après la première ligne vide, tu n'as pas de saisie de données
dans le reste de la colonne, tu peux utiliser :
=Somme(D:D) -> fait la somme de la colonne D

En VBA -> X = Application.Sum(range("D:D"))


Pour additionner de D1 à Dx x étant la première ligne vide
rencontrée :

Validation matricielle : Ctrl + Maj + Enter
=SOMME(INDIRECT("D1:D"&MIN(SI(NBCAR(D:D)=0;LIGNE(D:D)))))



"David"
Bonjour à tous,

Comment obtenir la somme de toutes les
cellules jusque la 1ere cellule vide de la colonne D
part exemple.
Sous XP, Excel 2003 et VBA.

Merci à tous.
--
a+ Jean-Pol
Site Web : www.colovid.be
Site Web perso pour le fun : http://users.skynet.be/DAVID/
Cette page est transmise avec des électrons 100% recyclés.
michdenis
Le #21143521
Et cette syntaxe :

With Range("D2:D" & Range("D65536").End(xlUp).Row - 1)
.Offset(.Rows.Count + 3).Resize(1).Formula = "=Sum(" & .Address & ")"
End With




"David"
Re-Boujour,

Je me réponds à moi-même :

Adresse = Range("D2:D65536").End(xlDown).Row
Formule = "=SUM(D2:D" & (Adresse - 1) & ")"
Range("D" & Adresse + 2).Value = Formule

S'i y a mieux je suis preneur.

Merci.
--
a+ Jean-Pol
Site Web : www.colovid.be
Site Web perso pour le fun : http://users.skynet.be/DAVID/
Cette page est transmise avec des électrons 100% recyclés.

"David"
Bonjour à tous,

Comment obtenir la somme de toutes les
cellules jusque la 1ere cellule vide de la colonne D
part exemple.
Sous XP, Excel 2003 et VBA.

Merci à tous.
--
a+ Jean-Pol
Site Web : www.colovid.be
Site Web perso pour le fun : http://users.skynet.be/DAVID/
Cette page est transmise avec des électrons 100% recyclés.




David
Le #21143641
Bonjour,

Merci pour vos réponses.
Je ne sais pas ou vous allez chercher tout cela;
à mon avis vous devez avoir 2 cerveaux :-))

--
a+ Jean-Pol
Site Web : www.colovid.be
Site Web perso pour le fun : http://users.skynet.be/DAVID/
Cette page est transmise avec des électrons 100% recyclés.

"michdenis" %
Bonjour,

Une suggestion...

Si après la première ligne vide, tu n'as pas de saisie de données
dans le reste de la colonne, tu peux utiliser :
=Somme(D:D) -> fait la somme de la colonne D

En VBA -> X = Application.Sum(range("D:D"))


Pour additionner de D1 à Dx x étant la première ligne vide
rencontrée :

Validation matricielle : Ctrl + Maj + Enter
=SOMME(INDIRECT("D1:D"&MIN(SI(NBCAR(D:D)=0;LIGNE(D:D)))))



"David" discussion :

Bonjour à tous,

Comment obtenir la somme de toutes les
cellules jusque la 1ere cellule vide de la colonne D
part exemple.
Sous XP, Excel 2003 et VBA.

Merci à tous.
--
a+ Jean-Pol
Site Web : www.colovid.be
Site Web perso pour le fun : http://users.skynet.be/DAVID/
Cette page est transmise avec des électrons 100% recyclés.



Publicité
Poster une réponse
Anonyme