Addition des montants négatifs des lignes de sous-totaux

Le
bernard2010 Hors ligne
Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans lequel j'ai fait des sous-totaux. Je souhaiterai additionner uniquement les montants négatifs des sous-totaux.

Merci d'avance de votre aide

Bernard
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #22972001
Bonjour,

Pour additionner ta colonne tu pourrais utiliser ceci :

Tu adaptes l'adresse de ta colonne :
=SOMME.SI(C1:C5;"<" & 0;C1:C5)



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion :

Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans lequel j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants négatifs des
sous-totaux.

Merci d'avance de votre aide

Bernard
bernard2010 Hors ligne
Le #22972191
michdenis a écrit le 30/12/2010 à 19h19 :
Bonjour,

Pour additionner ta colonne tu pourrais utiliser ceci :

Tu adaptes l'adresse de ta colonne :
=SOMME.SI(C1:C5;"<" & 0;C1:C5)



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion
:

Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans lequel
j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants négatifs
des
sous-totaux.

Merci d'avance de votre aide

Bernard


merci de ta réponse rapide, mais mon problème subsite. Ta formule additionne l'ensemble des montants négatifs de la plage, alors que je souhaiterai additionner uniquement les montants négatifs issus des sous-totaux.

D'avance merci de ton aide

Bernard
michdenis
Le #22972291
Tu as bien raison, le sous-total était passé inaperçu !
;-)

Tu adaptes la plage de cellules
Validation matricielle : Maj + Ctrl + Enter
=SOMME(N(SI(SOUS.TOTAL(9;DECALER(F1;LIGNE(F1:F10)-LIGNE(F1);))*(F1:F10<0);F1:F10)))


MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion :

michdenis a écrit le 30/12/2010 à 19h19 :
Bonjour,

Pour additionner ta colonne tu pourrais utiliser ceci :

Tu adaptes l'adresse de ta colonne :
=SOMME.SI(C1:C5;"<" & 0;C1:C5)



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion
:

Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans lequel
j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants négatifs
des
sous-totaux.

Merci d'avance de votre aide

Bernard


merci de ta réponse rapide, mais mon problème subsite. Ta formule additionne
l'ensemble des montants négatifs de la plage, alors que je souhaiterai
additionner uniquement les montants négatifs issus des sous-totaux.

D'avance merci de ton aide

Bernard
bernard2010 Hors ligne
Le #22972351
michdenis a écrit le 30/12/2010 à 20h28 :
Tu as bien raison, le sous-total était passé inaperçu !
;-)

Tu adaptes la plage de cellules
Validation matricielle : Maj + Ctrl + Enter
=SOMME(N(SI(SOUS.TOTAL(9;DECALER(F1;LIGNE(F1:F10)-LIGNE(F1);))*(F1:F10<0);F1:F10)))


MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion
:

michdenis a écrit le 30/12/2010 à 19h19 :
Bonjour,

Pour additionner ta colonne tu pourrais utiliser ceci :

Tu adaptes l'adresse de ta colonne :
=SOMME.SI(C1:C5;"<" & 0;C1:C5)



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de
discussion
:

Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans
lequel
j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants
négatifs
des
sous-totaux.

Merci d'avance de votre aide

Bernard



merci de ta réponse rapide, mais mon problème subsite. Ta formule
additionne
l'ensemble des montants négatifs de la plage, alors que je souhaiterai
additionner uniquement les montants négatifs issus des sous-totaux.

D'avance merci de ton aide

Bernard


Le résultat de la formule que tu me proposes me donne : #nom?
Mais peut être n'ai je pas compris la formule ?
Quand tu écris F1 de quoi s'agit-il ? cellule ?
Même question pour F1:F10 : plage ?

Merci encore de ton aide

Bernard
bernard2010 Hors ligne
Le #22972401
michdenis a écrit le 30/12/2010 à 20h28 :
Tu as bien raison, le sous-total était passé inaperçu !
;-)

Tu adaptes la plage de cellules
Validation matricielle : Maj + Ctrl + Enter
=SOMME(N(SI(SOUS.TOTAL(9;DECALER(F1;LIGNE(F1:F10)-LIGNE(F1);))*(F1:F10<0);F1:F10)))


MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion
:

michdenis a écrit le 30/12/2010 à 19h19 :
Bonjour,

Pour additionner ta colonne tu pourrais utiliser ceci :

Tu adaptes l'adresse de ta colonne :
=SOMME.SI(C1:C5;"<" & 0;C1:C5)



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de
discussion
:

Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans
lequel
j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants
négatifs
des
sous-totaux.

Merci d'avance de votre aide

Bernard



merci de ta réponse rapide, mais mon problème subsite. Ta formule
additionne
l'ensemble des montants négatifs de la plage, alors que je souhaiterai
additionner uniquement les montants négatifs issus des sous-totaux.

D'avance merci de ton aide

Bernard


Pour bien visualiser le tableau, voici comment il se présente
bip 23
bip -5
bip -7
Total bip 11
dad 25
dad -75
Total dad -50
eng 30
eng -65
Total eng -35
Ce que je cherche à faire c'est additionner -50 et -35 soit -85

Merci

Bernard
Jacky
Le #22972441
Bonsoir,

Une fonction perso peut-être..

Dans un module standard
'------------------
Function TotalDesNegatifs(Plage)
For Each c In Plage
If Left(c.Formula, 9) = "=SUBTOTAL" And c < 0 Then
TotalDesNegatifs = TotalDesNegatifs + c.Value
End If
Next
End Function
'-------------
Dans une cellule
=TotalDesNegatifs(A1:A10)

A1:A10 étant la plage des chiffres

--
Salutations
JJ


"bernard2010"
Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans lequel j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants négatifs des
sous-totaux.

Merci d'avance de votre aide

Bernard
Jacky
Le #22972621
Re..

Démo ici
http://www.cijoint.fr/cjlink.php?file=cj201012/cijBsakatY.xls

--
Salutations
JJ


"Jacky"
Bonsoir,

Une fonction perso peut-être..

Dans un module standard
'------------------
Function TotalDesNegatifs(Plage)
For Each c In Plage
If Left(c.Formula, 9) = "=SUBTOTAL" And c < 0 Then
TotalDesNegatifs = TotalDesNegatifs + c.Value
End If
Next
End Function
'-------------
Dans une cellule
=TotalDesNegatifs(A1:A10)

A1:A10 étant la plage des chiffres

--
Salutations
JJ


"bernard2010"
Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans lequel j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants négatifs des
sous-totaux.

Merci d'avance de votre aide

Bernard




michdenis
Le #22972701
Un fichier exemple : http://cjoint.com/?0mEwYBrKFmN


MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion :

michdenis a écrit le 30/12/2010 à 20h28 :
Tu as bien raison, le sous-total était passé inaperçu !
;-)

Tu adaptes la plage de cellules
Validation matricielle : Maj + Ctrl + Enter



=SOMME(N(SI(SOUS.TOTAL(9;DECALER(F1;LIGNE(F1:F10)-LIGNE(F1);))*(F1:F10<0);F1:F10)))


MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion
:

michdenis a écrit le 30/12/2010 à 19h19 :
Bonjour,

Pour additionner ta colonne tu pourrais utiliser ceci :

Tu adaptes l'adresse de ta colonne :
=SOMME.SI(C1:C5;"<" & 0;C1:C5)



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de
discussion
:

Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans
lequel
j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants
négatifs
des
sous-totaux.

Merci d'avance de votre aide

Bernard



merci de ta réponse rapide, mais mon problème subsite. Ta formule
additionne
l'ensemble des montants négatifs de la plage, alors que je souhaiterai
additionner uniquement les montants négatifs issus des sous-totaux.

D'avance merci de ton aide

Bernard


Le résultat de la formule que tu me proposes me donne : #nom?
Mais peut être n'ai je pas compris la formule ?
Quand tu écris F1 de quoi s'agit-il ? cellule ?
Même question pour F1:F10 : plage ?

Merci encore de ton aide

Bernard
michdenis
Le #22972751
Pour ton problème, si les noms sont en A:A et les valeurs en B:B

utilise cette formule :
=SOMMEPROD((ESTNUM(CHERCHE("total";A1:A10;1)))*(B1:B10<0)*(B1:B10))



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion :

michdenis a écrit le 30/12/2010 à 20h28 :
Tu as bien raison, le sous-total était passé inaperçu !
;-)

Tu adaptes la plage de cellules
Validation matricielle : Maj + Ctrl + Enter



=SOMME(N(SI(SOUS.TOTAL(9;DECALER(F1;LIGNE(F1:F10)-LIGNE(F1);))*(F1:F10<0);F1:F10)))


MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion
:

michdenis a écrit le 30/12/2010 à 19h19 :
Bonjour,

Pour additionner ta colonne tu pourrais utiliser ceci :

Tu adaptes l'adresse de ta colonne :
=SOMME.SI(C1:C5;"<" & 0;C1:C5)



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de
discussion
:

Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans
lequel
j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants
négatifs
des
sous-totaux.

Merci d'avance de votre aide

Bernard



merci de ta réponse rapide, mais mon problème subsite. Ta formule
additionne
l'ensemble des montants négatifs de la plage, alors que je souhaiterai
additionner uniquement les montants négatifs issus des sous-totaux.

D'avance merci de ton aide

Bernard


Pour bien visualiser le tableau, voici comment il se présente
bip 23
bip -5
bip -7
Total bip 11
dad 25
dad -75
Total dad -50
eng 30
eng -65
Total eng -35
Ce que je cherche à faire c'est additionner -50 et -35 soit -85

Merci

Bernard
bernard2010 Hors ligne
Le #22973211
michdenis a écrit le 30/12/2010 à 23h18 :
Pour ton problème, si les noms sont en A:A et les valeurs en B:B

utilise cette formule :
=SOMMEPROD((ESTNUM(CHERCHE("total";A1:A10;1)))*(B1:B10<0)*(B1:B10))



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de discussion
:

michdenis a écrit le 30/12/2010 à 20h28 :
Tu as bien raison, le sous-total était passé inaperçu !
;-)

Tu adaptes la plage de cellules
Validation matricielle : Maj + Ctrl + Enter




=SOMME(N(SI(SOUS.TOTAL(9;DECALER(F1;LIGNE(F1:F10)-LIGNE(F1);))*(F1:F10<0);F1:F10)))


MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de
discussion
:

michdenis a écrit le 30/12/2010 à 19h19 :
Bonjour,

Pour additionner ta colonne tu pourrais utiliser ceci :

Tu adaptes l'adresse de ta colonne :
=SOMME.SI(C1:C5;"<" & 0;C1:C5)



MichD
--------------------------------------------
"bernard2010" a écrit dans le message de groupe de
discussion
:

Bonjour,
Je vous présente mon problème : j'ai un tableau excel dans
lequel
j'ai fait des
sous-totaux. Je souhaiterai additionner uniquement les montants
négatifs
des
sous-totaux.

Merci d'avance de votre aide

Bernard




merci de ta réponse rapide, mais mon problème subsite. Ta
formule
additionne
l'ensemble des montants négatifs de la plage, alors que je souhaiterai
additionner uniquement les montants négatifs issus des sous-totaux.

D'avance merci de ton aide

Bernard



Pour bien visualiser le tableau, voici comment il se présente
bip 23
bip -5
bip -7
Total bip 11
dad 25
dad -75
Total dad -50
eng 30
eng -65
Total eng -35
Ce que je cherche à faire c'est additionner -50 et -35 soit -85

Merci

Bernard


Merci beaucoup pour ta prompte réponse mais surtout exacte.
Soit assuré que je trinquerai à ta santé ce soir.
Passe un joyeux réveillon.

Bernard
Publicité
Poster une réponse
Anonyme