additionner chiffres non barrés

Le
Phil_de_Paris
Bonjour,

Dans Excel 2002, j'ai une colonne de chiffres,

je souhaite additionner les chiffres qui ne sont pas barrés

Existe t-il une solution ?

Merci d'avance de votre aide,

Cordialement,

Phil.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #6796541
Bonjour,

Dans un module: Alt+F11 puis Insertion/Module


Function sommebarre(champ As Range)
Application.Volatile
For Each c In champ
If Not c.Font.Strikethrough Then
t = t + c.Value
End If
Next
sommebarre = t
End Function

Dans une cellule:

=SommeBarre(A1:A10)

JB
http://boisgontierjacques.free.fr/

On 7 juin, 11:05, "Phil_de_Paris"
Bonjour,

Dans Excel 2002, j'ai une colonne de chiffres,

je souhaite additionner les chiffres qui ne sont pas barrés...

Existe t-il une solution ?

Merci d'avance de votre aide,

Cordialement,

Phil.


Modeste
Le #6797021
Bonsour® Phil_de_Paris avec ferveur ;o))) vous nous disiez :

Dans Excel 2002, j'ai une colonne de chiffres,
je souhaite additionner les chiffres qui ne sont pas barrés...
Existe t-il une solution ?



positionner le curseur en cellule A2
définir le nom personnalisé : Barré
fait référence à : LIRE.CELLULE(23,A1)

cette fonction renvoie VRAI si la cellule immédiatement à gauche est barrée

Inserer un colonne à droite de la colonne à sommer
ecrire la formule : = Barré
recopier vers le bas autant que nécessaire
la largeur de cette colonne pourra etre éventuellement réduite ou masquée

Utiliser ensuite la formule :
=SOMME.SI(plage avec Formule Barré;FAUX;plage à sommer)



--
--
@+
;o)))

Phil_de_Paris
Le #6797491
Merci !

Bonne journée,

Phil.

"JB" news:
Bonjour,

Dans un module: Alt+F11 puis Insertion/Module


Function sommebarre(champ As Range)
Application.Volatile
For Each c In champ
If Not c.Font.Strikethrough Then
t = t + c.Value
End If
Next
sommebarre = t
End Function

Dans une cellule:

=SommeBarre(A1:A10)

JB
http://boisgontierjacques.free.fr/

On 7 juin, 11:05, "Phil_de_Paris"
Bonjour,

Dans Excel 2002, j'ai une colonne de chiffres,

je souhaite additionner les chiffres qui ne sont pas barrés...

Existe t-il une solution ?

Merci d'avance de votre aide,

Cordialement,

Phil.


Phil_de_Paris
Le #6797481
Merci !

Bonne journée,

Phil.


"Modeste" news:OG0$
Bonsour® Phil_de_Paris avec ferveur ;o))) vous nous disiez :

Dans Excel 2002, j'ai une colonne de chiffres,
je souhaite additionner les chiffres qui ne sont pas barrés...
Existe t-il une solution ?



positionner le curseur en cellule A2
définir le nom personnalisé : Barré
fait référence à : LIRE.CELLULE(23,A1)

cette fonction renvoie VRAI si la cellule immédiatement à gauche est barrée

Inserer un colonne à droite de la colonne à sommer
ecrire la formule : = Barré
recopier vers le bas autant que nécessaire
la largeur de cette colonne pourra etre éventuellement réduite ou masquée

Utiliser ensuite la formule :
=SOMME.SI(plage avec Formule Barré;FAUX;plage à sommer)



--
--
@+
;o)))

Publicité
Poster une réponse
Anonyme