Affichage sur IE7

Le
1connu
Bonjour,

Je m'occupe d'un site eacpt2013.org sans avoir aucune compètence de Webdesigner.
L'affichage sous IE7 n'est pas conforme (ex : saut vertical entre logo et menu)- Il passe même avec IE8 et les navigateurs standards (Firefox/Chrome etc).

Y a t'il une astuce que je puisse utiliser pour que l'affichage soit correct aussi sur IE7 ?

D'avance merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier Miakinen
Le #24799952
Bonjour,

Le 21/09/2012 09:20, 1connu a écrit :

Je m'occupe d'un site eacpt2013.org sans avoir aucune compètence de Webdesigner.
L'affichage sous IE7 n'est pas conforme (ex : saut vertical entre logo et menu)- Il passe même avec IE8 et les navigateurs standards (Firefox/Chrome etc).



De quelle page parles-tu ? La page d'accueil ?

Y a t'il une astuce que je puisse utiliser pour que l'affichage soit correct aussi sur IE7 ?



La première chose à faire serait de passer un validateur, et de
corriger toutes les erreurs.

Par exemple, on voit que la page d'accueil n'a pas de DOCTYPE :
http://validator.w3.org/check?uri=http%3A%2F%2Feacpt2013.org%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

Si on en force un, il y a moins d'erreurs, mais on voit quand même une
balise qu'il faudrait retirer l'espace :
http://validator.w3.org/check?uri=http%3A%2F%2Feacpt2013.org%2F&charset=%28detect+automatically%29&doctype=XHTML+1.0+Frameset&group=0&user-agent=W3C_Validator%2F1.3

Et puis bien sûr, si l'erreur se trouve dans les frames elles-mêmes,
il faudra passer les pages individuelles au validateur. Une fois les
erreurs corrigées, et si le problème persiste, il sera plus facile
d'étudier ce qui peut aller de travers.

P.-S. : Tes lignes sont trop longues, merci de régler Thunderbird pour
qu'il coupe lui-même aux environs de 72 caractères.

Cordialement,
--
Olivier Miakinen
Olivier Miakinen
Le #24800052
Le 21/09/2012 10:49, je répondais à 1connu :

Et puis bien sûr, si l'erreur se trouve dans les frames elles-mêmes,
il faudra passer les pages individuelles au validateur.



La trame unique de la page d'accueil est un joyeux mélange de HTML
et de XHTML :
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.midapi.ch%2Fcgi-bin%2FWebObjects%2FEacpt.woa&charset=%28detect+automatically%29&doctype=Inline&group=0&ss=1

Ligne 1 : DOCTYPE html
Ligne 2 : contient un namespace XML : xhtml
Ligne 3 : balise meta non fermée : html
Ligne 8 : balise link fermée : xhtml
... et ainsi de suite.

Ceci ne doit pas aider un navigateur à savoir comment afficher la
page.

Une fois les
erreurs corrigées, et si le problème persiste, il sera plus facile
d'étudier ce qui peut aller de travers.



Voilà.

Cordialement,
--
Olivier Miakinen
1connu
Le #24800102
Olivier Miakinen a écrit :
Le 21/09/2012 10:49, je répondais à 1connu :
Et puis bien sûr, si l'erreur se trouve dans les frames elles-mêmes,
il faudra passer les pages individuelles au validateur.



La trame unique de la page d'accueil est un joyeux mélange de HTML
et de XHTML :
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.midapi.ch%2Fcgi-bin%2FWebObjects%2FEacpt.woa&charset=%28detect+automatically%29&doctype=Inline&group=0&ss=1

Ligne 1 : DOCTYPE html
Ligne 2 : contient un namespace XML : xhtml
Ligne 3 : balise meta non fermée : html
Ligne 8 : balise link fermée : xhtml
... et ainsi de suite.

Ceci ne doit pas aider un navigateur à savoir comment afficher la
page.

Une fois les
erreurs corrigées, et si le problème persiste, il sera plus facile
d'étudier ce qui peut aller de travers.



Voilà.

Cordialement,


Super merci, je vais regarder tout ca
1connu
Le #24800172
Olivier Miakinen a écrit :
Le 21/09/2012 10:49, je répondais à 1connu :
Et puis bien sûr, si l'erreur se trouve dans les frames elles-mêmes,
il faudra passer les pages individuelles au validateur.



La trame unique de la page d'accueil est un joyeux mélange de HTML
et de XHTML :
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.midapi.ch%2Fcgi-bin%2FWebObjects%2FEacpt.woa&charset=%28detect+automatically%29&doctype=Inline&group=0&ss=1

Ligne 1 : DOCTYPE html
Ligne 2 : contient un namespace XML : xhtml
Ligne 3 : balise meta non fermée : html
Ligne 8 : balise link fermée : xhtml
... et ainsi de suite.

Ceci ne doit pas aider un navigateur à savoir comment afficher la
page.

Une fois les
erreurs corrigées, et si le problème persiste, il sera plus facile
d'étudier ce qui peut aller de travers.



Voilà.

Cordialement,



J'ai copié le contenu de la frame dans http://eacpt2013.org/test.html
Il n'a plus d'erreur dans la validation de cette page.
Par contre, le résultat sur ie8 http://eacpt2013.org/eacptIe8.png
et ie7 http://eacpt2013.org/eacptie7.png montre bien 2 différences :

1) écart vertical entre image logo et menu jaune
2) écart dans la "ligne" noir sous le menu jaune


Là, ça dépense nettement mes compétences html/css.

Merci si vous avez une idée.
Olivier Miakinen
Le #24800192
Le 21/09/2012 11:51, 1connu a écrit :

J'ai copié le contenu de la frame dans http://eacpt2013.org/test.html
Il n'a plus d'erreur dans la validation de cette page.



Exact, et pas d'erreur de validation CSS non plus. Bravo !

Par contre, le résultat sur ie8 http://eacpt2013.org/eacptIe8.png
et ie7 http://eacpt2013.org/eacptie7.png montre bien 2 différences :

1) écart vertical entre image logo et menu jaune
2) écart dans la "ligne" noir sous le menu jaune



En effet.

Là, ça dépense nettement mes compétences html/css.



Je vais regarder, et d'autres lecteurs de ce groupe aussi je suppose.

Cordialement,
--
Olivier Miakinen
yamo'
Le #24800522
Salut,

Le 21/09/2012 11:51, 1connu a écrit:
J'ai copié le contenu de la frame dans http://eacpt2013.org/test.html
Il n'a plus d'erreur dans la validation de cette page.
Par contre, le résultat sur ie8 http://eacpt2013.org/eacptIe8.png
et ie7 http://eacpt2013.org/eacptie7.png montre bien 2 différences :

1) écart vertical entre image logo et menu jaune
2) écart dans la "ligne" noir sous le menu jaune


Là, ça dépense nettement mes compétences html/css.

Merci si vous avez une idée.



Le plus simple à court terme, c'est les commentaires conditionnels qui
seront malheureusement abandonnés avec IE10 :(


--
Stéphane
SAM
Le #24818832
Le 21/09/12 10:49, Olivier Miakinen a écrit :
Le 21/09/2012 09:20, 1connu a écrit :

Y a t'il une astuce que je puisse utiliser pour que l'affichage soit correct aussi sur IE7 ?




(snip)
P.-S. : Tes lignes sont trop longues, merci de régler Thunderbird pour
qu'il coupe lui-même aux environs de 72 caractères.




Pourquoi ne les corriges-tu pas toi-même ?
(menu : Edition / Reformater )

Mon Th coupe les lignes chez moi, mais j'ai comme l'impression qu'elles
ne sont pas coupées à l'envoi. Peux-tu me le confirmer ?


--
Stéphane Moriaux avec/with iMac-intel
Olivier Miakinen
Le #24818822
Bonjour,

Le 27/09/2012 15:08, SAM m'a répondu :

P.-S. : Tes lignes sont trop longues, merci de régler Thunderbird pour
qu'il coupe lui-même aux environs de 72 caractères.



Pourquoi ne les corriges-tu pas toi-même ?
(menu : Edition / Reformater )



Parce que cela reformate un peu trop, fusionnant les phrases qui ne
sont pas séparées par deux sauts de ligne au lieu d'un. Pour reformater
correctement un tel texte, je devrais :
1) rajouter un à un autant de sauts de ligne qu'il y a de phrases ;
2) faire Édition / Reformater ;
3) supprimer un à un les sauts de ligne ajoutés.

Sur le texte auquel je répondais c'était encore possible, puisqu'il
n'y avait que deux phrases enchaînées. Mais je préférais prévenir
1connu avant qu'il n'écrive un texte plus long.

Mon Th coupe les lignes chez moi, mais j'ai comme l'impression qu'elles
ne sont pas coupées à l'envoi. Peux-tu me le confirmer ?



Je confirme qu'elles sont coupées à l'envoi, ce qui me permet de te
répondre sans difficultés. Simplement, comme tu utilises en émission
et en lecture le format flowed (ou flawed diront les mauvaises langues
dont je suis), tu ne le vois pas.

Soit dit en passant, 1connu envoie aussi ses articles en format flawed,
et c'est probablement pour ça qu'il n'a pas vu la différence entre
couper à 72 et couper à plus de 72. Je comprends qu'on se fiche de
modifier une préférence si pour soi cela ne fait pas de différence.

Cordialement,
--
Olivier Miakinen
Publicité
Poster une réponse
Anonyme