affichage de video

Le
jdanield
Bonjour,

je suis en train de tester différentes solutions pour afficher des vidéos sur
un site web.

Pouvez-vous me dire si vous voyez une video sur cette page, et en quel endroit
de la page :-)

http://dodin.info/~piwigo/testplayers/test2quicktime.html

merci
jdd
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LeLapin
Le #26286802
jdanield a baliverné

Bonjour,

je suis en train de tester différentes solutions pour afficher des vidéos sur
un site web.

Pouvez-vous me dire si vous voyez une video sur cette page, et en quel endroit
de la page :-)

http://dodin.info/~piwigo/testplayers/test2quicktime.html

merci
jdd



http://cjoint.com/14ju/DGuoEuS5JnJ_jddvido.jpg

Le player vidéo du milieu est 100% fonctionnel.
jdanield
Le #26286942
Le 20/07/2014 14:31, LeLapin a écrit :

http://dodin.info/~piwigo/testplayers/test2quicktime.html

merci
jdd



http://cjoint.com/14ju/DGuoEuS5JnJ_jddvido.jpg

Le player vidéo du milieu est 100% fonctionnel.



oui, et celui du bas affiche la fenetre quicktime (il ne le fait pas chez
moi), tu as quel systeme et quel navigateur?

merci
jdd
Olivier Miakinen
Le #26287112
Bonjour,

Le 20/07/2014 11:30, jdanield a écrit :

Pouvez-vous me dire si vous voyez une video sur cette page, et en quel endroit
de la page :-)

http://dodin.info/~piwigo/testplayers/test2quicktime.html




1) Avec SeaMonkey 2.26.1 sur Linux, de haut en bas :

- texte « lien direct etc. »

- lien « vignette » (testmov.jpg)
- image testmov.jpg
- lien « video » (testmov.mov, fonctionnel)

- texte « html5 »

- gros rectangle gris foncé avec au centre une croix gris clair et le
texte « No video with supported format and MIME type found. »

- texte « Insertion de la video »

- gros rectangle noir cliquable ; quand on clique dessus, popup d'erreur
« Une erreur est survenue / Impossible d'ouvrir l'emplacement ; vous
n'avez peut-être pas la permission d'ouvrir le fichier. »

- texte « fin d'insertion »


2) Avec Firefox 30.0 sur Linux, de haut en bas :

- texte « lien direct etc. »

- lien « vignette » (testmov.jpg)
- image testmov.jpg
- lien « video » (testmov.mov, fonctionnel)

- texte « html5 »

- vidéo fonctionnelle

- texte « Insertion de la video »

- gros rectangle gris foncé, avec l'image d'une pièce de légo et en
desssous un lien « Activer Quicktime » ; une fois Quicktime activé,
même comportement que SeaMonkey (rectangle noir cliquable, même
erreur quand on clique)

- texte « fin d'insertion »
jdanield
Le #26287102
Le 20/07/2014 17:31, Olivier Miakinen a écrit :

2) Avec Firefox 30.0 sur Linux, de haut en bas :

- vidéo fonctionnelle

- texte « Insertion de la video »

- gros rectangle gris foncé, avec l'image d'une pièce de légo et en
desssous un lien « Activer Quicktime » ; une fois Quicktime activé,
même comportement que SeaMonkey (rectangle noir cliquable, même
erreur quand on clique)

- texte « fin d'insertion »



comment fais-tu pour "activer quicktime"? Moi j'ai le module xine, si il est
activé je n'ai rien qui s'affiche, si il est désactivé j'ai le rectangle gris
de demande de plugin, mais si je clique ca m'envoie juste dans le répertoire
des plugins, sans me dire ce qui manque :-(

merci
jdd
voir_le_reply-to
Le #26287172
jdanield
je suis en train de tester différentes solutions pour afficher des vidéos sur
un site web.



AMHA tu te compliques la vie inutilement. Je me suis posé la question
tout comme toi récemment, en recherchant un maximum de compatibilité
(systèmes et navigateurs). "La" solution est indiquée ici et tient en
cinq lignes, pas une de plus :

à savoir :
<video width="320" height="240" controls>
Your browser does not support the video tag.
</video>

hth,
--
Gérald
Olivier Miakinen
Le #26287322
Le 20/07/2014 17:47, jdanield a écrit :

- gros rectangle gris foncé, avec l'image d'une pièce de légo et en
desssous un lien « Activer Quicktime » ; une fois Quicktime activé,
même comportement que SeaMonkey (rectangle noir cliquable, même
erreur quand on clique)



comment fais-tu pour "activer quicktime"?



C'est une bonne question.

Lorsque je recherche dans la « logithèque Ubuntu » le mot-clé quicktime,
je vois six logiciels, dont trois qui sont déjà installés chez moi :
xine, Greffons GStreamer, et Lecteur multimédia VLC.

De toute façons, comme je l'ai déjà écrit, ça ne fonctionne pas (popup
d'erreur, cf. mon article précédent).

--
Olivier Miakinen
jdanield
Le #26287312
Le 20/07/2014 18:02, Gerald a écrit :
jdanield
je suis en train de tester différentes solutions pour afficher des vidéos sur
un site web.



AMHA tu te compliques la vie inutilement. Je me suis posé la question
tout comme toi récemment, en recherchant un maximum de compatibilité
(systèmes et navigateurs). "La" solution est indiquée ici et tient en
cinq lignes, pas une de plus :

à savoir :
<video width="320" height="240" controls>
Your browser does not support the video tag.
</video>

hth,



mais ca suppose d'avoir les video dans un format particulier, et en double.

et ca ne résoud pas le problème que je pose. A moins qu'il s'agisse d'un
problème de codec.

il y a, par exemple, des millions de video en flv, on ne peut pas demander aux
gens de les convertir toutes, pareil pour les mov...

jdd
jdanield
Le #26287302
Le 20/07/2014 18:17, Olivier Miakinen a écrit :

Lorsque je recherche dans la « logithèque Ubuntu » le mot-clé quicktime,
je vois six logiciels, dont trois qui sont déjà installés chez moi :
xine, Greffons GStreamer, et Lecteur multimédia VLC.

De toute façons, comme je l'ai déjà écrit, ça ne fonctionne pas (popup
d'erreur, cf. mon article précédent).



oui mais bon... ca ne marche pas non plus sous windows :-(

pour mon linux, j'ai trouvé ca:

https://support.mozilla.org/fr/kb/utiliser-plugin-quicktime-ecouter-voir

pas mieux

jdd
voir_le_reply-to
Le #26287292
jdanield
mais ca suppose d'avoir les video dans un format particulier, et en double.



Particulier... les deux principaux standards quand même ! :-) Et puis le
doublon c'est pour des raisons de compatibilité maximum.

et ca ne résoud pas le problème que je pose. A moins qu'il s'agisse d'un
problème de codec.



Sous réserves de me tromper, puisque c'est multi-plateformes, je suppose
que, comme dans VLC, les navigateurs compatibles HTML5 embarquent de
quoi décoder ?

il y a, par exemple, des millions de video en flv, on ne peut pas demander aux
gens de les convertir toutes, pareil pour les mov...



Aux gens je ne sais pas. À toi je peux peut-être le suggérer ? Ici ça
marche, ça fait très "propre" et ça satisfait pleinement même les
aveugles, c'est dire !

Parce que j'ai exploré un temps les solutions de lecteurs externes
gratuits importés/activés par le script : rien n'est jamais gratuit sur
le net...

--
Gérald
jdanield
Le #26287352
Le 20/07/2014 18:32, Gerald a écrit :

Aux gens je ne sais pas. À toi je peux peut-être le suggérer ? Ici ça
marche, ça fait très "propre" et ça satisfait pleinement même les
aveugles, c'est dire !



il s'agit d'écrire un plugin pour une galerie video, ce ne sont pas *mes*
videos :-)

la page de démo apple marche

http://dodin.info/temp/apple/last-time-i-saw-paris.html

le .mov que j'utilise en démo vient directement d'un appareil photo sony

jdd
Publicité
Poster une réponse
Anonyme