Afficher 1 pour une valeur trouvée

Le
Yves
BONJOUR A TOUS
Je suis sous EXCEL 97
J'AI UN FICHIER EXCEL DE 2 ONGLETS.
Dans mon 1er onglet nommé "CI", je récupère avec une requète des données en
format standard dans une base ACCESS.
J'obtiens un fichier de 5 colonnes avec entêtes et un nombre de lignes
aléatoire.
Dans la case D2 J'ai une Origine en 3 caractères maxi et en E2 j'ai un code
de 4 caractères.
Je retrouve ce code de 4 caractères dans la Colonne A de mon 2ème onglet
"liste".
Mon onglet "liste" est le récapitulatif sur 800 lignes et 32 colonnes (de A
à AF) de toutes les origines correspondants aux différents codes.
J'aimerai afficher le chifffre 1 par exemple dans la case F2 de mon onglet
"CI" quand pour le code affiché en E2 l'origine affichée D2 n'a aucunes
correspondances dans mon onglet "liste".

onglet CI

A B C D E F
1 ART STR POP ORIG NUM
2 211 242 6 73 250W 1
3 013 411 5 94 380F 0
4 255 322 1 77 0431 0


onglet LISTE

A B C D E ETC
1 N° DEPT DEPT DEPT DEPT DEPT
22 380F 59 12 94 01 22
53 0431 67 29 92 41 66
78 250W 51 17 77 06 93

Si quelqu'un ou quelqu'une peut m'indiquer une macro ou une formule je l'en
remercie d'avance!!!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #5076751
Bonjour,

=SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)

Camille


BONJOUR A TOUS
Je suis sous EXCEL 97
J'AI UN FICHIER EXCEL DE 2 ONGLETS.
Dans mon 1er onglet nommé "CI", je récupère avec une requète des données en
format standard dans une base ACCESS.
J'obtiens un fichier de 5 colonnes avec entêtes et un nombre de lignes
aléatoire.
Dans la case D2 J'ai une Origine en 3 caractères maxi et en E2 j'ai un code
de 4 caractères.
Je retrouve ce code de 4 caractères dans la Colonne A de mon 2ème onglet
"liste".
Mon onglet "liste" est le récapitulatif sur 800 lignes et 32 colonnes (de A
à AF) de toutes les origines correspondants aux différents codes.
J'aimerai afficher le chifffre 1 par exemple dans la case F2 de mon onglet
"CI" quand pour le code affiché en E2 l'origine affichée D2 n'a aucunes
correspondances dans mon onglet "liste".

onglet CI

A B C D E F
1 ART STR POP ORIG NUM
2 211 242 6 73 250W 1
3 013 411 5 94 380F 0
4 255 322 1 77 0431 0


onglet LISTE

A B C D E ETC...
1 N° DEPT DEPT DEPT DEPT DEPT
22 380F 59 12 94 01 22
53 0431 67 29 92 41 66
78 250W 51 17 77 06 93

Si quelqu'un ou quelqu'une peut m'indiquer une macro ou une formule je l'en
remercie d'avance!!!





Yves
Le #5076601
merci de m'aider, mais cette formule ne répond pas à mon problème
"Ellimac" news:
Bonjour,

=SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)

Camille


BONJOUR A TOUS
Je suis sous EXCEL 97
J'AI UN FICHIER EXCEL DE 2 ONGLETS.
Dans mon 1er onglet nommé "CI", je récupère avec une requète des données
en
format standard dans une base ACCESS.
J'obtiens un fichier de 5 colonnes avec entêtes et un nombre de lignes
aléatoire.
Dans la case D2 J'ai une Origine en 3 caractères maxi et en E2 j'ai un
code
de 4 caractères.
Je retrouve ce code de 4 caractères dans la Colonne A de mon 2ème onglet
"liste".
Mon onglet "liste" est le récapitulatif sur 800 lignes et 32 colonnes (de
A
à AF) de toutes les origines correspondants aux différents codes.
J'aimerai afficher le chifffre 1 par exemple dans la case F2 de mon
onglet
"CI" quand pour le code affiché en E2 l'origine affichée D2 n'a aucunes
correspondances dans mon onglet "liste".

onglet CI

A B C D E F
1 ART STR POP ORIG NUM
2 211 242 6 73 250W 1
3 013 411 5 94 380F 0
4 255 322 1 77 0431 0


onglet LISTE

A B C D E ETC...
1 N° DEPT DEPT DEPT DEPT DEPT
22 380F 59 12 94 01 22
53 0431 67 29 92 41 66
78 250W 51 17 77 06 93

Si quelqu'un ou quelqu'une peut m'indiquer une macro ou une formule je
l'en
remercie d'avance!!!







Ellimac
Le #5076121
Bonjour,

cette formule ne répond pas à mon problème
Pourquoi ?

As-tu pensé à modifier le nom de la feuille pour la feuille Liste :
=SI(NB.SI(Liste!$A$2:$A$5000;E2)>0;1;0)

Camille


merci de m'aider, mais cette formule ne répond pas à mon problème
"Ellimac" news:
Bonjour,

=SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)

Camille


BONJOUR A TOUS
Je suis sous EXCEL 97
J'AI UN FICHIER EXCEL DE 2 ONGLETS.
Dans mon 1er onglet nommé "CI", je récupère avec une requète des données
en
format standard dans une base ACCESS.
J'obtiens un fichier de 5 colonnes avec entêtes et un nombre de lignes
aléatoire.
Dans la case D2 J'ai une Origine en 3 caractères maxi et en E2 j'ai un
code
de 4 caractères.
Je retrouve ce code de 4 caractères dans la Colonne A de mon 2ème onglet
"liste".
Mon onglet "liste" est le récapitulatif sur 800 lignes et 32 colonnes (de
A
à AF) de toutes les origines correspondants aux différents codes.
J'aimerai afficher le chifffre 1 par exemple dans la case F2 de mon
onglet
"CI" quand pour le code affiché en E2 l'origine affichée D2 n'a aucunes
correspondances dans mon onglet "liste".

onglet CI

A B C D E F
1 ART STR POP ORIG NUM
2 211 242 6 73 250W 1
3 013 411 5 94 380F 0
4 255 322 1 77 0431 0


onglet LISTE

A B C D E ETC...
1 N° DEPT DEPT DEPT DEPT DEPT
22 380F 59 12 94 01 22
53 0431 67 29 92 41 66
78 250W 51 17 77 06 93

Si quelqu'un ou quelqu'une peut m'indiquer une macro ou une formule je
l'en
remercie d'avance!!!












Yves
Le #5390581
ReRE et j'en passe bonjour et merçi
En fait ta formule m'affiche 1 lorsqu'elle trouve une correspondance dans la
colonne A de mon onglet liste.
Moi je suis sans doute un peu exigeant mais j'aimerais qu'elle m'affiche 1
quand pour le num 250W en E5 et 71 en D5, je retrouve par exemple ce même
code 250W à la ligne 356 de mon onglet liste et seulement si sur la droite
de la case A356 je retrouve mon 71 en B356 ou C356 etc...
"Ellimac" news:
Bonjour,

cette formule ne répond pas à mon problème
Pourquoi ?

As-tu pensé à modifier le nom de la feuille pour la feuille Liste :
=SI(NB.SI(Liste!$A$2:$A$5000;E2)>0;1;0)

Camille


merci de m'aider, mais cette formule ne répond pas à mon problème
"Ellimac" news:
Bonjour,

=SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)

Camille


BONJOUR A TOUS
Je suis sous EXCEL 97
J'AI UN FICHIER EXCEL DE 2 ONGLETS.
Dans mon 1er onglet nommé "CI", je récupère avec une requète des
données
en
format standard dans une base ACCESS.
J'obtiens un fichier de 5 colonnes avec entêtes et un nombre de lignes
aléatoire.
Dans la case D2 J'ai une Origine en 3 caractères maxi et en E2 j'ai un
code
de 4 caractères.
Je retrouve ce code de 4 caractères dans la Colonne A de mon 2ème
onglet
"liste".
Mon onglet "liste" est le récapitulatif sur 800 lignes et 32 colonnes
(de
A
à AF) de toutes les origines correspondants aux différents codes.
J'aimerai afficher le chifffre 1 par exemple dans la case F2 de mon
onglet
"CI" quand pour le code affiché en E2 l'origine affichée D2 n'a
aucunes
correspondances dans mon onglet "liste".

onglet CI

A B C D E F
1 ART STR POP ORIG NUM
2 211 242 6 73 250W 1
3 013 411 5 94 380F 0
4 255 322 1 77 0431 0


onglet LISTE

A B C D E ETC...
1 N° DEPT DEPT DEPT DEPT DEPT
22 380F 59 12 94 01 22
53 0431 67 29 92 41 66
356 250W 51 17 71 06 93

Si quelqu'un ou quelqu'une peut m'indiquer une macro ou une formule je
l'en
remercie d'avance!!!














Yves
Le #5386211
Bonjour
j'espère que mon fichier t'aidera

http://cjoint.com/?mhqLaWiCOy
"Ellimac" news:
Bonjour,

cette formule ne répond pas à mon problème
Pourquoi ?

As-tu pensé à modifier le nom de la feuille pour la feuille Liste :
=SI(NB.SI(Liste!$A$2:$A$5000;E2)>0;1;0)

Camille


merci de m'aider, mais cette formule ne répond pas à mon problème
"Ellimac" news:
Bonjour,

=SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)

Camille


BONJOUR A TOUS
Je suis sous EXCEL 97
J'AI UN FICHIER EXCEL DE 2 ONGLETS.
Dans mon 1er onglet nommé "CI", je récupère avec une requète des
données
en
format standard dans une base ACCESS.
J'obtiens un fichier de 5 colonnes avec entêtes et un nombre de lignes
aléatoire.
Dans la case D2 J'ai une Origine en 3 caractères maxi et en E2 j'ai un
code
de 4 caractères.
Je retrouve ce code de 4 caractères dans la Colonne A de mon 2ème
onglet
"liste".
Mon onglet "liste" est le récapitulatif sur 800 lignes et 32 colonnes
(de
A
à AF) de toutes les origines correspondants aux différents codes.
J'aimerai afficher le chifffre 1 par exemple dans la case F2 de mon
onglet
"CI" quand pour le code affiché en E2 l'origine affichée D2 n'a
aucunes
correspondances dans mon onglet "liste".

onglet CI

A B C D E F
1 ART STR POP ORIG NUM
2 211 242 6 73 250W 1
3 013 411 5 94 380F 0
4 255 322 1 77 0431 0


onglet LISTE

A B C D E ETC...
1 N° DEPT DEPT DEPT DEPT DEPT
22 380F 59 12 94 01 22
53 0431 67 29 92 41 66
78 250W 51 17 77 06 93

Si quelqu'un ou quelqu'une peut m'indiquer une macro ou une formule je
l'en
remercie d'avance!!!














Publicité
Poster une réponse
Anonyme