Afficher 1 Quand et SI Résolu en partie

Le
Yves
Encore une fois loin de moi l'idée de contester les formules qu'on me donne
je ne refais pas tout l'historique.
C'est ok pour la multiplication par 1 pour les cellules genre 0457 mais quid
des cellules du genre P03 parceque des désagréables comme ça j'en ai
aussi
snif! snif! sanglot! sanglot!
Daniel.C" <dZZZcolardelle@free.fr> a écrit dans le message de news:
edp6QXPOIHA.4752@TK2MSFTNGP05.phx.gbl
> Les codes de la colonne E de Feuil1 ne correspondent PAS à ceux de la
> colonne A de Feuil2.
> On ne conteste pas MES formules (surtout rectifiées par Youki) ;-)))
> De plus le département de la colonne D de Feuil1 est au format texte, ce
> qu'on ne peut pas deviner; il faut donc modifier la formule comme suit :
> =ESTNA(EQUIV(CNUM(D2);INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$1000;0)&":AZ"&EQUIV(E2;Feuil2!A$1:A$1000;0));0))*1
> Daniel

Super merçi en format texte!!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5385851
En adaptant la formule de Carim :
=SI(ESTNUM(EQUIV(SI(ESTERR(CNUM(D2));D2;CNUM(D2));INDEX(Feuil2!$A$1:$E$2000;EQUIV(E2;Feuil2!A:A;0););0));0;1)
Daniel
C'est à dire, mettre la plage au format texte et les ressaisir
"Yves"
Encore une fois loin de moi l'idée de contester les formules qu'on me
donne
je ne refais pas tout l'historique.
C'est ok pour la multiplication par 1 pour les cellules genre 0457 mais
quid des cellules du genre P03 parceque des désagréables comme ça j'en ai
aussi...
snif! snif! sanglot! sanglot!
Daniel.C"
Les codes de la colonne E de Feuil1 ne correspondent PAS à ceux de la
colonne A de Feuil2.
On ne conteste pas MES formules (surtout rectifiées par Youki) ;-)))
De plus le département de la colonne D de Feuil1 est au format texte, ce
qu'on ne peut pas deviner; il faut donc modifier la formule comme suit :
=ESTNA(EQUIV(CNUM(D2);INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$1000;0)&":AZ"&EQUIV(E2;Feuil2!A$1:A$1000;0));0))*1
Daniel


Super merçi en format texte!!





Daniel.C
Le #5385821
Erreur de copier / coller dans mon message, ne tiens pas compte de la
phrase, après "Daniel".

"Daniel.C"
En adaptant la formule de Carim :
=SI(ESTNUM(EQUIV(SI(ESTERR(CNUM(D2));D2;CNUM(D2));INDEX(Feuil2!$A$1:$E$2000;EQUIV(E2;Feuil2!A:A;0););0));0;1)
Daniel
C'est à dire, mettre la plage au format texte et les ressaisir
"Yves"
Encore une fois loin de moi l'idée de contester les formules qu'on me
donne
je ne refais pas tout l'historique.
C'est ok pour la multiplication par 1 pour les cellules genre 0457 mais
quid des cellules du genre P03 parceque des désagréables comme ça j'en
ai aussi...
snif! snif! sanglot! sanglot!
Daniel.C"
Les codes de la colonne E de Feuil1 ne correspondent PAS à ceux de la
colonne A de Feuil2.
On ne conteste pas MES formules (surtout rectifiées par Youki) ;-)))
De plus le département de la colonne D de Feuil1 est au format texte, ce
qu'on ne peut pas deviner; il faut donc modifier la formule comme suit :
=ESTNA(EQUIV(CNUM(D2);INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$1000;0)&":AZ"&EQUIV(E2;Feuil2!A$1:A$1000;0));0))*1
Daniel


Super merçi en format texte!!









Yves
Le #5385811
et un merci de plus
"Daniel.C"
En adaptant la formule de Carim :
=SI(ESTNUM(EQUIV(SI(ESTERR(CNUM(D2));D2;CNUM(D2));INDEX(Feuil2!$A$1:$E$2000;EQUIV(E2;Feuil2!A:A;0););0));0;1)
Daniel
C'est à dire, mettre la plage au format texte et les ressaisir
"Yves"
Encore une fois loin de moi l'idée de contester les formules qu'on me
donne
je ne refais pas tout l'historique.
C'est ok pour la multiplication par 1 pour les cellules genre 0457 mais
quid des cellules du genre P03 parceque des désagréables comme ça j'en
ai aussi...
snif! snif! sanglot! sanglot!
Daniel.C"
Les codes de la colonne E de Feuil1 ne correspondent PAS à ceux de la
colonne A de Feuil2.
On ne conteste pas MES formules (surtout rectifiées par Youki) ;-)))
De plus le département de la colonne D de Feuil1 est au format texte, ce
qu'on ne peut pas deviner; il faut donc modifier la formule comme suit :
=ESTNA(EQUIV(CNUM(D2);INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$1000;0)&":AZ"&EQUIV(E2;Feuil2!A$1:A$1000;0));0))*1
Daniel


Super merçi en format texte!!









Publicité
Poster une réponse
Anonyme