Afficher 1 Quand et Si suite

Le
Yves
Bonjour à tous
Je suis sous excel 97


Ellimac tout d'abord m'a proposé(e) cette formule
" =SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)"
puis Daniel, et Youky m' on proposés cette autre formule
"=ESTNA(EQUIV(D2;INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$20;0)&":G"&EQUIV(E2;Feuil2!A$1:A$20;0));0))*1"
Je leur renouvelle mais remerciements malheureusement pour moi ces formules
m'affichent invariablement un 1 en colonne F .
Dans mon onglet Feuil2 j'ai un tableau d'environ 900 lignes sur environ 30
colonnes,alors une vérification automatique me soulagerait grandement!

en feuil1 colonne E j'ai un code et un N° de département en colonne D
j'ai par exemple le CODE 250W et le DEPT 73

Feuil1
A B C D E
ART STR POP DEPT CODE
211 242 6 73 250W
013 411 5 94 380F
255 322 1 77 0431

en Feuil2 je dois retrouver ce CODE dans la colonne A et sur la droite des
N° de départements

Feuil2
A B C D E ETC
N° DEPT DEPT DEPT DEPT DEPT DEPT
380F 59 12 94 01
1431 67 29 92 41 66 38
250W 51 17 77 88 45
982D 76 94

Je Cherche afficher automatiquement 1 en colonne F de Feuil1 si pour le mëme
CODE je ne retrouve pas mon département en Feuil2 et 0 si je le trouve

Feuil1
A B C D E F
ART STR POP DEPT CODE VERIF
211 242 6 73 250W 1
013 411 5 94 380F 0
255 322 1 77 0431 0


merçi d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #5386241
Bonjour,

Peux-tu déposer un extrait de ton fichier sur cjoint.com ?

Camille


Bonjour à tous
Je suis sous excel 97


Ellimac tout d'abord m'a proposé(e) cette formule
" =SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)"
puis Daniel, et Youky m' on proposés cette autre formule
"=ESTNA(EQUIV(D2;INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$20;0)&":G"&EQUIV(E2;Feuil2!A$1:A$20;0));0))*1"
Je leur renouvelle mais remerciements malheureusement pour moi ces formules
m'affichent invariablement un 1 en colonne F .
Dans mon onglet Feuil2 j'ai un tableau d'environ 900 lignes sur environ 30
colonnes,alors une vérification automatique me soulagerait grandement!

en feuil1 colonne E j'ai un code et un N° de département en colonne D
j'ai par exemple le CODE 250W et le DEPT 73

Feuil1
A B C D E
ART STR POP DEPT CODE
211 242 6 73 250W
013 411 5 94 380F
255 322 1 77 0431

en Feuil2 je dois retrouver ce CODE dans la colonne A et sur la droite des
N° de départements

Feuil2
A B C D E ETC...
N° DEPT DEPT DEPT DEPT DEPT DEPT
380F 59 12 94 01
1431 67 29 92 41 66 38
250W 51 17 77 88 45
982D 76 94

Je Cherche afficher automatiquement 1 en colonne F de Feuil1 si pour le mëme
CODE je ne retrouve pas mon département en Feuil2 et 0 si je le trouve

Feuil1
A B C D E F
ART STR POP DEPT CODE VERIF
211 242 6 73 250W 1
013 411 5 94 380F 0
255 322 1 77 0431 0


merçi d'avance






Youky
Le #5386231
Salut,
j'ai remplacé qlq lettres de la formule de Daniel
G par AZ et A$20 par A$1000 pour agrandir un peu le tableau
si besoin de moins ou plus de colonnes mets AZ en fonction des colonnes de
feuil2.

=ESTNA(EQUIV(D2;INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$1000;0)&":AZ"&EQUIV(E2;Feuil2!A$1:A$1000;0));0))*1

Youky
"Yves"
Bonjour à tous
Je suis sous excel 97


Ellimac tout d'abord m'a proposé(e) cette formule
" =SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)"
puis Daniel, et Youky m' on proposés cette autre formule
"=ESTNA(EQUIV(D2;INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$20;0)&":G"&EQUIV(E2;Feuil2!A$1:A$20;0));0))*1"
Je leur renouvelle mais remerciements malheureusement pour moi ces
formules m'affichent invariablement un 1 en colonne F .
Dans mon onglet Feuil2 j'ai un tableau d'environ 900 lignes sur environ 30
colonnes,alors une vérification automatique me soulagerait grandement!

en feuil1 colonne E j'ai un code et un N° de département en colonne D
j'ai par exemple le CODE 250W et le DEPT 73

Feuil1
A B C D E
ART STR POP DEPT CODE
211 242 6 73 250W
013 411 5 94 380F
255 322 1 77 0431

en Feuil2 je dois retrouver ce CODE dans la colonne A et sur la droite des
N° de départements

Feuil2
A B C D E ETC...
N° DEPT DEPT DEPT DEPT DEPT DEPT
380F 59 12 94 01
1431 67 29 92 41 66 38
250W 51 17 77 88 45
982D 76 94

Je Cherche afficher automatiquement 1 en colonne F de Feuil1 si pour le
mëme
CODE je ne retrouve pas mon département en Feuil2 et 0 si je le trouve

Feuil1
A B C D E F
ART STR POP DEPT CODE VERIF
211 242 6 73 250W 1
013 411 5 94 380F 0
255 322 1 77 0431 0


merçi d'avance





Yves
Le #5386191
je n'ai pas vu ma réponse s'afficher alors je recommence

http://cjoint.com/?mhqXdmYb7H
"Ellimac" news:
Bonjour,

Peux-tu déposer un extrait de ton fichier sur cjoint.com ?

Camille


Bonjour à tous
Je suis sous excel 97


Ellimac tout d'abord m'a proposé(e) cette formule
" =SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)"
puis Daniel, et Youky m' on proposés cette autre formule
"=ESTNA(EQUIV(D2;INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$20;0)&":G"&EQUIV(E2;Feuil2!A$1:A$20;0));0))*1"
Je leur renouvelle mais remerciements malheureusement pour moi ces
formules
m'affichent invariablement un 1 en colonne F .
Dans mon onglet Feuil2 j'ai un tableau d'environ 900 lignes sur environ
30
colonnes,alors une vérification automatique me soulagerait grandement!

en feuil1 colonne E j'ai un code et un N° de département en colonne D
j'ai par exemple le CODE 250W et le DEPT 73

Feuil1
A B C D E
ART STR POP DEPT CODE
211 242 6 73 250W
013 411 5 94 380F
255 322 1 77 0431

en Feuil2 je dois retrouver ce CODE dans la colonne A et sur la droite
des
N° de départements

Feuil2
A B C D E ETC...
N° DEPT DEPT DEPT DEPT DEPT DEPT
380F 59 12 94 01
1431 67 29 92 41 66
38
250W 51 17 77 88 45
982D 76 94

Je Cherche afficher automatiquement 1 en colonne F de Feuil1 si pour le
mëme
CODE je ne retrouve pas mon département en Feuil2 et 0 si je le trouve

Feuil1
A B C D E F
ART STR POP DEPT CODE VERIF
211 242 6 73 250W 1
013 411 5 94 380F 0
255 322 1 77 0431 0


merçi d'avance








Carim
Le #5386161
Salut,

Sans doute cette formule t'aidera :

=SI(ESTNUM(EQUIV(D2,INDEX(Feuil2!$A$1:$E$20,EQUIV(E2,Feuil2!A:A,0),),
0)),0,1)

A+
Carim
Carim
Le #5386141
Salut,

Sans doute cette formule fera ta vérif ...


=SI(ESTNUM(EQUIV(D2,INDEX(Feuil2!$A$1:$E$20,EQUIV(E2,Feuil2!A:A,0),),
0)),0,1)

A+
Yves
Le #5386121
Merçi Carim
apparement il y a une petite erreur dans ta formule je cherche
"Carim"
Salut,

Sans doute cette formule t'aidera :

=SI(ESTNUM(EQUIV(D2,INDEX(Feuil2!$A$1:$E$20,EQUIV(E2,Feuil2!A:A,0),),
0)),0,1)

A+
Carim


Carim
Le #5386061
Oops pardon ...
Tu utilises le ; comme séparateur ... alors que moi j'utilise la
virgule ...
Il faut également que tu ajustes les tailles des zones à tes
véritables besoins ...

A+
Daniel.C
Le #5386041
Les codes de la colonne E de Feuil1 ne correspondent PAS à ceux de la
colonne A de Feuil2.
On ne conteste pas MES formules (surtout rectifiées par Youki) ;-)))
De plus le département de la colonne D de Feuil1 est au format texte, ce
qu'on ne peut pas deviner; il faut donc modifier la formule comme suit :
=ESTNA(EQUIV(CNUM(D2);INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$1000;0)&":AZ"&EQUIV(E2;Feuil2!A$1:A$1000;0));0))*1
Daniel
"Yves"
je n'ai pas vu ma réponse s'afficher alors je recommence

http://cjoint.com/?mhqXdmYb7H
"Ellimac" news:
Bonjour,

Peux-tu déposer un extrait de ton fichier sur cjoint.com ?

Camille


Bonjour à tous
Je suis sous excel 97


Ellimac tout d'abord m'a proposé(e) cette formule
" =SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)"
puis Daniel, et Youky m' on proposés cette autre formule
"=ESTNA(EQUIV(D2;INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$20;0)&":G"&EQUIV(E2;Feuil2!A$1:A$20;0));0))*1"
Je leur renouvelle mais remerciements malheureusement pour moi ces
formules
m'affichent invariablement un 1 en colonne F .
Dans mon onglet Feuil2 j'ai un tableau d'environ 900 lignes sur environ
30
colonnes,alors une vérification automatique me soulagerait grandement!

en feuil1 colonne E j'ai un code et un N° de département en colonne D
j'ai par exemple le CODE 250W et le DEPT 73

Feuil1
A B C D E
ART STR POP DEPT CODE
211 242 6 73 250W
013 411 5 94 380F
255 322 1 77 0431

en Feuil2 je dois retrouver ce CODE dans la colonne A et sur la droite
des
N° de départements

Feuil2
A B C D E ETC...
N° DEPT DEPT DEPT DEPT DEPT DEPT
380F 59 12 94 01
1431 67 29 92 41 66 38
250W 51 17 77 88 45
982D 76 94

Je Cherche afficher automatiquement 1 en colonne F de Feuil1 si pour le
mëme
CODE je ne retrouve pas mon département en Feuil2 et 0 si je le trouve

Feuil1
A B C D E F
ART STR POP DEPT CODE VERIF
211 242 6 73 250W 1
013 411 5 94 380F 0
255 322 1 77 0431 0


merçi d'avance












Youky
Le #5386031
Le problème viens du format des cellules
exemple écrit un chiffre en D25 de Feuil2
tu remarqueras que le chiffre se mets à droite
Il est important que tes données importées soient dans les mêmes formats.
Pour les mettrent en nombre on tape 1 dans une cellule et on le copie
ensuite on selectionne la colonne et menu>Edition>collage spécial>cocher
multiplication et ok
Sur le fichier joint il n'y a pas de CODE qui correspondent pour bien tester
Youky
Yves
Le #5386021
mon fichier code 2 contient des données identiques lui
ouf!!
http://cjoint.com/?mhskXAWVAp
"Ellimac" news:
Bonjour,

Peux-tu déposer un extrait de ton fichier sur cjoint.com ?

Camille


Bonjour à tous
Je suis sous excel 97


Ellimac tout d'abord m'a proposé(e) cette formule
" =SI(NB.SI(Feuil2!$A$2:$A$5000;E2)>0;1;0)"
puis Daniel, et Youky m' on proposés cette autre formule
"=ESTNA(EQUIV(D2;INDIRECT("Feuil2!B"&EQUIV(E2;Feuil2!A$1:A$20;0)&":G"&EQUIV(E2;Feuil2!A$1:A$20;0));0))*1"
Je leur renouvelle mais remerciements malheureusement pour moi ces
formules
m'affichent invariablement un 1 en colonne F .
Dans mon onglet Feuil2 j'ai un tableau d'environ 900 lignes sur environ
30
colonnes,alors une vérification automatique me soulagerait grandement!

en feuil1 colonne E j'ai un code et un N° de département en colonne D
j'ai par exemple le CODE 250W et le DEPT 73

Feuil1
A B C D E
ART STR POP DEPT CODE
211 242 6 73 250W
013 411 5 94 380F
255 322 1 77 0431

en Feuil2 je dois retrouver ce CODE dans la colonne A et sur la droite
des
N° de départements

Feuil2
A B C D E ETC...
N° DEPT DEPT DEPT DEPT DEPT DEPT
380F 59 12 94 01
1431 67 29 92 41 66
38
250W 51 17 77 88 45
982D 76 94

Je Cherche afficher automatiquement 1 en colonne F de Feuil1 si pour le
mëme
CODE je ne retrouve pas mon département en Feuil2 et 0 si je le trouve

Feuil1
A B C D E F
ART STR POP DEPT CODE VERIF
211 242 6 73 250W 1
013 411 5 94 380F 0
255 322 1 77 0431 0


merçi d'avance








Publicité
Poster une réponse
Anonyme