Afficher du texte selon des conditions

Le
Apitos
Bonsoir,

Dans la feuille Source, cellule N4, j'ai un nombre qui diminue chaque
jour.

J'aimerais écrire du texte selon cette valeur dans Feuil1 :

Dans la cellule I121 :

=SI((SI(Source!N4>15;"Attention 1ere 15aine !! + de Source!M2 de " &
TEXTE(H121-Source!M2;"0,00");"Attention 2eme 15aine !! + de Source!M6
de " & TEXTE(H121-Source!M6;"0,00")))<0;"";"")

- Si N4 est > à 15 et (H121-Source!M2) > 0 alors écrire :
"Attention 1ere 15aine !! + de Source!M2 de " & TEXTE(H121-Source!
M2;"0,00"

- Sinon Si N4 <= 15 et (H121-Source!M6) > 0
"Attention 2eme 15aine !! + de Source!M6 de " & TEXTE(H121-Source!
M6;"0,00")

J'aimerais corriger cette formule.

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #5028031
Bonsoir,

Quelque chose comme cela peut-être

=SI(N4="";"";SI(N4>15;"Attention 1ere 15aine !! de "&Source!M2&" de
"&TEXTE(H121-Source!M2;"0,00");SI(ET(N4<;H121-Source!M6>0);"Attention
2ere 15aine !! de "&Source!M6&" de "&TEXTE(H121-Source!M6;"0,00");"")))

--
Salutations
JJ


"Apitos"
Bonsoir,

Dans la feuille Source, cellule N4, j'ai un nombre qui diminue chaque
jour.

J'aimerais écrire du texte selon cette valeur dans Feuil1 :

Dans la cellule I121 :

=SI((SI(Source!N4>15;"Attention 1ere 15aine !! + de Source!M2 de " &
TEXTE(H121-Source!M2;"0,00");"Attention 2eme 15aine !! + de Source!M6
de " & TEXTE(H121-Source!M6;"0,00")))<0;"";"")

- Si N4 est > à 15 et (H121-Source!M2) > 0 alors écrire :
"Attention 1ere 15aine !! + de Source!M2 de " & TEXTE(H121-Source!
M2;"0,00"

- Sinon Si N4 <= 15 et (H121-Source!M6) > 0
"Attention 2eme 15aine !! + de Source!M6 de " & TEXTE(H121-Source!
M6;"0,00")

J'aimerais corriger cette formule.

Merci.
Apitos
Le #5027961
Bonsoir Jacky,

J'ai apporté une modification à ta formule, mais elle me donne cette
résultat : #VALEUR


=SI(Source!N4="";"";SI(ET(Source!N4>15;H131-Source!M2>0);"Attention
1ere 15aine !! + de "&Source!M2&" de "&TEXTE(H131-Source!
M2;"0,00");SI(ET(N4<;H131-Source!M6>0);"Attention 2ere 15aine !! +
de "&Source!M6&" de "&TEXTE(H131-Source!M6;"0,00");"")))

Merci
Apitos
Le #5027951
Bonsoir Jacky,

J'ai apporté une modification à ta formule, mais elle me donne cette
résultat : #VALEUR


=SI(Source!N4="";"";SI(ET(Source!N4>15;H131-Source!M2>0);"Attention
1ere 15aine !! + de "&Source!M2&" de "&TEXTE(H131-Source!
M2;"0,00");SI(ET(N4<;H131-Source!M6>0);"Attention 2ere 15aine !! +
de "&Source!M6&" de "&TEXTE(H131-Source!M6;"0,00");"")))

Merci
Jacky
Le #5027941
Re...

Ceci
.....SI(ET(N4<;H131-Source!M6>0);"........
devrait être cela:
....SI(ET(Source!N4<;H131-Source!M6>0);".....
et H131 sur la feuille active

Ceci fonctionne chez moi......

=SI(Source!N4="";"";SI(ET(Source!N4>15;H131-Source!M2>0);"Attention 1ere
15aine !! + de "&Source!M2&" de
"&TEXTE(H131-Source!M2;"0,00");SI(ET(Source!N4<;H131-Source!M6>0);"Attention
2ere 15aine !! +de "&Source!M6&" de "&TEXTE(H131-Source!M6;"0,00");"")))

--
Salutations
JJ


"Apitos"


Bonsoir Jacky,

J'ai apporté une modification à ta formule, mais elle me donne cette
résultat : #VALEUR


=SI(Source!N4="";"";SI(ET(Source!N4>15;H131-Source!M2>0);"Attention
1ere 15aine !! + de "&Source!M2&" de "&TEXTE(H131-Source!
M2;"0,00");SI(ET(N4<;H131-Source!M6>0);"Attention 2ere 15aine !! +
de "&Source!M6&" de "&TEXTE(H131-Source!M6;"0,00");"")))

Merci
Apitos
Le #5027231
Bonsoir à tous,

J'ai essayé d'étudier tout les cas possibles avec la formule de Jacky.

mais il reste encore des anomalies.

En fichier joint j'ai présenté tout les cas possibles, avec la les
résultats voulus par cette formule.

http://cjoint.com/?lit76U0kjO

Merci d'avance.
Jacky
Le #5027081
Re,
Regardes si cela colle.....

=SI(Source!N4="";"";SI(ET(Source!N4>15;H10-Source!M2>=0);"Attention 1ere
15aine !! + de "&Source!M2&" de
"&H10-Source!M2;SI(OU(ET(Source!N4;H10-Source!M6>0);ET(Source!N4<15;H10-Source!M6=0);ET(Source!N4<15;H10-Source!M6>0);ET(Source!N4<15;H10-Source!M6<0));"Attention
2eme 15aine !! +de " &Source!M6 & " de " &H10-Source!M6;"")))

Et ici pour voir comment
http://cjoint.com/?lixkTawYSq
--
Salutations
JJ


"Apitos"
Bonsoir à tous,

J'ai essayé d'étudier tout les cas possibles avec la formule de Jacky.

mais il reste encore des anomalies.

En fichier joint j'ai présenté tout les cas possibles, avec la les
résultats voulus par cette formule.

http://cjoint.com/?lit76U0kjO

Merci d'avance.
Apitos
Le #5027021
Bonsoir Jacky,

Je te remercie d'être penché sur mon problème.

A première vue, j'ai quelques remarques :

- Les valeurs de L2, M2; M4 et M6 sont toujours positifs (Se sont des
sommes d'argents !).
- La valeur en L2 diminue chaque jour jusqu'à l'atteinte de la valeur
zéro. (Dépenses quotidiennes).
- La formule en N4, calcule le reste de la période (27/mois au 27/mois
+1) en jours. (Elle est utile).
- M6 est renseignée lorsque la valeur de N4 est égal à 15 (Cette
valeur doit être aussi gardée dans cette cellule, mais je ne sais pas
comment le faire pour ne pas avoir un 0.00 lorsque N4 est différente
de 15).

Merci.
-
Apitos
Le #5026971
Re,

- La formule dans Source!M6 qui me permis de garder la valeur lorsque
N< est :

=SI(N4<;M4;"0,00")

- Résultat concluante pour N4 = 15.

- Pour le cas ou N4 est < 15, il y'a affichage du texte pour tout les
cas de (H10-Source!M6) [=0; <0; >0]

- Pour le cas ou N4 > 15, il y'a affichage du texte pour les deux cas
de (H10-Source!M2) [=0;>0]
Apitos
Le #5026841
On 9 nov, 00:28, Apitos
Re,

- La formule dans Source!M6 qui me permis de garder la valeur lorsque
N< est :

=SI(N4<;M4;"0,00")


Non, c'est faux.

M4 prend chaque fois une nouvelle valeur, or c'est seulement la valeur
ou N4 = 15 que je voudrais garder.

Publicité
Poster une réponse
Anonyme