Aide dans les formules contenant "SI" "INDEX" "EQUIV" + recherches

Le
Mic
Bonjour,

Si qqn maitrises parfaitement ce type de formule, merci de me contact.
J'ai un tableur assez complexe qui établit des recherches sur base de code
et les transforme en nom d'article (sur base de comparaison).

le hic c'est que 1 code ne donne pas le bon nom d'article alors que tous les
infos sont justes.

voici le type de formule utilisée:
=SI(OU($C163="";ESTNA(INDEX(nomArt;EQUIV($C163;ean12;0))));"";INDEX(bdd2007;EQUIV($C163;ean12;0);2))

Qui accepterait de recevoir mon fichier et y jettez un oeil??
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
dre
Le #4800551

Bonjour,

Si qqn maitrises parfaitement ce type de formule, merci de me contact.
J'ai un tableur assez complexe qui établit des recherches sur base de code
et les transforme en nom d'article (sur base de comparaison).

le hic c'est que 1 code ne donne pas le bon nom d'article alors que tous les
infos sont justes.

voici le type de formule utilisée:
=SI(OU($C163="";ESTNA(INDEX(nomArt;EQUIV($C163;ean12;0))));"";INDEX(bdd2007;EQUIV($C163;ean12;0);2))

Qui accepterait de recevoir mon fichier et y jettez un oeil??


dre
Le #4800541
Bonjour,

Il te suffit de mettre quelques lignes sur CiJoint et de coller le lien dans
ta reponse.

Quant à ta formule, je vois qu'il y a un double test au départ : cellule
vide ou valeur non trouvée.
Puis un simple INDEX EQUIV

Ce qui m'interpèlle est que la plage du test "nomArt" n'est pas la même que
celle de la recherche "bdd2007".

dré




Bonjour,

Si qqn maitrises parfaitement ce type de formule, merci de me contact.
J'ai un tableur assez complexe qui établit des recherches sur base de code
et les transforme en nom d'article (sur base de comparaison).

le hic c'est que 1 code ne donne pas le bon nom d'article alors que tous les
infos sont justes.

voici le type de formule utilisée:
=SI(OU($C163="";ESTNA(INDEX(nomArt;EQUIV($C163;ean12;0))));"";INDEX(bdd2007;EQUIV($C163;ean12;0);2))

Qui accepterait de recevoir mon fichier et y jettez un oeil??


Mic
Le #4800531
Pourriez vous m'envoyer votre email direct svp ?

ce serait genial car je patauge! (mes nerfs lachent)

Michael


Bonjour,

Il te suffit de mettre quelques lignes sur CiJoint et de coller le lien dans
ta reponse.

Quant à ta formule, je vois qu'il y a un double test au départ : cellule
vide ou valeur non trouvée.
Puis un simple INDEX EQUIV

Ce qui m'interpèlle est que la plage du test "nomArt" n'est pas la même que
celle de la recherche "bdd2007".

dré




Bonjour,

Si qqn maitrises parfaitement ce type de formule, merci de me contact.
J'ai un tableur assez complexe qui établit des recherches sur base de code
et les transforme en nom d'article (sur base de comparaison).

le hic c'est que 1 code ne donne pas le bon nom d'article alors que tous les
infos sont justes.

voici le type de formule utilisée:
=SI(OU($C163="";ESTNA(INDEX(nomArt;EQUIV($C163;ean12;0))));"";INDEX(bdd2007;EQUIV($C163;ean12;0);2))

Qui accepterait de recevoir mon fichier et y jettez un oeil??




Mic
Le #4800521
http://cjoint.com/?iwnqbTru4g
= fichier 1 BDDETE

http://cjoint.com/?iwnrnp0erU

= feuille de reassort

article qui pose probleme: code 0000000059299 = normalement RABELAIS et
affice PUDDING!



Bonjour,

Il te suffit de mettre quelques lignes sur CiJoint et de coller le lien dans
ta reponse.

Quant à ta formule, je vois qu'il y a un double test au départ : cellule
vide ou valeur non trouvée.
Puis un simple INDEX EQUIV

Ce qui m'interpèlle est que la plage du test "nomArt" n'est pas la même que
celle de la recherche "bdd2007".

dré




Bonjour,

Si qqn maitrises parfaitement ce type de formule, merci de me contact.
J'ai un tableur assez complexe qui établit des recherches sur base de code
et les transforme en nom d'article (sur base de comparaison).

le hic c'est que 1 code ne donne pas le bon nom d'article alors que tous les
infos sont justes.

voici le type de formule utilisée:
=SI(OU($C163="";ESTNA(INDEX(nomArt;EQUIV($C163;ean12;0))));"";INDEX(bdd2007;EQUIV($C163;ean12;0);2))

Qui accepterait de recevoir mon fichier et y jettez un oeil??




Publicité
Poster une réponse
Anonyme