Aide pour mise à jour de Icedove sous une vieille distro

Le
Bernard
Bonjour à tous,

Mon vieux desktop est équipé de Debian Lenny, et j'hésite énormément à
réinstaller une nouvelle version. Lorsque, il y a déjà plusieurs années,
j'étais passé de Sarge à Lenny, cela m'avait pris au moins trois mois
que de tout récupérer, tant j'avais d'applications supplémentaires
installées. J'en ai même trouvé qui n'étaient plus supportées dans la
nouvelle version, alors qu'elle fonctionnaient parfaitement avec
l'ancienne. Quelle galère ! Et, si cela se trouve, mon vieux PC, qui
date de 2006, n'a pas les ressources suffisantes pour fonctionner avec
une distro moderne, ou alors cela va ramer un maximum Je dispose bien
également d'un portable récent, sous Ubuntu 14.04, mais mon vieux
Desktop m'est précieux pour toutes les vieilles applis, d'autant que j'y
suis bien mieux installé ergonomiquement que devant mon portable.

Tout irait donc pour le mieux avec ce Desktop, s'il n'y avait le souci
majeur de Icedove : de moins en moins d'applications sont reconnues ;
comme précisé dans mon précédent message, je ne peux même plus afficher
l'interface de ma Livebox. Je ne sais comment faire une maj de mon
Icedove 2.0.0.22 (20090706), étant donné que Lenny n'est plus supporté.
Les url qui se trouvent dans mon fichier /etc/apt/sources.list ne sont
plus actives.

Ma question est la suivante: quelles sont les url des archives de Lenny,
à mettre dans mon sources.list pour tenter d'upgrader mon icedove ainsi
que mon plugin flashplayer ou l'application qui en tient lieu ? Sinon,
comment installer un icedove récent, celui prévu pour Jessie par
exemple, sur mon Lenny ? En faisant usage d'un 'backport' par exemple
? Sur mon portable, j'ai Firefox 42.0 qui fonctionne assez bien
mais, comme expliqué, le souci est de faire fonctionner un navigateur
sur la vieille machine sous Lenny.

Ou alors, comment installer un firefox récent depuis les fichiers
sources ou des précompilations ? Je viens de tenter d'installer Firefox
44.0 après téléchargement et décompactage d'un fichier proposé par
mozilla.com mais cela ne fonctionne pas: ==> 'libxul.so : undefined
symbol : gtk_widget_set_can_focus' Sans doute n'ai-je pas les
bibliothèques adéquates pour faire fonctionner cette version.

Merci d'avance pour votre aide.

Bernard
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Obry
Le #26388251
Icedove? Ne parlerais-tu pas plutôt de Iceweasel?

Cordialement,

--
Pascal Obry / Magny Les Hameaux (78)

The best way to travel is by means of imagination

http://v2p.fr.eu.org
http://www.obry.net

gpg --keyserver keys.gnupg.net --recv-key F949BD3B
Bernard Isambert
Le #26388261
J'ai du matériel de 2005, en squeeze, qui marche très bien. Les firef ox
actuels tournent dessus avec des plantages fréquents, mais je m'en
contente. J'ai essayé wheezy, totalement incompatible avec ce que je
fais (j'utilise, sans avoir le choix, un vieux VMplayer qui ne supporte
pas les noyaux au-delà du 2.6.38). Je reste en squeeze...

--
Bernard.
20 ans d'utilisation de Debian. Comme le temps passe...
maderios
Le #26388270
On 02/06/2016 08:13 PM, Bernard Isambert wrote:
J'ai du matériel de 2005, en squeeze, qui marche très bien. Les firefox
actuels tournent dessus avec des plantages fréquents, mais je m'en
contente. J'ai essayé wheezy, totalement incompatible avec ce que je
fais (j'utilise, sans avoir le choix, un vieux VMplayer qui ne supporte
pas les noyaux au-delà du 2.6.38). Je reste en squeeze...



Bonjour
Tes ennuis me semblent bizarres. Ta configuration n'est peut-être pas
suffisamment optimisée. J'ai une Jessie installée sur un vieux portable
acheté il y a plus de treize ans (vers 2002) et tout marche parfaitement
à part le disque d qui rame "un peu", c'est le point faible. Bin oui,
c'est un dd ide... J'arrive même à compiler le noyau avec ce PC. Aucun
problème avec les derniers iceweasel/firefox, aucun problème avec le
multimédia, vlc, clementine, avidemux, etc...
Bien évidemment, pas de gnome ou kde mais E17.
J'ai testé avec xfce4, ça roule, mais pas aussi bien que E.

--
Maderios
Bernard
Le #26388273
Pascal Obry wrote:
Icedove? Ne parlerais-tu pas plutôt de Iceweasel?




Mais si, bien sur, Iceweasel... ma langue (mon clavier) a fourché...
Fabien R
Le #26388330
On 06/02/2016 19:08, Bernard wrote:
comment installer un icedove récent, celui prévu pour Jessie par
exemple, sur mon Lenny ? En faisant usage d'un 'backport' par exemple


Tu peux toujours essayer et voir s'il te propose un upgrade.
Pour la maj de flash, tu peux utiliser:
dpkg-reconfigure flashplugin-nonfree

--
Fabien
yamo'
Le #26388355
Salut,

Bernard a écrit le 06/02/2016 19:10 :
Mon vieux desktop est équipé de Debian Lenny, et j'hésite énormément à
réinstaller une nouvelle version.




Tu peux peut-être commencer par migrer ce qui est trop vieux en faisant
du pinning. Et comme ça petit à petit faire la mise à jour.
En faisant apt-get install monpaquet -t wheezy
Je ne sais pas si mélanger des paquets lenny et jessie est l'idéal...

Si tu utilises gnome, il faudrait plutôt utiliser mate mais il n'est
apparemment disponible pour debian que depuis wheezy :


J'utiliserais plutôt xfce mais mate a des d'adeptes nostalgiques de gnome2.

Ici, je suis en stable avec le repo multimedia en plus et j'ai besoin de
quelques paquets en testing du repo multipedia :

Pou l'exemple, voici ma conf de pinning :
/etc/apt/preferences.d/apt-listbugs
::::::::::::::
::::::::::::::
/etc/apt/preferences.d/multimedia
::::::::::::::
Package: *
Pin: origin "www.deb-multimedia.org"
Pin-Priority: 500

Package: qarte
Pin: origin "www.deb-multimedia.org"
Pin-Priority: 950
::::::::::::::
/etc/apt/preferences.d/stable
::::::::::::::
Package: *
Pin: release a=stable
Pin-priority: 900

Package: *
Pin: release n=jessie
Pin-priority: 900
::::::::::::::
/etc/apt/preferences.d/testing
::::::::::::::
Package: *
Pin: release a=testing
Pin-priority: 100


Voici ce que ça donne par exemple pour vlc :

$ apt-cache policy vlc
vlc:
Installé : 1:2.2.1-dmo3
Candidat : 1:2.2.1-dmo3
Table de version :
1:2.2.1-dmo14 0
500 http://www.deb-multimedia.org/ testing/main i386 Packages
*** 1:2.2.1-dmo3 0
990 http://www.deb-multimedia.org/ jessie/main i386 Packages
100 /var/lib/dpkg/status
2.2.1-5+b2 0
100 http://httpredir.debian.org//debian/ testing/main i386 Packages
2.2.1-1~deb8u1 0
990 http://httpredir.debian.org//debian/ jessie/main i386 Packages
2.2.0~rc2-2+deb8u1 0
990 http://security.debian.org/ jessie/updates/main i386 Packages



--
Stéphane
Bernard
Le #26388418
Fabien R wrote:
On 06/02/2016 19:08, Bernard wrote:

comment installer un icedove récent, celui prévu pour Jessie par
exemple, sur mon Lenny ? En faisant usage d'un 'backport' par exemple



Tu peux toujours essayer et voir s'il te propose un upgrade.



Trop risqué. J'en connais qui s'en sont mordus les doigts. Sur une
installation aussi ancienne, plus supportée depuis des années, au cas où
un upgrade serait toujours proposé, on risque de tomber sur des url
désactivés et autres surprises. Déjà qu'un upgrade fait dans les
conditions normales n'est pas toujours une réussite...

Pour la maj de flash, tu peux utiliser:
dpkg-reconfigure flashplugin-nonfree



Voici la réponse :

:/home/bd# dpkg-reconfigure flashplugin-nonfree

/usr/sbin/dpkg-reconfigure: flashplugin-nonfree est cassé ou
partiellement installé

Je pourrais tenter un apt-get 'remove' ou 'purge', mais alors je risque
fort de ne pouvoir réinstaller. C'est que Flashplugin-nonfree n'est
apparemment plus disponible, tout au moins avec mes sources.list :

# apt-get install -s flashplugin-nonfree

paquet introuvable

$ apt-cache search flashplugin

flashplugin-nonfree-extrasound (c'est le seul paquet disponible)

Sur mon système, aucun fichier .deb concernant flashplugin

Par ailleurs:

$ vi /var/lib/dpkg/status :/flashplugin :

Package: flashplugin-nonfree
Status: deinstall ok config-files
Priority: optional
Section: contrib/web
Installed-Size: 128
Maintainer: Bart Martens Architecture: i386
Version: 1:2.5~bpo50+1
Config-Version: 1:2.5~bpo50+1
Replaces: flashplugin (<< 6)
Depends: debconf | debconf-2.0, wget, gnupg, libatk1.0-0, libcairo2,
libfontconfig1, libfreetype6, libgcc1, libglib2.0-0, libgtk2.0-0,
libnspr4-0d, libnss3-1d, libpango1.0-0, libstdc++6, libx11-6,
libxext6, libxt6, libcurl3-gnutls
Suggests: iceweasel, konqueror-nsplugins, x-ttcidfont-conf,
msttcorefonts, ttf-dejavu, ttf-xfree86-nonfree, xfs (>= 1:1.0.1-5),
flashplugin-nonfree-extrasound
Conflicts: flashplayer-mozilla, flashplugin (<< 6), xfs (<< 1:1.0.1-5)

Ainsi donc, apparemment je l'avais déinstallé ! Et en effet cela me
rappelle de vagues souvenirs: des problèmes étant survenus, j'avais fait
divers essais et trouvé à l'époque que cela fonctionnait mieux avec le
'flashplayer-mozilla', et que les deux entraient en conflit. Mais
l'amélioration n'a duré que quelques mois, un peu plus d'un an
peut-être, ensuite de quoi des sites de plus en plus nombreux ont été
programmés avec de nouvelles fonctionnalités incompatibles, et comme il
n'y avait plus de mises à jour, j'en suis là aujourd'hui.

Si seulement je trouvais le moyen d'installer une version récente de
Iceweasel ou Firefox (ou autre Opera etc...) qui soit compatible avec
les bibliothèques disponibles sur mon vieux Lenny, ce serait une
solution très satisfaisante. Par contre, s'il me faut upgrader trop de
bibliothèques et que celles-ci n'aient pas été testées par Debian sur
Lenny, je risque fort d'avoir de sérieux déboires.

Vrai: comme je l'ai dit, je dispose sur mon portable (mal commode
d'utilisation prolongée), du dernier Firefox sous Ubuntu 14.04 64bit.
Mais là non plus ce n'est pas tout à fait idéal. Si, par exemple,
j'essaye de visualiser une video d'infos sur franceinter.fr, j'obtiens
ceci :

- Firefox has prevented the outdated plugin 'Adobe Flash' from
running on http://franceinter.fr: Continue Blocking ? Allow now ?
Remember ? Et ce n'est qu'après avoir choisi l'option Allow que la
vidéo apparaît. Mais il y a tout lieu de supposer que ceci ne va pas
durer et que, tôt ou tard l'on ne pourra plus accéder à ce qui nécessite
Flash pour fonctionner, sachant que les nouvelles versions ne sont plus
disponibles pour Linux, même en nonfree, même en payant.
Bernard Schoenacker
Le #26388423
Le Sun, 07 Feb 2016 16:53:35 +0100,
Bernard
Fabien R wrote:
> On 06/02/2016 19:08, Bernard wrote:
>
>> comment installer un icedove récent, celui prévu pour Jessie par
>> exemple, sur mon Lenny ? En faisant usage d'un 'backport' par
>> exemple
> Tu peux toujours essayer et voir s'il te propose un upgrade.
>
Trop risqué. J'en connais qui s'en sont mordus les doigts. Sur une
installation aussi ancienne, plus supportée depuis des années, au cas
où un upgrade serait toujours proposé, on risque de tomber sur des
url désactivés et autres surprises. Déjà qu'un upgrade fait dans les
conditions normales n'est pas toujours une réussite...

> Pour la maj de flash, tu peux utiliser:
> dpkg-reconfigure flashplugin-nonfree
>
Voici la réponse :

:/home/bd# dpkg-reconfigure flashplugin-nonfree

/usr/sbin/dpkg-reconfigure: flashplugin-nonfree est cassé ou
partiellement installé

Je pourrais tenter un apt-get 'remove' ou 'purge', mais alors je
risque fort de ne pouvoir réinstaller. C'est que Flashplugin-nonfree
n'est apparemment plus disponible, tout au moins avec mes
sources.list :

# apt-get install -s flashplugin-nonfree

paquet introuvable

$ apt-cache search flashplugin

flashplugin-nonfree-extrasound (c'est le seul paquet disponible)

Sur mon système, aucun fichier .deb concernant flashplugin

Par ailleurs:

$ vi /var/lib/dpkg/status :/flashplugin :

Package: flashplugin-nonfree
Status: deinstall ok config-files
Priority: optional
Section: contrib/web
Installed-Size: 128
Maintainer: Bart Martens Architecture: i386
Version: 1:2.5~bpo50+1
Config-Version: 1:2.5~bpo50+1
Replaces: flashplugin (<< 6)
Depends: debconf | debconf-2.0, wget, gnupg, libatk1.0-0,
libcairo2, libfontconfig1, libfreetype6, libgcc1, libglib2.0-0,
libgtk2.0-0, libnspr4-0d, libnss3-1d, libpango1.0-0,
libstdc++6, libx11-6, libxext6, libxt6, libcurl3-gnutls
Suggests: iceweasel, konqueror-nsplugins, x-ttcidfont-conf,
msttcorefonts, ttf-dejavu, ttf-xfree86-nonfree, xfs (> > 1:1.0.1-5), flashplugin-nonfree-extrasound
Conflicts: flashplayer-mozilla, flashplugin (<< 6), xfs (<<
1:1.0.1-5)

Ainsi donc, apparemment je l'avais déinstallé ! Et en effet cela me
rappelle de vagues souvenirs: des problèmes étant survenus, j'avais
fait divers essais et trouvé à l'époque que cela fonctionnait mieux
avec le 'flashplayer-mozilla', et que les deux entraient en conflit.
Mais l'amélioration n'a duré que quelques mois, un peu plus d'un an
peut-être, ensuite de quoi des sites de plus en plus nombreux ont été
programmés avec de nouvelles fonctionnalités incompatibles, et comme
il n'y avait plus de mises à jour, j'en suis là aujourd'hui.

Si seulement je trouvais le moyen d'installer une version récente de
Iceweasel ou Firefox (ou autre Opera etc...) qui soit compatible avec
les bibliothèques disponibles sur mon vieux Lenny, ce serait une
solution très satisfaisante. Par contre, s'il me faut upgrader trop
de bibliothèques et que celles-ci n'aient pas été testées par Debian
sur Lenny, je risque fort d'avoir de sérieux déboires.

Vrai: comme je l'ai dit, je dispose sur mon portable (mal commode
d'utilisation prolongée), du dernier Firefox sous Ubuntu 14.04
64bit. Mais là non plus ce n'est pas tout à fait idéal. Si, par
exemple, j'essaye de visualiser une video d'infos sur franceinter.fr,
j'obtiens ceci :

- Firefox has prevented the outdated plugin 'Adobe Flash' from
running on http://franceinter.fr: Continue Blocking ? Allow now ?
Remember ? Et ce n'est qu'après avoir choisi l'option Allow que la
vidéo apparaît. Mais il y a tout lieu de supposer que ceci ne va pas
durer et que, tôt ou tard l'on ne pourra plus accéder à ce qui
nécessite Flash pour fonctionner, sachant que les nouvelles versions
ne sont plus disponibles pour Linux, même en nonfree, même en payant.




bonjour,

serait il possible d'obtenir de l'information concernant le
sources.list ?

la doc en ligne traitant du sujet :

https://www.debian.org/distrib/archive

normalement il doit y avoir ceci :

deb http://archive.debian.org/debian/ lenny contrib main non-free

slt
bernard
yamo'
Le #26388435
Salut,

Bernard a écrit le 07/02/2016 17:00 :
- Firefox has prevented the outdated plugin 'Adobe Flash' from
running on http://franceinter.fr: Continue Blocking ? Allow now ?
Remember ? Et ce n'est qu'après avoir choisi l'option Allow que la
vidéo apparaît. Mais il y a tout lieu de supposer que ceci ne va pas
durer et que, tôt ou tard l'on ne pourra plus accéder à ce qui nécessite
Flash pour fonctionner, sachant que les nouvelles versions ne sont plus
disponibles pour Linux, même en nonfree, même en payant.



La version actuelle sur linux est 11.2.202.559

Si l'outil est présent, c'est avec :
# update-flashplugin-nonfree --install -v
Qu'on peut mettre à jour flash ...

Pour France Inter, je viens de trouver :


--
Stéphane
Bernard Schoenacker
Le #26388439
Le Sun, 7 Feb 2016 17:59:06 +0100,
yamo'
Salut,

Bernard a écrit le 07/02/2016 17:00 :
> - Firefox has prevented the outdated plugin 'Adobe Flash' from
> running on http://franceinter.fr: Continue Blocking ? Allow now ?
> Remember ? Et ce n'est qu'après avoir choisi l'option Allow que la
> vidéo apparaît. Mais il y a tout lieu de supposer que ceci ne va
> pas durer et que, tôt ou tard l'on ne pourra plus accéder à ce qui
> nécessite Flash pour fonctionner, sachant que les nouvelles
> versions ne sont plus disponibles pour Linux, même en nonfree, même
> en payant.

La version actuelle sur linux est 11.2.202.559

Si l'outil est présent, c'est avec :
# update-flashplugin-nonfree --install -v
Qu'on peut mettre à jour flash ...

Pour France Inter, je viens de trouver :
flash.





bonjour,


il est possible d'éviter tout ceci en prenant le lien en direct :


france inter :

http://audio.scdn.arkena.com/11008/franceinter-midfi128.mp3

france musique :
http://audio.scdn.arkena.com/11012/francemusique-midfi128.mp3

pour plus de détail voici la page à consulter :

http://www.radiofrance.fr/sites/default/files/pages_uploaded_files/radio_france_-_adresses_flux_mp3_-_mai_2015.pdf


slt
bernard
Publicité
Poster une réponse
Anonyme