aide pour slack

Le
newbee-slack
bonjour!

y aurai t'il un "specialiste" slackware dans le coin :)
je connais linux, debian and comais pour mon portable compacq, seul la
slack s'est installerje n'ai rien contre, mais j'ai besoin d"un peu
d'aide pour la carte graphigue (nvidia), mais surtout pour le reseaux et
le son
à votre bon coeur ;)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
doug713705
Le #4167601
Le dimanche 12 août 2007 13:06, newbee-slack s'est exprimé de la sorte sur
alt.fr.comp.os.linux.configuration :

bonjour!



Bonjour,

y aurai t'il un "specialiste" slackware dans le coin :)
je connais linux, debian and co...mais pour mon portable compacq, seul la
slack s'est installer...je n'ai rien contre, mais j'ai besoin d"un peu
d'aide pour la carte graphigue (nvidia), mais surtout pour le reseaux et
le son...


Pour la carte video, il suffit de téléchager le driver sur le site de nvidia
et de l'installer conformément aux instructions fournies par nvidia.

C'est simple comme bonjour et autant que je m'en souvienne, il suffit
d'executer le fichier que tu auras téléchargé depuis le site de nvidia.

Ensuite, il te faudra éditer /etc/X11/xorg.conf afin de prendre en compte ce
nouveau driver.

Pour info, à chaque recompilation du noyau, il faudra réinstaller le driver
à la main (par contre inutile de remodifier xorg.conf)

L'interêt de Slackware est justeemnt que dans 99.9% des cas, les docs
fournies par les concepteurs des programmes qu'on veut installer suffisent
pour s'en sortir. Pas besoin de patch ou de commandes exotiques pour
installer un programme.

J'ai mal digéré l'évolution de la Slack current au moment du passage à la
12.0 sur mon poste de travail et du coup je suis passé à Gentoo, mais
parfois il m'arrive de regretter ma bonne vielle Slack (bah, j'en ai
toujours 3 qui tournent sur des serveurs, 'pas fou le gars ;-)

Pour la configuration du réseau, en toute logique elle a du être faite au
moment de l'installation. Si tu as sauté cette étape, tu peux :
- soit modifier les fichiers de conf à la main (/etc/rc.d/rc.inet1.conf pour
la config des adresses ip, masque sous réseaux et passerelles, dhcp...)
- Soit lancer l'utilitaire netconfig (en root) qui s'occupera de tout ça
pour toi.


à votre bon coeur ;)


Charité est faite ;-)

--
[ Plus ou moins avec une chance de peut-être ]
- Pour me contacter, enlever nospam (2X) -

didier gaumet
Le #4167591
Bonjour,

Juste quelques mots pour ajouter que pour ceux qui lisent l'anglais
(malheureusement pas de traduction française pour l'instant), le livre
officiel de Slackware est téléchargeable ici: http://www.slackbook.org/ et
comme c'est l'une des rares distributions Linux qui a une vraie doc bien
construite, ce serait bête de s'en priver.
Pour les réfractaires à la langue de Winston Shakespeare et William
Churchill, Christian Casteyde a pondu un guide Linux "à la Unix",
intéressant et structuré, qui est polyvalent bien que basé sur la
Slackware: http://casteyde.christian.free.fr/system/linux/guide/index.html
newbee-slack
Le #4167581
Bonjour et merci de votre aide.

je suis passer par slack car souci avec debian...
je prefere ma debian, mais ayant des problemes apres install j'ai essayer
autre chose.
tetu comme je suis, j'ai réessayer la deb, et y suis arriver :)
un de mes probleme etait la non reconnaissance du cdrom apres install et
reboot [dd sata et cdrom sur hda].
le probleme venait d'options manquante à grub.
j'y ai mis lilo pour l'intant et cela fonctionne.
par contre, quelqu'un à t'il une solution pour une carte son connexant
CXT5045 sous linux?
elle fonctionne tre bien sous back track2, mais aucun mixer sous debian ou
suse...
merci
newbee-slack
Le #4167571
re :)
la backtrack est base sur une slack.
comme le son marche sous backtrack [noyau 2.6.20 patché] il devrai marcher
sous slack.
une idée pour debian?
didier gaumet
Le #4167561
On Wed, 15 Aug 2007 10:56:00 +0000, newbee-slack wrote:

re :)
la backtrack est base sur une slack.
comme le son marche sous backtrack [noyau 2.6.20 patché] il devrai marcher
sous slack.
une idée pour debian?


d'après
http://www.alsa-project.org/main/index.php/Changes_v1.0.13_v1.0.14rc1
il semble que le support ALSA de ce chipset soit récent (à partir des
versions 1.0.14 beta et rc et inclus dans la dernière stable 1.0.14).

en consultant
http://packages.debian.org/cgi-bin/search_packages.pl?keywords=alsa-base&searchon=names&subword=1&version=all&release=all
tu peux voir que stable est en 1.0.13 alors que testing et unstable sont
en 1.0.14.

Si tu es en Debian stable, pour passer en ALSA 1.0.14, soit tu récupères
des paquets binaires unstable ou testing et tu te fais un mix
stable/unstable ou stable/testing dans sources.list, soit tu regardes sur
backports.org pour (distrib etch, pas sarge) et tu récupères des binaires.
(Quand je parle des binaires, je parle du noyau et des alsa*).

Sinon, tu peux éventuellement passer en testing ou unstable.

newbee-slack
Le #4167551
merci pour cette piste :)

j'ai encore le probleme de reseaux à regler et ensuite je vois cela.

par contre sous suse j'ai alsa 1.0.14a-0

je doit devoir modifier des fichiers de config car le n'ai ni mixer ni
sons :]
newbee-slack
Le #4167541
en "configurant" une carte son alsa sous yast [suse] , j'ai un mixer, je
"pousse" tout à fond, mais aucun son...
xmms ou kde, aucun son...alors que les 'graphs' du mixer dans xmms
fonctionnent, mais c'est muet :]]
à suivre.
sansflotusspam
Le #4167531
newbee-slack a commis :

en "configurant" une carte son alsa sous yast [suse] , j'ai un mixer,
je "pousse" tout à fond, mais aucun son...
xmms ou kde, aucun son...alors que les 'graphs' du mixer dans xmms
fonctionnent, mais c'est muet :]]
à suivre.


au départ, alsa met tout à 0, en mute "M" en bas de colonne
il faut lancer alsamixer en root dans une console, dé-muter (barre
d'espace sur M), monter les niveaux et sauver.

newbee-slack
Le #4167521
Le Thu, 16 Aug 2007 09:24:36 +0200, sansflotusspam a écrit:

au départ, alsa met tout à 0, en mute "M" en bas de colonne
il faut lancer alsamixer en root dans une console, dé-muter (barre
d'espace sur M), monter les niveaux et sauver.


Bonsoir
J'ai fais cela [je savais pas pour alsamixer]
résultat: xmms= problème "PCM" alsamixer ???
mplayer ou totem= un autre programme peut bloquer la carte
son???lequel?

toujours muet :]

J'essaye de recompiler un noyau [2.6.20], on verras bien

sinon, je pense à acquérir une carte son externe usb...quand pensez vous?
merci

sansflotusspam
Le #4167511
newbee-slack a commis :

Le Thu, 16 Aug 2007 09:24:36 +0200, sansflotusspam a écrit:

au départ, alsa met tout à 0, en mute "M" en bas de colonne
il faut lancer alsamixer en root dans une console, dé-muter (barre
d'espace sur M), monter les niveaux et sauver.


Bonsoir
J'ai fais cela [je savais pas pour alsamixer]
résultat: xmms= problème "PCM" alsamixer ???
mplayer ou totem= un autre programme peut bloquer la carte
son???lequel?

toujours muet :]

J'essaye de recompiler un noyau [2.6.20], on verras bien

sinon, je pense à acquérir une carte son externe usb...quand pensez
vous? merci


recompiler le noyau est peut'être un peu trop radical ...
alsa et le module connexant CXT5045 suffiraient certainement.
on trouve ce circuit son dans pas mal de portables, et il est reconnu et
exploité par le Live-CD/DVD récents.

une autre idée : le serveur de sons (esd pour Gnome et E, arts pour
KDE), qui doit souvent être relancé à la main avec les derniers noyaux
et alsa 1.0xx.
par exemple, sous KDE, lancer Arts Control, arrêter le serveur, le
relancer, et ré-activer les périphs son ; pour info, c'est ce que je
dois faire avec les noyaux 2.6.x pour charger les soundfonts midi et
activer emu10k1 (Sound Blaster).

quant aux cartes son externes en usb, c'est la loterie, il n'y a pas de
standard, yen a qui passent, yen a beaucoup qui ne passent pas.

au fait, tes users appartiennent bien au groupe audio, comme les
devices ?


Publicité
Poster une réponse
Anonyme