ajout qtte

Le
oliv06nice Hors ligne
Bonjour,

J'ai besoin d'un petit coup de main pour mon appli!!

Voilà, j'ai une table stock et une table commande.
J'aimerai qu'à la réception de la commande, identifiée par un numero de commande, je puisse entrer tous les produits de la commande dans le stock en incrémentant la quantité automatiquement.

Je vous remercie vivement par avance pour votre aide

Olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Romain PETIT
Le #23898871
oliv06nice avait énoncé :
Bonjour,



Bonjour,

J'ai besoin d'un petit coup de main pour mon appli!!
Voilà, j'ai une table stock et une table commande.
J'aimerai qu'à la réception de la commande, identifiée par un numero de
commande, je puisse entrer tous les produits de la commande dans le stock en
incrémentant la quantité automatiquement.
Je vous remercie vivement par avance pour votre aide



Il faudrait préciser de quoi sont composés tes fichiers Commande et
stock...



--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup
oliv06nice Hors ligne
Le #23898981
Romain PETIT a écrit le 24/10/2011 à 17h07 :
oliv06nice avait énoncé :
Bonjour,




Bonjour,

J'ai besoin d'un petit coup de main pour mon appli!!
Voilà, j'ai une table stock et une table commande.
J'aimerai qu'à la réception de la commande, identifiée
par un numero de
commande, je puisse entrer tous les produits de la commande dans le stock en
incrémentant la quantité automatiquement.
Je vous remercie vivement par avance pour votre aide




Il faudrait préciser de quoi sont composés tes fichiers Commande
et
stock...



--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup


Bonjour

Le fichier stock est composé des rubriques suivantes :
Reference
Nom Article
Quantité en stock
fournisseur

le fichier commande est composé des rubriques suivantes :
Numéro commande
Référence article
Nom article
Quantité commandée
Fournisseur

Je voudrai qu'à la réception de la commande, l'ensemble des produits commandé, et reçus s’ajoutent automatiquement selon la référence de l'article dans le fichier stock.

j'espère que je suis clair !
Romain PETIT
Le #23899031
Il se trouve que oliv06nice a formulé :
Bonjour

Le fichier stock est composé des rubriques suivantes :
Reference
Nom Article
Quantité en stock
fournisseur

le fichier commande est composé des rubriques suivantes :
Numéro commande
Référence article
Nom article
Quantité commandée
Fournisseur

Je voudrai qu'à la réception de la commande, l'ensemble des produits
commandé, et reçus s'ajoutent automatiquement selon la référence de l'article
dans le fichier stock.

j'espère que je suis clair !



Pas tant que ça, mais on va faire avec...
(clé composée référence+fournisseur ?)

POUR TOUTE Commande AVEC NumCommande = "xxxxx"
SI HLitRecherchePremier(STOCK, REFERENCE, COMMANDE.REFERENCE) ALORS
STOCK.QUANTITE++
SI PAS HModifie(STOCK) ALORS
Trace("Erreur "+ HInfoErreur())
FIN
SINON
Trace(COMMANDE.REFERENCE +" : référence inconnue!)
FIN
FIN

--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup
oliv06nice Hors ligne
Le #23899051
Romain PETIT a écrit le 24/10/2011 à 18h17 :
Il se trouve que oliv06nice a formulé :
Bonjour

Le fichier stock est composé des rubriques suivantes :
Reference
Nom Article
Quantité en stock
fournisseur

le fichier commande est composé des rubriques suivantes :
Numéro commande
Référence article
Nom article
Quantité commandée
Fournisseur

Je voudrai qu'à la réception de la commande, l'ensemble des
produits
commandé, et reçus s'ajoutent automatiquement selon la
référence de l'article
dans le fichier stock.

j'espère que je suis clair !




Pas tant que ça, mais on va faire avec...
(clé composée référence+fournisseur ?)

POUR TOUTE Commande AVEC NumCommande = "xxxxx"
SI HLitRecherchePremier(STOCK, REFERENCE, COMMANDE.REFERENCE) ALORS
STOCK.QUANTITE++
SI PAS HModifie(STOCK) ALORS
Trace("Erreur "+ HInfoErreur())
FIN
SINON
Trace(COMMANDE.REFERENCE +" : référence inconnue!)
FIN
FIN

--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup


Merci beaucoup, je teste et je vous dis si ça fonctionne, et encore merci de votre aide
oliv06nice Hors ligne
Le #23899391
oliv06nice a écrit le 24/10/2011 à 18h35 :
Romain PETIT a écrit le 24/10/2011 à 18h17 :
Il se trouve que oliv06nice a formulé :
Bonjour

Le fichier stock est composé des rubriques suivantes :
Reference
Nom Article
Quantité en stock
fournisseur

le fichier commande est composé des rubriques suivantes :
Numéro commande
Référence article
Nom article
Quantité commandée
Fournisseur

Je voudrai qu'à la réception de la commande, l'ensemble des
produits
commandé, et reçus s'ajoutent automatiquement selon la
référence de l'article
dans le fichier stock.

j'espère que je suis clair !





Pas tant que ça, mais on va faire avec...
(clé composée référence+fournisseur ?)

POUR TOUTE Commande AVEC NumCommande = "xxxxx"
SI HLitRecherchePremier(STOCK, REFERENCE, COMMANDE.REFERENCE) ALORS
STOCK.QUANTITE++
SI PAS HModifie(STOCK) ALORS
Trace("Erreur "+ HInfoErreur())
FIN
SINON
Trace(COMMANDE.REFERENCE +" : référence inconnue!)
FIN
FIN

--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup



Merci beaucoup, je teste et je vous dis si ça fonctionne, et encore
merci de votre aide


Ca fonctionne, super, sauf qu'il y a un petit souci

Il m'ajoute le nombre de lignes et non la quantité dans la rubrique "quantité"

Dans ma table commande
J'ai les champs :
numero de commande,
reference de l'article
nom de l'article
quantite commandée

et dans ma table stocks
j'ai les champs
reference de l'article
nom de l'aticle
quantité en stock

J'aimerai que lorsque je clique sur un bouton quand je reçois la commande, qu'il ajoute au stock selon le numéro de commande, et la référence de l'article, la quantité que l'on trouve dans le champs "Quantité" de la commande

Encore merci
oliv06nice Hors ligne
Le #23899551
oliv06nice a écrit le 24/10/2011 à 19h48 :
oliv06nice a écrit le 24/10/2011 à 18h35 :
Romain PETIT a écrit le 24/10/2011 à 18h17 :
Il se trouve que oliv06nice a formulé :
Bonjour

Le fichier stock est composé des rubriques suivantes :
Reference
Nom Article
Quantité en stock
fournisseur

le fichier commande est composé des rubriques suivantes :
Numéro commande
Référence article
Nom article
Quantité commandée
Fournisseur

Je voudrai qu'à la réception de la commande, l'ensemble des
produits
commandé, et reçus s'ajoutent automatiquement selon la
référence de l'article
dans le fichier stock.

j'espère que je suis clair !






Pas tant que ça, mais on va faire avec...
(clé composée référence+fournisseur ?)

POUR TOUTE Commande AVEC NumCommande = "xxxxx"
SI HLitRecherchePremier(STOCK, REFERENCE, COMMANDE.REFERENCE) ALORS
STOCK.QUANTITE++
SI PAS HModifie(STOCK) ALORS
Trace("Erreur "+ HInfoErreur())
FIN
SINON
Trace(COMMANDE.REFERENCE +" : référence inconnue!)
FIN
FIN

--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup




Merci beaucoup, je teste et je vous dis si ça fonctionne, et encore
merci de votre aide



Ca fonctionne, super, sauf qu'il y a un petit souci

Il m'ajoute le nombre de lignes et non la quantité dans la rubrique
"quantité"

Dans ma table commande
J'ai les champs :
numero de commande,
reference de l'article
nom de l'article
quantite commandée

et dans ma table stocks
j'ai les champs
reference de l'article
nom de l'aticle
quantité en stock

J'aimerai que lorsque je clique sur un bouton quand je reçois la
commande, qu'il ajoute au stock selon le numéro de commande, et la
référence de l'article, la quantité que l'on trouve dans
le champs "Quantité" de la commande

Encore merci


J'ai trouvé la réponse à ma demande, espérant que cela pourra servir à d'autres :


POUR TOUTE commandesHab AVEC numcommande = COMBO_REQ_numcommande
SI HLitRecherche(Stocks, Reference, commandesHab.NumOrdre) ALORS
Stocks.Quantité = commandesHab.qttecommandee+Stocks.Quantité
SI PAS HModifie(Stocks) ALORS

Trace("Erreur ")
FIN
SINON
Trace(commandesHab.NumOrdre +" : référence inconnue!")
FIN
FIN


Un grand merci à Romain PETIT pour son aide
Romain PETIT
Le #23899691
Le 24/10/2011, oliv06nice a supposé :
oliv06nice a écrit le 24/10/2011 à 18h35 :
Ca fonctionne, super, sauf qu'il y a un petit souci
Il m'ajoute le nombre de lignes et non la quantité dans la rubrique
"quantité"



Oui, mais bon franchement il faudrait faire un effort, tu ne vas pas
aller loin si tu ne vois pas ce qu'il fallait changer...
Je te conseille de lire le manuel...

A la place de
STOCK.QUANTITE++
(équivalent à STOCK.QUANTITE = STOCK.QUANTITE + 1)

Mettre
STOCK.QUANTITE+=COMMANDE.QUANTITE
(équivalent à STOCK.QUANTITE = STOCK.QUANTITE + COMMANDE.QUANTITE)

--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup
tt
Le #23901631
Le Mon, 24 Oct 2011 20:21:53 +0200, Romain PETIT écrit:

Le 24/10/2011, oliv06nice a supposé :
oliv06nice a écrit le 24/10/2011 à 18h35 :
Ca fonctionne, super, sauf qu'il y a un petit souci
Il m'ajoute le nombre de lignes et non la quantité dans la rubrique
"quantité"



Oui, mais bon franchement il faudrait faire un effort, tu ne vas pas
aller loin si tu ne vois pas ce qu'il fallait changer...
Je te conseille de lire le manuel...

A la place de
STOCK.QUANTITE++
(équivalent à STOCK.QUANTITE = STOCK.QUANTITE + 1)

Mettre
STOCK.QUANTITE+=COMMANDE.QUANTITE
(équivalent à STOCK.QUANTITE = STOCK.QUANTITE + COMMANDE.QUANTIT E)



+1 !

--
TT
Publicité
Poster une réponse
Anonyme