ALERT - canary mismatch on efree() - heap overflow detected [old: Apache2 - Sur 1 repertoire j'obtiens 500 Internal Server Error]

Le
Hugues MORIN
--0016364ed5deefe9e804a2eb5882
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour

Il y a quelques jours je me suis apercu que je ne pouvais plus acceder a
certain site (erreur 500) sur ma machine de developpement alors que cela ne
poser aucun probleme pour d'autre. (Cf plus bas pour le detail)

J'ai fait tout les test et les controle sur la configuration d'apache sans
trouve d'erreur.

D'apres Artur, il semblerait que ce soit une corruption de la pile
(débordement de buffer ?) et Suhosin m'en avertis

En ce qui concerne suhosin, j'ai trouve ces explications mais je dois
avouer que je ne comprends pas tres bien.
C'est meme tres obscur pour moi.
Je n'ai pas un bon niveau en linux et mon anglais n'est pas non plus super
:-(
Et du coups je ne trouve pas de solution qui pourrai m'aider a reparer.

Comment fait-on pour savoir s'il y a "une corruption de la pile (débordem=
ent
de buffer ?)" ?
Et surtout comment on pour reparer? ou alors dans quel direction dois-je
chercher?



Merci
Cordialement
Hugues


DETAILS DU PROBLEME
Ancien post: Apache2 - Sur 1 repertoire j'obtiens 500 Internal Server Error


> Le 5 mai 2011 17:03, Artur Pydo <artur.pydo@netdirect.fr> a écrit :
>
> Re,
>>
>> Au passage il y a probablement une corruption de la pile (débordement =
de
>> buffer ?) et Suhosin t'en avertis :
>>
>>
>> http://www.suspekt.org/2008/10/12/suhosin-canary-mismatch-on-efree-heap-=
overflow-detected/
>>
>> Le 05/05/2011 16:41, Hugues MORIN a écrit :
>>
>> Bonjour
>>
>> Je rencontre un probleme sur un Lenny avec apache2 (ou qquechose d'autre
>> O_o )
>> Lenny est installe sur un notebook qui me sert de serveur de
>> developpement.
>> Le systeme de fichier est organise comme ca:
>> /home/myuser/public_html/
>> |_ alpha
>> |_ beta
>> |_ production
>>
>> Chacun de ces repertoires (alpha, beta et production) contiennent les
>> sites dans leur differentes etapes de developpement.
>> Soit par exemple:
>> /home/myuser/public_html/beta/
>> |_ site1.com
>> |_ site2.com
>> |_ etc..
>>
>> Chaque site version peut etre consulter par des URL de la forme
>> www.alpha-site1.com ou www.production-site2.com
>>
>> LE PROBLEME est le suivant:
>> Je peux consulter et utiliser tous les sites des repertoires alpha et be=
ta
>>
>> mais des que je veux consulter un site du repertoire production
>> j'obtiens la joli erreur 500 Internal Server Error
>> par contre si je saisie l'URL suivante:
>> www.production-site1.com/phpmyadmin/
>> cela fonctionne parfaitement. PhpMyAdmin n'est pas installe dans
>> l'arborescence de/home/
>>
>> Jusqu'ici je n'ai jamais rencontrer ce probleme.
>> Je ne me rappelle pas precisement quand est ce que j'ai utilse cette
>> machine pour la derniere fois et ou elle fonctionnait normalement.
>> Depuis la derniere fois se cette machine pour du developpement, j'ai fai=
t
>> des mise a jour.
>>
>> J'ai consulter les logs des sites et j'ai trouve ces entrees sur l'un
>> d'eux:
>>
>> [Thu Feb 03 11:21:11 2011] [error] [client 192.168.0.3] ALERT - canary
>> mismatch on efree() - heap overflow detected (attacker '192.168.0.3', fi=
le
>> '/home/myuser/public_html/production/www/admin/includes/functions/sessio=
ns.php',
>> line 67), referer:
>> http://www.production-site1.com/admin/categories.php?cPath=78
>> [Fri Feb 04 11:30:34 2011] [error] [client 192.168.0.3] ALERT - canary
>> mismatch on efree() - heap overflow detected (attacker '192.168.0.3', fi=
le
>> '/home/myuser/public_html/production/www/includes/application_top.php', =
line
>> 182)
>> [Fri Feb 04 11:30:40 2011] [error] [client 192.168.0.3] ALERT - canary
>> mismatch on efree() - heap overflow detected (attacker '192.168.0.3', fi=
le
>> '/home/myuser/public_html/production/www/includes/application_top.php', =
line
>> 182)
>> [Wed May 04 16:43:49 2011] [error] [client 192.168.0.8] ALERT - canary
>> mismatch on efree() - heap overflow detected (attacker '192.168.0.8', fi=
le
>> '/usr/share/phpmyadmin/db_structure.php'), referer:
>> http://www.production-site1.com/phpmyadmin/navigation.php?server=1&tok=
en=9eff1f8a55dd5e9a8187df0478b44408&db=betawwwcommon&table=&lang=fr=
-utf-8&collation_connection=utf8_general_ci
>> [Wed May 04 16:45:16 2011] [alert] [client 192.168.0.8]
>> /home/myuser/public_html/production/.htaccess: Options not allowed here
>> [Wed May 04 16:45:25 2011] [alert] [client 192.168.0.8]
>> /home/myuser/public_html/production/.htaccess: Options not allowed here
>> La derniere entree se repete depuis et sur tous les logs des differents
>> sites.
>>
>> J'espere que j'ai fournie suffisament d'elements pour que vous puissiez
>> m'aider.
>>
>> J'ai fait des recherche mais sans succes, je n'ai rien trouve qui puisse
>> m'aider ou alors je ne l'ai pas compris :-[
>>
>>
>> Cordialement
>> Hugues
>>
>> --
>>
>> Cordialement,
>>
>> Artur Pydo.
>>
>> www.NetDirect.fr <http://www.netdirect.fr/>
>>
>
>

--0016364ed5deefe9e804a2eb5882
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<div>Bonjour</div>
<div> </div>
<div>Il y a quelques jours je me suis apercu que je ne pouvais plus acced=
er a certain site (erreur 500) sur ma machine de developpement alors que ce=
la ne poser aucun probleme pour d&#39;autre. (Cf plus bas pour le detail)</=
div>

<div> </div>
<div>J&#39;ai fait tout les test et les controle sur la configuration d&#39=
;apache sans trouve d&#39;erreur.</div>
<div> </div>
<div>D&#39;apres Artur, il semblerait que ce soit <font face="Helvetica">=
une corruption de la pile (débordement de buffer ?) et Suhosin m&#39;en a=
vertis </font></div>
<div> </div>
<div>En ce  qui concerne suhosin, j&#39;ai trouve ces explications mais j=
e dois avouer que je ne comprends pas tres bien.</div>
<div>C&#39;est meme tres obscur pour moi.</div>
<div>Je n&#39;ai pas un bon niveau en linux et mon anglais n&#39;est pas =
non plus super :-(</div>
<div>Et du coups je ne trouve pas de solution qui pourrai m&#39;aider a r=
eparer.</div>
<div> </div>
<div>Comment fait-on pour savoir s&#39;il y a &quot;une corruption de la =
pile (débordement de buffer ?)&quot; ?</div>
<div>Et surtout comment on pour reparer? ou alors dans quel direction dois-=
je chercher?</div>
<div> </div>
<div> </div>
<div> </div>
<div>Merci</div>
<div>Cordialement</div>
<div>Hugues</div>
<div> <br></div>
<div> </div>
<div>DETAILS DU PROBLEME</div>
<div>Ancien post: Apache2 - Sur 1 repertoire j&#39;obtiens 500 Internal Ser=
ver Error<br> </div>
<div class="gmail_quote">
<blockquote style="BORDER-LEFT: #ccc 1px solid; MARGIN: 0px 0px 0px 0.8ex=
; PADDING-LEFT: 1ex" class="gmail_quote">
<div class="gmail_quote">Le 5 mai 2011 17:03, Artur Pydo <span dir="ltr=
">&lt;<a href="mailto:artur.pydo@netdirect.fr" target="_blank">artur.py=
do@netdirect.fr</a>&gt;</span> a écrit :
<div>
<div></div>
<div><br>
<blockquote style="BORDER-LEFT: #ccc 1px solid; MARGIN: 0px 0px 0px 0.8ex=
; PADDING-LEFT: 1ex" class="gmail_quote">
<div text="#000000" bgcolor="#ffffff"><font face="Helvetica, Arial, s=
ans-serif">Re,<br><br>Au passage il y a probablement une corruption de la p=
ile (débordement de buffer ?) et Suhosin t&#39;en avertis :<br><br><a hre=
f="http://www.suspekt.org/2008/10/12/suhosin-canary-mismatch-on-efree-hea=
p-overflow-detected/" target="_blank">http://www.suspekt.org/2008/10/12/s=
uhosin-canary-mismatch-on-efree-heap-overflow-detected/</a><br>
</font>
<div><br>Le 05/05/2011 16:41, Hugues MORIN a écrit : </div>
<blockquote type="cite">
<div>Bonjour</div>
<div>
<div></div>
<div>
<div> </div>
<div>Je rencontre un probleme sur un Lenny avec apache2 (ou qquechose d&#39=
;autre O_o )</div>
<div>Lenny est installe sur un notebook qui me sert de serveur de developpe=
ment.</div>
<div>Le systeme de fichier est organise comme ca:</div>
<div>/home/myuser/public_html/ </div>
<div>|_ alpha</div>
<div>|_ beta</div>
<div>|_ production</div>
<div> </div>
<div>Chacun de ces repertoires (alpha, beta et production) contiennent le=
s sites dans leur differentes etapes de developpement.</div>
<div>Soit par exemple:</div>
<div>/home/myuser/public_html/beta/</div>
<div>|_ <a href="http://site1.com/" target="_blank">site1.com</a></div>
<div>|_ <a href="http://site2.com/" target="_blank">site2.com</a></div>
<div>|_ etc..</div>
<div> </div>
<div>Chaque site version peut etre consulter par des URL de la forme <a hre=
f="http://www.alpha-site1.com/" target="_blank">www.alpha-site1.com</a>=
ou <a href="http://www.production-site2.com/" target="_blank">www.prod=
uction-site2.com</a></div>

<div> </div>
<div>LE PROBLEME est le suivant:</div>
<div>Je peux consulter et utiliser tous les sites des repertoires alpha=
et beta </div>
<div>mais des que je veux consulter un site du repertoire production</div>
<div>j&#39;obtiens la joli erreur 500 Internal Server Error</div>
<div>par contre si je saisie l&#39;URL suivante: <a href="http://www.prod=
uction-site1.com/phpmyadmin/" target="_blank">www.production-site1.com/ph=
pmyadmin/</a></div>
<div>cela fonctionne parfaitement. PhpMyAdmin n&#39;est pas installe dans l=
&#39;arborescence de/home/</div>
<div> </div>
<div>
<div>Jusqu&#39;ici je n&#39;ai jamais rencontrer ce probleme.</div>
<div>Je ne me rappelle pas precisement quand est ce que j&#39;ai utilse cet=
te machine pour la derniere fois et ou elle fonctionnait normalement.</div>=
</div>
<div>Depuis la derniere fois se cette machine pour du developpement, j&#39;=
ai fait des mise a jour.</div>
<div> </div>
<div>J&#39;ai consulter les logs des sites et j&#39;ai trouve ces entrees s=
ur l&#39;un d&#39;eux:</div>
<div> </div>
<div>[Thu Feb 03 11:21:11 2011] [error] [client 192.168.0.3] ALERT - canary=
mismatch on efree() - heap overflow detected (attacker &#39;192.168.0.3&#3=
9;, file &#39;/home/myuser/public_html/production/www/admin/includes/functi=
ons/sessions.php&#39;, line 67), referer: <a href="http://www.production-=
site1.com/admin/categories.php?cPath=78" target="_blank">http://www.pro=
duction-site1.com/admin/categories.php?cPath=78</a><br>
[Fri Feb 04 11:30:34 2011] [error] [client 192.168.0.3] ALERT - canary mism=
atch on efree() - heap overflow detected (attacker &#39;192.168.0.3&#39;, f=
ile &#39;/home/myuser/public_html/production/www/includes/application_top.p=
hp&#39;, line 182)<br>
[Fri Feb 04 11:30:40 2011] [error] [client 192.168.0.3] ALERT - canary mism=
atch on efree() - heap overflow detected (attacker &#39;192.168.0.3&#39;, f=
ile &#39;/home/myuser/public_html/production/www/includes/application_top.p=
hp&#39;, line 182)<br>
[Wed May 04 16:43:49 2011] [error] [client 192.168.0.8] ALERT - canary mism=
atch on efree() - heap overflow detected (attacker &#39;192.168.0.8&#39;, f=
ile &#39;/usr/share/phpmyadmin/db_structure.php&#39;), referer: <a href="=
http://www.production-site1.com/phpmyadmin/navigation.php?server=1&amp;to=
ken=9eff1f8a55dd5e9a8187df0478b44408&amp;db=betawwwcommon&amp;table=&=
amp;lang=fr-utf-8&amp;collation_connection=utf8_general_ci" target="_=
blank">http://www.production-site1.com/phpmyadmin/navigation.php?server=1=
&amp;token=9eff1f8a55dd5e9a8187df0478b44408&amp;db=betawwwcommon&amp;ta=
ble=&amp;lang=fr-utf-8&amp;collation_connection=utf8_general_ci</a><b=
r>
[Wed May 04 16:45:16 2011] [alert] [client 192.168.0.8] /home/myuser/public=
_html/production/.htaccess: Options not allowed here<br>[Wed May 04 16:45:2=
5 2011] [alert] [client 192.168.0.8] /home/myuser/public_html/production/.h=
taccess: Options not allowed here<br>
</div>
<div>La derniere entree se repete depuis et sur tous les logs des different=
s sites.</div>
<div> </div>
<div>J&#39;espere que j&#39;ai fournie suffisament d&#39;elements pour que =
vous puissiez m&#39;aider.</div>
<div> </div>
<div>J&#39;ai fait des recherche mais sans succes, je n&#39;ai rien trouve =
qui puisse m&#39;aider ou alors je ne l&#39;ai pas compris :-[</div>
<div> </div>
<div> </div>
<div>Cordialement</div>
<div>Hugues</div>
<div> </div>
<div>-- <br></div></div></div></blockquote>
<div>
<div><font size="-1" face="Helvetica, Arial, sans-serif">
<p>Cordialement,</p>
<p>Artur Pydo.</p>
<p><a href="http://www.netdirect.fr/" target="_blank">www.NetDirect.fr<=
/a></p></font></div></div></div></blockquote></div></div></div><br></blockq=
uote></div><br>

--0016364ed5deefe9e804a2eb5882--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/BANLkTi=oyj+iWOStAS9BsvuMgHHmZ3ZHzQ@mail.gmail.com
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
hogren
Le #23350471
Bonjour,

Tout d'abord, prend mes conseils avec des pincettes car je ne suis pas
expert, loin de là.

Avec mes petit moyen des débutant voilà ce que je ferais ;

- Sauvegarde tout (sites et configuration apache, phpmyadmin, etc.)
- Installe sur une autre machine (ou une machine virtuelle à la
rigueur) la même version de Debian.
- Installe les packets nécessaire à ton service web.
- Configure le tout.
- Installe les autres paquets actuellement sur ton serveur (pour les
autres services) un par un en faisant des tests.

Tu arriveras peut-être à attraper le(s) paquet(s) qui modifie(nt) ta
configuration pour ton service WEB.



C'est une méthode longue, mais comme cela fait un moment que tu es
dessus, je pense que c'est relatif.


Bon courage !


Florian HEGRON





On Tue, 10 May 2011 14:46:39 +0200, Hugues MORIN wrote:

Bonjour

Il y a quelques jours je me suis apercu que je ne pouvais plus
acceder a
certain site (erreur 500) sur ma machine de developpement alors que
cela
ne poser aucun probleme pour d'autre. (Cf plus bas pour le detail)

J'ai fait tout les test et les controle sur la configuration d'apache
sans trouve d'erreur.

D'apres Artur, il semblerait que ce soit une corruption de la pile
(débordement de buffer ?) et Suhosin m'en avertis

En ce qui concerne suhosin, j'ai trouve ces explications mais je dois
avouer que je ne comprends pas tres bien.
C'est meme tres obscur pour moi.
Je n'ai pas un bon niveau en linux et mon anglais n'est pas non plus
super :-(
Et du coups je ne trouve pas de solution qui pourrai m'aider a
reparer.

Comment fait-on pour savoir s'il y a "une corruption de la pile
(débordement de buffer ?)" ?
Et surtout comment on pour reparer? ou alors dans quel direction
dois-je
chercher?

Merci
Cordialement
Hugues

DETAILS DU PROBLEME
Ancien post: Apache2 - Sur 1 repertoire j'obtiens 500 Internal Server
Error



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Hugues MORIN
Le #23352301
--20cf30334dcf1cc6bf04a30531cc
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Salut

Merci, c'est que je crois que je vais etre obliger de faire.

J'esperai qu'il y aurai une autre solution moins "laborieuse"

Il y a quand meme un truc qui m'intrigue et que j'aimerai comprendre:
Pourquoi une partie des sites fonctionnent, ceux des repertoires /alpha et
/beta
tandis que ceux du repertoires /production ne fonctionne pas
alors qu'il fonctionne sur la meme instance de apache O_o !!

Je ne suis vraiment pas un expert mais je ne trouve pas ca logique.
Je ne comprends qu'est ce qui pourrai etre "endommage" pour engendrer un te l
comportement.


Amicalement
Hugues


Le 11 mai 2011 09:22,
Bonjour,

Tout d'abord, prend mes conseils avec des pincettes car je ne suis pas
expert, loin de là.

Avec mes petit moyen des débutant voilà ce que je ferais ;

- Sauvegarde tout (sites et configuration apache, phpmyadmin, etc.)
- Installe sur une autre machine (ou une machine virtuelle à la rigueur ) la
même version de Debian.
- Installe les packets nécessaire à ton service web.
- Configure le tout.
- Installe les autres paquets actuellement sur ton serveur (pour les autr es
services) un par un en faisant des tests.

Tu arriveras peut-être à attraper le(s) paquet(s) qui modifie(nt) ta
configuration pour ton service WEB.



C'est une méthode longue, mais comme cela fait un moment que tu es dess us,
je pense que c'est relatif.


Bon courage !


Florian HEGRON






On Tue, 10 May 2011 14:46:39 +0200, Hugues MORIN wrote:

Bonjour

Il y a quelques jours je me suis apercu que je ne pouvais plus acceder a
certain site (erreur 500) sur ma machine de developpement alors que cela
ne poser aucun probleme pour d'autre. (Cf plus bas pour le detail)

J'ai fait tout les test et les controle sur la configuration d'apache
sans trouve d'erreur.

D'apres Artur, il semblerait que ce soit une corruption de la pile
(débordement de buffer ?) et Suhosin m'en avertis

En ce qui concerne suhosin, j'ai trouve ces explications mais je dois
avouer que je ne comprends pas tres bien.
C'est meme tres obscur pour moi.
Je n'ai pas un bon niveau en linux et mon anglais n'est pas non plus
super :-(
Et du coups je ne trouve pas de solution qui pourrai m'aider a reparer.

Comment fait-on pour savoir s'il y a "une corruption de la pile
(débordement de buffer ?)" ?
Et surtout comment on pour reparer? ou alors dans quel direction dois-je
chercher?

Merci
Cordialement
Hugues

DETAILS DU PROBLEME
Ancien post: Apache2 - Sur 1 repertoire j'obtiens 500 Internal Server
Error




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive:
http://lists.debian.org/





--20cf30334dcf1cc6bf04a30531cc
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Il y a quand meme un truc qui m&#39;intrigue et que j&#39;aimerai comprendr e:</div><div>Pourquoi une partie des sites fonctionnent, ceux des repertoir es /alpha et /beta</div><div>tandis que ceux du repertoires /production ne fonctionne pas</div>
<br>
Tout d&#39;abord, prend mes conseils avec des pincettes car je ne suis pas expert, loin de là.<br>
<br>
Avec mes petit moyen des débutant voilà ce que je ferais ;<br>
<br>
- Sauvegarde tout (sites et configuration apache, phpmyadmin, etc.)<br>
- Installe sur une autre machine (ou une machine virtuelle à la rigueur) la même version de Debian.<br>
- Installe les packets nécessaire à ton service web.<br>
- Configure le tout.<br>
- Installe les autres paquets actuellement sur ton serveur (pour les autres services) un par un en faisant des tests.<br>
<br>
Tu arriveras peut-être à attraper le(s) paquet(s) qui modifie(nt) ta co nfiguration pour ton service WEB.<br>
<br>
<br>
<br>
C&#39;est une méthode longue, mais comme cela fait un moment que tu es de ssus, je pense que c&#39;est relatif.<br>
<br>
<br>
Bon courage !<br>
<br>
<br>
Florian HEGRON<div><div></div><div class="h5"><br>
<br>
<br>
<br>
<br>
<br>
On Tue, 10 May 2011 14:46:39 +0200, Hugues MORIN wrote:<br>
<br>
Bonjour<br>
<br>
Il y a quelques jours je me suis apercu que je ne pouvais plus acceder a<br >
certain site (erreur 500) sur ma machine de developpement alors que cela<br >
ne poser aucun probleme pour d&#39;autre. (Cf plus bas pour le detail)<br>
<br>
J&#39;ai fait tout les test et les controle sur la configuration d&#39;apac he<br>
sans trouve d&#39;erreur.<br>
<br>
D&#39;apres Artur, il semblerait que ce soit une corruption de la pile<br>
(débordement de buffer ?) et Suhosin m&#39;en avertis<br>
<br>
En ce qui concerne suhosin, j&#39;ai trouve ces explications mais je dois<b r>
avouer que je ne comprends pas tres bien.<br>
C&#39;est meme tres obscur pour moi.<br>
Je n&#39;ai pas un bon niveau en linux et mon anglais n&#39;est pas non plu s<br>
super :-(<br>
Et du coups je ne trouve pas de solution qui pourrai m&#39;aider a reparer. <br>
<br>
Comment fait-on pour savoir s&#39;il y a &quot;une corruption de la pile<br >
(débordement de buffer ?)&quot; ?<br>
Et surtout comment on pour reparer? ou alors dans quel direction dois-je<br >
chercher?<br>
<br>
Merci<br>
Cordialement<br>
Hugues<br>
<br>
DETAILS DU PROBLEME<br>
Ancien post: Apache2 - Sur 1 repertoire j&#39;obtiens 500 Internal Server<b r>
Error<br>
</blockquote>
<br></div></div><font color="#888888">
-- <br>
Lisez la FAQ de la liste avant de poser une question :<br>
<br>
Pour vous DESABONNER, envoyez un message avec comme objet &quot;unsubscribe &quot;<br>
vers En cas de soucis, contactez EN ANGLAIS Archive: <br>
</font></blockquote></div><br>

--20cf30334dcf1cc6bf04a30531cc--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/BANLkTinTUBLcZ4Ljy7S5s8jp+
Publicité
Poster une réponse
Anonyme