Alsa ou OSS?

Le
Kevin Denis
Bonjour,

je suis en train de paramétrer une carte son snd-hda-intel.
Le but est d'utiliser Audacious comme lecteur audio.

Si je paramètre Audacious pour utiliser OSS, ça fonctionne.
Si je le paramètre pour utiliser ALSA, je n'entends plus rien.

Sur un autre PC, cela fonctionne out-of-the box aussi bien en
OSS qu'alsa dès que le module est chargé.

Ma question, quelle doc lire? Ou creuser?

Merci
--
Kevin
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
WR35NN89
Le #16595531
Kevin Denis a écrit :
Bonjour,

je suis en train de paramétrer une carte son snd-hda-intel.
Le but est d'utiliser Audacious comme lecteur audio.

Si je paramètre Audacious pour utiliser OSS, ça fonctionne.
Si je le paramètre pour utiliser ALSA, je n'entends plus rien.

Sur un autre PC, cela fonctionne out-of-the box aussi bien en
OSS qu'alsa dès que le module est chargé.

Ma question, quelle doc lire? Ou creuser?

Merci


Bonsoir,
Alsa, toujours alsa.... OSS est obsolète....
As-tu vérifié que ton mixer alsa était correctement paramêtré ? volume ?
Kevin Denis
Le #16595861
Le 21-08-2008, WR35NN89
je suis en train de paramétrer une carte son snd-hda-intel.
Le but est d'utiliser Audacious comme lecteur audio.

Si je paramètre Audacious pour utiliser OSS, ça fonctionne.
Si je le paramètre pour utiliser ALSA, je n'entends plus rien.

Sur un autre PC, cela fonctionne out-of-the box aussi bien en
OSS qu'alsa dès que le module est chargé.

Ma question, quelle doc lire? Ou creuser?



Alsa, toujours alsa.... OSS est obsolète....



Tout à fait.

As-tu vérifié que ton mixer alsa était correctement paramêtré ? volume ?



Oui. L'étonnant, c'est que dans audacious, le morceau se joue bien,
les égaliseurs de volume montrent bien le son, mais c'est le silence.
--
Kevin
Nicolas S.
Le #16596151
Kevin Denis a écrit:

> Alsa, toujours alsa.... OSS est obsolète....

Tout à fait.



Il est possible qu'il faille décharger les modules qui concernent OSS
puis recharger ceux pour ALSA.

--
Nicolas S.
Doug713705
Le #16596571
Le jeudi 21 août 2008 21:42, Kevin Denis s'est exprimé de la sorte sur
fr.comp.os.linux.configuration :

Oui. L'étonnant, c'est que dans audacious, le morceau se joue bien,
les égaliseurs de volume montrent bien le son, mais c'est le silence



Si alsa fontionne pour d'autre application, vérifier dans Audacious :
Préférences --> Audio --> Préférences --> Audio devices.

Chez moi l'HDA Intel apparait en analogique et en digital mais le son ne
sort que sur la sortie analogique.

--
@+
Doug - Linux user #307925 - Gentoo rocks ;-)
[ Plus ou moins avec une chance de peut-être ]
Nicolas George
Le #16596881
Doug713705 wrote in message
Chez moi l'HDA Intel apparait en analogique et en digital mais le son ne
sort que sur la sortie analogique.



Tu as essayé de jouer sur le réglage « IEC958 Playback Source » ?
Kevin Denis
Le #16598161
Le 21-08-2008, Doug713705
Oui. L'étonnant, c'est que dans audacious, le morceau se joue bien,
les égaliseurs de volume montrent bien le son, mais c'est le silence



Si alsa fontionne pour d'autre application,



ALSA ne fonctionne pour aucune application. C'est juste qu'audacious est
pratique pour choisir la sortie son.

vérifier dans Audacious :
Préférences --> Audio --> Préférences --> Audio devices.

Chez moi l'HDA Intel apparait en analogique et en digital mais le son ne
sort que sur la sortie analogique.



L'hda-intel a le problème d'exister en un très grand nombre de variétés.
Je dois le charger avec l'option model="xxx" sinon, ça n'est pas reconnu.
Quasiment chaque constructeur a modifié un peu la carte ce qui fait que
l'autodétection foire pas mal.
Ceci dit, alsa devrait fonctionner une fois que le bon module est
chargé.
--
Kevin
Doug713705
Le #16602392
Le vendredi 22 ao»t 2008 01:37, Nicolas George s'est exprim© de la sorte sur
fr.comp.os.linux.configuration :

Doug713705  wrote in message
Chez moi l'HDA Intel apparait en analogique et en digital mais le son ne
sort que sur la sortie analogique.



Tu as essay© de jouer sur le r©glage « IEC958 Playback Source » ?



Non, je ne me suis pas plus pris la tªte que de s©lectionner la sortie qui
va bien.

Pour tout dire, je n'ai rencontr© aucun probl¨me car d¨s le d©part tout
c'est bien goupill© sans que je n'intervienne.

Ce n'est qu'en essayant de comprendre le probl¨me de Kevin que je me suis
aper§u qu'il y avait le choix entre 2 sorties (analogique et num©rique)

Cependant, je suis forc© de constater que IEC958 est   0 dans alsamixer :-D

Ceci explique peut-ªtre cela (et j'ai la flemme de ramper sous le bureau
pour brancher tout §a pour v©rifier)

--
@+
Doug - Linux user #307925 - Gentoo rocks ;-)
[ Plus ou moins avec une chance de peut-ªtre ]
Nicolas George
Le #16602511
Doug713705 wrote in message
Cependant, je suis forc
Trinine
Le #16763491
Kevin Denis a écrit:

Alsa, toujours alsa.... OSS est obsolète....



Tout à fait.



Ou plus exactement, OSS _fourni avec les sources du noyau linux_ est
obsolète.

T.
Publicité
Poster une réponse
Anonyme