Améliorer une formule

Le
albert
Bonjour

J'ai cette formule dans un fichier
=SI(B2-D2=0;"";B2-D2)) mais j'ai alors l'erreur #valeur
J'ai modifié comme suit
=SI(ESTERREUR(B2-D2);"";SI(B2-D2=0;"";B2-D2))

Mais je pense qu'un seul SI est nécessaire, est-ce possible d'améliorer?

Merci vos conseils sont appréciés.

--
albertri-at-videotron.ca.invalid
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #26353876
bonjour,

J'ai cette formule dans un fichier
=SI(B2-D2=0;"";B2-D2))



il y a une parenthèse de trop à la fin de cette formule

isabelle
JièL
Le #26353875
Le 22/05/2015 21:46, albert a écrit :
Bonjour

J'ai cette formule dans un fichier
=SI(B2-D2=0;"";B2-D2)) mais j'ai alors l'erreur #valeur
J'ai modifié comme suit
=SI(ESTERREUR(B2-D2);"";SI(B2-D2=0;"";B2-D2))

Mais je pense qu'un seul SI est nécessaire, est-ce possible d'améliorer?



Pas sur qu'on y gagne qqchose
=SI(OU(B2-D2=0;ESTERREUR(B2-D2));"";B2-D2)

Merci vos conseils sont appréciés.



--
JièL OUhOU
db
Le #26353880
Le 22/05/2015 21:46, albert a écrit :
Bonjour

J'ai cette formule dans un fichier
=SI(B2-D2=0;"";B2-D2)) mais j'ai alors l'erreur #valeur
J'ai modifié comme suit
=SI(ESTERREUR(B2-D2);"";SI(B2-D2=0;"";B2-D2))

Mais je pense qu'un seul SI est nécessaire, est-ce possible d'améliorer?

Merci vos conseils sont appréciés.





Bonsoir

Je pense qu'un format de cellule serait bien préférable (par exemple
0,00;0,00;)…

db
JièL
Le #26353879
Le 22/05/2015 23:25, JièL a écrit :
Le 22/05/2015 21:46, albert a écrit :
Bonjour

J'ai cette formule dans un fichier
=SI(B2-D2=0;"";B2-D2)) mais j'ai alors l'erreur #valeur
J'ai modifié comme suit
=SI(ESTERREUR(B2-D2);"";SI(B2-D2=0;"";B2-D2))

Mais je pense qu'un seul SI est nécessaire, est-ce possible d'améliorer?



Pas sur qu'on y gagne qqchose
=SI(OU(B2-D2=0;ESTERREUR(B2-D2));"";B2-D2)



non seulement on y gagne rien, mais en plus c'est faux... désolé

--
JièL eraré humanum est
JièL
Le #26353878
Le 22/05/2015 23:33, db a écrit :
Le 22/05/2015 21:46, albert a écrit :
Bonjour

J'ai cette formule dans un fichier
=SI(B2-D2=0;"";B2-D2)) mais j'ai alors l'erreur #valeur
J'ai modifié comme suit
=SI(ESTERREUR(B2-D2);"";SI(B2-D2=0;"";B2-D2))

Mais je pense qu'un seul SI est nécessaire, est-ce possible d'améliorer?

Merci vos conseils sont appréciés.





Bonsoir

Je pense qu'un format de cellule serait bien préférable (par exemple
0,00;0,00;)…



Un format de cellule ne change rien quand il y a une erreur...

--
JièL Fort Mat
albert
Le #26353891
Bonsoir Isabelle
ici on gèle cette nuit

La deuxième parenthèse est une erreur de copier/coller, car car j'ai fait un
control X sur la deuxième formule.
Dans le fichier original D2 est une formule (somme(E2:N8) et si toutes ces
cellules sont vides cela génère l'erreur #valeur.

Bonne soirée

Albert

"isabelle" news:mjo6fk$ht2$
bonjour,

J'ai cette formule dans un fichier
=SI(B2-D2=0;"";B2-D2))



il y a une parenthèse de trop à la fin de cette formule

isabelle
albert
Le #26353890
"albert" news:mjodth$3gn$
Bonsoir Isabelle
ici on gèle cette nuit

La deuxième parenthèse est une erreur de copier/coller, car car j'ai fait
un control X sur la deuxième formule pour la copier dans la première
ligne.

Dans le fichier original D2 est une formule (somme(E2:N8)


Lire (E2:N2)
et si toutes ces
cellules sont vides cela génère l'erreur #valeur.

Bonne soirée

Albert

"isabelle" news:mjo6fk$ht2$
bonjour,

J'ai cette formule dans un fichier
=SI(B2-D2=0;"";B2-D2))



il y a une parenthèse de trop à la fin de cette formule

isabelle



albert
Le #26353893
Bonsoir JièL

C'est la formulation que je recherchais, mais vous avez raison, la formule
ne fonctionne pas et affiche #valeur si les cellules de la somme(E2:N2) dans
D2 sont vides.
J'ai essayé avec "ET" au lieu de "OU" avec le même résultat.
Merci

Albert


"JièL" news:mjo7sl$kt5$
Le 22/05/2015 23:25, JièL a écrit :
Le 22/05/2015 21:46, albert a écrit :
Bonjour

J'ai cette formule dans un fichier
=SI(B2-D2=0;"";B2-D2)) mais j'ai alors l'erreur #valeur
J'ai modifié comme suit
=SI(ESTERREUR(B2-D2);"";SI(B2-D2=0;"";B2-D2))

Mais je pense qu'un seul SI est nécessaire, est-ce possible
d'améliorer?



Pas sur qu'on y gagne qqchose
=SI(OU(B2-D2=0;ESTERREUR(B2-D2));"";B2-D2)



non seulement on y gagne rien, mais en plus c'est faux... désolé

--
JièL eraré humanum est

isabelle
Le #26353897
bonsoir Albert,

ici aussi on gèle (3 c),

je ne voie pas comment l'erreur peut se produire,

voici un exemple: http://cjoint.com/?EExcSwg44Me

isabelle à Sherbrooke

Le 2015-05-22 19:25, albert a écrit :
Bonsoir Isabelle
ici on gèle cette nuit

La deuxième parenthèse est une erreur de copier/coller, car car j'ai fait un
control X sur la deuxième formule.
Dans le fichier original D2 est une formule (somme(E2:N8) et si toutes ces
cellules sont vides cela génère l'erreur #valeur.

Bonne soirée

Albert
albert
Le #26353901
Bonsoir Isabelle

J'ai bien arrosé le jardin pour que les petites pousses ne gèlent pas.

Voir mon fichier sur http://cjoint.com/?EExdrEe01OL

albert à St-Bruno-de-Montarville


"isabelle" news:mjoio1$dju$
bonsoir Albert,

ici aussi on gèle (3 c),

je ne voie pas comment l'erreur peut se produire,

voici un exemple: http://cjoint.com/?EExcSwg44Me

isabelle à Sherbrooke


Publicité
Poster une réponse
Anonyme