année mobile

Le
Faute de Frappe
Bonjour,
Existe-il une commande permettant de décaler automatiquement les mois,
en permutant les colonnes "mois" ?
Merci
FdF
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
HD
Le #4542291
Existe-il une commande permettant de décaler
automatiquement les mois, en permutant les
colonnes "mois" ?


Que veux tu dire par là ?

--
@+
HD

Faute de Frappe
Le #4542261
HD wrote:
:: Existe-il une commande permettant de décaler
:: automatiquement les mois, en permutant les
:: colonnes "mois" ?
:
: Que veux tu dire par là ?

Voila, j'ai besoin de connaître des valeurs sur un an. De mai à mai,
juin à juin, juillet à juillet etc, en décalant automatiquement d'un
mois, de façon a toujours avoir un total sur un an. Les mois sont dans
12 colonnes.
En fait, le calcul doit toujours se faire sur 1 an.
Suis je assez clair ? A chaque mois, je désire me décaller, pour
prendre en compte automatiquement les 12 derniers mois.
Merci
FdF
AV
Le #4542231
En fait, le calcul doit toujours se faire sur 1 an.
Suis je assez clair ? A chaque mois, je désire me décaller, pour
prendre en compte automatiquement les 12 derniers mois.


Plages nommées et formule matricielle :

=MOYENNE(SI((Dates>ÚTE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI())-12;1))*(Dates<ÚTE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI())+1;0));Valeurs))

http://cjoint.com/?fDlbUSUrRz

AV

JB
Le #4542201
Bonjour,

Exemple: http://cjoint.com/?fDliYYddsJ

=SOMME(DECALER(B2;EQUIV(D2;A2:A1000;0)-1;0;12))

JB

On 29 mai, 10:45, "Faute de Frappe" wrote:
HD wrote:

:: Existe-il une commande permettant de décaler
:: automatiquement les mois, en permutant les
:: colonnes "mois" ?
:
: Que veux tu dire par là ?

Voila, j'ai besoin de connaître des valeurs sur un an. De mai à mai,
juin à juin, juillet à juillet etc, en décalant automatiquement d'un
mois, de façon a toujours avoir un total sur un an. Les mois sont dans
12 colonnes.
En fait, le calcul doit toujours se faire sur 1 an.
Suis je assez clair ? A chaque mois, je désire me décaller, pour
prendre en compte automatiquement les 12 derniers mois.
Merci
FdF


Jean Berti
Le #4541981
Salut
Colonne B les valeurs.Essaies
=SOMME(DECALER(B:B;NBVAL(B:B)-1;;-12))
Jean Berti

"Faute de Frappe" de news: 465be17a$0$27375$
Bonjour,
Existe-il une commande permettant de décaler automatiquement les mois,
en permutant les colonnes "mois" ?
Merci
FdF



Publicité
Poster une réponse
Anonyme