Apache1.3.x supprimé de debian lenny

Le
tech
Bonjour à tous,
J'ai depuis quelques jours un gros problème sur mon serveur web en production.
j'utilise une debian lenny (testing)
le 20 mai apt-get m'a proposé une mise à jour de perl vers la version 5.10.0-10 intégrée à lenny depuis le 18 mai.
J'ai lancé l'upgrade
Malheureusement mon serveur apache est encore en version 1.3.34 et celui-ci a été retiré de lenny depuis le 5 février.
Résultat : la mise à jour de perl a en même temps supprimé libapache-mod-perl
heureusement mon serveur apache tourne encore tant bien que mal, l'upgrade n'étant pas allé jusqu'à le supprimer, mais
il m'est impossible de le re-démarrer :
apachectl configtest me renvoie des erreurs sur tous les paramètres concernant mod-perl et avant tout :

> Cannot load /usr/lib/apache/1.3/mod_perl.so into server: /usr/lib/apache/1.3/mod_perl.so:
> cannot open shared object file: No such file or directory

forcément puisque /usr/lib/apache/1.3/mod_perl.so n'existe plus

Deux solutions s'offrent à moi à présent :
soit migrer définitivement mes quelques 50 sites vers apache2, avec les problèmes de configuration que cela implique
(différence de format, entre autre l'absence de dossiers mods et sites available et enable dans la version 1.3.x )
soit downgrader totalement ma lenny vers etch puisque apache1.x existe toujours sur etch en suivant la procédure décrite
ici http://lists.debian.org/debian-user-french/2008/04/msg00630.html mais ça concerne une masse énorme de paquets

J'ai déjà modifié mon fichier /etc/apt/preference en poussant la priorité de etch à 1001 et testé un
apt-get install libapache-mod-perl -s
et dans ce cas seule une vingtaine de paquets seraient concernés, ce qui me semble une solution jouable
mais je crains quand même qu'il y ait des problèmes de fonctionnement et certains des sites hébergés sont pour moi
"critiques"

Est-ce que quelqu'un parmi vous a déjà effectué ce genre de manip et aurait des conseils à me donner à ce sujet ?







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Émile CARRY
Le #9667891
Le Tue, 27 May 2008 17:09:54 +0200,
""
Bonjour à tous,
J'ai depuis quelques jours un gros problème sur mon serveur web en
production. j'utilise une debian lenny (testing)
le 20 mai apt-get m'a proposé une mise à jour de perl vers la v ersion
5.10.0-10 intégrée à lenny depuis le 18 mai. J'ai lancà © l'upgrade
Malheureusement mon serveur apache est encore en version 1.3.34 et
celui-ci a été retiré de lenny depuis le 5 février. R ésultat : la
mise à jour de perl a en même temps supprimé libapache-mod -perl
heureusement mon serveur apache tourne encore tant bien que mal,
l'upgrade n'étant pas allé jusqu'à le supprimer, mais il m 'est
impossible de le re-démarrer : apachectl configtest me renvoie des
erreurs sur tous les paramètres concernant mod-perl et avant tout :

> Cannot load /usr/lib/apache/1.3/mod_perl.so into
> server: /usr/lib/apache/1.3/mod_perl.so:
> cannot open shared object file: No such file or directory

forcément puisque /usr/lib/apache/1.3/mod_perl.so n'existe plus

Deux solutions s'offrent à moi à présent :
soit migrer définitivement mes quelques 50 sites vers apache2, avec
les problèmes de configuration que cela implique (différence de
format, entre autre l'absence de dossiers mods et sites available et
enable dans la version 1.3.x ...) soit downgrader totalement ma lenny
vers etch puisque apache1.x existe toujours sur etch en suivant la
procédure décrite ici
http://lists.debian.org/debian-user-french/2008/04/msg00630.html mais
ça concerne une masse énorme de paquets...

J'ai déjà modifié mon fichier /etc/apt/preference en pouss ant la
priorité de etch à 1001 et testé un apt-get install
libapache-mod-perl -s et dans ce cas seule une vingtaine de paquets
seraient concernés, ce qui me semble une solution jouable mais je
crains quand même qu'il y ait des problèmes de fonctionnement et
certains des sites hébergés sont pour moi "critiques"...

Est-ce que quelqu'un parmi vous a déjà effectué ce genre d e manip et
aurait des conseils à me donner à ce sujet ?



Je n'ai pas de solution à ton pb, mais je me demande si tu ne pourrais
pas utiliser : http://snapshot.debian.net/

Tu forces l'install de la version précédente du paquet perl juste avant
le 20 mai, et tu réinstalles la dernière version de
libapache-mod-perl... au moins le temps de trouver/tester une autre
solution...

mil

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Michelle Konzack
Le #9667661
--LyciRD1jyfeSSjG0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

En court: Le config de 1.3 est compatible avec 2.x et tu peut installer
apache2 en parallel copier les configs (une par site?) et
changer temporairement le TDL des sites sur "foo" et installer
une /etc/hosts avec les TLD modifier...

Lancer un explorateur internet et verifier...

Si tou va bien, changer les TLD retour sur le origine,
eleminer les /etc/hosts, arreter apache1.3 et REDEMARER
apache2.

Bone chance
(t'attender trop longue parce la elimination de
apache etait prevue depuis l'anne derniere...)

Thanks, Greetings and nice Day
Michelle Konzack
Systemadministrator
24V Electronic Engineer
Tamay Dogan Network
Debian GNU/Linux Consultant


--
Linux-User #280138 with the Linux Counter, http://counter.li.org/
##################### Debian GNU/Linux Consultant #####################
Michelle Konzack Apt. 917 ICQ #328449886
+49/177/9351947 50, rue de Soultz MSN LinuxMichi
+33/6/61925193 67100 Strasbourg/France IRC #Debian (irc.icq.com)

--LyciRD1jyfeSSjG0
Content-Type: application/pgp-signature; name="signature.pgp"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFIPIN/C0FPBMSS+BIRArJrAJ4tipEG5M2DpTB7OSYSGAjdqNcxZACeOwXt
+OHBKwlKwpiy3JlFOyQs/eE =InqI
-----END PGP SIGNATURE-----

--LyciRD1jyfeSSjG0--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme