Apache2 et favicon

Le
Une Bévue
Si je ne renseigne pas, dans le head d'un fichier html5, le favicon,
j'ai un sgribouilli comme ça :
<http://cjoint.com/data/0Lik1FLLIep_apache-et-favicon.png>

y a t'il une sorte de favicon par défaut à placer qqpart pour Apache2.

je ne comprends pas pourquoi Google Chrome, par exemple donne se
sgriboulli plutôt qu'une icône standard genre fichier

--
L'homme est imparfait, mais ce n'est pas étonnant
quand on pense à l'époque où il a été créé.
— Alphonse Allais
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
SAM
Le #25034612
Le 08/12/12 10:56, Une Bévue a écrit :
Si je ne renseigne pas, dans le head d'un fichier html5, le favicon,
j'ai un sgribouilli comme ça :

y a t'il une sorte de favicon par défaut à placer qqpart pour Apache2.



Normalement c'est un 'favicon.ico' (un fichier Windows quoi)
à la racine

et ... à ce que j'ai cru comprendre, c'est à la discrétion du couple
navigateur/serveur pour son affichage
(ça ne fonctionne pas à tous coups avec IE, à ce que j'ai capté de ce
que j'ai cru entendre raconter dans les chaumières)

Son absence produirait des erreurs rapportées dans les logs du serveur (?!)

Perso, dans mon Apache Mac, j'ai dû la mettre en racine racine
c a d en racine du site localhost
(dossier 'server' de bibli principale)

J'imagine qu'il doit être possible de glisser une ligne dans le fichier
de config d'Apache ou un htaccess pour pouvoir distribuer l'icône qui
serait en racine du 'site' ~Yvon ?
Aller au dossier ... /etc/Apache2/
et aussi : /etc/Apache2/extra/
/etc/Apache2/users/
fouiller les *.conf
(faire des copies préalables)

ou voir/revoir les histoires de vhost
histoire de tenter de re-programmer la "racine" de chaque sitos ?


je ne comprends pas pourquoi Google Chrome, par exemple donne se
sgriboulli plutôt qu'une icône standard genre fichier...



format de ton favicon ?
ça doit être un *.ico
(à réaliser avec GraphicConverter, par exemple)
sauf à ce que tu n'aies précisé autre chose dans le config d'Apache ?

Mon chrome ne me montre pas ça, juste une image de fichier.
Ré-installer Chrome ? (qu'il retrouve ses bébés !) ou re-démarrer ?
Refaire l'ico ? (ça ne souffre pas les à peu près)
à moins que ce ne soit à cause de ça :

--
Stéphane Moriaux avec/with iMac-intel
Une Bévue
Le #25035492
Le 08/12/12 12:52, SAM a écrit :
c a d en racine du site localhost


OK, merci, ça roule.
Publicité
Poster une réponse
Anonyme