apt-get build-dep ne fonctionne pas...

Le
David BERCOT
Bonsoir,

J'ai un petit pour un logiciel que je compile à partir des sources
(Galaxium pour ne pas le nommer). En effet, si je fais un apt-get
build-dep galaxium-svn, ça ne fonctionne plus :
E: Les dépendances de compilation pour galaxium-svn ne peuvent pas Ã=
ªtre
satisfaites

Je dois reconnaître que ce message ne m'inspire pas trop Bien
évidemment, j'ai la ligne deb-src correspondante dans mon sources.list.

Auriez-vous une idée de la provenance de ce genre de message ? Où
puis-je trouver plus d'infos sur l'erreur ?

Merci d'avance.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Alain Baeckeroot
Le #19147471
Le 19/04/2009 à 20:38, David BERCOT a écrit :

Bonsoir,

J'ai un petit pour un logiciel que je compile à partir des sources
(Galaxium pour ne pas le nommer). En effet, si je fais un apt-get
build-dep galaxium-svn, ça ne fonctionne plus :
E: Les dépendances de compilation pour galaxium-svn ne peuvent pas être
satisfaites...

Je dois reconnaître que ce message ne m'inspire pas trop... Bien
évidemment, j'ai la ligne deb-src correspondante dans mon sources.li st.

Auriez-vous une idée de la provenance de ce genre de message ? Oà ¹
puis-je trouver plus d'infos sur l'erreur ?

Merci d'avance.

David.




d'ou vient ce paquet ? je ne le vois pas dans
http://packages.debian.org/search?keywords=galaxium&searchon=names&suit e=all&section=all

Alain

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Alain Baeckeroot
Le #19147521
Le 19/04/2009 à 20:38, David BERCOT a écrit :

Bonsoir,

J'ai un petit pour un logiciel que je compile à partir des sources
(Galaxium pour ne pas le nommer). En effet, si je fais un apt-get
build-dep galaxium-svn, ça ne fonctionne plus :
E: Les dépendances de compilation pour galaxium-svn ne peuvent pas être
satisfaites...

Je dois reconnaître que ce message ne m'inspire pas trop... Bien
évidemment, j'ai la ligne deb-src correspondante dans mon sources.li st.

Auriez-vous une idée de la provenance de ce genre de message ? Oà ¹
puis-je trouver plus d'infos sur l'erreur ?



ca signifie qu'apt ne trouve pas dans les dépots certains paquets requ is.

Si le paquet vient d'un site hors des dépots debian, il y a probabalem ent
d'autres paquets a installer (dans le bon ordre) pour satisfaire
les dépendances.

Alain

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David BERCOT
Le #19149211
Bonjour,

Le Sun, 19 Apr 2009 21:54:14 +0200,
Alain Baeckeroot
Le 19/04/2009 à 20:38, David BERCOT a écrit :

Bonsoir,

J'ai un petit pour un logiciel que je compile à partir des sources
(Galaxium pour ne pas le nommer). En effet, si je fais un apt-get
build-dep galaxium-svn, ça ne fonctionne plus :
E: Les dépendances de compilation pour galaxium-svn ne peuvent pas
être satisfaites...

Je dois reconnaître que ce message ne m'inspire pas trop... Bien
évidemment, j'ai la ligne deb-src correspondante dans mon
sources.list.

Auriez-vous une idée de la provenance de ce genre de message ? Oà ¹
puis-je trouver plus d'infos sur l'erreur ?



ca signifie qu'apt ne trouve pas dans les dépots certains paquets
requis.

Si le paquet vient d'un site hors des dépots debian, il y a
probabalement d'autres paquets a installer (dans le bon ordre) pour
satisfaire les dépendances.



Alors, en effet, il ne vient pas d'un dépôt Debian. Mais justemen t, mon
problème serait de savoir quelles sont ces dépendances qui ne peu vent
être satisfaites. Le message me semble beaucoup trop vague : aucun
détail n'est précisé...

J'imagine qu'on doit pouvoir avoir plus d'infos, non ? Mais je ne sais
pas du tout comment faire :-(

Merci.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Charles Plessy
Le #19149191
Le Mon, Apr 20, 2009 at 09:06:00AM +0200, David BERCOT a écrit :

Alors, en effet, il ne vient pas d'un dépôt Debian. Mais justement, mon
problème serait de savoir quelles sont ces dépendances qui ne peuvent
être satisfaites. Le message me semble beaucoup trop vague : aucun
détail n'est précisé...

J'imagine qu'on doit pouvoir avoir plus d'infos, non ? Mais je ne sais
pas du tout comment faire :-(



Bonjour David,

je pense qu'il faut rajouter le dépôt source en plus du dépôt binaire. Par
exemple, pour le dépôt non-officiel (et obsolète, ne l'utilisez pas) de Bibus:

deb http://switch.dl.sourceforge.net/sourceforge/bibus-biblio ./
deb-src http://switch.dl.sourceforge.net/sourceforge/bibus-biblio ./

Amicalement,

--
Charles Plessy
Tsurumi, Kanagawa, Japan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David BERCOT
Le #19149351
Re-bonjour,

Le Mon, 20 Apr 2009 16:18:16 +0900,
Charles Plessy
Le Mon, Apr 20, 2009 at 09:06:00AM +0200, David BERCOT a écrit :

Alors, en effet, il ne vient pas d'un dépôt Debian. Mais juste ment,
mon problème serait de savoir quelles sont ces dépendances qui ne
peuvent être satisfaites. Le message me semble beaucoup trop vague :
aucun détail n'est précisé...

J'imagine qu'on doit pouvoir avoir plus d'infos, non ? Mais je ne
sais pas du tout comment faire :-(



Bonjour David,

je pense qu'il faut rajouter le dépôt source en plus du dép ôt binaire.
Par exemple, pour le dépôt non-officiel (et obsolète, ne l' utilisez
pas) de Bibus:

deb http://switch.dl.sourceforge.net/sourceforge/bibus-biblio ./
deb-src http://switch.dl.sourceforge.net/sourceforge/bibus-biblio ./



En effet, mais c'est exactement ce que j'ai fait ;-)
Pour info, voici mes deux lignes :
### Galaxium (client MSN) ###
deb http://ppa.launchpad.net/galaxium/ubuntu jaunty main
deb-src http://ppa.launchpad.net/galaxium/ubuntu jaunty main

Donc, il doit y avoir autre chose...

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Charles Plessy
Le #19149561
Le Mon, Apr 20, 2009 at 09:32:02AM +0200, David BERCOT a écrit :

En effet, mais c'est exactement ce que j'ai fait ;-)
Pour info, voici mes deux lignes :
### Galaxium (client MSN) ###
deb http://ppa.launchpad.net/galaxium/ubuntu jaunty main
deb-src http://ppa.launchpad.net/galaxium/ubuntu jaunty main



Ah désolé, j'ai répondu à côté de la plaque.

Il y a une possibilité de plan B:

sudo aptitude install devscripts
apt-get source galaxium-svn
cd galaxium-svn-0.8~svn1388
sudo mk-build-deps -r -i

Ça ne répond pas à la question sur apt-get build-dep, mais ça pourrait bien
marcher :)

Bonne journée,

--
Charles Plessy
Tsurumi, Kanagawa, Japon

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Guy Roussin
Le #19149701
David BERCOT a écrit :
Re-bonjour,

Le Mon, 20 Apr 2009 16:18:16 +0900,
Charles Plessy
Le Mon, Apr 20, 2009 at 09:06:00AM +0200, David BERCOT a écrit :

Alors, en effet, il ne vient pas d'un dépôt Debian. Mais ju stement,
mon problème serait de savoir quelles sont ces dépendances qui ne
peuvent être satisfaites. Le message me semble beaucoup trop vag ue :
aucun détail n'est précisé...

J'imagine qu'on doit pouvoir avoir plus d'infos, non ? Mais je ne
sais pas du tout comment faire :-(



Bonjour David,

je pense qu'il faut rajouter le dépôt source en plus du dà ©pôt binaire.
Par exemple, pour le dépôt non-officiel (et obsolète, n e l'utilisez
pas) de Bibus:

deb http://switch.dl.sourceforge.net/sourceforge/bibus-biblio ./
deb-src http://switch.dl.sourceforge.net/sourceforge/bibus-biblio ./




En effet, mais c'est exactement ce que j'ai fait ;-)
Pour info, voici mes deux lignes :
### Galaxium (client MSN) ###
deb http://ppa.launchpad.net/galaxium/ubuntu jaunty main
deb-src http://ppa.launchpad.net/galaxium/ubuntu jaunty main

Donc, il doit y avoir autre chose..


Sans doute des dépendances présentes dans jaunty (dépô ts officiels)
et absentes de debian. Essayer un 'apt-cache show galaxium' pour les
repérer ...

Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Guy Roussin
Le #19149681
> Sans doute des dépendances présentes dans jaunty (dépà ´ts officiels)
et absentes de debian. Essayer un 'apt-cache show galaxium' pour les
repérer ...


pardon "apt-cache showsrc galaxium"

Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David BERCOT
Le #19151081
Re-bonjour,

Le Mon, 20 Apr 2009 10:05:42 +0200,
Guy Roussin
Sans doute des dépendances présentes dans jaunty (dépà ´ts officiels)
et absentes de debian. Essayer un 'apt-cache show galaxium' pour les
repérer ...


pardon "apt-cache showsrc galaxium"



En effet, ça me donne bien la liste des dépendances...
Toutefois, ce n'est pas très pratique...

Est-ce qu'il y aurait une solution pour demander à n'installer QUE les
dépendances ? Ensuite, je n'aurais plus qu'à compiler les sources ...

Néanmoins, est-ce qu'il ne me manquerait pas d'autres paquets
utilisées pendant la compilation ? J'imagine que si, sinon, apt-get
build-dep ne servirait à rien...
Dans ce cas, ne serait-il pas possible qu'apt-get build-dep ne donne la
liste des problèmes de dépendances rencontrés ?

Merci d'avance.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David BERCOT
Le #19151121
Le Mon, 20 Apr 2009 20:23:01 +0900,
Charles Plessy
Le Mon, Apr 20, 2009 at 01:17:58PM +0200, David BERCOT a écrit :

Est-ce qu'il y aurait une solution pour demander à n'installer QUE
les dépendances ?


http://lists.debian.org/debian-user-french/2009/04/msg00573.html

(mk-build-deps)

Je n'ai pas fait un test complet, mais il avait l'air de ne pas donner
d'erreur avant de proposer le téléchargement (c'est à ce mo ment là que
je l'ai interrompu).



Oups, j'avais oublié ce message :-(
Bon, je teste ça ce soir sur l'ordi qui me pose problème...

Merci.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme