/etc/apt/preferences

Le
anisometropie
--001636416adf8a22cb046f0cb2e6
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,
voici mon* /etc/apt/preferences* :

Package: iceweasel
> Pin: release a=experimental
> Pin-Priority: 990
>
> Package: nvidia*
> Pin: release a=unstable
> Pin-Priority: 990
>
> Package: *
> Pin: release a=testing
> Pin-Priority: 900
>
> Package: *
> Pin: release a=unstable
> Pin-Priority: 800
>

vous l'aurez compris j'aimerais bien installer la dernière version
d'iceweasel et des pilotes nvidia.

pour iceweasel j'ai un problème de dépendance. ni apt-get dist-up=
grade ni
aptitude safe-upgrade ne veulent avoir raison des dépendances.
quels moyens y-a-t'il pour lui dire d'installer les dépendances (sans =
avoir
à rajouter un par un les paquets dans le fichier *preferences* év=
idement) ?

pour nvidia, je n'ai pas de retour de apt-cache policy, alors que j'ai bien
celui ci pour iceweasel :


> Paquets étiquetés :
> iceweasel -> 3.5.1-1


des idées ?

merci !!

--001636416adf8a22cb046f0cb2e6
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour, <br>voici mon<i> /etc/apt/preferences</i> :<br><br><blockquote sty=
le="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex;=
padding-left: 1ex;" class="gmail_quote">Package: iceweasel<br>Pin: relea=
se a=experimental<br>
Pin-Priority: 990<br><br>Package: nvidia*<br>Pin: release a=unstable<br>P=
in-Priority: 990<br><br>Package: *<br>Pin: release a=testing<br>Pin-Prior=
ity: 900<br><br>Package: *<br>Pin: release a=unstable<br>Pin-Priority: 80=
0<br>
</blockquote><br>vous l&#39;aurez compris j&#39;aimerais bien installer la =
dernière version d&#39;iceweasel et des pilotes nvidia.<br><br>pour ic=
eweasel j&#39;ai un problème de dépendance. ni apt-get dist-upgra=
de ni aptitude safe-upgrade ne veulent avoir raison des dépendances.<b=
r>
quels moyens y-a-t&#39;il pour lui dire d&#39;installer les dépendance=
s (sans avoir à rajouter un par un les paquets dans le fichier <i>pref=
erences</i> évidement) ?<br><br>pour nvidia, je n&#39;ai pas de retour=
de apt-cache policy, alors que j&#39;ai bien celui ci pour iceweasel :<br>
<br><blockquote style="border-left: 1px solid rgb(204, 204, 204); margin:=
0pt 0pt 0pt 0.8ex; padding-left: 1ex;" class="gmail_quote"><br>Paquets =
étiquetés :<br>     iceweasel -&gt; 3.5.=
1-1</blockquote><div> </div><div>des idées ? <br>
<br>merci !!<br></div>

--001636416adf8a22cb046f0cb2e6--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guy Roussin
Le #19787921
Bonjour,


voici mon/ /etc/apt/preferences/ :

Package: iceweasel
Pin: release a=experimental
Pin-Priority: 990

Package: nvidia*
Pin: release a=unstable
Pin-Priority: 990

Package: *
Pin: release a=testing
Pin-Priority: 900

Package: *
Pin: release a=unstable
Pin-Priority: 800


vous l'aurez compris j'aimerais bien installer la dernière version
d'iceweasel et des pilotes nvidia.

pour iceweasel j'ai un problème de dépendance. ni apt-get dist-upgrade
ni aptitude safe-upgrade ne veulent avoir raison des dépendances.
quels moyens y-a-t'il pour lui dire d'installer les dépendances (sans
avoir à rajouter un par un les paquets dans le fichier /preferences/
évidement) ?


Ce que je fais:
je met la ligne relative a experimental dans "sources.list"
par defaut la Priority est très faible ( 1 ?) et je vire les lignes
relatives à experimental dans "preferences".
Ensuite aptitude update et
aptitude install iceweasel=3.5-1

et tu regardes les paquets qu'il veut installer ... s'il y a du lourd
(libc6,...) ,
laisse tomber la méthode et tu as encore au moins 2 possibilités.
- Tu recup le source dans experimental que tu recompiles à la mode debian
(dpkg-buildpackage)
- Tu recup le paquet binaire firefox chez mozilla ...


Guy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
anisometropie
Le #19790261
--0016364166e90e0405046f1cf23f
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

en fait pour l'experimental par defaut tous les paquets sont à *5* don c on
est pas obligé de mettre quoi que ce soit.

pour les paquets nvidia, je me suis rendu compte que l'étoile marchait pas
dans le nom des paquets.
Package: *nvidia**
Pin: release a=unstable
Pin-Priority: 990
il a fallut mettre tous les paquets un par un à la suite.

d'ailleurs je ne comprend pas pourquoi les paquets propriétaire tels q ue les
pilotes de cartes graphique nvidia sont dans une version différente en
testing et sid.

pour iceweasel aptitude m'aura résolu le problème (il n'y avait q u'une
dependance )

Le 19 juillet 2009 19:43, Guy Roussin :

Ce que je fais:
je met la ligne relative a experimental dans "sources.list"
par defaut la Priority est très faible ( 1 ?) et je vire les lignes
relatives à experimental dans "preferences".
Ensuite aptitude update et
aptitude install iceweasel=3.5-1





et tu regardes les paquets qu'il veut installer ... s'il y a du lourd
(libc6,...) ,
laisse tomber la méthode et tu as encore au moins 2 possibilité s.
- Tu recup le source dans experimental que tu recompiles à la mode d ebian
(dpkg-buildpackage)
- Tu recup le paquet binaire firefox chez mozilla ...


Guy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS





--0016364166e90e0405046f1cf23f
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

   Package: <b>nvidia*</b><br>
   Pin: release a=unstable<br>
   Pin-Priority: 990 Ce que je fais:<br>
je met la ligne relative a experimental dans &quot;sources.list&quot;<br>
par defaut la Priority est très faible ( 1 ?) et je vire les lignes<br >
relatives à experimental dans &quot;preferences&quot;.<br>
Ensuite aptitude update et<br>
aptitude install iceweasel=3.5-1  <br>
et tu regardes les paquets qu&#39;il veut installer ... s&#39;il y a du lou rd (libc6,...) ,<br>
laisse tomber la méthode et tu as encore au moins 2 possibilités. <br>
- Tu recup le source dans experimental que tu recompiles à la mode deb ian<br>
(dpkg-buildpackage)<br>
- Tu recup le paquet binaire firefox chez mozilla ...<br>
<br>
<br>
Guy<br><font color="#888888">
<br>
<br>
-- <br>
Lisez la FAQ de la liste avant de poser une question :<br>
``spam&#39;&#39; dans vos champs &quot;From&quot; et &quot;Reply-To:&quot;< br>
<br>
Pour vous DESABONNER, envoyez un message avec comme objet &quot;unsubscribe &quot;<br>
vers En cas de soucis, contactez EN ANGLAIS <br>
</font></blockquote></div><br>

--0016364166e90e0405046f1cf23f--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme