[APT] Strange dependency problem

Le
Romaric Defaux
Hi all !


I hope I'm writing to the good mailing-list :)

My problem is I can't install libapache2-mod-security because of unmet
dependencies

Here I try to install libapache2-mod-security :
# apt-get install libapache2-mod-security

The following packages have unmet dependencies:
libapache2-mod-security: Depends: apache2-common but it is not going to
be installed
E: Broken packages

So I check my apache package installed :
# dpkg -l | grep -i 'apache'
ii apache-common 1.3.34-4.1+etc support files for all Apache webservers
ii apache2 2.2.3-4+etch4 Next generation, scalable, extendable web se
*rc apache2-common 2.0.54-5sarge1 next generation, scalable, extendable
web se*
ii apache2-mpm-pr 2.2.3-4+etch4 Traditional model for Apache HTTPD 2.1
ii apache2-prefor 2.2.3-4+etch4 development headers for apache2
ii apache2-utils 2.2.3-4+etch4 utility programs for webservers
ii apache2.2-comm 2.2.3-4+etch4 Next generation, scalable, extendable
web se
ii apachetop 0.12.5-1sarge1 Realtime Apache monitoring tool
ii libapache-mod- 4.4.4-8+etch4 server-side, HTML-embedded scripting
languag
rc libapache-mod- 1.8.7-1 Tighten web applications security for Apache
ii libapache2-mod 4.4.4-8+etch4 server-side, HTML-embedded scripting
languag
ii libapr0 2.0.54-5sarge1 the Apache Portable Runtime
ii libapr1 1.2.7-8.2 The Apache Portable Runtime Library
ii libapr1-dev 1.2.7-8.2 The Apache Portable Runtime Library - Develo
ii libaprutil1 1.2.7+dfsg-2 The Apache Portable Runtime Utility Library
ii libaprutil1-de 1.2.7+dfsg-2 The Apache Portable Runtime Utility Library

apache2-common is here but in sarge.

After checking my repository, I want to install it in etch :
# apt-get install apache2-common

And here I got the strange error :
The following packages have unmet dependencies:
apache2-common: Depends: apache2-utils (= 2.0.54-5sarge2) but
2.2.3-4+etch4 is to be installed
E: Broken packages

I said "strange" because the package apache2-utils is in the good
version (etch) !!!
*ii apache2-utils 2.2.3-4+etch4 utility programs for webservers*

As anyone an idea ?


Oh, and I try with aptitude too, but changed nothing


Thanks you

Regards
--

*Romaric DEFAUX*
Administrateur Systèmes et Réseaux
Tel: +33 (0) 820 00 70 70
Fax: +33 (0)3 20 63 88 89 assistance@audaxis.com
<mailto:assistance@audaxis.com>
www.audaxis.com <http://www.audaxis.com>



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
pascatgm
Le #9661371
Romaric Defaux a écrit :
Hi all !



Hi too but...You're posting to a *french* user list...So don't have to
speak a f****oreign language !

I hope I'm writing to the good mailing-list :)

My problem is I can't install libapache2-mod-security because of unmet
dependencies...

Here I try to install libapache2-mod-security :
# apt-get install libapache2-mod-security

The following packages have unmet dependencies:
libapache2-mod-security: Depends: apache2-common but it is not going
to be installed
E: Broken packages

So I check my apache package installed :
# dpkg -l | grep -i 'apache'
ii apache-common 1.3.34-4.1+etc support files for all Apache webservers
ii apache2 2.2.3-4+etch4 Next generation, scalable, extendable web se
*rc apache2-common 2.0.54-5sarge1 next generation, scalable,
extendable web se*
ii apache2-mpm-pr 2.2.3-4+etch4 Traditional model for Apache HTTPD 2.1
ii apache2-prefor 2.2.3-4+etch4 development headers for apache2
ii apache2-utils 2.2.3-4+etch4 utility programs for webservers
ii apache2.2-comm 2.2.3-4+etch4 Next generation, scalable, extendable
web se
ii apachetop 0.12.5-1sarge1 Realtime Apache monitoring tool
ii libapache-mod- 4.4.4-8+etch4 server-side, HTML-embedded scripting
languag
rc libapache-mod- 1.8.7-1 Tighten web applications security for Apache
ii libapache2-mod 4.4.4-8+etch4 server-side, HTML-embedded scripting
languag
ii libapr0 2.0.54-5sarge1 the Apache Portable Runtime
ii libapr1 1.2.7-8.2 The Apache Portable Runtime Library
ii libapr1-dev 1.2.7-8.2 The Apache Portable Runtime Library - Develo
ii libaprutil1 1.2.7+dfsg-2 The Apache Portable Runtime Utility Library
ii libaprutil1-de 1.2.7+dfsg-2 The Apache Portable Runtime Utility
Library

apache2-common is here but in sarge.

After checking my repository, I want to install it in etch :
# apt-get install apache2-common

And here I got the strange error :
The following packages have unmet dependencies:
apache2-common: Depends: apache2-utils (= 2.0.54-5sarge2) but
2.2.3-4+etch4 is to be installed
E: Broken packages

I said "strange" because the package apache2-utils is in the good
version (etch) !!!
*ii apache2-utils 2.2.3-4+etch4 utility programs for webservers*

As anyone an idea ?


Oh, and I try with aptitude too, but changed nothing...


Thanks you

Regards


It seems like you have a mix of sarge and etch ...
What about de-installing the sarge package before to try to install the
etch one ?
Also : did you check your sources.list too ?
Regards too then...
P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme