aptitude ou apt-get

Le
Xavier Maillard
Salut,

ca fait des plombes que je n'ai pas joue sur Debian et je me rend
compte que les choses ont quelque peu change en 4 ans de temps.

La question que je me pose est tout simplement de savoir si
apt-get est toujours d'actualite ou bien si il faut passer a
aptitude. Si apt-get est toujours utile (et utilise), peut-on
degager aptitude ?

Sinon, existe-t-il un doc permettant de faire le parallel entre
apt-get et aptitude ?

Merci a vous.

Xavier

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/m2tyr41mjr.fsf@deb.maillard.im
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
David Prévot
Le #21605651
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Le 21/04/2010 18:13, Xavier Maillard a écrit :
Salut,



Salut,

La question que je me pose est tout simplement de savoir si
apt-get est toujours d'actualite ou bien si il faut passer a
aptitude.



Il « faut » utiliser ce que tu préfères.

Si apt-get est toujours utile (et utilise), peut-on
degager aptitude ?



Si tu ne te sers pas d'aptitude, tu n'es pas obligé de le garder...

Sinon, existe-t-il un doc permettant de faire le parallel entre
apt-get et aptitude ?



Aptitude est plutôt bien documenté (paquet aptitude-doc-fr), est plus
puissant qu'apt-get, gère mieux les conflits, et c'est normalement
l'utilitaire de gestion de paquets conseillé dans Debian (mais il y a
des récalcitrants ;). Il permet d'utiliser une HUI (à la mutt) très
pratique, mais elle n'est pas obligatoire. Personnellement, je ne me
sers d'apt-get que pour récupérer les paquets source.

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkvPgkcACgkQ18/WetbTC/orCwCfVOjDeG4IL2i5SBtNFj04m5uA
TTYAnA5Ub3ucKB0lqD328OuxEuFanmYQ
=ExjY
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/hqnvoa$ai$
Goldy
Le #21606251
Le 22/04/2010 00:55, David Prévot a écrit :

Si apt-get est toujours utile (et utilise), peut-on
degager aptitude ?



Si tu ne te sers pas d'aptitude, tu n'es pas obligé de le garder...




Même si on en a pas l'utilisé, il n'est pas inutile de le conserver.
J'ai connu sous ubuntu des témoignages où apt-get n'était plus
disponible et il est toujours utile d'avoir un autre gestionnaire de
paquet en cas de problème.


Enfin personnellement, je trouve la nouvelle version d'aptitude
disponible dans testing depuis peu moins performante que l'ancienne. Il
arrive assez souvent en cas de problème de dépendance complexe de
suggérer la désinstallation du paquet que l'on souhaite installer tout
en mettant un tas d'autre paquet à jours (particulièrement dans le cas
de cohabitation de testing/sid)... ce qui n'est pas super cohérent.
Autant avant on avait le plus souvent la meilleure solution dès le
premier choix, maintenant il est souvent utile de vérifier plusieurs
possibilités avant de trouver la bonne (voir même de suggérer
l'installation de paquet pour la trouver).

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
François Cerbelle
Le #21606241
Goldy a écrit :
Enfin personnellement, je trouve la nouvelle version d'aptitude
disponible dans testing depuis peu moins performante que l'ancienne. Il
arrive assez souvent en cas de problème de dépendance complexe de
suggérer la désinstallation du paquet que l'on souhaite installer tout
en mettant un tas d'autre paquet à jours (particulièrement dans le cas
de cohabitation de testing/sid)... ce qui n'est pas super cohérent.
Autant avant on avait le plus souvent la meilleure solution dès le
premier choix, maintenant il est souvent utile de vérifier plusieurs
possibilités avant de trouver la bonne (voir même de suggérer
l'installation de paquet pour la trouver).




Je suis d'accord avec toi, l'ancienne version d'aptitude etait intelligente et proposait par défaut
le meileur choix dans la quasi-totalite des cas (sauf cas particulier avec plusieurs sources
stable/testing/sid et autres). La nouvelle est certes plus transparente et propose tous les choix
possibles sans en preconiser un par défaut. Ou alors, je l'ai mal configuré.

Par contre, apt-get reste indispensable pour récupérer les sources à ma connaissance.

Fanfan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe Barès
Le #21606881
François Cerbelle a écrit :
Par contre, apt-get reste indispensable pour récupérer les sources à
ma connaissance.



Il est bien rare dans le monde libre de n'avoir qu'une seule solution
possible...

En particulier, je vous conseille apt-src, qui gère les paquets source à
la manière d'apt-get/aptitude, c'est à dire qu'il peut mettre à jour les
paquets installés.
Le plus intéressant, c'est qu'on peut installer un paquet source où l'on
veut, et apt-src se souvient dans quel répertoire. Un petit:
$ apt-src list
vous donne la liste et l'endroit de tous vos paquets source (gérés par
apt-src bien sûr)
Et tous ça en utilisateur normal, bien entendu...

Toff'

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Xavier Maillard
Le #21619601
Salut,

On Thu, 22 Apr 2010 10:00:03 +0200, Christophe Barès
François Cerbelle a écrit :
> Par contre, apt-get reste indispensable pour récupérer les so urces à
> ma connaissance.

Il est bien rare dans le monde libre de n'avoir qu'une seule solution
possible...

En particulier, je vous conseille apt-src, qui gère les paquets sour ce à
la manière d'apt-get/aptitude, c'est à dire qu'il peut mettre à jour les
paquets installés.



Ca c'est tres tres interessant ! Merci du tuyau.

Le plus intéressant, c'est qu'on peut installer un paquet source o ù l'on
veut, et apt-src se souvient dans quel répertoire. Un petit:
$ apt-src list
vous donne la liste et l'endroit de tous vos paquets source (gérà ©s par
apt-src bien sûr)
Et tous ça en utilisateur normal, bien entendu...



Bien entendu, bien entendu, c'est vite dit. Deja a l'installation
de apt-src, il t'ajoute sudo ce qui suppose son utilisation. Et
effectivement, si on passe par apt-src list, errno 13 alors
qu'avec sudo, on a plus le probleme :)

Xavier

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Xavier Maillard
Le #21619631
Salut,

On Wed, 21 Apr 2010 18:55:04 -0400, David Prévot
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Le 21/04/2010 18:13, Xavier Maillard a écrit :
> Salut,

Salut,

> La question que je me pose est tout simplement de savoir si
> apt-get est toujours d'actualite ou bien si il faut passer a
> aptitude.

Il « faut » utiliser ce que tu préfères.



Je prefere utiliser ce qui est a) recommande et b) qui fonctionne
bien et c) ce que je connais. En fait pour tout dire, je ne
connais pas aptitude (sauf les aptitude install et autres trucs
tout bete).

> Si apt-get est toujours utile (et utilise), peut-on
> degager aptitude ?

Si tu ne te sers pas d'aptitude, tu n'es pas obligé de le garder...



Ok.

Merci beaucoup.

Xavier

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe Barès
Le #21620181
Salut,

Le 24/04/2010 05:30, Xavier Maillard a écrit :
Et tous ça en utilisateur normal, bien entendu...



Bien entendu, bien entendu, c'est vite dit. Deja a l'installation
de apt-src, il t'ajoute sudo ce qui suppose son utilisation. Et
effectivement, si on passe par apt-src list, errno 13 alors
qu'avec sudo, on a plus le probleme :)

Xavier



Oui, effectivement, apt-src demande parfois un mot de passe
pour sudo, mais c'est lui qui l'appelle directement:
- pour mettre à jour la base des paquets (apt-src update)
- pour installer les dépendances d'un paquet source

Si ta base est à jour, (via cron par exemple) et si le
paquet source à toutes ses dépendances satisfaites,
alors pas de besoin sudo (je viens de faire le test):

:~$ apt-src list
i gdb 7.0.1-2 /home/toff/src/gdb-7.0.1
:~$ sudo ls

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for toff:
toff is not in the sudoers file. This incident will be reported.
:~$

Voila sur ma machine (squeeze/sid), je ne sais pas pourquoi c'est
différent chez toi.

Toff'



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme