aptitude full-upgrade ne permet plus d'installer des paquets :(

Le
Serge SMEESTERS
Bonjour,

Système : Ubuntu 10.04 → 10.10
aptitude : 0.4.11.11→ 0.6.3

Remarque préliminaire :
Pour une raison obscure, aptitude n'est plus installé par défaut =
dans
Ubuntu 10.10 :(


J'espère ne pas être trop HS.
J'ai bien passé du temps sur le web à chercher l'évocation d=
e la
chose, mais j'ai rien trouvé.
Je pense qu'il devais s'agir d'un bogue au départ, car en relisant
bien la page de manuel,

Bref, j'avais l'habitude d'utiliser la commande

# aptitude full-upgrade nouveau-paquet

pour !en une seule opération! effectuer les mises à jours !et=
!
installer un (ou plusieurs !) nouveau(x) paquet(s).

Ainsi, j'avais confectionné une script pour compléter une install=
ation
(CD) qui après un apt-get update effectuais en une seul opération=
les
mises à jour et l'installation d'une série de nouveaux paquets


Maintenant, si j'ai bien compris, cela n'est plus possible ! :(

Je dois donc modifier mon script et faire en deux temps, une mise à
jour (full-upgrade) et ensuite l'installation de mes paquets (install)

Ce qui prends clairement plus de temps ! :( et demande d'être pré=
sent
entre les deux opération pour appuyer sur [enter] :(

Ais-je bien compris ?

Je serais étonné qu'il ne soit réellement plus possible de f=
aire en
une seul opération les mises à jour et installer de nouveaux
paquets Donc comment fait-on en vrai ? :)


Merci d'avance,
Serge S.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/AANLkTimW8MCmKpCX9dePyjVbnWJT5M-QkP6vMRjrD5O_@mail.gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jeremie COURREGES-ANGLAS
Le #22719231
--VrqPEDrXMn8OVzN4
Content-Type: text/plain; charset=utf-8
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Bonsoir

1) Debian n'est pas ubuntu, si ubuntu veut se débarrasser de aptitude, c'est
leur problème. Note que ça te donne une bonne raison de migrer, s 'il t'en
fallait encore une.

2) N'oublie pas de ne pas mélanger utilisation de apt-get et de aptitu de.

3) aptitude full-upgrade est réservé à un changement de vers ion, c'est
l'équivalent de apt-get dist-upgrade. À ne pas utiliser quotidien nement, donc.

Bonne soirée.

--
"Free software, free society."
Jérémie Courrèges-Anglas
GPG key : 06A11494

--VrqPEDrXMn8OVzN4
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (OpenBSD)

iQIcBAEBCAAGBQJMxdUmAAoJEGGRj78GoRSU1jcQAI4qh6FHR/h9Bez+6LiKI6IF
m7etmW9JR0Dwu0GAq23Rv3wtICWB+j2y8vFJsyyK/sGDv5QXTa9whxPx050K/ig2
C2pjFqAtTwhd6ybcUa9L9l+EVkLxGK9y1PgByf4k23WBPsXktIV7YtfNFAHvBPMZ
5VLqhVovd1ChCoqcaD1D9t/u9g/nPYj6b+HU1wRUMY4Z8sFGk1H4lrd5l39F3uaH
tOBTd1uuaNH/0Mdfv5GREJZPpZANhLzVi66mOT3O5jutUtqyEKr8sgqCuQtzrGDT
RlOwvPnaaSQJyr1uqJUWw2CUGp6AaojzgPr0zIGyiabKenAzn6Tx8wqcx7cCRnJQ
u4ZMEO8ZgxfdXJQu6pbDw4WJugs5ebcEG4GzU+Mn6IqsKaJnhOkR/zgjg0qVrBjZ
TBnRcyBrjxlXCoVFZ9da17kdv9uDjTj4Fb2P34vVJTqOnwHXgZ0c7m7v/RMgmCpA
UKqUdT++wN0UbGvxg+uTbXi2ZbQlhJTG8qZeD3JcWOwWcx7LYn2avKVIFO79y7Rz
kg7ZG4dnZF1/+aGOKUqX4BKL1Lt0uBSpvvaSy/8yhGGY7TuRI9cgJBsQZ4BSuypl
Q413BkqZ6TNh3C3RVQ+Mn+SLUkNIhUGdADAEHgbWPl5sw7AOIqJ1+9nefe4neSqS
OsUENXiTKlrgvhKuJ9Ew
=ULy0
-----END PGP SIGNATURE-----

--VrqPEDrXMn8OVzN4--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Simon Chopin
Le #22719391
On Mon, Oct 25, 2010 at 09:06:17PM +0200, Jeremie COURREGES-ANGLAS wrote:
Bonsoir


Bonsoir,



[snip]
3) aptitude full-upgrade est réservé à un changement de version, c'est
l'équivalent de apt-get dist-upgrade. À ne pas utiliser quotidiennement, donc.


Je vais peut-être dire une bêtise, mais n'est-ce pas aussi utilisable
dans le cadre d'un système sous sid ? En tout cas c'est la commande que
j'utilise, je trouve que j'ai moins de conflit quand ils font des
grosses mises à jour.

Bonne soirée.


De même,

Simon C.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
J
Le #22719671
Le lundi 25 octobre 2010 à 21:06 +0200, Jeremie COURREGES-ANGLAS a
écrit :
3) aptitude full-upgrade est réservé à un changement de version, c'est
l'équivalent de apt-get dist-upgrade. À ne pas utiliser
quotidiennement, donc.



Tss tss pas du tout et c'est justement pour ça qu'on a remplacé upgrade
et dist-upgrade par safe-upgrade et full-upgrade

Inutile de rappeler que la procédure "normale" et prudente est
safe-upgrade qui garantis de ne pas changer de version inopinément un
paquet que l'on voudrait conserver dans sa version actuelle (en le
fixant manuellement ou avec du pinning).

full-upgrade au contraire force la mise à jour vers la nouvelle version,
que ce soit d'un paquet unique (attention aux "dommages collatéraux") ou
de l'ensemble des paquet dans le cadre du changement de version de la
distribution.

Donc le résultat est sensiblement celui que tu pense, mais il y a des
nuances importantes.

P.S. Serge, pour grouper 2 commandes sous linux, oublie MSDos 3.1 :
aptitude update && aptitude safe-upgrade
(si la commande 1 est se termine bien, on enchaîne sur la commande 2)
--
Jérôme -

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme