Aptitude hold & aptitude safe-upgrade

Le
Arthur Clement
Bonjour,

Un de mes pc en sid ne fonctionne correctement qu'avec le xorg et le pilote=

fglrx en version lenny. J'ai donc fait un aptitude hold pour conserver les=

paquets concernés dans la version qui m'intéressait.
Mais le "hold" n'est pas reconnu quand je fais un aptitude safe-upgrade (ou=

aptitude upgrade tout court), je dois passer par la commande apt-get upgrad=
e
pour conserver la version des paquets "holdés" lors des MAJ.

Ce n'est pas très embêtant, mais j'aimerai comprendre pourquoi aptitude=
ne
comprend même pas ses propres commandes !


Merci pour votre aide
A.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fanfan
Le #19509421
--bp/iNruPH9dso1Pn
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Le Sunday 07 Jun 2009 à 13:06:19 (+0200), Arthur Clement a écrit :
Un de mes pc en sid ne fonctionne correctement qu'avec le xorg et le pilo te
fglrx en version lenny. J'ai donc fait un aptitude hold pour conserver le s
paquets concernés dans la version qui m'intéressait.
Mais le "hold" n'est pas reconnu quand je fais un aptitude safe-upgrade ( ou
aptitude upgrade tout court), je dois passer par la commande apt-get upgr ade
pour conserver la version des paquets "holdés" lors des MAJ.

Ce n'est pas très embêtant, mais j'aimerai comprendre pourquoi aptitu de ne
comprend même pas ses propres commandes !



Salut Arthur,

Je crois que tu devrais plutot regarder du côté du fichier (à créer)
/etc/apt/preferences (man apt_preferences), pour utiliser le système de
"pin" (punaise en Français) et attribuer des priorité personnelles à
certaines versions de certains paquets. Ainsi, aptitude aura plus de
liberté et tu auras des mises a jours moins booléennes (hold/unhold).

Fanfan

--
Ceux qui disent dormir comme un bébé, en général, n'en ont pas.
[Leo J. Burke]

--bp/iNruPH9dso1Pn
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFKK98bn0FdfiSfsswRAuk7AJ9Qa6rvZ2k15StPYwE/KgLJ/MlIrQCcCjLw
fnv8pUQvygfvG9IV7qwfzBo =Es7k
-----END PGP SIGNATURE-----

--bp/iNruPH9dso1Pn--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme