arrondir à 2 chiffres significatifs

Le
Val
Bonjour,

je cherche une solution me permettant d'arrondir n'importe quel nombre à 2
chiffres significatifs
exemple : 23800 devient 24000
Par avance merci de vos réponses car là je sèche complétement
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #20493561
bonjour Val,

pour les chiffres >0

=PLAFOND(A1;10^ENT(LOG10(A1))/10)

isabelle

Val a écrit :
Bonjour,

je cherche une solution me permettant d'arrondir n'importe quel nombre à 2
chiffres significatifs
exemple : 23800 devient 24000
Par avance merci de vos réponses car là je sèche complétement...




Alain
Le #20493961
Bonjour Val,

Pour arrondir au millier tu multiplie par 1000 avant d'arrondir et tu divise
par 1000 ensuite...

=ARRONDI(A1/1000;0)*1000

Alain

"Val" news:
Bonjour,

je cherche une solution me permettant d'arrondir n'importe quel nombre à 2
chiffres significatifs
exemple : 23800 devient 24000
Par avance merci de vos réponses car là je sèche complétement...



Martin Jean
Le #20494241
Et pourquoi pas: arrondi(A1;-3) (-3 pour arrondi au millier, -2 pour
arrondi à la centaine, -1 pour arrondi à la dizaine)
Sans tenir compte des nuances obtenues avec les fonctions ARRONDI.INF et
ARRONDI.SUP ...

Jean

"Val" discussion :
Bonjour,

je cherche une solution me permettant d'arrondir n'importe quel nombre Ã
2
chiffres significatifs
exemple : 23800 devient 24000
Par avance merci de vos réponses car là je sèche complétement...



Sam
Le #20495181
Bonjour,
=ARRONDI(A15;-NBCAR(A15)+2)
Cordialement
Michel dit "Sam"

"Val"
Bonjour,

je cherche une solution me permettant d'arrondir n'importe quel nombre à 2
chiffres significatifs
exemple : 23800 devient 24000
Par avance merci de vos réponses car là je sèche complétement...



Val
Le #20501101
Bonjour et merci de votre réponse

Toutefois mon arrondi n'est pas à faire forcément au millier.
L'objectif est d'arrondir m'inporte quel nombre à 2 chiffres significatifs.
ainsi 245 devient 250, 2468 devient 2500... et ainsi de suite

Quelqu'un aurait-il une solution ?


"Alain" a écrit :

Bonjour Val,

Pour arrondir au millier tu multiplie par 1000 avant d'arrondir et tu divise
par 1000 ensuite...

=ARRONDI(A1/1000;0)*1000

Alain

"Val" news:
> Bonjour,
>
> je cherche une solution me permettant d'arrondir n'importe quel nombre à 2
> chiffres significatifs
> exemple : 23800 devient 24000
> Par avance merci de vos réponses car là je sèche complétement...
>


Modeste
Le #20501701
Bonsour® Val avec ferveur ;o))) vous nous disiez :

Toutefois mon arrondi n'est pas à faire forcément au millier.
L'objectif est d'arrondir m'inporte quel nombre à 2 chiffres
significatifs. ainsi 245 devient 250, 2468 devient 2500... et ainsi
de suite

Quelqu'un aurait-il une solution ?



=ARRONDI(ENT(A1)/10^(NBCAR(ENT(A1))-2);0)*10^(NBCAR(ENT(A1))-2)
Caetera
Le #20502041
"Val"
Toutefois mon arrondi n'est pas à faire forcément au millier.
L'objectif est d'arrondir m'inporte quel nombre à 2 chiffres significatifs.
ainsi 245 devient 250, 2468 devient 2500... et ainsi de suite



10450 ça doit donner quoi ?

Etc
Modeste
Le #20503851
Bonsour® Caetera avec ferveur ;o))) vous nous disiez :

"Val"
Toutefois mon arrondi n'est pas à faire forcément au millier.
L'objectif est d'arrondir m'inporte quel nombre à 2 chiffres
significatifs. ainsi 245 devient 250, 2468 devient 2500... et ainsi
de suite



10450 ça doit donner quoi ?

Etc



;o))) !!!!!
L'objectif est d'arrondir m'inporte quel nombre à 2 chiffres significatifs
10450 ===> 10000
10550 ===> 11000
isabelle
Le #20502361
c'est exactement ce que fait cette formule,
=PLAFOND(A1;10^ENT(LOG10(A1))/10)
ou est le problème ?

isabelle

Val a écrit :
Bonjour et merci de votre réponse

Toutefois mon arrondi n'est pas à faire forcément au millier.
L'objectif est d'arrondir m'inporte quel nombre à 2 chiffres significatifs.
ainsi 245 devient 250, 2468 devient 2500... et ainsi de suite

Quelqu'un aurait-il une solution ?


"Alain" a écrit :


Bonjour Val,

Pour arrondir au millier tu multiplie par 1000 avant d'arrondir et tu divise
par 1000 ensuite...

=ARRONDI(A1/1000;0)*1000

Alain

"Val" news:

Bonjour,

je cherche une solution me permettant d'arrondir n'importe quel nombre à 2
chiffres significatifs
exemple : 23800 devient 24000
Par avance merci de vos réponses car là je sèche complétement...








Alain
Le #20502511
Alors la formule deviendrait:

=ARRONDI(F12/10^(TRONQUE(LOG10(F12))-1);0)*10^(TRONQUE(LOG10(F12))-1)


"Val" news:
Bonjour et merci de votre réponse

Toutefois mon arrondi n'est pas à faire forcément au millier.
L'objectif est d'arrondir m'inporte quel nombre à 2 chiffres
significatifs.
ainsi 245 devient 250, 2468 devient 2500... et ainsi de suite

Quelqu'un aurait-il une solution ?


"Alain" a écrit :

Bonjour Val,

Pour arrondir au millier tu multiplie par 1000 avant d'arrondir et tu
divise
par 1000 ensuite...

=ARRONDI(A1/1000;0)*1000

Alain

"Val" news:
> Bonjour,
>
> je cherche une solution me permettant d'arrondir n'importe quel nombre
> à 2
> chiffres significatifs
> exemple : 23800 devient 24000
> Par avance merci de vos réponses car là je sèche complétement...
>




Publicité
Poster une réponse
Anonyme