Arrondir un chiffre en 0.50 ou 0.90 dans excel

Le
Alex_f
Suite a un calcul de prix, je voudrai arrondir ces prix soit en 50 cts en en
90 cts selon le cas
Exemple 5.68 => 5.90 ou 8.18 => 8.50
Alors comment fait on ???
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jojolapin
Le #4326801
"Alex_f"
Suite a un calcul de prix, je voudrai arrondir ces prix soit en 50 cts en
en
90 cts selon le cas
Exemple 5.68 => 5.90 ou 8.18 => 8.50
Alors comment fait on ???


tu ne nous dis pas de qui se passe pour 8.91 et 9.00

Youky
Le #4326601
Salut,
si cts >50 alors 90 sinon 50cts
remplacer C18 par la bonne cellule
=SI(C18-ENT(C18)>0,5;ENT(C18)+0,9;ENT(C18)+0,5)
Youky
"jojolapin" news:

"Alex_f" news:
Suite a un calcul de prix, je voudrai arrondir ces prix soit en 50 cts en
en
90 cts selon le cas
Exemple 5.68 => 5.90 ou 8.18 => 8.50
Alors comment fait on ???


tu ne nous dis pas de qui se passe pour 8.91 et 9.00




Modeste
Le #4326571
Bonsour® Alex_f avec ferveur ;o))) vous nous disiez :

Suite a un calcul de prix, je voudrai arrondir ces prix soit en 50 cts en en
90 cts selon le cas
Exemple 5.68 => 5.90 ou 8.18 => 8.50
Alors comment fait on ???


B2 = ENT(A2) + SI( MOD(A2 ; 1) > 0,5 ; 0,9 ; 0,5)

c'est pour emmerder le client ????
il n'y a pas de prix rond dans ce magasin ;o)))


--
--
@+
;o)))

jojolapin
Le #4326541
"Youky" %
Salut,
si cts >50 alors 90 sinon 50cts
remplacer C18 par la bonne cellule
=SI(C18-ENT(C18)>0,5;ENT(C18)+0,9;ENT(C18)+0,5)


Oui c'est une possibilité mais cela aurait très bien pu être
de 0.51 à 0.90 --->0.90
de 0.90 à 0.99 -----1.50
de 0.00 à 0.50 ---->0.50

Youky
Le #4326361
Exact,
Souvent le plus dur pour trouver la carotte, mon cher jojolapin c'est de
lire entre les lignes.
Soit 0.5 soit 0.9 ....
bon si la formule ne conviens pas je pense que notre ami Alex reformulera
sa question
Youky
"jojolapin" news: OTdb%

"Youky" %
Salut,
si cts >50 alors 90 sinon 50cts
remplacer C18 par la bonne cellule
=SI(C18-ENT(C18)>0,5;ENT(C18)+0,9;ENT(C18)+0,5)


Oui c'est une possibilité mais cela aurait très bien pu être
de 0.51 à 0.90 --->0.90
de 0.90 à 0.99 -----1.50
de 0.00 à 0.50 ---->0.50




jojolapin
Le #4326031
"Youky"
Exact,
Souvent le plus dur pour trouver la carotte, mon cher jojolapin c'est de
lire entre les lignes.
Soit 0.5 soit 0.9 ....
bon si la formule ne conviens pas je pense que notre ami Alex reformulera
sa question
Je pensais au départ comme toi mais ensuite j'ai pensé à l'autre solution.

En faisant la remarque c'était surtout pour lui dire d'être plus explicite
dans ces exemples.

Alex_f
Le #4249151
oui c'est bien ça, mais j'ai oublié de preciser il y a des chiffres rond bien
sur !!
7.91 => 8.00
8.00 => 8.00

Merci beaucoup pour cette formule
et pour les chiffres rond alors ??
Alex_f
Le #4249041
Je vois que vous etes fort !
et si un jour je veux des prix en 0.20 0.50 0.90 et 00 ???
exemple :
1.02 => 1.20
1.22 => 1.50
1.65 => 1.90
1.90 => 1.90
1.91 => 2.00
1.00 => 1.00
1.50 => 1.50

J'espere n'avoir rien oublier cette fois !!


"Youky" wrote:

Salut,
si cts >50 alors 90 sinon 50cts
remplacer C18 par la bonne cellule
=SI(C18-ENT(C18)>0,5;ENT(C18)+0,9;ENT(C18)+0,5)
Youky
"jojolapin" news:

"Alex_f" news:
Suite a un calcul de prix, je voudrai arrondir ces prix soit en 50 cts en
en
90 cts selon le cas
Exemple 5.68 => 5.90 ou 8.18 => 8.50
Alors comment fait on ???


tu ne nous dis pas de qui se passe pour 8.91 et 9.00









cousinhub
Le #4249021
bonsoir,
Et après ça, on se demande pourquoi le salaire ne suit pas la hausse des
prix!!!!!!
-))))

Je vois que vous etes fort !
et si un jour je veux des prix en 0.20 0.50 0.90 et 00 ???
exemple :
1.02 => 1.20
1.22 => 1.50
1.65 => 1.90
1.90 => 1.90
1.91 => 2.00
1.00 => 1.00
1.50 => 1.50

J'espere n'avoir rien oublier cette fois !!


"Youky" wrote:

Salut,
si cts >50 alors 90 sinon 50cts
remplacer C18 par la bonne cellule
=SI(C18-ENT(C18)>0,5;ENT(C18)+0,9;ENT(C18)+0,5)
Youky
"jojolapin" news:
"Alex_f" news:
Suite a un calcul de prix, je voudrai arrondir ces prix soit en 50 cts en
en
90 cts selon le cas
Exemple 5.68 => 5.90 ou 8.18 => 8.50
Alors comment fait on ???
tu ne nous dis pas de qui se passe pour 8.91 et 9.00











Youky
Le #4248991
Tu avais raison jojolapin...! !
.......les arrondis sont plus pointus que prévu
.......à tout hasard
=SI(ENT(A2)¢;A2;SI(MOD(A2;1)>0,9;ENT(A2)+1;SI(MOD(A2;1)<0,51;ENT(A2)+0,5)))
Youky
"jojolapin" news:

"Youky"
Exact,
Souvent le plus dur pour trouver la carotte, mon cher jojolapin c'est de
lire entre les lignes.
Soit 0.5 soit 0.9 ....
bon si la formule ne conviens pas je pense que notre ami Alex
reformulera sa question
Je pensais au départ comme toi mais ensuite j'ai pensé à l'autre solution.

En faisant la remarque c'était surtout pour lui dire d'être plus explicite
dans ces exemples.






Publicité
Poster une réponse
Anonyme