arrondir à un nombre pair ou divisible par 5

Le
Bonjour,

Est-il possible de créer une fonction (ou une macro) pour arrondir un nombre
soit à un nombre pair soit à un nombre divisible par 5 ? Par exemple 4,4
devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 = 75 ?

Merci d'avance pour toute suggestion

René
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #21190311
Bonjour,

Est-il possible de créer une fonction (ou une macro) pour arrondir un nombre
soit à un nombre pair soit à un nombre divisible par 5 ? Par exemple 4,4
devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 = 75 ?

Dans une cellule, tu entres cette formule et tu remplaces
TonChiffre par l'adresse d'une cellule qui contient la valeur(chiffre)
ou la valeur directement.

=ARRONDI(TonChiffre;0,5)
Philippe.R
Le #21190301
Bonjour,
=ARRONDI(A1;0)+NON(EST.PAIR(ARRONDI(A1;0)))-(MOD(ARRONDI(A1;0);5)=0)
devrait pouvoir faire l'affaire
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
news:
Bonjour,

Est-il possible de créer une fonction (ou une macro) pour arrondir un
nombre soit à un nombre pair soit à un nombre divisible par 5 ? Par
exemple 4,4 devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 = 75 ?

Merci d'avance pour toute suggestion

René




Modeste
Le #21190281
Bonsour® avec ferveur ;o))) vous nous disiez :

Est-il possible de créer une fonction (ou une macro) pour arrondir un
nombre soit à un nombre pair soit à un nombre divisible par 5 ? Par
exemple 4,4 devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 =
75 ?



=SI(OU(MOD(A1;5)<1;MOD(A1;5)>4,5);5*(ENT((A1+2,5)/5));2*(ENT((A1+1)/2)) )

53,94 54
96,10 96
74,76 75
92,32 92
62,36 62
35,59 35
16,18 16
71,20 72
83,15 84
49,37 50
59,10 60

HTH
Philippe.R
Le #21190561
Oups !
Oublie ça ; la formule de Modeste est préférable !
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"Philippe.R" news:
Bonjour,
=ARRONDI(A1;0)+NON(EST.PAIR(ARRONDI(A1;0)))-(MOD(ARRONDI(A1;0);5)=0)
devrait pouvoir faire l'affaire
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
news:
Bonjour,

Est-il possible de créer une fonction (ou une macro) pour arrondir un
nombre soit à un nombre pair soit à un nombre divisible par 5 ? Par
exemple 4,4 devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 = 75 ?

Merci d'avance pour toute suggestion

René







Le #21190541
Bonjour Modeste,

Merci pour cette formule. Je l ai 'insérée dans la cellule B1 avec une
valeur dans la cellule A1 et c'est le message "La formule que vous avez
tapée contient une erreur" qui apparaît et ça flashe au niveau du 4,5.
Pourquoi ?

J'ai essayé de la disséquer, mais c'est ardu.

Merci d'avance pour votre aide

RL


"Modeste" #
Bonsour® avec ferveur ;o))) vous nous disiez :

Est-il possible de créer une fonction (ou une macro) pour arrondir un
nombre soit à un nombre pair soit à un nombre divisible par 5 ? Par
exemple 4,4 devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 >> 75 ?



=SI(OU(MOD(A1;5)<1;MOD(A1;5)>4,5);5*(ENT((A1+2,5)/5));2*(ENT((A1+1)/2)))

53,94 54
96,10 96
74,76 75
92,32 92
62,36 62
35,59 35
16,18 16
71,20 72
83,15 84
49,37 50
59,10 60

HTH


Le #21190691
Bonjour Philippe,

Merci pour la formule.

J'ai l'ai bien essayé mais c'est le message #NOM? qui s'affiche. Pourquoi ?

Merci d'avance pour toute aide supplémentaire

RL



"Philippe.R" de discussion :
Bonjour,
=ARRONDI(A1;0)+NON(EST.PAIR(ARRONDI(A1;0)))-(MOD(ARRONDI(A1;0);5)=0)
devrait pouvoir faire l'affaire
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
news:
Bonjour,

Est-il possible de créer une fonction (ou une macro) pour arrondir un
nombre soit à un nombre pair soit à un nombre divisible par 5 ? Par
exemple 4,4 devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 = 75 ?

Merci d'avance pour toute suggestion

René







Le #21190681
Merci Michdenis,

Cette formule ne donne pas le résultat espéré, il y a aussi les nombres
impairs autres que celles terminant par 5 qui s'affichent.

RL

"michdenis" discussion :
Bonjour,

Est-il possible de créer une fonction (ou une macro) pour arrondir un
nombre
soit à un nombre pair soit à un nombre divisible par 5 ? Par exemple 4,4
devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 = 75 ?

Dans une cellule, tu entres cette formule et tu remplaces
TonChiffre par l'adresse d'une cellule qui contient la valeur(chiffre)
ou la valeur directement.

=ARRONDI(TonChiffre;0,5)





Daniel.C
Le #21190761
Bonjour.
Quel est ton symbole décimal ?
Daniel

Bonjour Modeste,

Merci pour cette formule. Je l ai 'insérée dans la cellule B1 avec une
valeur dans la cellule A1 et c'est le message "La formule que vous avez tapée
contient une erreur" qui apparaît et ça flashe au niveau du 4,5. Pourquoi ?

J'ai essayé de la disséquer, mais c'est ardu.

Merci d'avance pour votre aide

RL


"Modeste" #
Bonsour® avec ferveur ;o))) vous nous disiez :

Est-il possible de créer une fonction (ou une macro) pour arrondir un
nombre soit à un nombre pair soit à un nombre divisible par 5 ? Par
exemple 4,4 devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 >>> 75 ?



=SI(OU(MOD(A1;5)<1;MOD(A1;5)>4,5);5*(ENT((A1+2,5)/5));2*(ENT((A1+1)/2)))

53,94 54
96,10 96
74,76 75
92,32 92
62,36 62
35,59 35
16,18 16
71,20 72
83,15 84
49,37 50
59,10 60

HTH




Modeste
Le #21191431
Bonsour® Philippe.R avec ferveur ;o))) vous nous disiez :

Oups !
Oublie ça ; la formule de Modeste est préférable !



il y a encore un petit schmilblik entre 5,00 et 6
;o)))
Sam
Le #21191761
Bonjour,
pour 35,59 ne faudrait il pas trouver 36 ?

autrement j'ai ceci
=SI(MOD(A1-0,5;5)>=4;5*ARRONDI(A1/5;0);2*ARRONDI(A1/2;0))

Cordialement
Michel dit "Sam"

"Modeste" %
Bonsour® avec ferveur ;o))) vous nous disiez :

Est-il possible de créer une fonction (ou une macro) pour arrondir un
nombre soit à un nombre pair soit à un nombre divisible par 5 ? Par
exemple 4,4 devrait donner 4 et 4,6 = 5, aussi 73,4 = 74 et 74,5 > 75 ?



=SI(OU(MOD(A1;5)<1;MOD(A1;5)>4,5);5*(ENT((A1+2,5)/5));2*(ENT((A1+1)/2)))

53,94 54
96,10 96
74,76 75
92,32 92
62,36 62
35,59 35
16,18 16
71,20 72
83,15 84
49,37 50
59,10 60

HTH
Publicité
Poster une réponse
Anonyme