Asus K53E, ubuntu 11.10 webcam.

Le
Dominique
Bonjour,

Certaines touches de fonction de mon clavier ne sont pas attribuées,
notamment celle qui active ou désactive ma webcam intégrée.

Cette dernière est parfaitement reconnue :

### v4l2 device info [/dev/video0] ###
general info
VIDIOC_QUERYCAP
driver : "uvcvideo"
card : "USB 2.0 UVC VGA WebCam"
bus_info : "usb-0000:00:1a.0-1.2"
version : 1.1.0
capabilities : 0x4000001 [VIDEO_CAPTURE,STREAMING]

et elle fonctionne très bien avec cheese ou mplayer.

Mais pour l'activer (allumage du témoin vert à côté de l'objectif), je
dois passer par une application. La combinaison de touches fn + v
(clavier de l'Asus K53E) est inopérante.

Quelle est la commande à passer pour activer ma webcam sans avoir besoin
d'utiliser un logiciel ?

Il existe une application qui permet d'intercepter le code des touches
utilisées. Je ne me souviens plus de son nom.

Je suppose que si je trouve le code de « fn + v », et que je connais la
commande à passer pour activer la webcam, je devrais arriver à réunir
les deux et à activer ma webcam à la demande avec fn + v.

J'ai cherché sur le web mais je n'ai pas trouvé la réponse à mes
questions. On me dit comment configurer ma webcam mais là n'est pas mon
souci.

Merci pour votre aide et bonne journée,


--
Dominique
Courriel : dominique point sextant ate orange en France
Esto quod es
Vidéos High-Tech et Jeu Vidéo
Téléchargements
  • Ubuntu Sudio est une distribution Linux orientée multimédia.
  • Ubuntu est une distribution Linux libre et gratuite basée sur Debian.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pronchery Jacques
Le #24369821
Le 02/04/2012 06:48, Dominique a écrit :
Bonjour,

Certaines touches de fonction de mon clavier ne sont pas attribuées,
notamment celle qui active ou désactive ma webcam intégrée.

Cette dernière est parfaitement reconnue :

### v4l2 device info [/dev/video0] ###
general info
VIDIOC_QUERYCAP
driver : "uvcvideo"
card : "USB 2.0 UVC VGA WebCam"
bus_info : "usb-0000:00:1a.0-1.2"
version : 1.1.0
capabilities : 0x4000001 [VIDEO_CAPTURE,STREAMING]

et elle fonctionne très bien avec cheese ou mplayer.

Mais pour l'activer (allumage du témoin vert à côté de l'objectif), je
dois passer par une application. La combinaison de touches fn + v
(clavier de l'Asus K53E) est inopérante.

Quelle est la commande à passer pour activer ma webcam sans avoir besoin
d'utiliser un logiciel ?

Il existe une application qui permet d'intercepter le code des touches
utilisées. Je ne me souviens plus de son nom.

Je suppose que si je trouve le code de « fn + v », et que je connais la
commande à passer pour activer la webcam, je devrais arriver à réunir
les deux et à activer ma webcam à la demande avec fn + v.

J'ai cherché sur le web mais je n'ai pas trouvé la réponse à mes
questions. On me dit comment configurer ma webcam mais là n'est pas mon
souci.

Merci pour votre aide et bonne journée,




Bonjour,

je pense qu'en installant le module "wistron_btns"
les touches de fonction devraient être actives.

Jacques.
moi-meme
Le #24369901
Le Mon, 02 Apr 2012 07:26:43 +0200, Pronchery Jacques a écrit :


je pense qu'en installant le module "wistron_btns" les touches de
fonction devraient être actives.



ou alors la méthode classique xev, etc
http://www.laboiteaprog.com/article90-5-configurer_son_clavier_multimedia_sous_linux

par exemple
Dominique
Le #24369981
Le 02/04/2012 07:26, Pronchery Jacques a écrit :


je pense qu'en installant le module "wistron_btns"
les touches de fonction devraient être actives.



Apparemment, il est compilé avec le kernel :

:~/Temp$ locate wistron_btns
/lib/modules/3.0.0-12-generic/kernel/drivers/input/misc/wistron_btns.ko
/lib/modules/3.0.0-16-generic/kernel/drivers/input/misc/wistron_btns.ko
/lib/modules/3.0.0-16-generic-pae/kernel/drivers/input/misc/wistron_btns.ko
/lib/modules/3.0.0-17-generic/kernel/drivers/input/misc/wistron_btns.ko
/lib/modules/3.0.0-17-generic-pae/kernel/drivers/input/misc/wistron_btns.ko

mais un lsmod ne me retourne rien même après un modprobe -a
wistron_btns. Je dois me planter quelque part d'autant que je ne touche
généralement jamais aux modules...

Merci pour le conseil et bonne journée,

--
Dominique
Courriel : dominique point sextant ate orange en France
Esto quod es
Dominique
Le #24369971
Le 02/04/2012 08:15, moi-meme a écrit :
Le Mon, 02 Apr 2012 07:26:43 +0200, Pronchery Jacques a écrit :


je pense qu'en installant le module "wistron_btns" les touches de
fonction devraient être actives.



ou alors la méthode classique xev, etc
http://www.laboiteaprog.com/article90-5-configurer_son_clavier_multimedia_sous_linux



Voilà, c'est xev que je cherchais. Mais ce que je ne sais toujours pas,
c'est comment on active la webcam en ligne de commande pour pouvoir
associer cette fonction )à une combinaison de touches.

Merci pour l'aide.


--
Dominique
Courriel : dominique point sextant ate orange en France
Esto quod es
Dominique
Le #24369961
Le 02/04/2012 08:28, Dominique a écrit :
Le 02/04/2012 07:26, Pronchery Jacques a écrit :


je pense qu'en installant le module "wistron_btns"
les touches de fonction devraient être actives.





J'ai oublié de préciser que certaines touches de fonction (notamment le
réglage du son et les fonctions de lecture de vidéo) sont actives.
D'autres non et en particulier celle relative à l'activation ou à la
désactivation de la webcam.


--
Dominique
Courriel : dominique point sextant ate orange en France
Esto quod es
moi-meme
Le #24370141
Le Mon, 02 Apr 2012 08:29:20 +0200, Dominique a écrit :

Voilà, c'est xev que je cherchais. Mais ce que je ne sais toujours pas,
c'est comment on active la webcam en ligne de commande pour pouvoir
associer cette fonction )à une combinaison de touches.



sous openbox ~/config/openbox/rc.xml
config en direct

pour gnome/KDE ya des trucs spécifiques que je ne connais pas.
yamo'
Le #24370311
Salut,

moi-meme a tapoté, le 02/04/2012 09:18:
sous openbox ~/config/openbox/rc.xml
config en direct



Le fichier c'est plutôt : ~/.config/openbox/rc.xml


Je n'ai pas réussit à configurer le lancement de la mise en veille par
la combinaison : Windows + l
Alors que le raccourci Windows + e écrit juste au dessus dans le fichier
de conf lance bien le gestionnaire de fichier, la commande indiquée est
peut-être trop longue, j'ai même créé un fichier /sbin/sleep contenant
cette commande avec les droits 555, dans un terminal ça met bien
l’ordinateur en veille mais ça ne fonctionne pas pour le raccourci W-l :(


<keybind key="W-l">
<action name="Execute">
<startupnotify>
<enabled>true</enabled>
<name>Suspend</name>
</startupnotify>
<command>dbus-send --system --print-reply
--dest=org.freedesktop.Hal /org/freedesktop/Hal/devices/computer
org.freedesktop.Hal.Device.S
ystemPowerManagement.Suspend int32:0</command>
</action>
</keybind>




--
Stéphane BOFH excuse #139:

UBNC (user brain not connected)
moi-meme
Le #24371011
Le Mon, 02 Apr 2012 10:32:57 +0200, yamo' a écrit :

Le fichier c'est plutôt : ~/.config/openbox/rc.xml



j'ai le point qui fourche ...
moi-meme
Le #24371001
Le Mon, 02 Apr 2012 10:32:57 +0200, yamo' a écrit :

Alors que le raccourci Windows + e écrit juste au dessus dans le fichier
de conf lance bien le gestionnaire de fichier, la commande indiquée est
peut-être trop longue, j'ai même créé un fichier /sbin/sleep contenant
cette commande avec les droits 555, dans un terminal ça met bien
l’ordinateur en veille mais ça ne fonctionne pas pour le raccourci W-l



Dans un autre cas j'ai été obligé de faire un script pour lancer la
commande par le script.

À tenter
Publicité
Poster une réponse
Anonyme