Autre retour d'expérience

Le
Philippe Deleval
Bonjour à tous

Je viens de passer - presque par accident - de Squeeze à Wheezy. je suis
satisfait de ce passage, malgré quelques soucis. j'ai rechargé à la
base, simplement sans reformater le volume de /home, car j'avais
quelques problèmes de configuration dans mon squeeze et je voulais avoir
une configuration plus propre.

Le plus gros souci, un bug dans "burn", dans squeeze comme dans wheezy,
pas besoin de faire un rapport, c'est le bug 643597. Impossible de faire
une sauvegarde car c'était mon outil pour celà, impossible aussi de
graver sur CD l'image ISO de l'amorce de wheezy, je me suis retrouvé à
charger wheezy à partir de l'amorce de squeeze.

Autre problème, "gnat", le compilateur Ada, exige gcc-4.6, alors que
d'autres outils entraînent l'installation de gcc-4.7. Le compilateur est
inutilisable tel quel. Et tous les packages debian (y compris sid, j'ai
vérifié sur le site de Debian) concernent gnat-4.6. Dois-je télécharger
une version plus récente directement de chez gnat?

Par ailleurs, les discussions sur la conception du logiciel libre, sur
les environnements de programmation, deviennent franchement casse-pieds.
Pour la "liberté", je crois que 99,9 % des paquets sur ma machine sont
en licence libre, mais j'ai tout de même Adobe Flash. Quelques paquets,
par exemple autour de LaTeX, sont aussi en "contrib", à cause d'une
licence s'écartant de la charte Debian.

Pour l'environnement, après avoir installé mon système, je me suis
dépêché d'éradiquer gnome (sauf les jeux de cartes) et je travaille
directement au prompt. Il semblerait que beaucoup ont connu
l'informatique via Windows(R), moi, j'ai commencé vers 1984, j'ai connu
CP/M, MS/DOS (et Windows 2 !), AOS-VS, VMS et même, le temps d'un projet
quelque peu mathématique, MVS/TSO. Et mon premier Linux (une Slackware)
n'avait pas de login par X. Je charge X quand j'en ai bien besoin, c'est
la plupart du temps pour utiliser un terminal, emacs, xdvi, un peu gv,
et par ailleurs icedove et iceweasel, quelques rares autres logiciels
par moments. Pas besoin d'icônes, d'autant que startx est maintenant
pour moi une vieiilerie et quand je veux travailler en LaTeX, j'ai une
commande qui me charge directement au lancement de X les fenêtres
d'emacs, du terminal et de xdvi. Blackbox est parfaitement apte à gérer
tout ça, pas besoin de plus. Je précise que j'utilise Linux sur machine
de bureau depuis plus de dix ans, et qu'il est le seul système installé
sur ma machine depuis Woody. Mais j'ai peut-être un peu plus de métier
en informatique que madame Michu!

Mon point de vue dans le débat est simple et peu original: le logiciel
libre, c'est un moyen de faire ce qu'on veut!

Bonne soirée à tous

Philippe Deleval

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/51ABB6EE.9020501@wanadoo.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ken-Patrick Lehrmann
Le #25456512
On 02/06/2013 23:19, Philippe Deleval wrote:
Bonjour à tous



Bonjour Philippe,

Autre problème, "gnat", le compilateur Ada, exige gcc-4.6, alors que
d'autres outils entraînent l'installation de gcc-4.7. Le compilateur est
inutilisable tel quel. Et tous les packages debian (y compris sid, j'ai
vérifié sur le site de Debian) concernent gnat-4.6. Dois-je télécharger
une version plus récente directement de chez gnat?



Ça ne devrait pas être un problème, tu peux avoir plusieurs versions de
gcc installées conjointement :

aptitude search ~igcc-4
i A gcc-4.6
i A gcc-4.6-base
i A gcc-4.7
i gcc-4.7-base
i A gcc-4.7-base:i386
i A gcc-4.7-multilib

++
Ken-Patrick

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Philippe Deleval
Le #25456882
Bonjour à tous

On 03/06/2013 19:34, Ken-Patrick Lehrmann wrote:
On 02/06/2013 23:19, Philippe Deleval wrote:
Bonjour à tous


Bonjour Philippe,

Autre problème, "gnat", le compilateur Ada, exige gcc-4.6, alors que
d'autres outils entraînent l'installation de gcc-4.7. Le compilateur est
inutilisable tel quel. Et tous les packages debian (y compris sid, j'ai
vérifié sur le site de Debian) concernent gnat-4.6. Dois-je télécharger
une version plus récente directement de chez gnat?


Ça ne devrait pas être un problème, tu peux avoir plusieurs versions de
gcc installées conjointement :

aptitude search ~igcc-4
i A gcc-4.6
i A gcc-4.6-base
i A gcc-4.7
i gcc-4.7-base
i A gcc-4.7-base:i386
i A gcc-4.7-multilib

++
Ken-Patrick



Je le sais bien, les liens logiques, ça existe. Mais en compilant avec
gcc-4.6, l'éditeur de lien ne fonctionne plus (celui de ADA, qui ne doit
pas trouver le ld qu'il attend, je présume), et en compilant avec
gcc-4.7, c'est gcc qui ne retrouve plus ses petits: il me dit qu'il ne
trouve pas gnat1, comme je ne m'étais jamais posé de question sur les
rapports entre gcc et gnat, ça ne me dit rien. C'est manifestement un
problème gnat!

Je précise que si je ne peux pas faire tourner mes programmes écrits en
ADA, uniquement à cause du changement de numéro de la bibliothèque, je
n'ai aucun problème à faire tourner les programmes écrits sous squeeze
en assembleur!

Merci tout de même.

Bonne soirée

Philippe Deleval

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme