d'autres question avant migration

Le
jipe
bonjour,
moi aussi j'ai voulu migrer de etch vers lenny, j'ai donc modifie mon
sources.list, puis la série aptitude upgrade, update, dist upgrade,
le résultat donne :
dpkg : trop d'erreurs, arrêt
dpkg: ../../src/packages.c:265: process_queue: l'assertion «
!queue.length » a échoué.
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets Fait
Écriture de l'information d'état étendu Fait
Lecture des descriptions de tâches Fait

j'ai perdu des applis, certaine sont cassées, bref, je suis un peu paumé.
à chaque sfe-update que je fait j'ai le même résultat.
je peux vous envoyer tout ce qui s'écrit dans ma console ou autre chose
si nécessaire.
je suis novice sous deb (et sous linux),
questions : c'est grave docteur ? faut-il tout réinstaller ou attendre
que lenny soit stable pour que tout re-fonctionne normalement.

j'attends vos précieux conseils, avant de sombrer dans un noir désespoir.
cordialement

--
jipe
"L'émerveillement est une vertu qui ouvre tout sur son passage, qui transfigure les choses, les lieux et les visages."
Jacqueline Kelen
Linux NunuxDeb 2.6.18-5-k7 #1 SMP Mon Dec 24 17:18:11 UTC 2007 i686 GNU/Linux
Distributor ID: Debian Description: Debian GNU/Linux testing (lenny) Codename: lenny


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Stephane Bortzmeyer
Le #16768561
On Tue, Sep 09, 2008 at 06:44:35PM +0200,
jipe a message of 42 lines which said:

dpkg : trop d'erreurs, arrêt
dpkg: ../../src/packages.c:265: process_queue: l'assertion «
!queue.length » a échoué.



Aïe.

questions : c'est grave docteur ?



Oui, c'est tout à fait anormal.

Suggestions :

1) Essayer de mettre à jour aptitude d'abord (aptitude install
aptitude)

2) Mettre LANG=C avant, pour avoir les messages d'erreur dans la
langue de la Fédération du Commerce et chercher ces messages dans
votre moteur de recherche favori.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sébastien NOBILI
Le #16771251
Le mardi 09 septembre 08 à 18:44, jipe a écrit :

[...]

| je suis novice sous deb (et sous linux),
| questions : c'est grave docteur ? faut-il tout réinstaller ou attendre
| que lenny soit stable pour que tout re-fonctionne normalement.

Il en faut bien plus à une Debian pour être obligé de réinstaller !!!
La qualité et la robustesse du système de paquets de Debian permet de
réparer des situations presque désespérées sans avoir besoin de
réinstaller. En revanche, la manipulation est plus simple quand on a un
peu d'expérience.

Si tu n'as pas un besoin vital et urgent de la machine, je pense que tu
trouveras sur la liste l'aide qui te permettra de réparer ton système
sans le réinstaller. Sinon, une réinstallation (depuis un NetInstall de
Lenny, par exemple) sera plus simple et plus rapide, mais beaucoup moins
profitable en terme d'expérience acquise.

Si tu choisis de réparer, commence par rechercher sur Google (en ayant
positionné la variable LANG=C, comme on te l'a si bien suggéré), si tu
ne trouves rien, alors poste les dernières lignes de l'exécution
d'aptitude sur la liste.

| jipe

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jipe
Le #16772101
Sébastien NOBILI a écrit :
Le mardi 09 septembre 08 à 18:44, jipe a écrit :

[...]

| je suis novice sous deb (et sous linux),
| questions : c'est grave docteur ? faut-il tout réinstaller ou attendre
| que lenny soit stable pour que tout re-fonctionne normalement.

Il en faut bien plus à une Debian pour être obligé de réinstaller !!!
La qualité et la robustesse du système de paquets de Debian permet de
réparer des situations presque désespérées sans avoir besoin de
réinstaller. En revanche, la manipulation est plus simple quand on a un
peu d'expérience.




complètement d'accord malgré mon peu d'expérience
Si tu n'as pas un besoin vital et urgent de la machine, je pense que tu
trouveras sur la liste l'aide qui te permettra de réparer ton système
sans le réinstaller. Sinon, une réinstallation (depuis un NetInstall de
Lenny, par exemple) sera plus simple et plus rapide, mais beaucoup moins
profitable en terme d'expérience acquise.




ok
Si tu choisis de réparer, commence par rechercher sur Google (en ayant
positionné la variable LANG=C, comme on te l'a si bien suggéré), si tu
ne trouves rien, alors poste les dernières lignes de l'exécution
d'aptitude sur la liste.

| jipe

Seb




j'ai déja essayé un #aptitude install aptitude, mais je ne peux rien
installer
NunuxDeb:/home/jipe# aptitude install aptitude
Lecture des listes de paquets... Fait
.........
Les paquets suivants sont CASSÉS : suit une liste impressionnante
Les paquets suivants seront ENLEVÉS :.............
Les paquets partiellement installés suivants seront configurés :..........

0 paquets mis à jour, 0 nouvellement installés, 5 à enlever et 564 non
mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage,
14,6Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
kdelibs4c2a: Dépend: kdelibs-data (> 4:3.5.9.dfsg.1) mais
4:3.5.5a.dfsg.1-8etch1 est installé et a été conservé
Dépend: x11-xserver-utils mais il n'est pas installable
et une suite de n'est pas installable

Laisser les dépendances suivantes non satisfaites :
ksmserver recommande kpersonalizer (= 4:3.5.5a.dfsg.1-6etch2)
Le score est de 1049

Accepter cette solution ? [Y/n/q/?]
yes

tout a l'air de se passer normalement jusqu'à:
Traitement des « déclenchements (triggers) » pour « man-db »...
(Lecture de la base de données... 151385 fichiers et répertoires déjà
installés.)
Suppression de gs-common ...
Can't locate File/Copy.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl .) at /usr/bin/defoma-app line 7.
BEGIN failed--compilation aborted at /usr/bin/defoma-app line 7.
dpkg : erreur de traitement de gs-common (--remove) :
le sous-processus pre-removal script a retourné une erreur de sortie
d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
gs-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
avec une suite de lignes qui disent :
dpkg : des problèmes de dépendances empêchent la configuration de
kdelibs4c2a :
kdelibs4c2a dépend de kdelibs-data (>> 4:3.5.9.dfsg.1) ; cependant :
La version de kdelibs-data sur le système est 4:3.5.5a.dfsg.1-8etch1.
dpkg : trop d'erreurs, arrêt
dpkg: ../../src/packages.c:265: process_queue: l'assertion «
!queue.length » a échoué.
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
correct the problem.
E: Impossible de récupérer le verrou système ! (il est possible qu'un
autre processus apt ou dpkg soit en cours)
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
correct the problem.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait


et ça se termine par :

État actuel : 24 paquets cassés [-37], 560 mises à jour restantes [-5].
W: Impossible de verrouiller le fichier cache : cela est en général dû à
une installation simultanée de paquets avec dpkg ou un autre outil comme
APT. Ouverture en mode lecture seule : AUCUNE des modifications de
l'état des paquets que vous pourrez faire ne sera conservée.
NunuxDeb:/home/jipe#

voila où j'en suis.
quand à la variable LANG=C ça se met où ?
désolé pour la longueur.
et merci de votre aide
cordialement

--
jipe

"L'émerveillement est... une vertu qui ouvre tout sur son passage, qui transfigure les choses, les lieux et les visages."
Jacqueline Kelen







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thierry Leurent
Le #16772291
Je te dirais d'installer manuellement (dpkg) la version Lenny d'aptitude,
tu trouvera les packets sur le net où dans ton cache (/var/cache/apt/)
et de faire un aptitude update et un aptitude install -f

jipe a écrit :
Sébastien NOBILI a écrit :
Le mardi 09 septembre 08 à 18:44, jipe a écrit :

[...]

| je suis novice sous deb (et sous linux),
| questions : c'est grave docteur ? faut-il tout réinstaller ou attendre
| que lenny soit stable pour que tout re-fonctionne normalement.

Il en faut bien plus à une Debian pour être obligé de réinstaller !!!
La qualité et la robustesse du système de paquets de Debian permet de
réparer des situations presque désespérées sans avoir besoin de
réinstaller. En revanche, la manipulation est plus simple quand on a un
peu d'expérience.




complètement d'accord malgré mon peu d'expérience
Si tu n'as pas un besoin vital et urgent de la machine, je pense que tu
trouveras sur la liste l'aide qui te permettra de réparer ton système
sans le réinstaller. Sinon, une réinstallation (depuis un NetInstall de
Lenny, par exemple) sera plus simple et plus rapide, mais beaucoup moins
profitable en terme d'expérience acquise.




ok
Si tu choisis de réparer, commence par rechercher sur Google (en ayant
positionné la variable LANG=C, comme on te l'a si bien suggéré), si tu
ne trouves rien, alors poste les dernières lignes de l'exécution
d'aptitude sur la liste.

| jipe

Seb




j'ai déja essayé un #aptitude install aptitude, mais je ne peux rien
installer
NunuxDeb:/home/jipe# aptitude install aptitude
Lecture des listes de paquets... Fait
.........
Les paquets suivants sont CASSÉS : suit une liste impressionnante
Les paquets suivants seront ENLEVÉS :.............
Les paquets partiellement installés suivants seront configurés :..........

0 paquets mis à jour, 0 nouvellement installés, 5 à enlever et 564 non
mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage,
14,6Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
kdelibs4c2a: Dépend: kdelibs-data (> 4:3.5.9.dfsg.1) mais
4:3.5.5a.dfsg.1-8etch1 est installé et a été conservé
Dépend: x11-xserver-utils mais il n'est pas installable
et une suite de n'est pas installable

Laisser les dépendances suivantes non satisfaites :
ksmserver recommande kpersonalizer (= 4:3.5.5a.dfsg.1-6etch2)
Le score est de 1049

Accepter cette solution ? [Y/n/q/?]
yes

tout a l'air de se passer normalement jusqu'à:
Traitement des « déclenchements (triggers) » pour « man-db »...
(Lecture de la base de données... 151385 fichiers et répertoires déjà
installés.)
Suppression de gs-common ...
Can't locate File/Copy.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl .) at /usr/bin/defoma-app line 7.
BEGIN failed--compilation aborted at /usr/bin/defoma-app line 7.
dpkg : erreur de traitement de gs-common (--remove) :
le sous-processus pre-removal script a retourné une erreur de sortie
d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
gs-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
avec une suite de lignes qui disent :
dpkg : des problèmes de dépendances empêchent la configuration de
kdelibs4c2a :
kdelibs4c2a dépend de kdelibs-data (>> 4:3.5.9.dfsg.1) ; cependant :
La version de kdelibs-data sur le système est 4:3.5.5a.dfsg.1-8etch1.
dpkg : trop d'erreurs, arrêt
dpkg: ../../src/packages.c:265: process_queue: l'assertion «
!queue.length » a échoué.
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
correct the problem.
E: Impossible de récupérer le verrou système ! (il est possible qu'un
autre processus apt ou dpkg soit en cours)
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
correct the problem.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait


et ça se termine par :

État actuel : 24 paquets cassés [-37], 560 mises à jour restantes [-5].
W: Impossible de verrouiller le fichier cache : cela est en général dû à
une installation simultanée de paquets avec dpkg ou un autre outil comme
APT. Ouverture en mode lecture seule : AUCUNE des modifications de
l'état des paquets que vous pourrez faire ne sera conservée.
NunuxDeb:/home/jipe#

voila où j'en suis.
quand à la variable LANG=C ça se met où ?
désolé pour la longueur.
et merci de votre aide
cordialement

--
jipe

"L'émerveillement est... une vertu qui ouvre tout sur son passage, qui
transfigure les choses, les lieux et les visages."
Jacqueline Kelen







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact







--
Thierry Leurent
Phone : +32 476/20.23.98
E-mail :
Website (en developpement) : http://www.asgardian.be

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jipe
Le #16772531
Sébastien NOBILI a écrit :
Le mardi 09 septembre 08 à 18:44, jipe a écrit :

[...]

| je suis novice sous deb (et sous linux),
| questions : c'est grave docteur ? faut-il tout réinstaller ou attendre
| que lenny soit stable pour que tout re-fonctionne normalement.

Il en faut bien plus à une Debian pour être obligé de réinstaller !!!
La qualité et la robustesse du système de paquets de Debian permet de
réparer des situations presque désespérées sans avoir besoin de
réinstaller. En revanche, la manipulation est plus simple quand on a un
peu d'expérience.

Si tu n'as pas un besoin vital et urgent de la machine, je pense que tu
trouveras sur la liste l'aide qui te permettra de réparer ton système
sans le réinstaller. Sinon, une réinstallation (depuis un NetInstall de
Lenny, par exemple) sera plus simple et plus rapide, mais beaucoup moins
profitable en terme d'expérience acquise.

Si tu choisis de réparer, commence par rechercher sur Google (en ayant
positionné la variable LANG=C, comme on te l'a si bien suggéré), si tu
ne trouves rien, alors poste les dernières lignes de l'exécution
d'aptitude sur la liste.

| jipe

Seb




bonjour
suite du précédent message.
j'ai trouvé ça
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugI5359
et ça :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugH2140

mais ça m'avance pas beaucoup, l'anglais et moi ça fait deux :-[ dans
le peu que je comprends je retrouve dans le bug 495359 à peu près les
mêmes lignes que chez moi.
est-ce que c'est la solution de mon problème ?
cordialement.

--
jipe

"L'émerveillement est... une vertu qui ouvre tout sur son passage, qui transfigure les choses, les lieux et les visages."
Jacqueline Kelen

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Raphael Hertzog
Le #16773131
On Tue, 09 Sep 2008, Stephane Bortzmeyer wrote:
On Tue, Sep 09, 2008 at 06:44:35PM +0200,
jipe a message of 42 lines which said:

> dpkg : trop d'erreurs, arrêt
> dpkg: ../../src/packages.c:265: process_queue: l'assertion «
> !queue.length » a échoué.

Aïe.

> questions : c'est grave docteur ?

Oui, c'est tout à fait anormal.

Suggestions :

1) Essayer de mettre à jour aptitude d'abord (aptitude install
aptitude)



Dans ce cas, c'est dpkg qu'il faut mettre à jour. Prendre la version
1.14.22 de sid qui doit migrer dans lenny sous peu.

http://packages.qa.debian.org/d/dpkg.html
http://ftp.debian.org/debian/pool/main/d/dpkg/dpkg_1.14.22_i386.deb

Elle corrige cela et bien plus.

a+
--
Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :
http://www.ouaza.com/livre/admin-debian/

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Raphael Hertzog
Le #16773121
On Wed, 10 Sep 2008, jipe wrote:
mais ça m'avance pas beaucoup, l'anglais et moi ça fait deux :-[ dans
le peu que je comprends je retrouve dans le bug 495359 à peu près les
mêmes lignes que chez moi.
est-ce que c'est la solution de mon problème ?



La solution c'est de refaire marcher perl en installant les paquets perl,
perl-base et perl-modules à coup de dpkg -i si apt-get n'en est pas
capable.

a+
--
Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :
http://www.ouaza.com/livre/admin-debian/

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sébastien NOBILI
Le #16773681
Le mercredi 10 septembre 08 à 10:35, jipe a écrit :

[...]

| voila où j'en suis.
| quand à la variable LANG=C ça se met où ?

La variable LANG permet de définir la langue utilisée par les
commandes pour « dialoguer » avec l'utilisateur.
Par exemple, sur un système en Français (LANG=fr_FR.UTF-8) :
:/home/sni$ rm
rm: opérande manquante
Pour en savoir davantage, faites: « rm --help ».

Il y a deux moyens de la redéfinir :
- uniquement pour la commande courante, dans ce cas on la définit en
tête de commande comme ça :
:/home/sni$ LANG=C rm
rm: missing operand
Try `rm --help' for more information.
- pour toutes les commandes à venir dans le shell, dans ce cas on
l'exporte :
:/home/sni$ export LANG=C
:/home/sni$ rm
rm: missing operand
Try `rm --help' for more information.

| jipe

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jipe
Le #16780381
Raphael Hertzog a écrit :
On Tue, 09 Sep 2008, Stephane Bortzmeyer wrote:

On Tue, Sep 09, 2008 at 06:44:35PM +0200,
jipe a message of 42 lines which said:


dpkg : trop d'erreurs, arrêt
dpkg: ../../src/packages.c:265: process_queue: l'assertion «
!queue.length » a échoué.



Aïe.


questions : c'est grave docteur ?



Oui, c'est tout à fait anormal.

Suggestions :

1) Essayer de mettre à jour aptitude d'abord (aptitude install
aptitude)




Dans ce cas, c'est dpkg qu'il faut mettre à jour. Prendre la version
1.14.22 de sid qui doit migrer dans lenny sous peu.

http://packages.qa.debian.org/d/dpkg.html
http://ftp.debian.org/debian/pool/main/d/dpkg/dpkg_1.14.22_i386.deb

Elle corrige cela et bien plus.

a+



merci pour tout et à tous c'est reparti, ça marche :-)
donc en suivant :
aptitude install aptitude n'a rien donné
j'ai téléchargé et installé dpkg_1.14.22_i386.deb, comme tu me le dit,
sans problème
un aptitude upgrade suivi d'aptitude update ne donne rien.
ensuite je défini lang=C comme me le dit sebastien
puis un aptitude dist-upgrade et tout est rentré dans l'ordre. ça à duré
environ 20 minutes.
mes applications remarchent normalement, le passage de Etch à Lenny est
fait.
c'est le rêve.
merci Linux et merci la liste.
cordialement

--
jipe

"L'émerveillement est... une vertu qui ouvre tout sur son passage, qui transfigure les choses, les lieux et les visages."
Jacqueline Kelen

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sébastien NOBILI
Le #16782191
Le mercredi 10 septembre 08 à 23:09, jipe a écrit :
| un aptitude upgrade suivi d'aptitude update ne donne rien.
| ensuite je défini lang=C comme me le dit sebastien
| puis un aptitude dist-upgrade et tout est rentré dans l'ordre. ça à
| duré environ 20 minutes.

Deux choses :
- ce n'est pas moi qui l'avais suggéré le premier
- LANG=C permet juste de redéfinir la langue de sortie des
commandes, ce n'est pas ça qui a fait fonctionner la mise-à-jour

| mes applications remarchent normalement, le passage de Etch à Lenny est
| fait.

Très content pour toi.

| c'est le rêve.
| merci Linux et merci la liste.

Là, je crois qu'il faut plutôt remercier Debian et sa flopée de
développeurs...

| jipe

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme