Avec des SI....

Le
Esox38
Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais
cela ne fonctionne pas?

Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27

Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok

Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))

Merci pour votre aide.
Cordialement
Esox
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ty-Fanch'
Le #19606241
> Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais cela ne
fonctionne pas?



Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27



Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok



Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))



Merci pour votre aide.
Cordialement
Esox



Bonjour,

Quelle est la valeur de $I$6?

--
Amicalement

"La meilleure manière de tuer une taupe c'est de l'enterrer vivante"
Sam
Le #19606331
Bonjour,
=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
Cordialement
Michel dit "Sam"

"Esox38" 4a3d02e5$0$10218$
Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais cela
ne fonctionne pas?

Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27

Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok

Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))

Merci pour votre aide.
Cordialement
Esox


Esox38
Le #19606511
Ty-Fanch' a écrit :
Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais
cela ne fonctionne pas?



Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27



Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok



Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))




Merci pour votre aide.
Cordialement
Esox



Bonjour,

Quelle est la valeur de $I$6?



Bonsoir,

La valeur est de 5.75.

Cordialement
Esox38
Le #19606541
Bonsoir SAM,

Merci pour ta réponse mais sur la condition suivante cela ne fonctionne
pas :

4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40

Cordialement

Sam a écrit :
Bonjour,
=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
Cordialement
Michel dit "Sam"

"Esox38" 4a3d02e5$0$10218$
Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais cela
ne fonctionne pas?

Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27

Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok

Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))

Merci pour votre aide.
Cordialement
Esox






Ty-Fanch'
Le #19606721
> Ty-Fanch' a écrit :
Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais cela
ne fonctionne pas?



Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27



Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok



Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))




Merci pour votre aide.
Cordialement
Esox



Bonjour,

Quelle est la valeur de $I$6?



Bonsoir,



La valeur est de 5.75.



Cordialement



Le problème serait peut-être plus simple avec la création d'une formule
personnalisée utilisant des CASE.

--
Amicalement

Mon épouse a retrouvé une femme sur l'épaule droite de ma veste de
costume. Elle me soupçonne d'avoir une aventure avec un cheveu!
Ty-Fanch' (Qui est chauve)
Sam
Le #19606941
Bonjour,
?
chez moi, avec $I$16 supérieur à BK27, j'obtiens 3,4

$I$16 peut il être inférieur à BK27 ou BL27 ?
Cordialement
Michel dit "Sam"

"Esox38" 4a3d188d$0$428$
Bonsoir SAM,

Merci pour ta réponse mais sur la condition suivante cela ne fonctionne
pas :

4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40

Cordialement

Sam a écrit :
Bonjour,
=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
Cordialement
Michel dit "Sam"

"Esox38" 4a3d02e5$0$10218$
Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais
cela ne fonctionne pas?

Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27

Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok

Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))

Merci pour votre aide.
Cordialement
Esox







Esox38
Le #19607141
Bonsoir Sam,

Non BK27 ou BL 27 ne peut être > à $I$16 (5.75 dans mon exemple)

Voici les résultats avec ta formule copiée dans les cellules :

=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
J BK BL RESULTAT
1,80 1,83 3,40 1,80 Non Résultat correct = 1.83
2,51 2,00 3,40 2,51 Ok est entre 2.00 et 3.40
3,01 2,00 3,40 3,01 Ok est entre 2.00 et 3.40
4,29 2,00 3,40 4,29 Non Résultat correct = 3.40
6,61 2,00 3,40 6,61 Ok dépasse 5.75 donc 6.61
6,83 2,00 3,40 6,83 Ok idem
6,84 2,00 3,40 6,84 Ok idem

Cordialement

Sam a écrit :
Bonjour,
?
chez moi, avec $I$16 supérieur à BK27, j'obtiens 3,4

$I$16 peut il être inférieur à BK27 ou BL27 ?
Cordialement
Michel dit "Sam"

"Esox38" 4a3d188d$0$428$
Bonsoir SAM,

Merci pour ta réponse mais sur la condition suivante cela ne fonctionne
pas :

4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40

Cordialement

Sam a écrit :
Bonjour,
=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
Cordialement
Michel dit "Sam"

"Esox38" 4a3d02e5$0$10218$
Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais
cela ne fonctionne pas?

Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27

Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok

Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))

Merci pour votre aide.
Cordialement
Esox









Sam
Le #19607221
Bonjour, voici ce que j'obtiens
en 1ere colonne avec la formule
=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
en 2eme colonne avec une autre formule que j'avais prévue au cas de
priorisation des conditions
=SI(J27<=BK27;BK27;SI(J27<=BL27;J27;SI(J27<=$I$16;BL27;J27)))

1,83 1,83
2,51 2,51
3,01 3,01
3,4 3,4
6,61 6,61
6,83 6,83
6,84 6,84


J'ai également utilisé ta formule
=SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27))))
et elle donne également ce résultat.

Vérifie bien les références de tes cellules et aussi le contenu de la
cellule I16.
Cordialement
Michel dit "Sam"

"Esox38" 4a3d30bf$0$9963$
Bonsoir Sam,

Non BK27 ou BL 27 ne peut être > à $I$16 (5.75 dans mon exemple)

Voici les résultats avec ta formule copiée dans les cellules :

=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
J BK BL RESULTAT
1,80 1,83 3,40 1,80 Non Résultat correct = 1.83
2,51 2,00 3,40 2,51 Ok est entre 2.00 et 3.40
3,01 2,00 3,40 3,01 Ok est entre 2.00 et 3.40
4,29 2,00 3,40 4,29 Non Résultat correct = 3.40
6,61 2,00 3,40 6,61 Ok dépasse 5.75 donc 6.61
6,83 2,00 3,40 6,83 Ok idem
6,84 2,00 3,40 6,84 Ok idem

Cordialement

Sam a écrit :
Bonjour,
?
chez moi, avec $I$16 supérieur à BK27, j'obtiens 3,4

$I$16 peut il être inférieur à BK27 ou BL27 ?
Cordialement
Michel dit "Sam"

"Esox38" 4a3d188d$0$428$
Bonsoir SAM,

Merci pour ta réponse mais sur la condition suivante cela ne fonctionne
pas :

4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40

Cordialement

Sam a écrit :
Bonjour,
=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
Cordialement
Michel dit "Sam"

"Esox38" 4a3d02e5$0$10218$
Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais
cela ne fonctionne pas?

Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27

Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok

Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))

Merci pour votre aide.
Cordialement
Esox











Esox38
Le #19607811
Bonsoir Sam,

Merci pour les tests et ta réponse, elle m'a permis de corriger mon
problème!

J'ai vérifier à nouveau toute mes cellules et en faite il s'agit d'un
problème de format sur la cellule $I$16 qui était en pourcentage.
"> Vérifie bien les références de tes cellules et aussi le contenu de la
> cellule I16."

Comme quoi vérifier et revérifier ses feuilles de calculs avec un tas de
formules prend du temps et les erreurs et oublis son possible.

Merci encore!
Bon dimanche
Cordialement
esox

Sam a écrit :
Bonjour, voici ce que j'obtiens
en 1ere colonne avec la formule
=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
en 2eme colonne avec une autre formule que j'avais prévue au cas de
priorisation des conditions
=SI(J27<=BK27;BK27;SI(J27<=BL27;J27;SI(J27<=$I$16;BL27;J27)))

1,83 1,83
2,51 2,51
3,01 3,01
3,4 3,4
6,61 6,61
6,83 6,83
6,84 6,84


J'ai également utilisé ta formule
=SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27))))
et elle donne également ce résultat.

Vérifie bien les références de tes cellules et aussi le contenu de la
cellule I16.
Cordialement
Michel dit "Sam"

"Esox38" 4a3d30bf$0$9963$
Bonsoir Sam,

Non BK27 ou BL 27 ne peut être > à $I$16 (5.75 dans mon exemple)

Voici les résultats avec ta formule copiée dans les cellules :

=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
J BK BL RESULTAT
1,80 1,83 3,40 1,80 Non Résultat correct = 1.83
2,51 2,00 3,40 2,51 Ok est entre 2.00 et 3.40
3,01 2,00 3,40 3,01 Ok est entre 2.00 et 3.40
4,29 2,00 3,40 4,29 Non Résultat correct = 3.40
6,61 2,00 3,40 6,61 Ok dépasse 5.75 donc 6.61
6,83 2,00 3,40 6,83 Ok idem
6,84 2,00 3,40 6,84 Ok idem

Cordialement

Sam a écrit :
Bonjour,
?
chez moi, avec $I$16 supérieur à BK27, j'obtiens 3,4

$I$16 peut il être inférieur à BK27 ou BL27 ?
Cordialement
Michel dit "Sam"

"Esox38" 4a3d188d$0$428$
Bonsoir SAM,

Merci pour ta réponse mais sur la condition suivante cela ne fonctionne
pas :

4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40

Cordialement

Sam a écrit :
Bonjour,
=SI(J27>$I$16;J27;SI(J27>BL27;BL27;SI(J27>BK27;J27;BK27)))
Cordialement
Michel dit "Sam"

"Esox38" 4a3d02e5$0$10218$
Bonjour,
J'essaye d'imbriquer plusieurs conditions avec des SI et des ET mais
cela ne fonctionne pas?

Voici les conditions :
SI J27 < BK27 alors BK27
SI J27 > BK27 ET <= BL27 alors J27
SI J27 > BL27 ET <= $I$16 alors BL27
SI J27 > $I$16 alors J27

Petit exemple :
J BK BL Résultat
1.80 1.83 3.40 1.83 Ok
2.51 2.00 3.40 2.51 Ok
3.01 2.00 3.40 3.01 Ok
4.29 2.00 3.40 4.293 ICI problème devrait-être 3.40
6.60 2.00 3.40 6.60 Ok

Ma formule de calcul :
=SI(A27="";"";SI(J27<BK27;BK27;SI(J27>$I$16;J27;SI(ET(J27>BK27;J27<=BL27);J27;SI(ET(J27>BL27;J27<=$I$16);BL27)))))

Merci pour votre aide.
Cordialement
Esox














Publicité
Poster une réponse
Anonyme