Avoir une stable avec le dernier noyau sorti, est ce viable ?

Le
giggz
Bonjour la liste,

tout d'abord un joyeux Noel à tous!

Petite question :
J'ai pas mal testé la stable et l'instable sans jamais mélanger les
distrib. Mais cette fois-ci j'aimerais avoir une stable sur un ordi très
récent nécessitant les derniers noyaux sortis de kernel.org. Est ce
viable de compiler par exemple un 2.6.32 sur une stable actuelle ? ou
alors y a t il de gros problèmes de compatibilité ?

D'avance je vous remercie,
bye bye
Guillaume

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
maderios
Le #20829351
giggz a écrit :
Bonjour la liste,

tout d'abord un joyeux Noel à tous!

Petite question :
J'ai pas mal testé la stable et l'instable sans jamais mélanger les
distrib. Mais cette fois-ci j'aimerais avoir une stable sur un ordi très
récent nécessitant les derniers noyaux sortis de kernel.org. Est ce
viable de compiler par exemple un 2.6.32 sur une stable actuelle ? ou
alors y a t il de gros problèmes de compatibilité ?


Bonjour
Personnellement, je ne (me) pose jamais ce genre de question : je
fais, je teste .....
Concernant le sujet lui-même, j'ai compilé de nombreuses fois les
derniers noyaux avec une stable et je n'ai jamais rencontré de
problème, bien au contraire.
Joyeux Noël
M

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
giggz
Le #20829611
maderios a écrit :
giggz a écrit :
Bonjour la liste,

tout d'abord un joyeux Noel à tous!

Petite question :
J'ai pas mal testé la stable et l'instable sans jamais mélanger les
distrib. Mais cette fois-ci j'aimerais avoir une stable sur un ordi très
récent nécessitant les derniers noyaux sortis de kernel.org. Est ce
viable de compiler par exemple un 2.6.32 sur une stable actuelle ? ou
alors y a t il de gros problèmes de compatibilité ?


Bonjour
Personnellement, je ne (me) pose jamais ce genre de question : je fais,
je teste .....



oui c'est sur...mais bon sur cette liste il y a pas mal de gens qui ont
de l'expérience avec debian, alors autant profiter de cette expérience :D

Concernant le sujet lui-même, j'ai compilé de nombreuses fois les
derniers noyaux avec une stable et je n'ai jamais rencontré de problème,
bien au contraire.



bon bonne nouvelle! je vais tester tout ça.

Bye
Guillaume

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Stosse Florian
Le #20830561
--000e0cd139324be8c2047b7a82e9
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Disons qu'en faisant ça, tu perds l'intérêt de la branche St able en ce qui
concerne le noyau. A toi de voir, en fonction de l'utilisation de la
machine.

2009/12/24 giggz
maderios a écrit :
> giggz a écrit :
>> Bonjour la liste,
>>
>> tout d'abord un joyeux Noel à tous!
>>
>> Petite question :
>> J'ai pas mal testé la stable et l'instable sans jamais mélan ger les
>> distrib. Mais cette fois-ci j'aimerais avoir une stable sur un ordi tr ès
>> récent nécessitant les derniers noyaux sortis de kernel.org. Est ce
>> viable de compiler par exemple un 2.6.32 sur une stable actuelle ? ou
>> alors y a t il de gros problèmes de compatibilité ?
> Bonjour
> Personnellement, je ne (me) pose jamais ce genre de question : je fais,
> je teste .....

oui c'est sur...mais bon sur cette liste il y a pas mal de gens qui ont
de l'expérience avec debian, alors autant profiter de cette expà ©rience :D

> Concernant le sujet lui-même, j'ai compilé de nombreuses fois les
> derniers noyaux avec une stable et je n'ai jamais rencontré de pro blème,
> bien au contraire.

bon bonne nouvelle! je vais tester tout ça.

Bye
Guillaume

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS






--

Mike Ditka "If God had wanted man to play soccer, he wouldn't have given us arms."

--000e0cd139324be8c2047b7a82e9
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Disons qu'en faisant ça, tu perds l'intérêt de la br anche Stable en ce qui concerne le noyau. A toi de voir, en fonction de l&# 39;utilisation de la machine.
<div class="im">&gt; giggz a écrit :<br>
&gt;&gt; Bonjour la liste,<br>
&gt;&gt;<br>
&gt;&gt; tout d&#39;abord un joyeux Noel à tous!<br>
&gt;&gt;<br>
&gt;&gt; Petite question :<br>
&gt;&gt; J&#39;ai pas mal testé la stable et l&#39;instable sans jamai s mélanger les<br>
&gt;&gt; distrib. Mais cette fois-ci j&#39;aimerais avoir une stable sur un ordi très<br>
&gt;&gt; récent nécessitant les derniers noyaux sortis de &gt;&gt; viable de compiler par exemple un 2.6.32 sur une stable actuelle ? ou<br>
&gt;&gt; alors y a t il de gros problèmes de compatibilité ?<br>
&gt; Bonjour<br>
&gt; Personnellement, je ne (me) pose jamais ce genre de question : je fais ,<br>
&gt; je teste .....<br>
<br>
de l&#39;expérience avec debian, alors autant profiter de cette expà ©rience :D<br>
<div class="im"><br>
&gt; Concernant le sujet lui-même, j&#39;ai compilé de nombreuses fois les<br>
&gt; derniers noyaux avec une stable et je n&#39;ai jamais rencontré d e problème,<br>
&gt; bien au contraire.<br>
<br>
<br>
Bye<br>
Guillaume<br>
<div><div></div><div class="h5"><br>
--<br>
Lisez la FAQ de la liste avant de poser une question :<br>
``spam&#39;&#39; dans vos champs &quot;From&quot; et &quot;Reply-To:&quot;< br>
<br>
Pour vous DESABONNER, envoyez un message avec comme objet &quot;unsubscribe &quot;<br>
vers En cas de soucis, contactez EN ANGLAIS <br>

--000e0cd139324be8c2047b7a82e9--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David Prévot
Le #20830531
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Salut,

giggz a écrit :
[...]
Est ce viable de compiler par exemple un 2.6.32 sur une stable actuelle ?







Si tu veux t'économiser du temps (humain + machine), installer le 2.6.32
de sid est encore plus [viable|simple|rapide|efficace] ;). Ce sera
peut-être même le noyau officiel de la prochaine stable, donc il a des
chances pour qu'il soit suivi correctement.

ou alors y a t il de gros problèmes de compatibilité ?







Juste un problème avec l'installation de « non-modular nfsd » d'après la
liste de développement, mais des solution existent (#561674 #550153).

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkszgOIACgkQ18/WetbTC/rYaQCeM2BGAtra0GXaK6Iq8MMbhjDe
V4oAnjCaEcJkSHSVNxdagwddsZIOk6M3
=JY/F
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Nicolas KOWALSKI
Le #20830741
David Prévot
giggz a écrit : [...] >>> Est ce viable de compiler par exemple
un 2.6.32 sur une stable actuelle ? Si tu veux t'économiser du
temps (humain + machine), installer le 2.6.32 de sid est encore
plus [viable|simple|rapide|efficace] ;). Ce sera peut-être même
le noyau officiel de la prochaine stable, donc il a des chances
pour qu'il soit suivi correctement.



+1.

L'utilisation des backports pour lenny est assez pratique aussi.
Pour l'instant c'est en 2.6.30:

http://packages.debian.org/search?keywords=linux-image&searchon=names&section=all&suite=lenny-backports

--
Nicolas

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
maderios
Le #20831271
David Prévot a écrit :
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Salut,

giggz a écrit :
[...]
Est ce viable de compiler par exemple un 2.6.32 sur une stable actuelle ?







Si tu veux t'économiser du temps (humain + machine), installer le 2.6.32
de sid est encore plus [viable|simple|rapide|efficace] ;).


Mauvaise solution
Un noyau 2.6.32.2 compilé avec des bibliothèques Lenny/stable sera
certainement bien plus stable qu'un noyau 2.6.32 générique Sid compilé
avec des bibliothèques "instables". De plus un noyau "maison" est
optimisable en fonction des besoins.
http://www.kernel.org/
M


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David Prévot
Le #20831691
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bonjour,

maderios a écrit :
David Prévot a écrit :
giggz a écrit :
[...]
Est ce viable de compiler par exemple un 2.6.32 sur une stable
actuelle ?







Si tu veux t'économiser du temps (humain + machine), installer le 2.6.32
de sid est encore plus [viable|simple|rapide|efficace] ;).





Mauvaise solution



Je n'ai noté aucun problème en utilisant le 2.6.32 de Sid sur une Lenny,
et Ben Hutchings du Debian Kernel Team écrivait hier pour répondre à une
question similaire :

« Currently you can install kernel images from unstable or backports
without any extra dependencies. » [1]

Le fil de discussion se poursuit en notant le problème avec
nfs-kernel-server dont j'ai parlé précédemment (grâce à ce fil : je n'ai
pas expérimenté le problème personnellement).

[1] http://lists.debian.org/debian-devel/2009/12/msg00653.html

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAksztR8ACgkQ18/WetbTC/oVDgCdFib6tgok9QXZhu8As73R2Xu9
CCAAn1nZ3rKcnZ7gc3/851rMq0x7E5vK
=thQI
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
maderios
Le #20831771
David Prévot a écrit :
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bonjour,

maderios a écrit :
David Prévot a écrit :
giggz a écrit :
[...]
Est ce viable de compiler par exemple un 2.6.32 sur une stable
actuelle ?






Si tu veux t'économiser du temps (humain + machine), installer le 2.6.32
de sid est encore plus [viable|simple|rapide|efficace] ;).





Mauvaise solution



Je n'ai noté aucun problème en utilisant le 2.6.32 de Sid sur une Lenny,


Sid est par définition mouvant et instable. Donc aucun problème
aujourd'hui mais demain ? Vu que j'ai besoin de ma machine pour
travailler, je fuis Sid comme la peste. Rien ne vaut un noyau maison,
c'est du moins mon expérience personnelle.
Joyeux Noël
M

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Pascal Hambourg
Le #20831821
Salut,

maderios a écrit :

Un noyau 2.6.32.2 compilé avec des bibliothèques Lenny/stable sera
certainement bien plus stable qu'un noyau 2.6.32 générique Sid compilé
avec des bibliothèques "instables".



Remarque intéressante, qui m'amène une question à laquelle je n'avais
jamais pensé : la compilation du noyau requiert-elle des bibliothèques
additionnelles en plus des sources du noyau ? Je n'en trouve aucune
mention dans la documentation du noyau. Néanmoins le fait de compiler
avec des outils plus ou moins récents peut effectivement jouer, et dans
les deux sens.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
maderios
Le #20831971
Pascal Hambourg a écrit :
Salut,

maderios a écrit :

Un noyau 2.6.32.2 compilé avec des bibliothèques Lenny/stable sera
certainement bien plus stable qu'un noyau 2.6.32 générique Sid compilé
avec des bibliothèques "instables".



Remarque intéressante, qui m'amène une question à laquelle je n'avais
jamais pensé : la compilation du noyau requiert-elle des bibliothèques
additionnelles en plus des sources du noyau ? Je n'en trouve aucune
mention dans la documentation du noyau. Néanmoins le fait de compiler
avec des outils plus ou moins récents peut effectivement jouer, et dans
les deux sens.



Il faut certains paquets "dev", gcc, etc...
Cela peut servir :
http://www.andesi.org/noyau/noyau
http://kernelnewbies.org/KernelBuild
http://kernelnewbies.org/FAQ/HowToApplyAPatch
http://www.lea-linux.org/documentations/index.php/Kernel-compil

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme