Base de donnée corrompue???

Le
JF
Bonjour,

Win2k3, Exchange 2003 sp2.
Depuis plusieurs mois, certains utilisateurs se sont plaints que des mails
disparaissaient de leur boîte de réception. Le soir il y a 50 mails, le
lendemain seulement 35. Ce sont des messages choisis "au hasard" qui
disparaissent (pas d'archivage, ni de remise dans un pst). J'ai tenté un
restore (Veritas Backup Exec)de ces users dans une nouvelle boîte aux lettres
temporaire . Le restore fonctionne bien, xxx MB restored. Dans Exchange
manager, la taille de la boîte temporaire correspond au volume de données
restaurées, mais en l'ouvrant, il n'y a aucun item, tout est vide !

J'ai tenté des restore sur la plupart de mes users (75) et je rencontre
ce problème dans ~50% des cas (ils ne perdent pas nécessairement tous des
mails). Les cas problématiques sont des boîtes de grande ou de petite taille,
récemment créées ou non.

Quelqu'un a une idée?

Merci
JF
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gregoire
Le #678734
Avec l'outil ISINTEG tu peux tester si tes bases sont corrompues.

http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html
JF
Le #678733
Ça a été fait (offline) et aucune erreur n'a été trouvée...

Quelqu'un m'a dit d'exporter le contenu des users dans des pst, de supprimer
leur boîte et ensuite les recréer puis réimporter. Est-ce une solution qui
semble sécuritaire?

"Gregoire" wrote:

Avec l'outil ISINTEG tu peux tester si tes bases sont corrompues.

http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html





Aurélia BELIN [MS]
Le #678732
Bonjour,

le resultat d'isinteg -test alltests a t'il donné 0 error, 0 warning et 0
fix ?
Si oui. Le fait de repartir sur une nouvelle boite aux lettres ne risque de
pas changer grand chose.

Est ce que lorsque les utilisateurs ne voient plus leurs mails, on a la même
chose avec OWA.

Aurélia
"JF" news:
Bonjour,

Win2k3, Exchange 2003 sp2.
Depuis plusieurs mois, certains utilisateurs se sont plaints que des mails
disparaissaient de leur boîte de réception. Le soir il y a 50 mails, le
lendemain seulement 35. Ce sont des messages choisis "au hasard" qui
disparaissent (pas d'archivage, ni de remise dans un pst). J'ai tenté un
restore (Veritas Backup Exec)de ces users dans une nouvelle boîte aux
lettres
temporaire . Le restore fonctionne bien, xxx MB restored. Dans Exchange
manager, la taille de la boîte temporaire correspond au volume de données
restaurées, mais en l'ouvrant, il n'y a aucun item, tout est vide !

J'ai tenté des restore sur la plupart de mes users (75...) et je rencontre
ce problème dans ~50% des cas (ils ne perdent pas nécessairement tous des
mails). Les cas problématiques sont des boîtes de grande ou de petite
taille,
récemment créées ou non.

Quelqu'un a une idée?

Merci
JF



Mathieu CHATEAU
Le #678730
Bonjour,

êtes-vous sûr de ne pas avoir mis de stratégies qui efface certains objets
(mails) ?
Avez-vous des produits tierces parties greffés sur l'exchange
(antivirus/antispam/archiveur..) ?

Est-ce que les bases (*.edb *.stm) sont bien exclues des analyses
antivirales?


--
Cordialement,
Mathieu CHATEAU
http://lordoftheping.blogspot.com


"JF" news:
Ça a été fait (offline) et aucune erreur n'a été trouvée...

Quelqu'un m'a dit d'exporter le contenu des users dans des pst, de
supprimer
leur boîte et ensuite les recréer puis réimporter. Est-ce une solution qui
semble sécuritaire?

"Gregoire" wrote:

Avec l'outil ISINTEG tu peux tester si tes bases sont corrompues.

http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html







JF
Le #678729
Nous avons Nod32 pour Exchange, et ces fichiers sont exclus de toutes les
analyses. Nous n'avons pas de stratégie qui efface les mails (ça
n'expliquerait pas le fait qu'on restore 200Mb de data et qu'on ne les voie
pas...). Les utilisateurs en problème ne voient pas leurs mails ni dans
Outlook, ni dans OWA.

Nous avons appelé une firme de consultants certifiés MS. Lors d'un downtime
planifié, ils ont fait des tests pour conclure que la bd n'a aucune erreur,
et la défragmentation n'a rien apporté. (Je ne peux pas refaire un autre
downtime maintenant pour revoir le résultat de la commande isinteg.)

Présentement, je crée des nouvelles mailboxes et je restore tous mes users.
Ensuite je me connecte dessus pour voir le contenu, et je marque ceux qui
sont vides et qui ne le devraient pas. À date j'en ai 25 / 75. Pourtant, ils
travaillent dans Outlook sans problème. Sauf que certains parmi eux perdent
occasionnellement des mails.




"Mathieu CHATEAU" wrote:

Bonjour,

êtes-vous sûr de ne pas avoir mis de stratégies qui efface certains objets
(mails) ?
Avez-vous des produits tierces parties greffés sur l'exchange
(antivirus/antispam/archiveur..) ?

Est-ce que les bases (*.edb *.stm) sont bien exclues des analyses
antivirales?


--
Cordialement,
Mathieu CHATEAU
http://lordoftheping.blogspot.com


"JF" news:
Ça a été fait (offline) et aucune erreur n'a été trouvée...

Quelqu'un m'a dit d'exporter le contenu des users dans des pst, de
supprimer
leur boîte et ensuite les recréer puis réimporter. Est-ce une solution qui
semble sécuritaire?

"Gregoire" wrote:

Avec l'outil ISINTEG tu peux tester si tes bases sont corrompues.

http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html











Gregoire
Le #678728
Mais cette firme de consultants certifiés MS ont fait des tests d'accord,
mais n'ont pas résolu le problème pour autant.
Ils ne t'ont pas donné de pistes?
Nina Popravka
Le #678727
On Wed, 5 Sep 2007 13:18:01 -0700, JF wrote:

Depuis plusieurs mois, certains utilisateurs se sont plaints que des mails
disparaissaient de leur boîte de réception. Le soir il y a 50 mails, le
lendemain seulement 35.


Et si tu vas voir la boîte avec un client IMAP, il se passe quoi ?
--
Nina

JF
Le #678726
À part de réimporter les boîtes dans des nouvelles, non. Ils ne savent pas la
cause de ce problème.

Je vais aller faire un test : Aller sur le poste d'un user défectueux et
exporter ses emails dans un pst. Ce soir je vais supprimer son compte et le
recréer, et ensuite réimporter. Après un backup, je vais tenter un restore de
sa nouvelle mailbox dans une autre temporaire pour voir si tout est visible.
J'en donnerai des nouvelles.

JF

"Gregoire" wrote:

Mais cette firme de consultants certifiés MS ont fait des tests d'accord,
mais n'ont pas résolu le problème pour autant.
Ils ne t'ont pas donné de pistes?





Nina Popravka
Le #678725
On Thu, 6 Sep 2007 10:24:01 -0700, JF wrote:

Aller sur le poste d'un user défectueux


Et le luser défectueux sur un poste, il est aussi défectueux si on le
loggue sur le poste d'un luser pas défectueux ?
--
Nina

Publicité
Poster une réponse
Anonyme