bash ne rend pas la main immédiatement

Le
Dominique MICOLLET
Bonjour,


Je constate un disfonctionnement aléatoire de bash sur deux machines
récemment installées.

Occasionnellement, même sur des commandes simples, bash ne rend pas la main
au retour-chariot. Il faut que j'en frappe un second pour voir réapparaître
l'invite.

Ce qui est curieux est que ce phénomène ne se produit pas sur ma machine
habituelle, installée il y a longtemps.
Par contre il se produit sur deux machines récemment installées (dont l'une
a d'ailleurs été réinstallée, et pour laquelle je n'avais pas constaté ce
phénomène).

Ce comportement se produit dans les "konsoles" de kde, en Debian/Lenny.

Y-en-a-t-il parmi vous qui constatent le même phénomène ?


--
Dominique MICOLLET
Adresse email : enlever deux francs
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #19659021
Dominique MICOLLET a écrit :

Je constate un disfonctionnement aléatoire de bash sur deux machines
récemment installées.

Occasionnellement, même sur des commandes simples, bash ne rend pas la main
au retour-chariot. Il faut que j'en frappe un second pour voir réapparaître
l'invite.

Ce qui est curieux est que ce phénomène ne se produit pas sur ma machine
habituelle, installée il y a longtemps.
Par contre il se produit sur deux machines récemment installées (dont l'une
a d'ailleurs été réinstallée, et pour laquelle je n'avais pas constaté ce
phénomène).

Ce comportement se produit dans les "konsoles" de kde, en Debian/Lenny.

Y-en-a-t-il parmi vous qui constatent le même phénomène ?



bash ou konsole ?

Avec une autre console (Ctrl-Alt-F1, xterm, rxvt...) est-ce que le
phénomène est le même ?

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Fabien LE LEZ
Le #19666921
On Mon, 29 Jun 2009 09:05:38 +0200, Dominique MICOLLET :

bash ne rend pas la main au retour-chariot.



Y a-t-il une différence entre les deux touches "Entrée" ?
Dominique MICOLLET
Le #19667991
Sergio wrote:

bash ou konsole ?



Bonne question. Je n'y avait pas pensé...

Avec une autre console (Ctrl-Alt-F1, xterm, rxvt...) est-ce que le
phénomène est le même ?



Il va falloir que j'expérimente (ce qui n'est pas facile car j'ai rarement
la machine sous la main).

--
Dominique MICOLLET
Adresse email : enlever deux francs
Dominique MICOLLET
Le #19667981
Fabien LE LEZ wrote:

Y a-t-il une différence entre les deux touches "Entrée" ?




Je n'ai pas essayé. Il va falloir que j'expérimente.

--
Dominique MICOLLET
Adresse email : enlever deux francs
Jean-Pierre
Le #19746641
Dominique MICOLLET wrote:

Bonjour,


Je constate un disfonctionnement aléatoire de bash sur deux machines
récemment installées.

Occasionnellement, même sur des commandes simples, bash ne rend pas la
main au retour-chariot. Il faut que j'en frappe un second pour voir
réapparaître l'invite.

Ce qui est curieux est que ce phénomène ne se produit pas sur ma machine
habituelle, installée il y a longtemps.
Par contre il se produit sur deux machines récemment installées (dont
l'une a d'ailleurs été réinstallée, et pour laquelle je n'avais pas
constaté ce phénomène).

Ce comportement se produit dans les "konsoles" de kde, en Debian/Lenny.

Y-en-a-t-il parmi vous qui constatent le même phénomène ?





Bonjour,

j'ai eu le problème depuis longtemps c'est-à-dire depuis que j'ai installé
lenny/kde 3.5 (même quand elle était en instable en 2008) : ça semble venir
(dans mon cas) de konsole (pas eu de souci avec d'autres consoles comme
xterm) et il est vrai que c'est désagréable mais bon à mon avis les
développeurs s'en tapent complètement car ils ont d'autres soucis!
Et comme je suis récemment passé sous ubuntu sans utiliser kde vista je n'ai
plus de souci.


--

Ah l'informatique! Ou pourquoi faire simple quand on peut faire
compliqué!...

Jean-Pierre.
Dellara
Le #19746671
Jean-Pierre a papoté sur Usenet le 12 juillet 2009 18:00:

Et comme je suis récemment passé sous ubuntu sans utiliser kde vista
je n'ai plus de souci.



Comme quoi c'est facile de faire de la désinformation. Que vous ne
compreniez pas ou que vous n'aimiez pas le fonctionnement de KDE 4 je le
comprends. Que vous le compariez à un SE qui fait la honte de MS, c'est
carrément exagéré selon moi.
Dominique MICOLLET
Le #19748911
Jean-Pierre wrote:

j'ai eu le problème depuis longtemps



Voilà qui me rassure....
J'ai le phénomène sur une cinquième machine, récemment installée...

c'est-à-dire depuis que j'ai installé
lenny/kde 3.5 (même quand elle était en instable en 2008) : ça semble
venir (dans mon cas) de konsole (pas eu de souci avec d'autres consoles
comme xterm) et il est vrai que c'est désagréable mais bon à mon avis les
développeurs s'en tapent complètement car ils ont d'autres soucis!



Il faut dire que le phénomène étant intermittent ça n'est pas facile à
débugger.

J'ai plus ou moins réussi à provoquer le phénomène à volonté.
Si quelques uns parmi vous peuvent essayer pour voir.
Sous konsole, avec bash, taper rapidement deux fois la touche de tabulation
pour provoquer un completion automatique (sans avoir tapé quoi que ce soit
auparavant).
Le shell demande si l'on souhaite réellement afficher les milliers de
possibilités. Répondre n => sur mes machines buggantes, l'invite ne se
réaffiche pas.

De mémoire (je n'ai pas de machine buggante sous la main), cela se produit
aussi avec xterm.


--
Dominique MICOLLET
Adresse email : enlever deux francs
Fabien LE LEZ
Le #19751971
On Mon, 13 Jul 2009 13:38:58 +0200, Dominique MICOLLET

l'invite ne se réaffiche pas.



Est-ce uniquement un problème cosmétique ? Peux-tu taper quand même
une commande ?
Dominique MICOLLET
Le #19791871
Fabien LE LEZ wrote:

On Mon, 13 Jul 2009 13:38:58 +0200, Dominique MICOLLET

l'invite ne se réaffiche pas.



Est-ce uniquement un problème cosmétique ? Peux-tu taper quand même
une commande ?




Je suis obligé de retaper un retour chariot : à ce moment là, deux invites
apparaissent.

Il faudrait que je voie si je peux taper une commande en aveugle.

Par ailleurs il semblerait que le problème n'existe pas sous le compte root
(je sais que c'est mal de se connecter en root sous X, mais j'assume :-) ).
--
Dominique MICOLLET
Adresse email : enlever deux francs
Publicité
Poster une réponse
Anonyme