Besoin d'aide...

Le
sbaeumchen
Bonjour à vous tous,

Chaque mois je reçois un fichier excel. Dans ce fichier, j'ai des
noms dans la colonne A, qui peut changer d'un mois à un autre, et des
chiffres dans la colonne B.
Ce que je souhaite faire:
1) aditionner la colonne C, en fonction des noms de la colonne A.
2) pareil pour la colonne D, qui elle sera tributaire de la colonne B
mais aussi du nom de la colonne A
ex
A B C D
Stephane CR1 120 52
Stéphane CR1 30 72
Stéphane CR2 50 32
Fabienne CR2 -12 0
Fabienne CR1 36 10
Christian CR3 0 5
Christian CR3 9 5

En résultat on doit avoir:
pour le 1)
Pour stéphane on a 120+30+50
Pour Fabienne on a 50+(-12)
Pour Christian on a: 0+5

Pour le 2)
Pour stéphane:
CR1=52+72
CR2=32
Pour Fabienne:
CR2=0
CR1=10
Pour Christian
CR3=5+5


Voilà, j'espère que c'était clair.
Je vous remercie à tous par avance de votre aide
Cordialement,

Stéphane BAEUMCHEN
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
papou
Le #4542401
Bonjour
A adapter avec les plages qui vont bien :
1°) au choix :
=SOMME.SI(A2:A8;"Stephane";C2:C8)
ou
=SOMMEPROD((A2:A8="Stephane")*(C2:C8))
ou matricielle à valider par Ctrl + Shift + Enter
=SOMME(SI(A2:A8="Stephane";C2:C8;0))

2°)
=SOMME.SI(B2:B8;"CR1";D2:D8)
ou
=SOMMEPROD((B2:B8="CR1")*(D2:D8))
ou matricielle à valider par Ctrl + Shift + Enter :
=SOMME(SI(B2:B8="CR1";D2;D8;0))

Cordialement


Bonjour à vous tous,

Chaque mois je reçois un fichier excel. Dans ce fichier, j'ai des
noms dans la colonne A, qui peut changer d'un mois à un autre, et des
chiffres dans la colonne B.
Ce que je souhaite faire:
1) aditionner la colonne C, en fonction des noms de la colonne A.
2) pareil pour la colonne D, qui elle sera tributaire de la colonne B
mais aussi du nom de la colonne A
ex
A B C D
Stephane CR1 120 52
Stéphane CR1 30 72
Stéphane CR2 50 32
Fabienne CR2 -12 0
Fabienne CR1 36 10
Christian CR3 0 5
Christian CR3 9 5

En résultat on doit avoir:
pour le 1)
Pour stéphane on a 120+30+50
Pour Fabienne on a 50+(-12)
Pour Christian on a: 0+5

Pour le 2)
Pour stéphane:
CR1R+72
CR22
Pour Fabienne:
CR2=0
CR1
Pour Christian
CR3=5+5


Voilà, j'espère que c'était clair.
Je vous remercie à tous par avance de votre aide
Cordialement,

Stéphane BAEUMCHEN
cousinhub
Le #4944591
Bonsoir,
Avec un Tableau Croisé Dynamique, peut-être?
Regarde l'exemple ci-joint, et reviens si tu as un souci

http://cjoint.com/?fDsHk3OLEK


Bon courage

Bonjour à vous tous,

Chaque mois je reçois un fichier excel. Dans ce fichier, j'ai des
noms dans la colonne A, qui peut changer d'un mois à un autre, et des
chiffres dans la colonne B.
Ce que je souhaite faire:
1) aditionner la colonne C, en fonction des noms de la colonne A.
2) pareil pour la colonne D, qui elle sera tributaire de la colonne B
mais aussi du nom de la colonne A
ex
A B C D
Stephane CR1 120 52
Stéphane CR1 30 72
Stéphane CR2 50 32
Fabienne CR2 -12 0
Fabienne CR1 36 10
Christian CR3 0 5
Christian CR3 9 5

En résultat on doit avoir:
pour le 1)
Pour stéphane on a 120+30+50
Pour Fabienne on a 50+(-12)
Pour Christian on a: 0+5

Pour le 2)
Pour stéphane:
CR1R+72
CR22
Pour Fabienne:
CR2=0
CR1
Pour Christian
CR3=5+5


Voilà, j'espère que c'était clair.
Je vous remercie à tous par avance de votre aide
Cordialement,

Stéphane BAEUMCHEN



sbaeumchen
Le #4573291
On 29 mai, 18:33, cousinhub
Bonsoir,
Avec un Tableau Croisé Dynamique, peut-être?
Regarde l'exemple ci-joint, et reviens si tu as un souci

http://cjoint.com/?fDsHk3OLEK


Bon courage


Bonjour à vous tous,

Chaque mois je reçois un fichier excel. Dans ce fichier, j'ai des
noms dans la colonne A, qui peut changer d'un mois à un autre, et des
chiffres dans la colonne B.
Ce que je souhaite faire:
1) aditionner la colonne C, en fonction des noms de la colonne A.
2) pareil pour la colonne D, qui elle sera tributaire de la colonne B
mais aussi du nom de la colonne A
ex
A B C D
Stephane CR1 120 52
Stéphane CR1 30 72
Stéphane CR2 50 32
Fabienne CR2 -12 0
Fabienne CR1 36 10
Christian CR3 0 5
Christian CR3 9 5

En résultat on doit avoir:
pour le 1)
Pour stéphane on a 120+30+50
Pour Fabienne on a 50+(-12)
Pour Christian on a: 0+5

Pour le 2)
Pour stéphane:
CR1R+72
CR22
Pour Fabienne:
CR2=0
CR1
Pour Christian
CR3=5+5

Voilà, j'espère que c'était clair.
Je vous remercie à tous par avance de votre aide
Cordialement,

Stéphane BAEUMCHEN



Bonjour,
Je viens de tester le tableau croisé dynamique, et ça commence à
prendre forme.
Par contre, est ce que je peux faire une soustraction entre "donnée2
et donnée1" et ensuite de le faire semi-automatiser pour les autres
cellules, car j'ai environ 4000 lignes. Par exemple, je tape la
formule pour la première cellule, et ensuite avec la souris je
descends jusqu'en bas. Bien sûr j'ai testé mais ça ne marche pas. Exel
garde toujours la somme de la première cellule.
Cordialement;

Stéphane BAEUMCHEN


cousinhub
Le #4570741
Bonjour,
En partant de ce que j'ai transmis, tu peux, soit rajouter un TCD, même
principe, tu mets le champ nom dans la case Ligne, et insère Données1
par exemple dans le champ Données (que tu masqueras ensuite)
Tu termines ton TCD, puis en cliquant dessus, dans la barre d'outils
TCD, tu cliques sur Tableau Croisé Dynamique, tu sélectionnes Formules
puis Champ calculé
Tu nommes ton champ (par ex : Différence), puis dans la case formule, tu
entres = Donnée2 - donnée1
Tu peux adopter cette méthode sur un des TCD existant.
Ps : utilises-tu un nom dynamique pour déterminer la base de ton TCD?
Reviens en cas de problème
Bon courage

On 29 mai, 18:33, cousinhub
Bonsoir,
Avec un Tableau Croisé Dynamique, peut-être?
Regarde l'exemple ci-joint, et reviens si tu as un souci

http://cjoint.com/?fDsHk3OLEK
Bon courage



Bonjour à vous tous,
Chaque mois je reçois un fichier excel. Dans ce fichier, j'ai des
noms dans la colonne A, qui peut changer d'un mois à un autre, et des
chiffres dans la colonne B.
Ce que je souhaite faire:
1) aditionner la colonne C, en fonction des noms de la colonne A.
2) pareil pour la colonne D, qui elle sera tributaire de la colonne B
mais aussi du nom de la colonne A
ex
A B C D
Stephane CR1 120 52
Stéphane CR1 30 72
Stéphane CR2 50 32
Fabienne CR2 -12 0
Fabienne CR1 36 10
Christian CR3 0 5
Christian CR3 9 5
En résultat on doit avoir:
pour le 1)
Pour stéphane on a 120+30+50
Pour Fabienne on a 50+(-12)
Pour Christian on a: 0+5
Pour le 2)
Pour stéphane:
CR1R+72
CR22
Pour Fabienne:
CR2=0
CR1
Pour Christian
CR3=5+5
Voilà, j'espère que c'était clair.
Je vous remercie à tous par avance de votre aide
Cordialement,
Stéphane BAEUMCHEN



Bonjour,
Je viens de tester le tableau croisé dynamique, et ça commence à
prendre forme.
Par contre, est ce que je peux faire une soustraction entre "donnée2
et donnée1" et ensuite de le faire semi-automatiser pour les autres
cellules, car j'ai environ 4000 lignes. Par exemple, je tape la
formule pour la première cellule, et ensuite avec la souris je
descends jusqu'en bas. Bien sûr j'ai testé mais ça ne marche pas. Exel
garde toujours la somme de la première cellule.
Cordialement;

Stéphane BAEUMCHEN





Stéphane BAEUMCHEN
Le #4593211
Bonsoir à tous,

J'ai présenté ce matin la solution proposé par cousinhub, et bien
l'utilisateur en a été super content. Je lui fais gagné plein de jour de
travail.

Merci de m'avoir aidé

Cordialement,

Stéphane


Le 29/05/07 18:33, dans , « cousinhub »

Bonsoir,
Avec un Tableau Croisé Dynamique, peut-être?
Regarde l'exemple ci-joint, et reviens si tu as un souci

http://cjoint.com/?fDsHk3OLEK


Bon courage

Bonjour à vous tous,

Chaque mois je reçois un fichier excel. Dans ce fichier, j'ai des
noms dans la colonne A, qui peut changer d'un mois à un autre, et des
chiffres dans la colonne B.
Ce que je souhaite faire:
1) aditionner la colonne C, en fonction des noms de la colonne A.
2) pareil pour la colonne D, qui elle sera tributaire de la colonne B
mais aussi du nom de la colonne A
ex
A B C D
Stephane CR1 120 52
Stéphane CR1 30 72
Stéphane CR2 50 32
Fabienne CR2 -12 0
Fabienne CR1 36 10
Christian CR3 0 5
Christian CR3 9 5

En résultat on doit avoir:
pour le 1)
Pour stéphane on a 120+30+50
Pour Fabienne on a 50+(-12)
Pour Christian on a: 0+5

Pour le 2)
Pour stéphane:
CR1R+72
CR22
Pour Fabienne:
CR2=0
CR1
Pour Christian
CR3=5+5


Voilà, j'espère que c'était clair.
Je vous remercie à tous par avance de votre aide
Cordialement,

Stéphane BAEUMCHEN





Publicité
Poster une réponse
Anonyme